]> git.pld-linux.org Git - packages/kp5-plasma-browser-integration.git/blame - kp5-plasma-browser-integration.spec
- updated to 5.24.5
[packages/kp5-plasma-browser-integration.git] / kp5-plasma-browser-integration.spec
CommitLineData
71c87d24
WF
1#
2# Conditional build:
3%bcond_with tests # build with tests
a4fc390d 4%define kdeplasmaver 5.24.5
5d15b68f
WF
5%define qtver 5.11.0
6%define kpname plasma-browser-integration
7
8Summary: KDE Plasma Browser Integration
9Name: kp5-%{kpname}
a4fc390d 10Version: 5.24.5
5d15b68f
WF
11Release: 1
12License: LGPL v2.1+
13Group: X11/Libraries
14Source0: http://download.kde.org/stable/plasma/%{kdeplasmaver}/%{kpname}-%{version}.tar.xz
a4fc390d 15# Source0-md5: e123ec241c17a9c726b79f372d736ce3
5d15b68f
WF
16URL: http://www.kde.org/
17BuildRequires: Qt5Core-devel >= %{qtver}
18BuildRequires: Qt5DBus-devel
19BuildRequires: Qt5Gui-devel
20BuildRequires: Qt5Widgets-devel
21BuildRequires: cmake >= 2.8.12
22BuildRequires: gettext-devel
23BuildRequires: kf5-extra-cmake-modules
24BuildRequires: kf5-kactivities-devel
25BuildRequires: kf5-kauth-devel
26BuildRequires: kf5-kcodecs-devel
27BuildRequires: kf5-kcompletion-devel
28BuildRequires: kf5-kconfigwidgets-devel
29BuildRequires: kf5-kcoreaddons-devel
30BuildRequires: kf5-kcrash-devel
31BuildRequires: kf5-kdbusaddons-devel
32BuildRequires: kf5-kfilemetadata-devel
33BuildRequires: kf5-ki18n-devel
34BuildRequires: kf5-kio-devel
35BuildRequires: kf5-kitemviews-devel
36BuildRequires: kf5-kjobwidgets-devel
37BuildRequires: kf5-knotifications-devel
38BuildRequires: kf5-kpackage-devel
39BuildRequires: kf5-krunner-devel
40BuildRequires: kf5-kservice-devel
41BuildRequires: kf5-kwidgetsaddons-devel
42BuildRequires: kf5-kwindowsystem-devel
43BuildRequires: kf5-kxmlgui-devel
44BuildRequires: kf5-plasma-framework-devel
45BuildRequires: kf5-purpose-devel
46BuildRequires: kf5-solid-devel
5ee1138a 47BuildRequires: kp5-plasma-workspace-devel >= %{kdeplasmaver}
5d15b68f
WF
48BuildRequires: ninja
49BuildRequires: rpmbuild(macros) >= 1.164
50BuildRequires: xz
51BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53%define qt5dir %{_libdir}/qt5
54
55%description
56KDE Plasma Browser Integration.
57
58%prep
59%setup -q -n %{kpname}-%{version}
60
61%build
62install -d build
63cd build
64%cmake -G Ninja \
71c87d24 65 %{!?with_tests:-DBUILD_TESTING=OFF} \
5d15b68f
WF
66 -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
67 -DHTML_INSTALL_DIR=%{_kdedocdir} \
68 ../
69%ninja_build
70
71c87d24
WF
71%if %{with tests}
72ctest
73%endif
74
5d15b68f
WF
75%install
76rm -rf $RPM_BUILD_ROOT
77%ninja_install -C build
78
79%find_lang %{kpname} --all-name --with-kde
80
81%clean
82rm -rf $RPM_BUILD_ROOT
83
84%files -f %{kpname}.lang
85%defattr(644,root,root,755)
86%dir %{_sysconfdir}/chromium
87%dir %{_sysconfdir}/chromium/native-messaging-hosts
88%{_sysconfdir}/chromium/native-messaging-hosts/org.kde.plasma.browser_integration.json
89%dir %{_sysconfdir}/opt/chrome
90%dir %{_sysconfdir}/opt/chrome/native-messaging-hosts
91%{_sysconfdir}/opt/chrome/native-messaging-hosts/org.kde.plasma.browser_integration.json
92%attr(755,root,root) %{_bindir}/plasma-browser-integration-host
93%dir %{_prefix}/lib/mozilla
94%dir %{_prefix}/lib/mozilla/native-messaging-hosts
95%{_prefix}/lib/mozilla/native-messaging-hosts/org.kde.plasma.browser_integration.json
96%attr(755,root,root) %{_libdir}/qt5/plugins/kf5/kded/browserintegrationreminder.so
97%dir %{_sysconfdir}/opt/edge
98%dir %{_sysconfdir}/opt/edge/native-messaging-hosts
99%{_sysconfdir}/opt/edge/native-messaging-hosts/org.kde.plasma.browser_integration.json
100%{_datadir}/krunner/dbusplugins/plasma-runner-browserhistory.desktop
101%{_datadir}/krunner/dbusplugins/plasma-runner-browsertabs.desktop
fb5fc23f 102%{_desktopdir}/org.kde.plasma.browser_integration.host.desktop
This page took 0.125811 seconds and 4 git commands to generate.