]> git.pld-linux.org Git - packages/kp5-flatpak-kcm.git/blame - kp5-flatpak-kcm.spec
- updated to 5.27.3
[packages/kp5-flatpak-kcm.git] / kp5-flatpak-kcm.spec
CommitLineData
7fa5b440
WF
1#
2# Conditional build:
3%bcond_with tests # build with tests
75b4ef37 4%define kdeplasmaver 5.27.3
7fa5b440
WF
5%define qtver 5.15.2
6%define kpname flatpak-kcm
7
8Summary: KDE Config Module for flatpak
9Name: kp5-%{kpname}
75b4ef37 10Version: 5.27.3
7fa5b440
WF
11Release: 1
12License: LGPL v2.1+
13Group: X11/Libraries
14Source0: https://download.kde.org/stable/plasma/%{kdeplasmaver}/%{kpname}-%{version}.tar.xz
75b4ef37 15# Source0-md5: e9a72723b059265c210cd39c5a03a839
7fa5b440
WF
16URL: http://www.kde.org/
17BuildRequires: Qt5Core-devel >= %{qtver}
18BuildRequires: cmake >= 2.8.12
19BuildRequires: flatpak-devel
20BuildRequires: kf5-kauth-devel
21BuildRequires: kf5-kconfigwidgets-devel
22BuildRequires: kf5-kcoreaddons-devel
23BuildRequires: kf5-ki18n-devel
24BuildRequires: kf5-kio-devel
25BuildRequires: kf5-kxmlgui-devel
26BuildRequires: ninja
27BuildRequires: rpmbuild(macros) >= 1.164
28BuildRequires: xz
29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31%define qt5dir %{_libdir}/qt5
32
33%description
34KDE Config Module for flatpak.
35
36%prep
37%setup -q -n %{kpname}-%{version}
38
39%build
40install -d build
41cd build
42%cmake -G Ninja \
43 %{!?with_tests:-DBUILD_TESTING=OFF} \
44 -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
45 -DHTML_INSTALL_DIR=%{_kdedocdir} \
46 ../
47%ninja_build
48
49%if %{with tests}
50ctest
51%endif
52
53%install
54rm -rf $RPM_BUILD_ROOT
55%ninja_install -C build
56
57%find_lang %{kpname} --all-name --with-kde
58
59%clean
60rm -rf $RPM_BUILD_ROOT
61
62%files -f %{kpname}.lang
63%defattr(644,root,root,755)
64%{_libdir}/qt5/plugins/plasma/kcms/systemsettings/kcm_flatpak.so
65%{_desktopdir}/kcm_flatpak.desktop
c3a289d4
WF
66%dir %{_datadir}/kpackage/kcms/kcm_flatpak
67%dir %{_datadir}/kpackage/kcms/kcm_flatpak/contents
68%dir %{_datadir}/kpackage/kcms/kcm_flatpak/contents/ui
7fa5b440
WF
69%{_datadir}/kpackage/kcms/kcm_flatpak/contents/ui/main.qml
70%{_datadir}/kpackage/kcms/kcm_flatpak/contents/ui/permissions.qml
c3a289d4 71%{_datadir}/kpackage/kcms/kcm_flatpak/contents/ui/KcmPopupModal.qml
This page took 0.104426 seconds and 4 git commands to generate.