]> git.pld-linux.org Git - packages/kodi.git/blame - kodi.spec
build with ffmpeg from xbmc project
[packages/kodi.git] / kodi.spec
CommitLineData
18b90c81 1# TODO:
3a71016a 2# - fix build flags - some files are compiled with -O3 and without rpm*flags
c1b45330 3# - fix linking argument order
92b96980 4# - add and/or fix users/groups permissions
63ff963e 5# - split to subpackages?
928406b7
ER
6# - system ffmpeg (--with-ffmpeg=shared), DVDDemuxFFmpeg.cpp:542:41: error: 'av_read_frame_flush' was not declared in this scope
7# - bundled ffmpeg build (tools/depends/target/ffmpeg/autobuild.sh) enables nonfree & gpl!
18b90c81 8#
92b96980 9# Conditional build:
c0d69361
ER
10%bcond_with afpclient # AFP support via libafpclient
11%bcond_without airplay # AirPlay support
12%bcond_with airtunes # AirTunes support
98f23c16
ER
13%bcond_without dvdcss # DVDCSS support
14%bcond_without fishbmc # FishBMC visualisation
15%bcond_without gl # OpenGL rendering
16%bcond_without goom # GOOM visualisation
17%bcond_with gtest # configure Google Test Framework
37fbe511 18%bcond_with hal # build with HAL
98f23c16 19%bcond_without joystick # SDL joystick support
c0d69361
ER
20%bcond_without libcap # libcap support
21%bcond_with libcec # libcec support
22%bcond_with libusb # libusb support
23%bcond_with mdnsembedded # mDNSEmbedded support
24%bcond_with nfs # NFS support via libnfs
25%bcond_with openmax # OpenMax decoding, requires OpenGLES
98f23c16 26%bcond_without projectm # ProjectM visualisation
c0d69361 27%bcond_without pulse # PulseAudio support
98f23c16 28%bcond_without rsxs # really slick X screensavers
c0d69361
ER
29%bcond_without rtmp # RTMP support via librtmp
30%bcond_without sdl # SDL
98f23c16
ER
31%bcond_without spectrum # Spectrum visualisation
32%bcond_without texturepacker # texturepacker support
c0d69361
ER
33%bcond_without udev # udev support
34%bcond_without vaapi # VAAPI decoding
35%bcond_without vdpau # VDPAU decoding
36%bcond_with vtbdecoder # VTBDecoder decoding (VTB Decoder not supported on this platform)
98f23c16
ER
37%bcond_without waveform # Waveform visualisation
38%bcond_without x11 # x11 'Linux Only'
39%bcond_without xrandr # XRandR support
928406b7 40%bcond_with system_ffmpeg # build with system ffmpeg
92b96980 41
92b53b2c 42%define codename Helix
d61811e9 43Summary: Kodi is a free and open source media-player and entertainment hub
92b53b2c
ER
44Name: kodi
45Version: 14.0
46Release: 0.1
68612b1e 47License: GPL v2+ and GPL v3+
18b90c81 48Group: Applications/Multimedia
92b53b2c
ER
49Source0: http://mirrors.kodi.tv/releases/source/%{version}-%{codename}.tar.gz
50# Source0-md5: 9717c539789789b8aeaf1dcfdb9f2c69
928406b7
ER
51Source1: https://github.com/xbmc/FFmpeg/archive/2.4.4-Helix.tar.gz
52# Source1-md5: 19b5d29ef6b5a6fc202c652fe3905d9b
d2f0f4c7 53Patch0: jpeglib-boolean.patch
92b53b2c 54URL: http://kodi.tv/
b85db44b
AF
55BuildRequires: Mesa-libGLU-devel
56BuildRequires: OpenGL-devel
658b3aff 57BuildRequires: SDL2-devel
18b90c81
SP
58BuildRequires: SDL_image-devel
59BuildRequires: SDL_mixer-devel
60BuildRequires: alsa-lib-devel
61BuildRequires: autoconf
62BuildRequires: automake
63BuildRequires: avahi-devel
b85db44b 64BuildRequires: bluez-libs-devel >= 4.99
5a2f2b01 65BuildRequires: boost-devel
18b90c81
SP
66BuildRequires: bzip2-devel
67BuildRequires: cmake
68BuildRequires: curl-devel
69BuildRequires: dbus-devel
501e1d3e 70BuildRequires: doxygen
c462fd57 71BuildRequires: ffmpeg-devel
5a2f2b01 72BuildRequires: flac-devel
18b90c81
SP
73BuildRequires: fontconfig-devel
74BuildRequires: freetype-devel
75BuildRequires: fribidi-devel
76BuildRequires: gawk
63ff963e 77BuildRequires: gettext-autopoint
0747666f 78BuildRequires: gettext-tools
18b90c81
SP
79BuildRequires: glew-devel
80BuildRequires: gperf
37fbe511 81%{?with_hal:BuildRequires: hal-devel}
5a2f2b01 82BuildRequires: jasper-devel
37fbe511 83BuildRequires: jre
b85db44b 84BuildRequires: libass-devel
37fbe511
KK
85BuildRequires: libbluray-devel >= 0.2.1
86BuildRequires: libcap-devel
18b90c81 87BuildRequires: libcdio-devel
c0d69361 88%{?with_libcec:BuildRequires: libcec-devel}
1aef2bca 89%ifarch i686 pentium4 athlon %{x8664}
5f83fc0f 90BuildRequires: libcrystalhd-devel
1aef2bca 91%endif
b85db44b 92BuildRequires: libgcrypt-devel
18b90c81 93BuildRequires: libjpeg-devel
45a200ab 94BuildRequires: libltdl-devel
18b90c81 95BuildRequires: libmad-devel
63ff963e 96BuildRequires: libmicrohttpd-devel
63ff963e 97BuildRequires: libmodplug-devel
c462fd57 98BuildRequires: libmpeg2-devel
18b90c81 99BuildRequires: libogg-devel
b85db44b 100BuildRequires: libplist-devel
5a2f2b01 101BuildRequires: libpng-devel
b85db44b 102BuildRequires: librtmp-devel
18b90c81
SP
103BuildRequires: libsamplerate-devel
104BuildRequires: libsmbclient-devel
b85db44b 105BuildRequires: libssh-devel
5a2f2b01 106BuildRequires: libtiff-devel
107BuildRequires: libtool
b85db44b 108BuildRequires: libva-devel
5f83fc0f 109BuildRequires: libva-glx-devel
5a2f2b01 110BuildRequires: libvdpau-devel
18b90c81 111BuildRequires: libvorbis-devel
501e1d3e 112BuildRequires: libxslt-devel
5a2f2b01 113BuildRequires: lzo-devel
114BuildRequires: mysql-devel
c1b45330 115%ifarch %{ix86}
26cae375 116BuildRequires: nasm
c1b45330 117%endif
18b90c81 118BuildRequires: openssl-devel
63ff963e 119BuildRequires: pcre-cxx-devel
5a2f2b01 120BuildRequires: pkgconfig
18b90c81 121BuildRequires: pulseaudio-devel
b85db44b 122BuildRequires: python-devel >= 2.4
3a71016a 123BuildRequires: rpm-pythonprov
6f41c837 124BuildRequires: rpmbuild(macros) >= 1.566
c462fd57 125BuildRequires: sed >= 4.0
18b90c81 126BuildRequires: sqlite3-devel
37fbe511
KK
127BuildRequires: swig
128BuildRequires: taglib-devel >= 1.8
7613a43d 129BuildRequires: tinyxml-devel
b85db44b 130BuildRequires: udev-devel
5a2f2b01 131BuildRequires: unzip
b85db44b
AF
132BuildRequires: xorg-lib-libX11-devel
133BuildRequires: xorg-lib-libXext-devel
5a2f2b01 134BuildRequires: xorg-lib-libXinerama-devel
b85db44b 135BuildRequires: xorg-lib-libXmu-devel
18b90c81 136BuildRequires: xorg-lib-libXrandr-devel
b85db44b 137BuildRequires: xorg-lib-libXt-devel
5a2f2b01 138BuildRequires: xorg-lib-libXtst-devel
b85db44b 139BuildRequires: yajl-devel
501e1d3e 140BuildRequires: yasm
18b90c81
SP
141BuildRequires: zip
142BuildRequires: zlib-devel
b85db44b
AF
143#https://github.com/sahlberg/libnfs
144#BuildRequires: libnfs-devel
145#http://sites.google.com/site/alexthepuffin/home
146#BuildRequires: afpfs-ng-devel
147#http://mirrors.xbmc.org/build-deps/darwin-libs/libshairport-1.2.0.20310_lib.tar.gz
148#https://github.com/albertz/shairport
149#BuildRequires: libshairport
63ff963e 150Requires: /usr/bin/glxinfo
f4f8f308 151Requires: SDL >= 1.2.14-5
a58652d4
SP
152Requires: lsb-release
153Requires: xorg-app-xdpyinfo
06c1bb12 154# dlopened libraries:
d61811e9 155# grep 'DLL_PATH_.*lib.*\.so' xbmc/DllPaths_generated.h | grep -v special://
06c1bb12
ER
156Requires: curl-libs
157Requires: libass
158Requires: libbluray
159Requires: libmodplug
160Requires: libmpeg2-libs
161Requires: libogg
162Requires: libplist
163Requires: libvorbis
92b53b2c 164Obsoletes: xbmc < 14.0
18b90c81
SP
165BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
166
167%description
d61811e9
ER
168Kodi Entertainment Center (formerly XBMC) is a free and open-source
169media player software developed by the XBMC Foundation, a non-profit
170technology consortium. Kodi is available for multiple operating
171systems and hardware platforms, with a software 10-foot user interface
172for use with televisions and remote controls. It allows users to play
173and view most videos, music, such as podcasts from the internet, and
174all common digital media files from local and network storage media.
18b90c81
SP
175
176%prep
92b53b2c 177%setup -q -n xbmc-%{version}-%{codename}
bfa116d7 178%patch0 -p1
18b90c81 179
928406b7
ER
180%if %{with system_ffmpeg}
181ln -s %{SOURCE1} tools/depends/target/ffmpeg
182%endif
183
18b90c81
SP
184%build
185./bootstrap
65712ad3 186%configure \
ace9791d 187 --disable-silent-rules \
51b524ca 188 --disable-debug \
ace9791d 189 --disable-ccache \
928406b7 190 --with-ffmpeg=%{!?with_system_ffmpeg:force}%{?with_system_ffmpeg:shared} \
c0d69361
ER
191 %{__enable_disable afpclient} \
192 %{__enable_disable airplay} \
193 %{__enable_disable airtunes} \
98f23c16
ER
194 %{__enable_disable dvdcss} \
195 %{__enable_disable fishbmc} \
196 %{__enable_disable gl} \
b85db44b 197 %{__enable_disable goom} \
98f23c16
ER
198 %{__enable_disable gtest} \
199 %{__enable_disable gtexturepacker} \
37fbe511 200 %{__enable_disable hal} \
98f23c16 201 %{__enable_disable joystick} \
c0d69361 202 %{__enable_disable libcap} \
98f23c16 203 %{__enable_disable libcec} \
c0d69361
ER
204 %{__enable_disable libusb} \
205 %{__enable_disable mdnsembedded} \
206 %{__enable_disable nfs} \
207 %{__enable_disable openmax} \
98f23c16 208 %{__enable_disable projectm} \
c0d69361 209 %{__enable_disable pulse} \
98f23c16 210 %{__enable_disable rsxs} \
c0d69361
ER
211 %{__enable_disable rtmp} \
212 %{__enable_disable sdl} \
98f23c16 213 %{__enable_disable spectrum} \
c0d69361
ER
214 %{__enable_disable udev} \
215 %{__enable_disable vaapi} \
216 %{__enable_disable vdpau} \
217 %{__enable_disable vtbdecoder} \
98f23c16
ER
218 %{__enable_disable waveform} \
219 %{__enable_disable x11} \
220 %{__enable_disable xrandr} \
221 %{nil}
68612b1e 222
ace9791d 223%{__make}
18b90c81
SP
224
225%install
226rm -rf $RPM_BUILD_ROOT
18b90c81 227%{__make} install \
92b96980 228 DESTDIR=$RPM_BUILD_ROOT
18b90c81 229
25890c53
ER
230%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
231
232# no -devel package yet
233%{__rm} -r $RPM_BUILD_ROOT%{_includedir}/kodi
234%{__rm} -r $RPM_BUILD_ROOT%{_includedir}/xbmc
235
18b90c81
SP
236%clean
237rm -rf $RPM_BUILD_ROOT
238
239%files
240%defattr(644,root,root,755)
25890c53
ER
241%doc README.md docs/README.linux
242%attr(755,root,root) %{_bindir}/kodi
243%attr(755,root,root) %{_bindir}/kodi-standalone
18b90c81 244%{_datadir}/%{name}
92b96980 245%attr(755,root,root) %{_libdir}/%{name}
25890c53
ER
246%{_desktopdir}/kodi.desktop
247%{_iconsdir}/hicolor/*/apps/%{name}.png
248%{_datadir}/xsessions/kodi.desktop
249
250# legacy xbmc compatibility links
251%attr(755,root,root) %{_bindir}/xbmc
252%attr(755,root,root) %{_bindir}/xbmc-standalone
253%{_libdir}/xbmc
254%{_datadir}/xbmc
255%{_datadir}/xsessions/xbmc.desktop
This page took 0.102884 seconds and 4 git commands to generate.