]> git.pld-linux.org Git - packages/kf5-kplotting.git/blame - kf5-kplotting.spec
- updated to 5.53.0
[packages/kf5-kplotting.git] / kf5-kplotting.spec
CommitLineData
c4abd278
WF
1%define kdeframever 5.53
2%define qtver 5.9.0
3ff049dd
AM
3%define kfname kplotting
4#
8b0a37c1 5Summary: Data plotting
3ff049dd 6Name: kf5-%{kfname}
c4abd278 7Version: 5.53.0
3ff049dd 8Release: 1
8b0a37c1
WF
9License: LGPL v2.1+
10Group: X11/Libraries
3ff049dd 11Source0: http://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
c4abd278 12# Source0-md5: 34125fa1563feb9af831b1f7e05629ae
8b0a37c1
WF
13URL: http://www.kde.org/
14BuildRequires: Qt5Core-devel
15BuildRequires: Qt5Gui-devel >= 5.3.1
16BuildRequires: Qt5Test-devel
17BuildRequires: Qt5Widgets-devel
18BuildRequires: cmake >= 2.8.12
19BuildRequires: kf5-extra-cmake-modules >= 1.0.0
20BuildRequires: rpmbuild(macros) >= 1.164
cdba659b
ER
21BuildRequires: tar >= 1:1.22
22BuildRequires: xz
dd2c4685 23Requires: kf5-dirs
8b0a37c1
WF
24BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26%define qt5dir %{_libdir}/qt5
27
28%description
29KPlotWidget is a QWidget-derived class that provides a virtual base
30class for easy data-plotting. The idea behind KPlotWidget is that you
31only have to specify information in "data units"; i.e., the natural
32units of the data being plotted. KPlotWidget automatically converts
33everything to screen pixel units.
34
35KPlotWidget draws X and Y axes with tick marks and tick labels. It
36automatically determines how many tick marks to use and where they
37should be, based on the data limits specified for the plot. You change
38the limits by calling `setLimits(double x1, double x2, double y1,
39double y2)`.
40
41Data to be plotted are stored using the KPlotObject class. KPlotObject
42consists of a QList of QPointF's, each specifying the X,Y coordinates
43of a data point. KPlotObject also specifies the "type" of data to be
44plotted (POINTS or CURVE or POLYGON or LABEL).
45
46%package devel
3ff049dd
AM
47Summary: Header files for %{kfname} development
48Summary(pl.UTF-8): Pliki nagłówkowe dla programistów używających %{kfname}
8b0a37c1
WF
49Group: X11/Development/Libraries
50Requires: %{name} = %{version}-%{release}
51
52%description devel
3ff049dd 53Header files for %{kfname} development.
8b0a37c1
WF
54
55%description devel -l pl.UTF-8
3ff049dd 56Pliki nagłówkowe dla programistów używających %{kfname}.
8b0a37c1
WF
57
58%prep
3ff049dd 59%setup -q -n %{kfname}-%{version}
8b0a37c1
WF
60
61%build
62install -d build
63cd build
64%cmake \
3ff049dd 65 -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
8b0a37c1
WF
66 ../
67%{__make}
68
69%install
70rm -rf $RPM_BUILD_ROOT
71
72%{__make} -C build/ install \
73 DESTDIR=$RPM_BUILD_ROOT
74
75%clean
76rm -rf $RPM_BUILD_ROOT
77
78%post -p /sbin/ldconfig
79%postun -p /sbin/ldconfig
80
81%files
82%defattr(644,root,root,755)
83%doc README.md
84%attr(755,root,root) %ghost %{_libdir}/libKF5Plotting.so.5
3ff049dd 85%attr(755,root,root) %{_libdir}/libKF5Plotting.so.*.**
8b0a37c1
WF
86
87%files devel
88%defattr(644,root,root,755)
89%{_includedir}/KF5/KPlotting
90%{_includedir}/KF5/kplotting_version.h
91%{_libdir}/cmake/KF5Plotting
92%attr(755,root,root) %{_libdir}/libKF5Plotting.so
93%{qt5dir}/mkspecs/modules/qt_KPlotting.pri
This page took 0.075186 seconds and 4 git commands to generate.