]> git.pld-linux.org Git - packages/kf5-kitemmodels.git/blame - kf5-kitemmodels.spec
tar.xz deps
[packages/kf5-kitemmodels.git] / kf5-kitemmodels.spec
CommitLineData
2c8b5e74
WF
1# TODO:
2# - dir /usr/include/KF5 not packaged
3%define _state stable
4%define orgname kitemmodels
5
6Summary: Set of item models extending the Qt model-view framework
7Name: kf5-%{orgname}
8Version: 5.0.0
9Release: 0.1
10License: LGPL v2.1+
11Group: X11/Libraries
12Source0: ftp://ftp.kde.org/pub/kde/%{_state}/frameworks/%{version}/%{orgname}-%{version}.tar.xz
13# Source0-md5: c1bb781f39b2c6d232a0fb490f2aa9dc
14URL: http://www.kde.org/
15BuildRequires: Qt5Core-devel
16BuildRequires: Qt5Gui-devel >= 5.3.1
17BuildRequires: Qt5Test-devel
18BuildRequires: Qt5Widgets-devel >= 5.2.0
19BuildRequires: cmake >= 2.8.12
20BuildRequires: kf5-extra-cmake-modules >= 1.0.0
21BuildRequires: qt5-linguist
22BuildRequires: rpmbuild(macros) >= 1.164
d54e7fc9
ER
23BuildRequires: tar >= 1:1.22
24BuildRequires: xz
2c8b5e74
WF
25BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27%define qt5dir %{_libdir}/qt5
28
29%description
30KItemModels provides the following models:
31
32- KBreadcrumbSelectionModel - Selects the parents of selected items to
33 create breadcrumbs
34- KCheckableProxyModel - Adds a checkable capability to a source model
35- KDescendantsProxyModel - Proxy Model for restructuring a Tree into a
36 list
37- KLinkItemSelectionModel - Share a selection in multiple views which
38 do not have the same source model
39- KModelIndexProxyMapper - Mapping of indexes and selections through
40 proxy models
41- KRecursiveFilterProxyModel - Recursive filtering of models
42- KSelectionProxyModel - A Proxy Model which presents a subset of its
43 source model to observers
44
45%package devel
46Summary: Header files for %{orgname} development
47Summary(pl.UTF-8): Pliki nagłówkowe dla programistów używających %{orgname}
48Group: X11/Development/Libraries
49Requires: %{name} = %{version}-%{release}
50
51%description devel
52Header files for %{orgname} development.
53
54%description devel -l pl.UTF-8
55Pliki nagłówkowe dla programistów używających %{orgname}.
56
57%prep
58%setup -q -n %{orgname}-%{version}
59
60%build
61install -d build
62cd build
63%cmake \
64 -DBIN_INSTALL_DIR=%{_bindir} \
65 -DKCFG_INSTALL_DIR=%{_datadir}/config.kcfg \
66 -DPLUGIN_INSTALL_DIR=%{qt5dir}/plugins \
67 -DQT_PLUGIN_INSTALL_DIR=%{qt5dir}/plugins \
68 -DQML_INSTALL_DIR=%{qt5dir}/qml \
69 -DIMPORTS_INSTALL_DIR=%{qt5dirs}/imports \
70 -DSYSCONF_INSTALL_DIR=%{_sysconfdir} \
71 -DLIBEXEC_INSTALL_DIR=%{_libexecdir} \
72 -DKF5_LIBEXEC_INSTALL_DIR=%{_libexecdir} \
73 -DKF5_INCLUDE_INSTALL_DIR=%{_includedir} \
74 -DECM_MKSPECS_INSTALL_DIR=%{qt5dir}/mkspecs/modules \
75 ../
76%{__make}
77
78%install
79rm -rf $RPM_BUILD_ROOT
80
81%{__make} -C build/ install \
82 DESTDIR=$RPM_BUILD_ROOT
83
84%clean
85rm -rf $RPM_BUILD_ROOT
86
87%post -p /sbin/ldconfig
88%postun -p /sbin/ldconfig
89
90%files
91%defattr(644,root,root,755)
92%doc README.md
93%attr(755,root,root) %ghost %{_libdir}/libKF5ItemModels.so.5
94%attr(755,root,root) %{_libdir}/libKF5ItemModels.so.5.0.0
95
96%files devel
97%defattr(644,root,root,755)
98%{_includedir}/KF5/KItemModels
99%{_includedir}/KF5/kitemmodels_version.h
100%{_libdir}/cmake/KF5ItemModels
101%attr(755,root,root) %{_libdir}/libKF5ItemModels.so
102%{qt5dir}/mkspecs/modules/qt_KItemModels.pri
This page took 0.103912 seconds and 4 git commands to generate.