]> git.pld-linux.org Git - packages/kf5-kconfig.git/blame - kf5-kconfig.spec
- new
[packages/kf5-kconfig.git] / kf5-kconfig.spec
CommitLineData
c2bc7e94
WF
1# TODO:
2# - dir /usr/include/KF5 not packaged
3%define _state stable
4%define orgname kconfig
5
6Summary: Backend for storing application configuration
7Name: kf5-%{orgname}
8Version: 5.0.0
9Release: 0.1
10License: LGPL v2.1+
11Group: X11/Libraries
12Source0: ftp://ftp.kde.org/pub/kde/%{_state}/frameworks/%{version}/%{orgname}-%{version}.tar.xz
13# Source0-md5: d7cdb25dd4645904332ef9eee71143ec
14URL: http://www.kde.org/
15BuildRequires: Qt5Core-devel
16BuildRequires: Qt5Gui-devel >= 5.3.1
17BuildRequires: Qt5Test-devel
18BuildRequires: Qt5Xml-devel >= 5.2.0
19BuildRequires: cmake >= 2.8.12
20BuildRequires: kf5-extra-cmake-modules >= 1.0.0
21BuildRequires: qt5-linguist
22BuildRequires: rpmbuild(macros) >= 1.164
23BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25%define qt5dir %{_libdir}/qt5
26
27%description
28KConfig provides an advanced configuration system. It is made of two
29parts: KConfigCore and KConfigGui.
30
31KConfigCore provides access to the configuration files themselves. It
32features:
33
34- Code generation: describe your configuration in an XML file, and use
35 `kconfig_compiler to generate classes that read and write
36 configuration entries.
37- Cascading configuration files (global settings overridden by local
38 settings).
39- Optional shell expansion support (see [docs/options.md](@ref
40 options)).
41- The ability to lock down configuration options (see
42 [docs/options.md](@ref options)).
43
44KConfigGui provides a way to hook widgets to the configuration so that
45they are automatically initialized from the configuration and
46automatically propagate their changes to their respective
47configuration files.
48
49%package devel
50Summary: Header files for %{orgname} development
51Summary(pl.UTF-8): Pliki nagłówkowe dla programistów używających %{orgname}
52Group: X11/Development/Libraries
53Requires: %{name} = %{version}-%{release}
54
55%description devel
56Header files for %{orgname} development.
57
58%description devel -l pl.UTF-8
59Pliki nagłówkowe dla programistów używających %{orgname}.
60
61%prep
62%setup -q -n %{orgname}-%{version}
63
64%build
65install -d build
66cd build
67%cmake \
68 -DBIN_INSTALL_DIR=%{_bindir} \
69 -DKCFG_INSTALL_DIR=%{_datadir}/config.kcfg \
70 -DPLUGIN_INSTALL_DIR=%{qt5dir}/plugins \
71 -DQT_PLUGIN_INSTALL_DIR=%{qt5dir}/plugins \
72 -DQML_INSTALL_DIR=%{qt5dir}/qml \
73 -DIMPORTS_INSTALL_DIR=%{qt5dirs}/imports \
74 -DSYSCONF_INSTALL_DIR=%{_sysconfdir} \
75 -DLIBEXEC_INSTALL_DIR=%{_libexecdir} \
76 -DKF5_LIBEXEC_INSTALL_DIR=%{_libexecdir} \
77 -DKF5_INCLUDE_INSTALL_DIR=%{_includedir} \
78 -DECM_MKSPECS_INSTALL_DIR=%{qt5dir}/mkspecs/modules \
79 ../
80%{__make}
81
82%install
83rm -rf $RPM_BUILD_ROOT
84
85%{__make} -C build/ install \
86 DESTDIR=$RPM_BUILD_ROOT
87
88%find_lang %{orgname}5_qt --with-qm
89
90%clean
91rm -rf $RPM_BUILD_ROOT
92
93%post -p /sbin/ldconfig
94%postun -p /sbin/ldconfig
95
96%files -f %{orgname}5_qt.lang
97%defattr(644,root,root,755)
98%doc DESIGN README.md TODO
99%attr(755,root,root) %ghost %{_libdir}/libKF5ConfigCore.so.5
100%attr(755,root,root) %{_libdir}/libKF5ConfigCore.so.5.0.0
101%attr(755,root,root) %ghost %{_libdir}/libKF5ConfigGui.so.5
102%attr(755,root,root) %{_libdir}/libKF5ConfigGui.so.5.0.0
103%attr(755,root,root) %{_bindir}/kconfig_compiler_kf5
104%attr(755,root,root) %{_bindir}/kreadconfig5
105%attr(755,root,root) %{_bindir}/kwriteconfig5
106%attr(755,root,root) %{_libdir}/kf5/kconf_update
107
108%files devel
109%defattr(644,root,root,755)
110%attr(755,root,root) %{_libdir}/libKF5ConfigCore.so
111%attr(755,root,root) %{_libdir}/libKF5ConfigGui.so
112%{_includedir}/KF5/KConfigCore
113%{_includedir}/KF5/KConfigGui
114%{_includedir}/KF5/kconfig_version.h
115%{_libdir}/cmake/KF5Config
116%{qt5dir}/mkspecs/modules/qt_KConfigCore.pri
117%{qt5dir}/mkspecs/modules/qt_KConfigGui.pri
This page took 0.137929 seconds and 4 git commands to generate.