]> git.pld-linux.org Git - packages/kf5-extra-cmake-modules.git/blame - kf5-extra-cmake-modules.spec
- updated to 5.88.0
[packages/kf5-extra-cmake-modules.git] / kf5-extra-cmake-modules.spec
CommitLineData
01d13c31
ER
1#
2# Conditional build:
0dd76f0f 3%bcond_without doc # build without doc
53d00b1b 4%bcond_without tests # build without tests
071895c0 5
23845e79 6%define orgname extra-cmake-modules
daf60595 7%define kdeframever 5.88
23845e79 8Summary: Extra Cmake Modules for KF5
53d00b1b 9Summary(pl.UTF-8): Dodatkowe moduły Cmake'a dla KF5
01d13c31 10Name: kf5-%{orgname}
daf60595
WF
11Version: 5.88.0
12Release: 1
071895c0
AM
13License: BSD
14Group: Development/Building
bb2957f2 15Source0: https://download.kde.org/stable/frameworks/%{kdeframever}/%{orgname}-%{version}.tar.xz
daf60595 16# Source0-md5: 756c8f01c4b00c2b4ed0e4004f619e43
53d00b1b 17Patch0: %{orgname}-tests.patch
3d166c4a 18Patch1: kdefetchtranslations-test.patch
3ed29e1c
JB
19URL: https://kde.org/
20BuildRequires: cmake >= 3.16
2f178ef3 21BuildRequires: qt5-assistant >= 5.9.0
071895c0 22BuildRequires: qt5-linguist
98423a86 23BuildRequires: python3-charset_normalizer >= 2.0.0
3f354ca4 24BuildRequires: rpmbuild(macros) >= 1.698
53d00b1b
JB
25BuildRequires: sed >= 4.0
26BuildRequires: sphinx-pdg >= 1.2
434fec0f
WF
27BuildRequires: tar >= 1:1.22
28BuildRequires: xz
53d00b1b 29%if %{with tests}
2f178ef3
WF
30BuildRequires: Qt5Core-devel >= 5.9.0
31BuildRequires: Qt5Gui-devel >= 5.9.0
32BuildRequires: Qt5Network-devel >= 5.9.0
33BuildRequires: Qt5Qml-devel >= 5.9.0
34BuildRequires: Qt5Quick-devel >= 5.9.0
cc4fc263 35BuildRequires: libstdc++-devel >= 6:5
2f178ef3 36BuildRequires: qt5-build >= 5.9.0
53d00b1b 37%endif
43053bb5 38Obsoletes: kf5-extra-cmake-modules-doc
1a1e564e 39BuildArch: noarch
23845e79
WF
40BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
23845e79
WF
42%description
43The Extra CMake Modules package, or ECM, adds to the modules provided
01d13c31
ER
44by CMake, including both ones used by find_package() to find common
45software and ones that can be used directly in CMakeLists.txt files to
46perform common tasks.
23845e79
WF
47
48In addition, it provides common build settings used in software
49produced by the KDE community.
50
51While the driving force of this module is to reduce duplication in
52CMake scripts across KDE software, it is intended to be useful for any
53software that uses the CMake build system.
54
53d00b1b
JB
55%description -l pl.UTF-8
56Pakiet Extra CMake Modules (ECM) dostarcza dodatkowe moduły do tych
57dostarczanych przez CMake'a, zawierające te używane przez
58find_package() do szukania popularnego oprogramowania, a także takie,
59których można używać bezpośrednio w CMakeLists.txt do wykonywania
60wspólnych zadań.
61
62Ponadto pakiet dostarcza wspólne ustawienia budowana używane w
63oprogramowaniu tworzonym przez społeczność KDE.
64
65O ile główną motywacją tego modułu jest zmniejszenie duplikacji w
66skryptach CMake'a w oprogramowaniu KDE, ma także być przydatny dla
67dowolnych programów wykorzystujących system budowania CMake.
68
0dd76f0f 69%package apidocs
1f2c20d2
WF
70Summary: API documentation for %{orgname}
71Summary(pl.UTF-8): Dokumentacja API %{orgname}
0dd76f0f
WF
72Group: Documentation
73
74%description apidocs
75API documentation for %{orgname}.
76
77%description apidocs -l pl.UTF-8
78Dokumentacja API dla %{orgname}.
79
23845e79
WF
80%prep
81%setup -q -n %{orgname}-%{version}
53d00b1b 82%patch0 -p1
3d166c4a 83%patch1 -p0
53d00b1b
JB
84
85# causes make install failure after running tests
86%{__sed} -i -e '/ECMToolchainAndroidTest/d' tests/CMakeLists.txt
23845e79
WF
87
88%build
89install -d build
90cd build
3d166c4a
WF
91%cmake \
92 %{!?with_tests:-DBUILD_TESTING=OFF} \
0dd76f0f 93 %{!?with_doc:-DBUILD_HTML_DOCS=OFF} \
3d166c4a 94 ..
53d00b1b 95
23845e79
WF
96%{__make}
97
53d00b1b
JB
98%if %{with tests}
99# GenerateSipBindings wants clang and has libclang checks incompatible with libclang >= 4
9a54f06a
JR
100# ECMPoQmToolsTest fails to build it's own moc file
101ctest -E '(GenerateSipBindings|ECMPoQmToolsTest)'
53d00b1b 102%endif
071895c0 103
23845e79
WF
104%install
105rm -rf $RPM_BUILD_ROOT
53d00b1b
JB
106
107%{__make} -C build -j1 install \
23845e79
WF
108 DESTDIR=$RPM_BUILD_ROOT
109
3d166c4a
WF
110sed -i -e 's#/usr/bin/env bash#/bin/bash#' $RPM_BUILD_ROOT%{_datadir}/ECM/kde-modules/kde-git-commit-hooks/pre-commit.in
111sed -i -e 's#/usr/bin/env bash#/bin/bash#' $RPM_BUILD_ROOT%{_datadir}/ECM/kde-modules/kde-git-commit-hooks/clang-format.sh
112
0dd76f0f 113%if %{with doc}
53d00b1b 114%{__mv} $RPM_BUILD_ROOT%{_docdir}/ECM ECM-doc
0dd76f0f 115%endif
ed2c6fa7 116install -d $RPM_BUILD_ROOT%{_datadir}/qlogging-categories5
071895c0 117
23845e79
WF
118%clean
119rm -rf $RPM_BUILD_ROOT
120
121%files
122%defattr(644,root,root,755)
0dd76f0f 123%doc COPYING-CMAKE-SCRIPTS README.rst
23845e79 124%{_datadir}/ECM
ed2c6fa7 125%{_datadir}/qlogging-categories5
071895c0 126%{_mandir}/man7/ecm*.7*
0dd76f0f
WF
127
128%if %{with doc}
129%files apidocs
130%defattr(644,root,root,755)
131%doc ECM-doc/html/*
132%endif
This page took 0.111462 seconds and 4 git commands to generate.