]> git.pld-linux.org Git - packages/kernel-tools.git/blame - kernel-tools.spec
- added multilib bcond, updated perf comments
[packages/kernel-tools.git] / kernel-tools.spec
CommitLineData
bb6b0f50
ER
1# TODO:
2# - redefine: PACKAGE_BUGREPORT=cpufreq@vger.kernel.org
b1f08c11 3# - add -n python-perf?
b1f08c11 4# - add bcond to disable building docs (perf docs)
a5af5310 5# - install of perf links perf binary again
bb6b0f50 6
49fba13a
ER
7# Conditional build:
8%bcond_without verbose # verbose build (V=1)
db5f9ac9 9%bcond_without perf # perf tools
ae4c1fd4 10%bcond_without gtk # GTK+ 2.x perf support
5a8bbd03 11%bcond_without libunwind # libunwind perf support
a5af5310 12%bcond_without multilib # multilib perf support
5a8bbd03
JR
13
14%ifarch x32
15%undefine with_libunwind
16%endif
a5af5310
JB
17%ifnarch %{x8664}
18%undefine with_multilib
19%endif
49fba13a 20
da4153c4
JR
21%define basever 4.4
22%define postver .0
49fba13a 23Summary: Assortment of tools for the Linux kernel
bd620db3 24Summary(pl.UTF-8): Zestaw narzędzi dla jądra Linuksa
49fba13a
ER
25Name: kernel-tools
26Version: %{basever}%{postver}
da4153c4 27Release: 1
49fba13a 28License: GPL v2
fea1e605 29Group: Applications/System
3109d83e 30Source0: https://www.kernel.org/pub/linux/kernel/v4.x/linux-%{basever}.tar.xz
da4153c4 31# Source0-md5: 9a78fa2eb6c68ca5a40ed5af08142599
bedc6c43
JR
32Source1: cpupower.service
33Source2: cpupower.config
49fba13a 34%if "%{postver}" != ".0"
3109d83e 35Patch0: https://www.kernel.org/pub/linux/kernel/v4.x/patch-%{version}.xz
dcbcf21f 36# Patch0-md5: 3a465c7cf55ec9dbf2d72d9292aa5fde
49fba13a 37%endif
bedc6c43 38Patch1: x32.patch
52583efa 39URL: http://www.kernel.org/
4a7175d2 40BuildRequires: gettext-tools
9596c3d3 41BuildRequires: pciutils-devel
a8b28c3a 42BuildRequires: rpmbuild(macros) >= 1.647
49fba13a
ER
43BuildRequires: tar >= 1:1.22
44BuildRequires: xz
fea1e605
ER
45%if %{with perf}
46BuildRequires: asciidoc
52583efa 47BuildRequires: audit-libs-devel
db5f9ac9 48BuildRequires: binutils-devel
52583efa 49BuildRequires: bison
a8b28c3a 50BuildRequires: docbook-dtd45-xml
52583efa
JB
51BuildRequires: docbook-style-xsl
52BuildRequires: elfutils-devel
53BuildRequires: flex
a5af5310
JB
54%if %{with multilib}
55BuildRequires: gcc-multilib-32
56BuildRequires: gcc-multilib-x32
57%endif
5a8bbd03 58%{?with_libunwind:BuildRequires: libunwind-devel >= 0.99}
60ccbbd3 59BuildRequires: numactl-devel
52583efa 60BuildRequires: perl-devel >= 5.1
52583efa 61BuildRequires: python-devel
fea1e605 62BuildRequires: rpm-pythonprov
a1c57a8e 63BuildRequires: slang-devel
fea1e605 64BuildRequires: xmlto
a8b28c3a
ER
65%if %{with gtk}
66BuildRequires: gtk+2-devel >= 2.0
67BuildRequires: pkgconfig
68%endif
fea1e605 69%endif
49fba13a
ER
70BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
71
eb373af4
AM
72# otherwise /usr/lib/rpm/bin/debugedit: canonicalization unexpectedly shrank by one character
73%define _enable_debug_packages 0
74
60972f76
ER
75%define makeopts CC="%{__cc}" %{?with_verbose:V=1}
76
49fba13a 77%description
bd620db3
JB
78This package contains the software from tools/ subdirectory from Linux
79kernel source and the supporting documentation.
80
81%description -l pl.UTF-8
82Ten pakiet zawiera oprogramowanie z podkatalogu tools/ ze źródeł jądra
83Linuksa oraz związaną z nim dokumentację.
49fba13a 84
4bc5704a
JK
85%package cpupower
86Summary: cpupower - Shows and sets processor power related values
bd620db3 87Summary(pl.UTF-8): cpupower - wyświetlanie i ustawianie wartości związanych z zużyciem energii przez procesor
4bc5704a 88Group: Applications/System
f57fcd71 89Requires(post,preun,postun): systemd-units >= 38
91fd1f55 90Requires: %{name}-cpupower-libs = %{version}-%{release}
f57fcd71 91Requires: systemd-units >= 0.38
2bd21e06 92Provides: cpupowerutils = 1:009-0.6.p1
2bd21e06
ER
93Obsoletes: cpupowerutils < 1:009-0.6.p1
94Obsoletes: cpuspeed < 1:1.5-16
4bc5704a
JK
95
96%description cpupower
60972f76
ER
97cpupower is a collection of tools to examine and tune power saving
98related features of your processor.
4bc5704a 99
bd620db3
JB
100%description cpupower -l pl.UTF-8
101cpupower to zbiór narzędzi do sprawdzania i ustawiania opcji procesora
102związanych z oszczędzaniem energii.
103
4bc5704a 104%package cpupower-libs
bd620db3
JB
105Summary: cpupower library
106Summary(pl.UTF-8): Biblioteka cpupower
49fba13a
ER
107Group: Libraries
108
4bc5704a 109%description cpupower-libs
bd620db3
JB
110cpupower library.
111
112%description cpupower-libs -l pl.UTF-8
113Biblioteka cpupower.
49fba13a 114
4bc5704a 115%package cpupower-libs-devel
bd620db3
JB
116Summary: Development files for the cpupower library
117Summary(pl.UTF-8): Pliki programistyczne biblioteki cpupower
49fba13a 118Group: Development/Libraries
178c4b31
ER
119Requires: %{name} = %{version}-%{release}
120Requires: %{name}-cpupower-libs = %{version}-%{release}
49fba13a 121Provides: cpupowerutils-devel = 1:009-0.6.p1
49fba13a 122Obsoletes: cpupowerutils-devel < 1:009-0.6.p1
08be99c5 123Conflicts: cpufrequtils-devel
49fba13a 124
4bc5704a 125%description cpupower-libs-devel
bd620db3
JB
126Development files for the cpupower library.
127
128%description cpupower-libs-devel -l pl.UTF-8
129Pliki programistyczne biblioteki cpupower.
49fba13a 130
ae4c1fd4
JB
131%package perf
132Summary: perf profiler tool
133Summary(pl.UTF-8): Narzędzie profilujące perf
fea1e605 134Group: Applications/System
9efc8fed 135Suggests: binutils
ae4c1fd4
JB
136Obsoletes: perf-core
137Obsoletes: perf-slang
fea1e605 138
ae4c1fd4 139%description perf
fea1e605
ER
140Perf is a profiler tool for Linux 2.6+ based systems that abstracts
141away CPU hardware differences in Linux performance measurements and
142presents a simple commandline interface. Perf is based on the
143perf_events interface exported by recent versions of the Linux kernel.
144
ae4c1fd4 145This package contains core files, scripts and text interface (TUI).
db5f9ac9 146
ae4c1fd4 147%description perf -l pl.UTF-8
db5f9ac9
JB
148Perf to narzędzie profilujące dla systemów opartych na Linuksie 2.6+,
149odseparowujące od różnic sprzętowych między pomiarami wydajności w
150zależności od procesora oraz udostępniające prosty interfejs linii
151poleceń. Perf jest oparty na interfejsie perf_events eksportowanym
152przez nowe wersje jądra Linuksa.
153
ae4c1fd4
JB
154Ten pakiet zawiera podstawowe pliki, skrypty oraz interfejs tekstowy
155(TUI).
db5f9ac9 156
0a3bb9dd 157%package perf-vdso32
dda20c35
JB
158Summary: perf profiler tool - VDSO 32-bit ABI reader
159Summary(pl.UTF-8): Narzędzie profilujące perf - odczyt VDSO dla ABI 32-bitowego
0a3bb9dd
JR
160Group: Applications/System
161Requires: %{name}-perf = %{version}-%{release}
162
163%description perf-vdso32
164Perf is a profiler tool for Linux 2.6+ based systems that abstracts
165away CPU hardware differences in Linux performance measurements and
166presents a simple commandline interface. Perf is based on the
167perf_events interface exported by recent versions of the Linux kernel.
168
169This package contains perf-read-vdso32 tool for reading the 32-bit
170compatibility VDSO in 64-bit mode.
171
dda20c35
JB
172%description perf-vdso32 -l pl.UTF-8
173Perf to narzędzie profilujące dla systemów opartych na Linuksie 2.6+,
174odseparowujące od różnic sprzętowych między pomiarami wydajności w
175zależności od procesora oraz udostępniające prosty interfejs linii
176poleceń. Perf jest oparty na interfejsie perf_events eksportowanym
177przez nowe wersje jądra Linuksa.
178
179Ten pakiet zawiera narzędzie perf-read-vdso32 do odczytu VDSO dla
180binariów 32-bitowych w trybie 64-bitowym.
181
0a3bb9dd 182%package perf-vdsox32
dda20c35
JB
183Summary: perf profiler tool - VDSO x32 ABI reader
184Summary(pl.UTF-8): Narzędzie profilujące perf - odczyt VDSO dla ABI x32
0a3bb9dd
JR
185Group: Applications/System
186Requires: %{name}-perf = %{version}-%{release}
187
188%description perf-vdsox32
189Perf is a profiler tool for Linux 2.6+ based systems that abstracts
190away CPU hardware differences in Linux performance measurements and
191presents a simple commandline interface. Perf is based on the
192perf_events interface exported by recent versions of the Linux kernel.
193
194This package contains perf-read-vdso32 tool for reading the x32 mode
19532-bit compatibility VDSO in 64-bit mode.
196
dda20c35
JB
197%description perf-vdsox32 -l pl.UTF-8
198Perf to narzędzie profilujące dla systemów opartych na Linuksie 2.6+,
199odseparowujące od różnic sprzętowych między pomiarami wydajności w
200zależności od procesora oraz udostępniające prosty interfejs linii
201poleceń. Perf jest oparty na interfejsie perf_events eksportowanym
202przez nowe wersje jądra Linuksa.
203
204Ten pakiet zawiera narzędzie perf-read-vdso32 do odczytu VDSO dla
205binariów ABI x32 w trybie 64-bitowym.
206
db5f9ac9 207%package perf-gtk
ae4c1fd4
JB
208Summary: perf profiler tool (GTK+ 2 GUI)
209Summary(pl.UTF-8): Narzędzie profilujące perf (interfejs graficzny GTK+ 2)
db5f9ac9 210Group: X11/Applications
dad8cd2d 211Requires: %{name}-perf = %{version}-%{release}
db5f9ac9
JB
212
213%description perf-gtk
214Perf is a profiler tool for Linux 2.6+ based systems that abstracts
215away CPU hardware differences in Linux performance measurements and
216presents a simple commandline interface. Perf is based on the
217perf_events interface exported by recent versions of the Linux kernel.
218
ae4c1fd4 219This package contains GTK+ 2 based GUI.
db5f9ac9
JB
220
221%description perf-gtk -l pl.UTF-8
222Perf to narzędzie profilujące dla systemów opartych na Linuksie 2.6+,
223odseparowujące od różnic sprzętowych między pomiarami wydajności w
224zależności od procesora oraz udostępniające prosty interfejs linii
225poleceń. Perf jest oparty na interfejsie perf_events eksportowanym
226przez nowe wersje jądra Linuksa.
227
ae4c1fd4 228Ten pakiet zawiera graficzny interfejs oparty na GTK+ 2.
db5f9ac9 229
db5f9ac9
JB
230%package -n bash-completion-perf
231Summary: Bash completion for perf command
232Summary(pl.UTF-8): Bashowe uzupełnianie parametrów dla polecenia perf
233Group: Applications/Shells
3385eb86 234Requires: %{name}-perf
db5f9ac9 235Requires: bash-completion
741b96de
ER
236%if "%{_rpmversion}" >= "5"
237BuildArch: noarch
238%endif
db5f9ac9
JB
239
240%description -n bash-completion-perf
241Bash completion for perf command.
242
243%description -n bash-completion-perf -l pl.UTF-8
244Bashowe uzupełnianie parametrów dla polecenia perf.
245
49fba13a
ER
246%prep
247%setup -qc
248cd linux-%{basever}
249
250%if "%{postver}" != ".0"
251%patch0 -p1
252%endif
253
bedc6c43
JR
254%patch1 -p1
255
eb373af4
AM
256sed -i -e 's#libexec/perf-core#%{_datadir}/perf-core#g' tools/perf/config/Makefile
257
49fba13a
ER
258%build
259cd linux-%{basever}
260
b1f08c11
ER
261# Simple Disk Sleep Monitor
262%{__cc} %{rpmcppflags} %{rpmcflags} %{rpmldflags} Documentation/laptops/dslm.c -o dslm
263
49fba13a
ER
264# cpupower
265%{__make} -C tools/power/cpupower \
60972f76 266 %{makeopts} \
fb1ff9fc
JB
267 CPUFREQ_BENCH=false \
268 OPTIMIZATION="%{rpmcflags}" \
269 STRIPCMD=true
49fba13a 270
bedc6c43 271%ifarch %{ix86} x32
49fba13a 272%{__make} -C tools/power/cpupower/debug/i386 centrino-decode powernow-k8-decode \
fb1ff9fc
JB
273 CC="%{__cc}" \
274 CFLAGS="%{rpmcflags}"
49fba13a
ER
275%endif
276
bedc6c43 277%ifarch %{x8664} x32
49fba13a 278%{__make} -C tools/power/cpupower/debug/x86_64 centrino-decode powernow-k8-decode \
fb1ff9fc
JB
279 CC="%{__cc}" \
280 CFLAGS="%{rpmcflags}"
49fba13a
ER
281%endif
282
bedc6c43 283%ifarch %{ix86} %{x8664} x32
49fba13a 284%{__make} -C tools/power/x86/x86_energy_perf_policy \
fb1ff9fc
JB
285 CC="%{__cc}" \
286 CFLAGS="%{rpmcflags}"
4b352448 287CFLAGS="%{rpmcflags}" \
49fba13a 288%{__make} -C tools/power/x86/turbostat \
4b352448 289 CC="%{__cc}"
49fba13a
ER
290%endif
291
f111fe43
JK
292# page-types, slabinfo
293%{__make} -C tools/vm page-types slabinfo \
701b458f 294 CC="%{__cc}" \
f111fe43 295 CFLAGS="%{rpmcflags} -Wall -Wextra -I../lib"
701b458f 296
fea1e605 297%if %{with perf}
52583efa 298%{__make} -C tools/perf all man \
4dfb9dde
JR
299%ifarch %{x8664}
300 IS_X86_64=1 \
a5af5310 301 %{!?with_multilib:NO_PERF_READ_VDSO32=1 NO_PERF_READ_VDSOX32=1} \
4dfb9dde 302%endif
ae4c1fd4 303 %{!?with_gtk:NO_GTK2=1} \
5a8bbd03 304 %{!?with_libunwind:NO_LIBUNWIND=1} \
60972f76 305 %{makeopts} \
fb1ff9fc 306 CFLAGS_OPTIMIZE="%{rpmcflags}" \
d0e13ec9 307 WERROR=0 \
fea1e605
ER
308 prefix=%{_prefix} \
309 perfexecdir=%{_datadir}/perf-core \
4f4642fc 310 lib=%{_lib} \
fea1e605 311 template_dir=%{_datadir}/perf-core/templates
bc35d286 312%endif
fea1e605 313
dd28be58
JK
314# gen_init_cpio
315%{__make} -C usr gen_init_cpio \
60972f76 316 %{makeopts} \
fb1ff9fc 317 CFLAGS="%{rpmcflags}"
dd28be58 318
49fba13a
ER
319%install
320rm -rf $RPM_BUILD_ROOT
b1f08c11 321
49fba13a 322cd linux-%{basever}
b1f08c11 323install -d $RPM_BUILD_ROOT%{_sbindir}
49fba13a 324
bd620db3 325%{__make} -C tools/power/cpupower install \
49fba13a
ER
326 DESTDIR=$RPM_BUILD_ROOT \
327 libdir=%{_libdir} \
328 mandir=%{_mandir} \
329 CPUFREQ_BENCH=false
330
331%find_lang cpupower
332mv cpupower.lang ..
333
f57fcd71
ER
334install -d $RPM_BUILD_ROOT{/etc/sysconfig,%{systemdunitdir}}
335cp -p %{SOURCE1} $RPM_BUILD_ROOT%{systemdunitdir}/cpupower.service
336cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/cpupower
337
bedc6c43 338%ifarch %{ix86} x32
701b458f 339install -p tools/power/cpupower/debug/i386/{centrino,powernow-k8}-decode $RPM_BUILD_ROOT%{_bindir}
49fba13a 340%endif
bedc6c43 341%ifarch %{x8664} x32
701b458f 342install -p tools/power/cpupower/debug/x86_64/{centrino,powernow-k8}-decode $RPM_BUILD_ROOT%{_bindir}
49fba13a
ER
343%endif
344
b1f08c11 345install -p tools/vm/slabinfo $RPM_BUILD_ROOT%{_bindir}
f111fe43 346install -p tools/vm/page-types $RPM_BUILD_ROOT%{_sbindir}
b1f08c11 347install -p dslm $RPM_BUILD_ROOT%{_sbindir}
701b458f 348
bedc6c43 349%ifarch %{ix86} %{x8664} x32
49fba13a 350install -d $RPM_BUILD_ROOT%{_mandir}/man8
a5af5310 351%{__make} -C tools/power/x86/x86_energy_perf_policy install \
49fba13a 352 DESTDIR=$RPM_BUILD_ROOT
49fba13a 353
a5af5310 354%{__make} -C tools/power/x86/turbostat install \
49fba13a 355 DESTDIR=$RPM_BUILD_ROOT
49fba13a 356%endif
fea1e605
ER
357
358%if %{with perf}
a5af5310 359%{__make} -C tools/perf -j1 install install-man \
4dfb9dde
JR
360%ifarch %{x8664}
361 IS_X86_64=1 \
a5af5310 362 %{!?with_multilib:NO_PERF_READ_VDSO32=1 NO_PERF_READ_VDSOX32=1} \
4dfb9dde 363%endif
ae4c1fd4 364 %{!?with_gtk:NO_GTK2=1} \
5a8bbd03 365 %{!?with_libunwind:NO_LIBUNWIND=1} \
fea1e605 366 CC="%{__cc}" \
fb1ff9fc 367 CFLAGS_OPTIMIZE="%{rpmcflags}" \
6e9d46c8 368 WERROR=0 \
fea1e605
ER
369 %{?with_verbose:V=1} \
370 prefix=%{_prefix} \
371 perfexecdir=%{_datadir}/perf-core \
372 template_dir=%{_datadir}/perf-core/templates \
4f4642fc 373 lib=%{_lib} \
fea1e605 374 DESTDIR=$RPM_BUILD_ROOT
db5f9ac9
JB
375
376%py_comp $RPM_BUILD_ROOT%{_datadir}/perf-core/scripts/python
377%py_ocomp $RPM_BUILD_ROOT%{_datadir}/perf-core/scripts/python
a8b28c3a 378
4b352448 379%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/perf-core/tests
49fba13a
ER
380%endif
381
dd28be58 382# gen_init_cpio
60972f76 383install -p usr/gen_init_cpio $RPM_BUILD_ROOT%{_bindir}/gen_init_cpio
dd28be58 384
49fba13a
ER
385%clean
386rm -rf $RPM_BUILD_ROOT
387
4bc5704a
JK
388%post cpupower-libs -p /sbin/ldconfig
389%postun cpupower-libs -p /sbin/ldconfig
49fba13a 390
f57fcd71
ER
391%post cpupower
392%systemd_post cpupower.service
393
394%preun cpupower
395%systemd_preun cpupower.service
396
397%postun cpupower
398%systemd_reload
399
4bc5704a 400%files
49fba13a 401%defattr(644,root,root,755)
701b458f
JB
402%attr(755,root,root) %{_bindir}/gen_init_cpio
403%attr(755,root,root) %{_bindir}/slabinfo
b1f08c11 404%attr(755,root,root) %{_sbindir}/dslm
f111fe43 405%attr(755,root,root) %{_sbindir}/page-types
bedc6c43 406%ifarch %{ix86} %{x8664} x32
49fba13a
ER
407%attr(755,root,root) %{_bindir}/centrino-decode
408%attr(755,root,root) %{_bindir}/powernow-k8-decode
409%endif
bedc6c43 410%ifarch %{ix86} %{x8664} x32
49fba13a
ER
411%attr(755,root,root) %{_bindir}/turbostat
412%attr(755,root,root) %{_bindir}/x86_energy_perf_policy
bd620db3
JB
413%{_mandir}/man8/turbostat.8*
414%{_mandir}/man8/x86_energy_perf_policy.8*
49fba13a
ER
415%endif
416
4bc5704a
JK
417%files cpupower -f cpupower.lang
418%defattr(644,root,root,755)
419%attr(755,root,root) %{_bindir}/cpupower
bd620db3 420%{_mandir}/man1/cpupower*.1*
f57fcd71
ER
421%{systemdunitdir}/cpupower.service
422%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/cpupower
4bc5704a
JK
423
424%files cpupower-libs
49fba13a
ER
425%defattr(644,root,root,755)
426%attr(755,root,root) %{_libdir}/libcpupower.so.*.*.*
bd620db3 427%attr(755,root,root) %ghost %{_libdir}/libcpupower.so.0
49fba13a 428
4bc5704a 429%files cpupower-libs-devel
49fba13a 430%defattr(644,root,root,755)
bd620db3 431%attr(755,root,root) %{_libdir}/libcpupower.so
49fba13a 432%{_includedir}/cpufreq.h
fea1e605
ER
433
434%if %{with perf}
ae4c1fd4 435%files perf
fea1e605 436%defattr(644,root,root,755)
35be6466 437%attr(755,root,root) %{_bindir}/perf
ae4c1fd4 438%attr(755,root,root) %{_bindir}/trace
fea1e605
ER
439%{_mandir}/man1/perf*.1*
440%dir %{_datadir}/perf-core
441%attr(755,root,root) %{_datadir}/perf-core/perf-archive
4f4642fc 442%attr(755,root,root) %{_datadir}/perf-core/perf-with-kcore
fea1e605
ER
443
444%dir %{_datadir}/perf-core/scripts
445
446%dir %{_datadir}/perf-core/scripts/perl
447%dir %{_datadir}/perf-core/scripts/perl/Perf-Trace-Util
448%dir %{_datadir}/perf-core/scripts/perl/Perf-Trace-Util/lib
449%dir %{_datadir}/perf-core/scripts/perl/Perf-Trace-Util/lib/Perf
450%dir %{_datadir}/perf-core/scripts/perl/Perf-Trace-Util/lib/Perf/Trace
451%{_datadir}/perf-core/scripts/perl/Perf-Trace-Util/lib/Perf/Trace/*.pm
452%dir %{_datadir}/perf-core/scripts/perl/bin
453%attr(755,root,root) %{_datadir}/perf-core/scripts/perl/bin/*
454%{_datadir}/perf-core/scripts/perl/*.pl
455
456%dir %{_datadir}/perf-core/scripts/python
457%dir %{_datadir}/perf-core/scripts/python/Perf-Trace-Util
458%dir %{_datadir}/perf-core/scripts/python/Perf-Trace-Util/lib
459%dir %{_datadir}/perf-core/scripts/python/Perf-Trace-Util/lib/Perf
460%dir %{_datadir}/perf-core/scripts/python/Perf-Trace-Util/lib/Perf/Trace
db5f9ac9 461%{_datadir}/perf-core/scripts/python/Perf-Trace-Util/lib/Perf/Trace/*.py*
fea1e605
ER
462%dir %{_datadir}/perf-core/scripts/python/bin
463%attr(755,root,root) %{_datadir}/perf-core/scripts/python/bin/*
db5f9ac9
JB
464%{_datadir}/perf-core/scripts/python/*.py*
465
eb373af4
AM
466%dir %{_libdir}/traceevent
467%dir %{_libdir}/traceevent/plugins
468%attr(755,root,root) %{_libdir}/traceevent/plugins/plugin_*.so
469
a5af5310 470%if %{with multilib}
0a3bb9dd
JR
471%files perf-vdso32
472%defattr(644,root,root,755)
473%attr(755,root,root) %{_bindir}/perf-read-vdso32
474
475%files perf-vdsox32
476%defattr(644,root,root,755)
477%attr(755,root,root) %{_bindir}/perf-read-vdsox32
478%endif
479
bc35d286 480%if %{with gtk}
db5f9ac9
JB
481%files perf-gtk
482%defattr(644,root,root,755)
ae4c1fd4 483%attr(755,root,root) %{_libdir}/libperf-gtk.so
bc35d286 484%endif
db5f9ac9 485
db5f9ac9
JB
486%files -n bash-completion-perf
487%defattr(644,root,root,755)
488/etc/bash_completion.d/perf
fea1e605 489%endif
This page took 0.145503 seconds and 4 git commands to generate.