]> git.pld-linux.org Git - packages/kf5-kcodecs.git/blame - kde5-kcodecs.spec
- new
[packages/kf5-kcodecs.git] / kde5-kcodecs.spec
CommitLineData
68edf00e
WF
1# TODO:
2# - proper place for *.pri,
3# - set ECM_MKSPECS_INSTALL_DIR in kde5-extra-cmake-modules
4# - _IMPORT_PREFIX also must be set somewhere
5# - runtime Requires if any
6# - these dirs are not own by any package
7# /usr/include/KF5
8%define _state stable
9%define orgname kcodecs
10
11Summary: String encoding
12Name: kde5-%{orgname}
13Version: 5.0.0
14Release: 0.1
15License: GPL v2+/LGPL v2.1+
16Group: X11/Libraries
17Source0: ftp://ftp.kde.org/pub/kde/%{_state}/frameworks/%{version}/%{orgname}-%{version}.tar.xz
18# Source0-md5: f87384816f5685a380b5a74c44695c7b
19URL: http://www.kde.org/
20BuildRequires: Qt5Core-devel >= 5.2.0
21BuildRequires: Qt5Test-devel
22BuildRequires: cmake >= 2.8.12
23BuildRequires: kde5-extra-cmake-modules >= 1.0.0
24BuildRequires: qt5-linguist
25BuildRequires: rpmbuild(macros) >= 1.164
26BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28%description
29KCodecs provide a collection of methods to manipulate strings using
30various encodings. It supports:
31
32- base64
33- uu
34- quoted-printable
35
36%package devel
37Summary: Header files for %{orgname} development
38Summary(pl.UTF-8): Pliki nagłówkowe dla programistów używających %{orgname}
39Group: X11/Development/Libraries
40Requires: %{name} = %{version}-%{release}
41
42%description devel
43Header files for %{orgname} development.
44
45%description devel -l pl.UTF-8
46Pliki nagłówkowe dla programistów używających %{orgname}.
47
48%prep
49%setup -q -n %{orgname}-%{version}
50
51%build
52install -d build
53cd build
54%cmake \
55 -DECM_MKSPECS_INSTALL_DIR=%{_libdir}/qt5/mkspecs/modules \
56 -D_IMPORT_PREFIX=%{_prefix} \
57 ../
58%{__make}
59
60%install
61rm -rf $RPM_BUILD_ROOT
62
63%{__make} -C build/ install \
64 DESTDIR=$RPM_BUILD_ROOT
65
66%find_lang %{orgname}5_qt --with-qm
67
68%clean
69rm -rf $RPM_BUILD_ROOT
70
71%post -p /sbin/ldconfig
72%postun -p /sbin/ldconfig
73
74%files -f %{orgname}5_qt.lang
75%defattr(644,root,root,755)
76%doc README.md
77%attr(755,root,root) %ghost %{_libdir}/libKF5Codecs.so.5
78%attr(755,root,root) %{_libdir}/libKF5Codecs.so.5.0.0
79
80%files devel
81%defattr(644,root,root,755)
82%attr(755,root,root) %{_libdir}/libKF5Codecs.so
83%{_includedir}/KF5/KCodecs
84%{_includedir}/KF5/kcodecs_version.h
85%{_libdir}/cmake/KF5Codecs
86%{_libdir}/qt5/mkspecs/modules/qt_KCodecs.pri
This page took 0.062307 seconds and 4 git commands to generate.