]> git.pld-linux.org Git - packages/kde4-krdc.git/blame - kde4-krdc.spec
- up to 4.12.0
[packages/kde4-krdc.git] / kde4-krdc.spec
CommitLineData
bd42046a
LM
1#
2# Conditional build:
3#
4%define _state stable
5%define orgname krdc
6%define qtver 4.8.3
7
8Summary: Virtual Desktops
9Summary(pl.UTF-8): Wirtualne biurka
10Name: kde4-krdc
9522aea4 11Version: 4.12.0
bd42046a
LM
12Release: 1
13License: GPL v2+
14Group: X11/Applications
15Source0: ftp://ftp.kde.org/pub/kde/%{_state}/%{version}/src/%{orgname}-%{version}.tar.xz
9522aea4 16# Source0-md5: 2d72f49674393d5b4b74bd4a94934cfd
bd42046a
LM
17URL: http://www.kde.org/
18BuildRequires: Qt3Support-devel >= %{qtver}
19BuildRequires: QtOpenGL-devel >= %{qtver}
20BuildRequires: QtScript-devel >= %{qtver}
21BuildRequires: QtSql-devel >= %{qtver}
22BuildRequires: QtSvg-devel >= %{qtver}
23BuildRequires: QtTest-devel >= %{qtver}
24BuildRequires: QtWebKit-devel >= %{qtver}
25BuildRequires: alsa-lib-devel
26BuildRequires: automoc4 >= 0.9.88
27BuildRequires: boost-devel
28BuildRequires: cmake >= 2.8.0
29BuildRequires: giflib-devel
30BuildRequires: gmp-devel
31BuildRequires: gpgme-devel
32BuildRequires: jasper-devel
33BuildRequires: kde4-kdebase-devel >= %{version}
9522aea4 34BuildRequires: kde4-kdebase-workspace-devel >= 4.11.4
bd42046a
LM
35BuildRequires: kde4-kdelibs-devel >= %{version}
36BuildRequires: kde4-kdepimlibs-devel >= %{version}
37BuildRequires: libgadu-devel >= 1.8.0
38BuildRequires: libidn-devel
39BuildRequires: libjpeg-devel
40BuildRequires: libktorrent-devel >= 1.0.2
41BuildRequires: libmms-devel
42BuildRequires: libmsn-devel >= 4.1
43BuildRequires: libotr-devel >= 4.0.0
44BuildRequires: libv4l-devel >= 0.5.8
45BuildRequires: libvncserver-devel
46BuildRequires: libxml2-progs
47BuildRequires: libxslt-devel >= 1.0.7
48BuildRequires: meanwhile-devel >= 1.0.1
49BuildRequires: mediastreamer-devel >= 2.3.0
50BuildRequires: msilbc-devel >= 2.0.1
51BuildRequires: openssl-devel >= 0.9.7d
52BuildRequires: ortp-devel >= 0.16.1-3
53BuildRequires: pcre-devel
54BuildRequires: pkgconfig
55BuildRequires: qca-devel >= 2.0
56BuildRequires: qimageblitz-devel >= 0.0.6
57BuildRequires: qt4-build >= %{qtver}
58BuildRequires: qt4-qmake >= %{qtver}
59BuildRequires: rpm-pythonprov
60BuildRequires: rpmbuild(macros) >= 1.600
61BuildRequires: shared-desktop-ontologies-devel >= 0.5
62BuildRequires: soprano-devel >= 2.4.64
63BuildRequires: speex-devel
64BuildRequires: sqlite3-devel
65BuildRequires: strigi-devel >= 0.7.2
66BuildRequires: telepathy-qt4-devel >= 0.9.0
67BuildRequires: xmms-devel
68BuildRequires: xorg-lib-libXdamage-devel
69BuildRequires: xorg-lib-libXtst-devel
70Requires: kde4-kdebase >= %{version}
71# needed for /usr/share/telepathy
72Requires: telepathy-mission-control
73Suggests: rdesktop
74Obsoletes: kde4-kdenetwork-kopete-tool-alias
75Obsoletes: kdenetwork4
76Conflicts: kdenetwork4
77BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
78
79%description
80Remote Desktop Connection is a client application that allows you to
81view or even control the desktop session on another machine that is
82running a compatible (VNC) server. You would typically use Remote
83Desktop Connection with the KDE VNC server, which is Desktop Sharing
84(also provided in this package), since it closely matches the special
85features of Remote Desktop Connection.
86
87%description -l pl.UTF-8
88Remote Desktop Connection to aplikacja kliencka umożliwiająca
89oglądanie a nawet sterowanie sesją na innej maszynie z działającym
90kompatybilnym serwerem (VNC). Zwykle używa się Remote Desktop
91Connection z użyciem serwera KDE VNC, czyli "dzielenia pulpitu" (także
92dostarczanego przez ten pakiet), jako że najlepiej pasuje do
93specjalnych możliwości Remote Desktop Connection.
94
95%prep
96%setup -q -n %{orgname}-%{version}
97
98%build
99install -d build
100cd build
101%cmake \
102 -DMOZPLUGIN_INSTALL_DIR=%{_browserpluginsdir} \
103 ../
104
105%{__make}
106
107%install
108rm -rf $RPM_BUILD_ROOT
109
110%{__make} -C build install \
111 DESTDIR=$RPM_BUILD_ROOT \
112 kde_htmldir=%{_kdedocdir}
113
114%clean
115rm -rf $RPM_BUILD_ROOT
116
117%post -p /sbin/ldconfig
118%postun -p /sbin/ldconfig
119
120%files
121%defattr(644,root,root,755)
122%attr(755,root,root) %{_bindir}/krdc
123%attr(755,root,root) %{_bindir}/krdc_rfb_approver
124%attr(755,root,root) %ghost %{_libdir}/libkrdccore.so.?
125%attr(755,root,root) %{_libdir}/libkrdccore.so.*.*.*
126%attr(755,root,root) %{_libdir}/kde4/krdc_rdpplugin.so
127%attr(755,root,root) %{_libdir}/kde4/krdc_testplugin.so
128%attr(755,root,root) %{_libdir}/kde4/krdc_vncplugin.so
129%attr(755,root,root) %{_libdir}/kde4/kcm_krdc_rdpplugin.so
130%attr(755,root,root) %{_libdir}/kde4/kcm_krdc_vncplugin.so
131%{_datadir}/apps/krdc
132%{_datadir}/apps/krdc_rfb_approver
133%{_datadir}/config.kcfg/krdc.kcfg
134%{_datadir}/kde4/services/ServiceMenus/smb2rdc.desktop
135%{_datadir}/kde4/services/rdp.protocol
136%{_datadir}/kde4/services/vnc.protocol
137%{_datadir}/kde4/services/krdc_rdp.desktop
138%{_datadir}/kde4/services/krdc_rdp_config.desktop
139%{_datadir}/kde4/services/krdc_test.desktop
140%{_datadir}/kde4/services/krdc_vnc.desktop
141%{_datadir}/kde4/services/krdc_vnc_config.desktop
142%{_datadir}/kde4/servicetypes/krdc_plugin.desktop
143%{_desktopdir}/kde4/krdc.desktop
144%{_kdedocdir}/en/krdc
145%{_datadir}/dbus-1/services/org.freedesktop.Telepathy.Client.kr*.service
146%{_datadir}/telepathy/clients/kr*.client
147
This page took 0.061841 seconds and 4 git commands to generate.