]> git.pld-linux.org Git - packages/ka5-step.git/blame - ka5-step.spec
- bcond_with tests
[packages/ka5-step.git] / ka5-step.spec
CommitLineData
da94976b
WF
1#
2# Conditional build:
3%bcond_with tests # build with tests
f39909f6 4%define kdeappsver 21.12.3
fcbccbcb 5%define kframever 5.56.0
0962c153 6%define qtver 5.9.0
9a07b1d5
WF
7%define kaname step
8Summary: step
9Name: ka5-%{kaname}
f39909f6 10Version: 21.12.3
08619aff 11Release: 1
9a07b1d5
WF
12License: GPL v2+/LGPL v2.1+
13Group: X11/Applications
d9da16fd 14Source0: http://download.kde.org/stable/release-service/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
f39909f6 15# Source0-md5: f70c52584b6a4463282913fb11a6bd3a
9a07b1d5
WF
16URL: http://www.kde.org/
17BuildRequires: Qt5Core-devel >= %{qtver}
0962c153
WF
18BuildRequires: Qt5Gui-devel >= 5.11.1
19BuildRequires: Qt5OpenGL-devel
20BuildRequires: Qt5Svg-devel
21BuildRequires: Qt5Test-devel
22BuildRequires: Qt5Widgets-devel >= 5.11.1
23BuildRequires: Qt5Xml-devel
9a07b1d5 24BuildRequires: cmake >= 2.8.12
0962c153
WF
25BuildRequires: eigen3 >= 3.2.2
26BuildRequires: gettext-devel
fcbccbcb
WF
27BuildRequires: kf5-extra-cmake-modules >= %{kframever}
28BuildRequires: kf5-kconfig-devel >= %{kframever}
29BuildRequires: kf5-kcrash-devel >= %{kframever}
30BuildRequires: kf5-khtml-devel >= %{kframever}
31BuildRequires: kf5-kiconthemes-devel >= %{kframever}
32BuildRequires: kf5-knewstuff-devel >= %{kframever}
33BuildRequires: kf5-kplotting-devel >= %{kframever}
edf74d46 34BuildRequires: ninja
9a07b1d5
WF
35BuildRequires: qt5-build >= %{qtver}
36BuildRequires: rpmbuild(macros) >= 1.164
37BuildRequires: shared-mime-info
38BuildRequires: tar >= 1:1.22
39BuildRequires: xz
40BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42%description
0962c153
WF
43Step is an interactive physical simulator. It allows you to explore
44the physical world through simulations.
45
46Features
47
48- Classical mechanical simulation in two dimensions
49- Particles, springs with damping, gravitational and coulomb forces
50- Rigid bodies
51- Collision detection (currently only discrete) and handling
52- Soft (deformable) bodies simulated as user-editable
53 particles-springs system, sound waves
54- Molecular dynamics (currently using Lennard-Jones potential): gas
55 and liquid, condensation and evaporation, calculation of macroscopic
56 quantities and their variances
57- Units conversion and expression calculation: you can enter something
58 like "(2 days + 3 hours) * 80 km/h" and it will be accepted as
59 distance value (requires libqalculate)
60- Errors calculation and propagation: you can enter values like "1.3 ±
61 0.2" for any property and errors for all dependent properties will be
62 calculated using statistical formulas
63- Solver error estimation: errors introduced by the solver is
64 calculated and added to user-entered errors
65- Several different solvers: up to 8th order, explicit and implicit,
66 with or without adaptive timestep (most of the solvers require the GSL
67 library)
68- Controller tool to easily control properties during simulation (even
69 with custom keyboard shortcuts)
70- Tools to visualize results: graph, meter, tracer
71- Context information for all objects, integrated wikipedia browser
72- Collection of example experiments, more can be downloaded with
73 KNewStuff
74- Integrated tutorials
9a07b1d5
WF
75
76%prep
77%setup -q -n %{kaname}-%{version}
78
79%build
80install -d build
81cd build
82%cmake \
edf74d46 83 -G Ninja \
da94976b 84 %{!?with_tests:-DBUILD_TESTING=OFF} \
fcbccbcb 85 -DHTML_INSTALL_DIR=%{_kdedocdir} \
9a07b1d5
WF
86 -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
87 ..
edf74d46 88%ninja_build
9a07b1d5 89
da94976b
WF
90%if %{with tests}
91ctest
92%endif
93
94
9a07b1d5
WF
95%install
96rm -rf $RPM_BUILD_ROOT
edf74d46 97%ninja_install -C build
9a07b1d5 98
fcbccbcb 99%find_lang %{kaname} --all-name --with-kde --with-qm
9a07b1d5
WF
100
101%clean
102rm -rf $RPM_BUILD_ROOT
103
104%files -f %{kaname}.lang
105%defattr(644,root,root,755)
9a07b1d5
WF
106%attr(755,root,root) %{_bindir}/step
107%{_desktopdir}/org.kde.step.desktop
108%{_datadir}/config.kcfg/step.kcfg
109%{_iconsdir}/hicolor/128x128/apps/step.png
110%{_iconsdir}/hicolor/16x16/apps/step.png
111%{_iconsdir}/hicolor/22x22/actions/pointer.png
112%{_iconsdir}/hicolor/22x22/actions/step_object_Anchor.png
113%{_iconsdir}/hicolor/22x22/actions/step_object_Box.png
114%{_iconsdir}/hicolor/22x22/actions/step_object_ChargedParticle.png
115%{_iconsdir}/hicolor/22x22/actions/step_object_CircularMotor.png
116%{_iconsdir}/hicolor/22x22/actions/step_object_Controller.png
117%{_iconsdir}/hicolor/22x22/actions/step_object_CoulombForce.png
118%{_iconsdir}/hicolor/22x22/actions/step_object_Disk.png
119%{_iconsdir}/hicolor/22x22/actions/step_object_Gas.png
120%{_iconsdir}/hicolor/22x22/actions/step_object_GasParticle.png
121%{_iconsdir}/hicolor/22x22/actions/step_object_Graph.png
122%{_iconsdir}/hicolor/22x22/actions/step_object_GravitationForce.png
123%{_iconsdir}/hicolor/22x22/actions/step_object_LinearMotor.png
124%{_iconsdir}/hicolor/22x22/actions/step_object_Meter.png
125%{_iconsdir}/hicolor/22x22/actions/step_object_Note.png
126%{_iconsdir}/hicolor/22x22/actions/step_object_Particle.png
127%{_iconsdir}/hicolor/22x22/actions/step_object_Pin.png
128%{_iconsdir}/hicolor/22x22/actions/step_object_Polygon.png
129%{_iconsdir}/hicolor/22x22/actions/step_object_Rope.png
130%{_iconsdir}/hicolor/22x22/actions/step_object_SoftBody.png
131%{_iconsdir}/hicolor/22x22/actions/step_object_Spring.png
132%{_iconsdir}/hicolor/22x22/actions/step_object_Stick.png
133%{_iconsdir}/hicolor/22x22/actions/step_object_Tracer.png
134%{_iconsdir}/hicolor/22x22/actions/step_object_WeightForce.png
135%{_iconsdir}/hicolor/22x22/apps/step.png
136%{_iconsdir}/hicolor/32x32/apps/step.png
137%{_iconsdir}/hicolor/48x48/apps/step.png
138%{_iconsdir}/hicolor/64x64/apps/step.png
139%{_datadir}/kxmlgui5/step
140%{_datadir}/metainfo/org.kde.step.appdata.xml
141%{_datadir}/step
d9da16fd
WF
142%{_datadir}/mime/packages/org.kde.step.xml
143%{_datadir}/knsrcfiles/step.knsrc
This page took 0.105102 seconds and 4 git commands to generate.