]> git.pld-linux.org Git - packages/ka5-ktouch.git/blame - ka5-ktouch.spec
rebuild with qt5-5.15.6
[packages/ka5-ktouch.git] / ka5-ktouch.spec
CommitLineData
94a68838
WF
1#
2# Conditional build:
3%bcond_with tests # build with tests
470cff09 4%define kdeappsver 22.08.1
3cbb399a
WF
5%define kframever 5.94.0
6%define qtver 5.15.2
4dabf45e
WF
7%define kaname ktouch
8Summary: ktouch
9Name: ka5-%{kaname}
470cff09 10Version: 22.08.1
23678041 11Release: 2
4dabf45e
WF
12License: GPL v2+/LGPL v2.1+
13Group: X11/Libraries
85959ec5 14Source0: https://download.kde.org/stable/release-service/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
470cff09 15# Source0-md5: 693c0e45a3f26c98dac239f0e179f591
4dabf45e
WF
16URL: http://www.kde.org/
17BuildRequires: Qt5Core-devel >= %{qtver}
18BuildRequires: Qt5Gui-devel
19BuildRequires: Qt5Network-devel
20BuildRequires: Qt5Qml-devel
567df268 21BuildRequires: Qt5Quick-controls2-devel
4dabf45e
WF
22BuildRequires: Qt5Quick-devel
23BuildRequires: Qt5Script-devel
24BuildRequires: Qt5Sql-devel
25BuildRequires: Qt5Test-devel
26BuildRequires: Qt5Widgets-devel
27BuildRequires: Qt5X11Extras-devel
28BuildRequires: Qt5Xml-devel
29BuildRequires: Qt5XmlPatterns-devel
30BuildRequires: gettext-devel
7bd8aa48
WF
31BuildRequires: kf5-extra-cmake-modules >= %{kframever}
32BuildRequires: kf5-kcmutils-devel >= %{kframever}
33BuildRequires: kf5-kcompletion-devel >= %{kframever}
34BuildRequires: kf5-kconfig-devel >= %{kframever}
35BuildRequires: kf5-kconfigwidgets-devel >= %{kframever}
36BuildRequires: kf5-kcoreaddons-devel >= %{kframever}
37BuildRequires: kf5-kdeclarative-devel >= %{kframever}
38BuildRequires: kf5-kdoctools-devel >= %{kframever}
39BuildRequires: kf5-ki18n-devel >= %{kframever}
40BuildRequires: kf5-kitemviews-devel >= %{kframever}
41BuildRequires: kf5-ktextwidgets-devel >= %{kframever}
42BuildRequires: kf5-kwidgetsaddons-devel >= %{kframever}
43BuildRequires: kf5-kwindowsystem-devel >= %{kframever}
44BuildRequires: kf5-kxmlgui-devel >= %{kframever}
09dcff70 45BuildRequires: ninja
4dabf45e
WF
46BuildRequires: qt5-build >= %{qtver}
47BuildRequires: qt5-qtdeclarative >= %{qtver}
48BuildRequires: rpmbuild(macros) >= 1.164
49BuildRequires: shared-mime-info
50BuildRequires: tar >= 1:1.22
57b7f1c7 51BuildRequires: xorg-lib-libxkbfile-devel
4dabf45e
WF
52BuildRequires: xz
53BuildRequires: zlib-devel
54BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
55
56%description
57KTouch is a program to learn and practice touch typing. Every finger
58has its place on the keyboard with associated keys to press. Starting
59with only a few keys to remember you will advance through different
60training levels where additional keys are introduced.
61
8b8e25fe
WF
62%description -l pl.UTF-8
63KTouch jest programem do nauki i ćwiczenia szybkiego pisania na
64klawiaturze. Każdy palec ma swoje miejsce na klawiaturze i skojarzone
567df268 65klawisze, które ma naciskać. Zaczynając od kilku klawiszy do
4dcc5163
WF
66zapamiętania, będziesz rozwijał swoje umiejętności przez różne
67poziomy treningu, gdzie będą wprowadzane dodatkowe klawisze.
8b8e25fe 68
4dabf45e
WF
69%prep
70%setup -q -n %{kaname}-%{version}
71
72%build
73install -d build
74cd build
75%cmake \
09dcff70 76 -G Ninja \
94a68838 77 %{!?with_tests:-DBUILD_TESTING=OFF} \
7bd8aa48 78 -DHTML_INSTALL_DIR=%{_kdedocdir} \
4dabf45e
WF
79 -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
80 ..
09dcff70 81%ninja_build
4dabf45e 82
94a68838
WF
83%if %{with tests}
84ctest
85%endif
86
87
4dabf45e
WF
88%install
89rm -rf $RPM_BUILD_ROOT
09dcff70 90%ninja_install -C build
4dabf45e
WF
91
92%find_lang %{kaname} --all-name --with-kde --with-qm
93
94%clean
95rm -rf $RPM_BUILD_ROOT
96
97%files -f %{kaname}.lang
98%defattr(644,root,root,755)
99%attr(755,root,root) %{_bindir}/ktouch
100%{_desktopdir}/org.kde.ktouch.desktop
101%{_datadir}/config.kcfg/ktouch.kcfg
102%{_iconsdir}/hicolor/128x128/apps/ktouch.png
103%{_iconsdir}/hicolor/16x16/apps/ktouch.png
104%{_iconsdir}/hicolor/22x22/apps/ktouch.png
105%{_iconsdir}/hicolor/32x32/apps/ktouch.png
106%{_iconsdir}/hicolor/48x48/apps/ktouch.png
107%{_iconsdir}/hicolor/scalable/apps/ktouch.svgz
108%{_datadir}/ktouch
109%{_mandir}/ca/man1/ktouch.1*
110%{_mandir}/de/man1/ktouch.1*
111%{_mandir}/es/man1/ktouch.1*
112%{_mandir}/et/man1/ktouch.1*
113%{_mandir}/fr/man1/ktouch.1*
114%{_mandir}/gl/man1/ktouch.1*
115%{_mandir}/it/man1/ktouch.1*
116%{_mandir}/man1/ktouch.1*
117%{_mandir}/nl/man1/ktouch.1*
118%{_mandir}/pl/man1/ktouch.1*
119%{_mandir}/pt/man1/ktouch.1*
120%{_mandir}/pt_BR/man1/ktouch.1*
4dcc5163 121%{_mandir}/ru/man1/ktouch.1*
4dabf45e
WF
122%{_mandir}/sv/man1/ktouch.1*
123%{_mandir}/uk/man1/ktouch.1*
124%{_datadir}/metainfo/org.kde.ktouch.appdata.xml
This page took 0.352331 seconds and 4 git commands to generate.