]> git.pld-linux.org Git - packages/ka5-kdevelop.git/blame - ka5-kdevelop.spec
- missing dirs
[packages/ka5-kdevelop.git] / ka5-kdevelop.spec
CommitLineData
31c1fc50
RT
1#
2# Conditional build:
29f462f3
WF
3%bcond_with tests # build with tests
4
3821706a 5%define kdeappsver 22.04.1
d8690f20
BS
6%define kframever 5.78.0
7%define qtver 5.15.0
8%define kaname kdevelop
31c1fc50
RT
9
10Summary: KDE Integrated Development Environment
11Summary(de.UTF-8): KDevelop ist eine grafische Entwicklungsumgebung für KDE
12Summary(pl.UTF-8): Zintegrowane środowisko programisty dla KDE
13Summary(pt_BR.UTF-8): Ambiente Integrado de Desenvolvimento para o KDE
14Summary(zh_CN.UTF-8): KDE C/C++集成开发环境
0e20598c 15Name: ka5-kdevelop
3821706a 16Version: 22.04.1
71a46b0c 17Release: 2
31c1fc50
RT
18License: GPL
19Group: X11/Development/Tools
d8690f20 20Source0: https://download.kde.org/stable/release-service/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
3821706a 21# Source0-md5: c25d8e355ef3a2f5835c752032ac3cb0
31c1fc50 22URL: http://www.kdevelop.org/
60398f56
WF
23BuildRequires: Qt5Help-devel >= %{qtver}
24BuildRequires: Qt5WebEngine-devel >= %{qtver}
d8690f20 25BuildRequires: astyle-devel >= 3.1
60398f56 26BuildRequires: clang-devel
fcc99fb8 27BuildRequires: cmake >= 2.8.9
60398f56 28BuildRequires: docbook-dtd45-xml
86271305 29BuildRequires: docbook-style-xsl
6e6fe4ab 30BuildRequires: gettext-tools
2998fe97 31BuildRequires: ka5-libkomparediff2-devel
0e20598c 32BuildRequires: ka5-okteta-devel
d8690f20
BS
33BuildRequires: kf5-kcrash-devel >= %{kframever}
34BuildRequires: kf5-kdoctools-devel >= %{kframever}
d8690f20 35BuildRequires: kf5-krunner-devel >= %{kframever}
60398f56 36BuildRequires: kf5-plasma-framework-devel >= %{kframever}
d8690f20 37BuildRequires: kf5-syntax-highlighting-devel >= %{kframever}
683c5b4d 38BuildRequires: kp5-libksysguard-devel
d8690f20 39BuildRequires: qt5-assistant >= %{qtver}
0e20598c 40
89fa64f2 41BuildRequires: libstdc++-devel >= 3.3
60398f56 42BuildRequires: ninja
86271305 43BuildRequires: pkgconfig
05f256a4 44BuildRequires: rpmbuild(macros) >= 1.600
21807784 45BuildRequires: zlib-devel >= 1.2.0
31c1fc50 46BuildConflicts: star
ff86f956 47Requires: libstdc++-gdb
3cc6df6e
BZ
48Requires(post,postun): desktop-file-utils
49Requires(post,postun): shared-mime-info
31c1fc50
RT
50BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
d8690f20
BS
52%define _noautoreqfiles .*\\.zshrc
53
31c1fc50
RT
54%description
55The KDevelop Integrated Development Environment provides many features
56that developers need as well as providing a unified interface to
57programs like gdb, the C/C++ compiler, and make.
58
59KDevelop manages or provides: all development tools needed for C++
60programming like Compiler, Linker, automake and autoconf; KAppWizard,
61which generates complete, ready-to-go sample applications;
62Classgenerator, for creating new classes and integrating them into the
63current project; File management for sources, headers, documentation
64etc. to be included in the project; The creation of User-Handbooks
65written with SGML and the automatic generation of HTML-output with the
66KDE look and feel; Automatic HTML-based API-documentation for your
67project's classes with cross-references to the used libraries;
68Internationalization support for your application, allowing
69translators to easily add their target language to a project;
70
71KDevelop also includes WYSIWYG (What you see is what you get)-creation
72of user interfaces with a built-in dialog editor; Debugging your
73application by integrating KDbg; Editing of project-specific pixmaps
74with KIconEdit; The inclusion of any other program you need for
75development by adding it to the "Tools"-menu according to your
76individual needs.
77
78%description -l de.UTF-8
79KDevelop ist eine grafische Entwicklungsumgebung für KDE.
80
81Das KDevelop-Projekt wurde 1998 begonnen, um eine einfach zu
c2f8406a 82bedienende grafische (integrierte) Entwicklungsumgebung für C++ und C
31c1fc50
RT
83auf Unix-basierten Betriebssystemen bereitzustellen. Seit damals ist
84die KDevelop-IDE öffentlich unter der GPL erhältlich und unterstützt
85u. a. Qt-, KDE-, GNOME-, C++- und C-Projekte.
86
87%description -l pl.UTF-8
88KDevelop to zintegrowane środowisko programistyczne dla KDE, dające
89wiele możliwości przydatnych programistom oraz zunifikowany interfejs
90do programów typu gdb, kompilator C/C++ oraz make.
91
92KDevelop obsługuje lub zawiera: wszystkie narzędzia programistyczne
93potrzebne do programowania w C++ jak kompilator, linker, automake,
94autoconf; KAppWizard, generujący kompletne, gotowe do uruchomienia,
95proste aplikacje; Classgenerator do tworzenia nowych klas i włączania
96ich do projektu; zarządzanie plikami źródłowymi, nagłówkowymi,
97dokumentacją itp.; tworzenie podręczników użytkownika pisanych w SGML
98i automatyczne generowanie wyjścia HTML pasującego do KDE;
99automatyczne tworzenie dokumentacji API w HTML do klas projektu z
100odniesieniami do używanych bibliotek; wsparcie dla
101internacjonalizacji, pozwalające tłumaczom łatwo dodawać pliki z
102tłumaczeniami do projektu.
103
104KDevelop ma także tworzenie interfejsów użytkownika przy użyciu
105edytora dialogów WYSIWYG; odpluskwianie aplikacji poprzez integrację z
106KDbg; edycję ikon przy pomocy KIconEdit; dołączanie innych programów
107potrzebnych do programowania przez dodanie ich do menu Tools według
108własnych potrzeb.
109
6ad423a8 110%package devel
111Summary: kdevelop - header files and development documentation
112Summary(pl.UTF-8): kdevelop - pliki nagłówkowe i dokumentacja
113Group: X11/Development/Libraries
114Requires: %{name} = %{version}-%{release}
115
116%description devel
117This package contains header files and development documentation for
118kdevelop.
119
120%description devel -l pl.UTF-8
121Pakiet ten zawiera pliki nagłówkowe i dokumentację potrzebną przy
122pisaniu własnych programów wykorzystujących kdevelop.
123
d8690f20
BS
124%package -n bash-completion-kdevelop
125Summary: Bash completion for KDevelop commands
126Summary(pl.UTF-8): Bashowe uzupełnianie parametrów dla poleceń KDevelop
127Group: Applications/Shells
128Requires: %{name} = %{version}-%{release}
129Requires: bash-completion >= 2.0
130%{?noarchpackage}
131
132%description -n bash-completion-kdevelop
133Bash completion for KDevelop commands.
134
135%description -n bash-completion-kdevelop -l pl.UTF-8
136Bashowe uzupełnianie parametrów dla poleceń KDevelop.
137
31c1fc50 138%prep
d8690f20 139%setup -q -n %{kaname}-%{version}
31c1fc50
RT
140
141%build
4940a978 142install -d build
31c1fc50
RT
143cd build
144%cmake \
60398f56 145 -G Ninja \
29f462f3 146 %{!?with_tests:-DBUILD_TESTING=OFF} \
60398f56 147 -DHTML_INSTALL_DIR=%{_kdedocdir} \
0e20598c 148 -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
60398f56
WF
149 -DFORCE_BASH_COMPLETION_INSTALLATION=ON \
150 ..
151%ninja_build
31c1fc50 152
29f462f3
WF
153%if %{with tests}
154ctest
155%endif
156
157
31c1fc50
RT
158%install
159rm -rf $RPM_BUILD_ROOT
60398f56 160%ninja_install -C build
31c1fc50 161
d8690f20 162%find_lang %{kaname} --all-name --with-kde
8a932502 163
31c1fc50
RT
164%clean
165rm -rf $RPM_BUILD_ROOT
166
3cc6df6e
BZ
167%post
168/sbin/ldconfig
169%update_mime_database
170%update_desktop_database
171
172%postun
173/sbin/ldconfig
174%update_mime_database
175%update_desktop_database_postun
31c1fc50 176
d8690f20 177%files -f %{kaname}.lang
31c1fc50 178%defattr(644,root,root,755)
31c1fc50 179%attr(755,root,root) %{_bindir}/kdevelop
3c159b18 180%attr(755,root,root) %{_bindir}/kdevelop!
0e20598c 181%attr(755,root,root) %{_bindir}/kdev_includepathsconverter
d8690f20
BS
182%attr(755,root,root) %{_libdir}/libKDevClangPrivate.so.*
183%attr(755,root,root) %{_libdir}/libKDevCMakeCommon.so.*
184%attr(755,root,root) %{_libdir}/libKDevCompileAnalyzerCommon.so.*
cb22de41
ŁM
185%attr(755,root,root) %{_libdir}/libKDevelopSessionsWatch.so
186%dir %{_libdir}/qt5/plugins/kf5/krunner
187%attr(755,root,root) %{_libdir}/qt5/plugins/kf5/krunner/krunner_kdevelopsessions.so
188%dir %{_libdir}/qt5/qml/org/kde/plasma/private/kdevelopsessions
189%attr(755,root,root) %{_libdir}/qt5/qml/org/kde/plasma/private/kdevelopsessions/libkdevelopsessionsplugin.so
a2edda48 190%{_libdir}/qt5/qml/org/kde/plasma/private/kdevelopsessions/qmldir
cb22de41
ŁM
191%dir %{_datadir}/kdevplatform
192%dir %{_datadir}/kdevplatform/shellutils
193%{_datadir}/kdevplatform/shellutils/.zshrc
0e20598c
BS
194%{_datadir}/kdevappwizard
195%{_datadir}/kdevclangsupport
0e20598c
BS
196%{_datadir}/kdevelop
197%{_datadir}/kdevfiletemplates
198%{_datadir}/kdevgdb
683c5b4d 199%{_datadir}/kdevlldb
0e20598c 200%{_datadir}/kdevmanpage
0e20598c
BS
201%{_datadir}/kdevqmljssupport
202%{_datadir}/knotifications5/*
d8690f20 203%{_datadir}/knsrcfiles/kdev*.knsrc
683c5b4d 204%{_datadir}/metainfo/*
0e20598c
BS
205%{_datadir}/mime/packages/*
206%{_datadir}/kservices5/*
207%{_datadir}/plasma/plasmoids/kdevelopsessions
0e20598c 208%{_desktopdir}/org.kde.kdevelop.desktop
683c5b4d 209%{_desktopdir}/org.kde.kdevelop_*.desktop
6ad423a8 210%{_iconsdir}/*/*x*/*/*.png
2998fe97 211%{_datadir}/qlogging-categories5/kdev*.categories
683c5b4d
BS
212
213#kdevplatform
214%attr(755,root,root) %{_bindir}/kdev_dbus_socket_transformer
215%attr(755,root,root) %{_bindir}/kdev_format_source
216%attr(755,root,root) %{_bindir}/kdevplatform_shell_environment.sh
217%attr(755,root,root) %{_libdir}/libKDevPlatformDebugger.so.*.*.*
a2edda48 218%ghost %{_libdir}/libKDevPlatformDebugger.so.??
683c5b4d 219%attr(755,root,root) %{_libdir}/libKDevPlatformDocumentation.so.*.*.*
a2edda48 220%ghost %{_libdir}/libKDevPlatformDocumentation.so.??
683c5b4d 221%attr(755,root,root) %{_libdir}/libKDevPlatformInterfaces.so.*.*.*
a2edda48 222%ghost %{_libdir}/libKDevPlatformInterfaces.so.??
683c5b4d 223%attr(755,root,root) %{_libdir}/libKDevPlatformLanguage.so.*.*.*
a2edda48 224%ghost %{_libdir}/libKDevPlatformLanguage.so.??
683c5b4d 225%attr(755,root,root) %{_libdir}/libKDevPlatformOutputView.so.*.*.*
a2edda48 226%ghost %{_libdir}/libKDevPlatformOutputView.so.??
683c5b4d 227%attr(755,root,root) %{_libdir}/libKDevPlatformProject.so.*.*.*
a2edda48 228%ghost %{_libdir}/libKDevPlatformProject.so.??
683c5b4d 229%attr(755,root,root) %{_libdir}/libKDevPlatformSerialization.so.*.*.*
a2edda48 230%ghost %{_libdir}/libKDevPlatformSerialization.so.??
683c5b4d 231%attr(755,root,root) %{_libdir}/libKDevPlatformShell.so.*.*.*
a2edda48 232%ghost %{_libdir}/libKDevPlatformShell.so.??
683c5b4d 233%attr(755,root,root) %{_libdir}/libKDevPlatformSublime.so.*.*.*
a2edda48 234%ghost %{_libdir}/libKDevPlatformSublime.so.??
683c5b4d 235%attr(755,root,root) %{_libdir}/libKDevPlatformUtil.so.*.*.*
a2edda48 236%ghost %{_libdir}/libKDevPlatformUtil.so.??
683c5b4d 237%attr(755,root,root) %{_libdir}/libKDevPlatformVcs.so.*.*.*
a2edda48 238%ghost %{_libdir}/libKDevPlatformVcs.so.??
71a46b0c
KM
239%dir %{_libdir}/qt5/plugins/grantlee
240%dir %{_libdir}/qt5/plugins/grantlee/5.2
683c5b4d 241%attr(755,root,root) %{_libdir}/qt5/plugins/grantlee/*/kdev_filters.so
71a46b0c
KM
242%dir %{_libdir}/qt5/plugins/kdevplatform
243%dir %{_libdir}/qt5/plugins/kdevplatform/36
cb22de41
ŁM
244%attr(755,root,root) %{_libdir}/qt5/plugins/kdevplatform/*/kdev*.so
245
683c5b4d 246%{_libdir}/qt5/qml/org/kde/kdevplatform/qmldir
71a46b0c 247%dir %{_libdir}/qt5/qml/org/kde/kdevplatform
683c5b4d
BS
248%attr(755,root,root) %{_libdir}/qt5/qml/org/kde/kdevplatform/libkdevelopdashboarddeclarativeplugin.so
249%{_datadir}/kdevcodegen
250%{_datadir}/kdevcodeutils
251%{_datadir}/kservicetypes5/kdevelopplugin.desktop
252%{_iconsdir}/hicolor/*/actions/*.svg
253%{_iconsdir}/hicolor/*/apps/*.svg
254
6ad423a8 255
256%files devel
257%defattr(644,root,root,755)
0e20598c
BS
258%{_libdir}/cmake/KDevelop
259%{_includedir}/kdevelop
683c5b4d
BS
260
261#kdevplatform
262%{_includedir}/kdevplatform
263%{_libdir}/libKDevPlatformDebugger.so
264%{_libdir}/libKDevPlatformDocumentation.so
265%{_libdir}/libKDevPlatformInterfaces.so
266%{_libdir}/libKDevPlatformLanguage.so
267%{_libdir}/libKDevPlatformOutputView.so
268%{_libdir}/libKDevPlatformProject.so
269%{_libdir}/libKDevPlatformSerialization.so
270%{_libdir}/libKDevPlatformShell.so
271%{_libdir}/libKDevPlatformSublime.so
683c5b4d
BS
272%{_libdir}/libKDevPlatformUtil.so
273%{_libdir}/libKDevPlatformVcs.so
d8690f20
BS
274%dir %{_libdir}/cmake/KDevPlatform
275%{_libdir}/cmake/KDevPlatform/KDevPlatformConfig.cmake
276%{_libdir}/cmake/KDevPlatform/KDevPlatformConfigVersion.cmake
277%{_libdir}/cmake/KDevPlatform/KDevPlatformMacros.cmake
278%{_libdir}/cmake/KDevPlatform/KDevPlatformTargets.cmake
279%{_libdir}/cmake/KDevPlatform/KDevPlatformTargets-pld.cmake
280
281%files -n bash-completion-kdevelop
282%defattr(644,root,root,755)
283%{bash_compdir}/kdevelop
This page took 0.227662 seconds and 4 git commands to generate.