]> git.pld-linux.org Git - packages/jpcap.git/blame - jpcap.spec
recreate jars, fixed %install
[packages/jpcap.git] / jpcap.spec
CommitLineData
c069375f
TP
1Summary: A tool for capturing and visualizing network traffic
2Name: jpcap
3Version: 0.01.16
4Release: 1
5License: MPL 1.1
6Group: Development/Languages/Java
7Source0: http://downloads.sourceforge.net/jpcap/%{name}-%{version}.tar.gz
8# Source0-md5: 2307e2956dc2d4da1e9891bf22e8f7b4
9URL: http://jpcap.sourceforge.net/
10BuildRequires: jpackage-utils
11BuildRequires: jdk >= 1.2
12BuildRequires: libpcap-devel >= 0.4
13BuildRequires: sed >= 4.0
14BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16%description
17Jpcap captures network packets and allows the visualization of traffic
18patterns in real-time. Users can define filter expressions, examine packet
19data and manipulate graphical representations of hosts and network
20communications.
21
22Included is a jar file containing the jpcap packet capture library
23which can be used by Java developers who wish to create their own
24packet capture applications.
25
26Internally, jpcap provides Java-native bindings to and relies on libpcap.
27Jpcap also requires JDK1.2. JDK1.3+ is recommended.
28
29Install jpcap if you'd like to see what's happening on your network.
30
31%prep
32%setup -q
33sed -e 's|-lnsl /usr/lib/libpcap.a|-lnsl -lpcap|' -i src/java/net/sourceforge/jpcap/capture/makefile
34sed -e 's|for(;ifr < last; (char\*)ifr += ifrSize) {|for(;ifr < last; ifr = (ifreq*)((char*)ifr + ifrSize)) {|' -i src/java/net/sourceforge/jpcap/capture/jpcap.c
35
36%build
37MAKE_HOME=`pwd`/make
38CLASSPATH=`pwd`/src/java:`pwd`/thirdParty/jars/junit.jar:`pwd`/thirdParty/jars/fooware_CommandLine-1.0.jar:`pwd`/thirdParty/jars/dev-classes_net.ultrametrics-0.03.jar
39OSTYPE=linux
40export OSTYPE MAKE_HOME CLASSPATH
41%{__make} clean
42%{__make}
43
93db76d9
TP
44export RELEASE_HOME=`pwd`
45make -C src/java/net/sourceforge/jpcap release
46
c069375f
TP
47%install
48rm -rf $RPM_BUILD_ROOT
49
93db76d9
TP
50MAKE_HOME=`pwd`/make
51RELEASE_HOME=`pwd`
52export RELEASE_HOME MAKE_HOME
c069375f
TP
53%{__make} setup_pkgroot \
54 PKG_ROOT=$RPM_BUILD_ROOT
55
56%clean
57rm -rf $RPM_BUILD_ROOT
58
59%files
60%defattr(644,root,root,755)
61%doc README docs
62# src/java/net/sourceforge/jpcap/{tutorial,README}
63%attr(755,root,root) %{_bindir}/%{name}
64%attr(755,root,root) %{_libdir}/%{name}.so
65%{_libdir}/%{name}-%{version}
This page took 0.075242 seconds and 4 git commands to generate.