]> git.pld-linux.org Git - packages/ixion.git/blame - ixion.spec
- release 3 (by relup.sh)
[packages/ixion.git] / ixion.spec
CommitLineData
fb44557a
JB
1#
2# Conditional build:
3%bcond_without static_libs # static library
4#
5Summary: Generic formula compulation library
6Summary(pl.UTF-8): Ogólna biblioteka do obliczania wzorów
7Name: ixion
ef81fbd2 8Version: 0.9.1
7ac83649 9Release: 3
fb44557a
JB
10License: MIT
11Group: Libraries
ef81fbd2
JB
12#Source0Download: https://gitlab.com/ixion/ixion
13Source0: http://kohei.us/files/ixion/src/libixion-%{version}.tar.xz
14# Source0-md5: d292f6d62847f2305178459390842eac
15URL: https://gitlab.com/ixion/ixion
b8fb894e 16BuildRequires: autoconf >= 2.63
f369ddf3 17BuildRequires: automake >= 1:1.11
fb44557a
JB
18BuildRequires: boost-devel >= 1.36
19BuildRequires: libstdc++-devel
940f72a8 20BuildRequires: libtool >= 2:2
ef81fbd2
JB
21BuildRequires: mdds-devel >= 0.12.0
22BuildRequires: python >= 1:2.7.0
23BuildRequires: tar >= 1:1.22
24BuildRequires: xz
fb44557a
JB
25BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27%description
28Ixion aims to provide a library for calculating the results of formula
29expressions stored in multiple named targets, or "cells". The cells
30can be referenced from each other, and the library takes care of
31resolving their dependencies automatically upon calculation. The
32caller can run the calculation routine either in a single-threaded
33mode, or a multi-threaded mode. The library also supports
34re-calculation where the contents of one or more cells have been
35modified since the last calculation, and a partial calculation of only
36the affected cells gets performed. It is written entirely in C++, and
37makes extensive use of the boost library to achieve portability across
38different platforms.
39
40%description -l pl.UTF-8
41Projekt Ixion ma na celu dostarczenie biblioteki do obliczania wyników
42wyrażeń określonych wzorami zapisanymi w wielu nazwanych miejscach -
43"komórkach". Komórki mogą odwoływać się do siebie nawzajem, a
44biblioteka dba o automatyczne rozwiązywanie ich zależności przy
45obliczeniach. Procedura obliczająca może być wywołana w trybie
46jednowątkowym lub wielowątkowym. Biblioteka obsługuje także ponowne
47przeliczanie w przypadku zmiany zawartości jednej lub większej liczby
48komórek od poprzednich obliczeń; wykonywane jest tylko przeliczanie
49komórek, których zmiana dotyczy. Biblioteka jest napisana całkowicie w
50C++ i intensywnie wykorzystuje bibliotekę boost, aby osiągnąć
51przenośność na wiele platform.
52
53%package devel
54Summary: Development files for ixion
55Summary(pl.UTF-8): Pliki nagłówkowe dla ixion
56Group: Development/Libraries
57Requires: %{name} = %{version}-%{release}
58Requires: boost-devel >= 1.36
59Requires: libstdc++-devel
ef81fbd2 60Requires: mdds-devel >= 0.12.0
fb44557a
JB
61
62%description devel
63This package contains the header files for developing applications
64that use ixion.
65
66%description devel -l pl.UTF-8
67Pen pakiet zawiera pliki nagłówkowe do tworzenia aplikacji opartych na
68ixion.
69
70%package static
71Summary: Static ixion library
72Summary(pl.UTF-8): Statyczna biblioteka ixion
73Group: Development/Libraries
74Requires: %{name}-devel = %{version}-%{release}
75
76%description static
77Static ixion library.
78
79%description static -l pl.UTF-8
80Statyczna biblioteka ixion.
81
ef81fbd2
JB
82%package -n python-ixion
83Summary: Python interface to ixion library
84Summary(pl.UTF-8): Interfejs Pythona do biblioteki ixion
85Group: Libraries/Python
86Requires: %{name} = %{version}-%{release}
87
88%description -n python-ixion
89Python interface to ixion library.
90
91%description -n python-ixion -l pl.UTF-8
92Interfejs Pythona do biblioteki ixion.
93
fb44557a 94%prep
f369ddf3 95%setup -q -n libixion-%{version}
fb44557a
JB
96
97%build
b8fb894e
JB
98%{__libtoolize}
99%{__aclocal} -I m4
100%{__autoconf}
101%{__automake}
fb44557a 102%configure \
940f72a8
JB
103 --disable-silent-rules \
104 %{?with_static_libs:--enable-static}
fb44557a
JB
105
106%{__make}
107
108
109%install
110rm -rf $RPM_BUILD_ROOT
111%{__make} install \
112 DESTDIR=$RPM_BUILD_ROOT
113
ef81fbd2
JB
114%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/ixion.la
115%if %{with static_libs}
116%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/ixion.a
117%endif
fb44557a
JB
118# obsoleted by pkg-config
119%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
120
121%clean
122rm -rf $RPM_BUILD_ROOT
123
124%post -p /sbin/ldconfig
125%postun -p /sbin/ldconfig
126
127%files
128%defattr(644,root,root,755)
b8fb894e 129%doc AUTHORS COPYING README
fb44557a
JB
130%attr(755,root,root) %{_bindir}/ixion-parser
131%attr(755,root,root) %{_bindir}/ixion-sorter
ef81fbd2
JB
132%attr(755,root,root) %{_libdir}/libixion-0.10.so.*.*.*
133%attr(755,root,root) %ghost %{_libdir}/libixion-0.10.so.0
fb44557a
JB
134
135%files devel
136%defattr(644,root,root,755)
ef81fbd2
JB
137%attr(755,root,root) %{_libdir}/libixion-0.10.so
138%{_includedir}/libixion-0.10
139%{_pkgconfigdir}/libixion-0.10.pc
fb44557a
JB
140
141%if %{with static_libs}
142%files static
143%defattr(644,root,root,755)
ef81fbd2 144%{_libdir}/libixion-0.10.a
fb44557a 145%endif
ef81fbd2
JB
146
147%files -n python-ixion
148%defattr(644,root,root,755)
149%attr(755,root,root) %{py_sitedir}/ixion.so
This page took 0.106284 seconds and 4 git commands to generate.