]> git.pld-linux.org Git - packages/issue-fancy.git/blame - issue-fancy.spec
- fixed version, only use /etc/os-release for generating issue file
[packages/issue-fancy.git] / issue-fancy.spec
CommitLineData
bddcfea1 1%define distversion %(. /etc/os-release 2>/dev/null ; echo $VERSION)
f74c2584 2
07eabacd 3Summary: PLD Linux release file with logo
d49cd452
ER
4Summary(de.UTF-8): PLD Linux Release-Datei mit logo
5Summary(pl.UTF-8): Wersja Linuksa PLD z logiem
07eabacd 6Name: issue-fancy
bddcfea1 7Version: 3.0
42fc9a5a 8Release: 2
07eabacd 9License: GPL
10Group: Base
07eabacd 11Source0: %{name}-gen
12Source1: %{name}.crontab
1a624c2a 13Source2: %{name}.init
07eabacd 14# In fact it requires quote_logo_backslashes patch.
4c193e18 15BuildRequires: linux_logo >= 3.9b5
42fc9a5a
JR
16BuildRequires: pld-release >= 3.0
17%requires_eq pld-release
10b15c70 18Requires(post,preun): /sbin/chkconfig
e1b4539b 19Requires: linux_logo >= 3.9b5
4c193e18 20Requires: crondaemon
49ceaf73 21Provides: issue
dad812cb
JR
22Conflicts: issue-alpha < 3.0-1
23Conflicts: issue-logo < 3.0-1
24Conflicts: issue-nice < 3.0-1
25Conflicts: issue-pure < 3.0-1
b1edf42d
PZ
26BuildArch: noarch
27BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
07eabacd 28
a1787e86 29%define _sbindir /sbin
30
07eabacd 31%description
32PLD Linux release file with logo.
33
2670b29d 34%description -l pl.UTF-8
07eabacd 35Wersja Linuksa PLD z logiem.
36
37%prep
38
39%install
40rm -rf $RPM_BUILD_ROOT
3c3687a6 41install -d $RPM_BUILD_ROOT{/etc/{cron.d,rc.d/init.d},%{_sbindir}}
07eabacd 42
a1787e86 43install %{SOURCE0} $RPM_BUILD_ROOT%{_sbindir}
44install %{SOURCE1} $RPM_BUILD_ROOT/etc/cron.d/%{name}
45install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/issue-fancy
07eabacd 46
a1787e86 47$RPM_BUILD_ROOT%{_sbindir}/issue-fancy-gen $RPM_BUILD_ROOT
07eabacd 48
1a624c2a
JB
49%clean
50rm -rf $RPM_BUILD_ROOT
51
07eabacd 52%post
53/sbin/issue-fancy-gen
1a624c2a 54/sbin/chkconfig --add issue-fancy
337a3ebf 55
56%preun
57if [ "$1" = "0" ]; then
58 /sbin/chkconfig --del issue-fancy
59fi
60
07eabacd 61%files
62%defattr(644,root,root,755)
7d44a5a0 63# Can't use "noreplace" here because issues are regenerated from cron
07eabacd 64# and %post. Without "noreplace" at least ".rpmsave" will stay.
2a3d379f
SS
65%config %verify(not md5 mtime size) %{_sysconfdir}/issue
66%config %verify(not md5 mtime size) %{_sysconfdir}/issue.net
a1787e86 67%attr(755,root,root) %{_sbindir}/*
07eabacd 68%attr(600,root,root) /etc/cron.d/*
69%attr(754,root,root) /etc/rc.d/init.d/*
This page took 0.09884 seconds and 4 git commands to generate.