]> git.pld-linux.org Git - packages/ipython3.git/blame - ipython3.spec
- updated to 5.8.0 for now (there is also py3-only 7.7.0, but requires more python3...
[packages/ipython3.git] / ipython3.spec
CommitLineData
f504124f 1#
d0972d0f
JB
2# Conditional build:
3%bcond_with doc # Sphinx documentation (need to wait for fulfilling dependencies in PLD)
4%bcond_with tests # unit tests (need to wait for fulfilling dependencies in PLD)
5
e33c22cf 6Summary: An enhanced Interactive Python shell
ff6802f6 7Summary(pl.UTF-8): Interaktywna powłoka języka Python
b177bc0b 8Name: ipython3
d0972d0f
JB
9Version: 5.8.0
10Release: 1
91856dc0 11License: BSD
bc92a4bc 12Group: Applications/Shells
d0972d0f
JB
13Source0: http://archive.ipython.org/release/%{version}/ipython-%{version}.tar.gz
14# Source0-md5: 7014b8824981eef2cb893ea5398d6b8d
15Patch0: ipython-use-setuptools.patch
16URL: http://ipython.org/
17BuildRequires: pydoc3 >= 1:3.3
18BuildRequires: python3-devel >= 1:3.3
19BuildRequires: python3-devel-tools >= 1:3.3
20BuildRequires: python3-setuptools >= 18.5
4bd9f8e5 21BuildRequires: rpm-pythonprov
d0972d0f
JB
22BuildRequires: rpmbuild(macros) >= 1.714
23%if %{with tests}
24BuildRequires: python3-decorator
25BuildRequires: python3-ipykernel
26BuildRequires: python3-nbformat
27BuildRequires: python3-nose >= 0.10.1
28%if "%{py3_ver}" >= "3.4"
29BuildRequires: python3-numpy
30%endif
31%if "%{py3_ver}" < "3.4"
32BuildRequires: python3-pathlib2
33%endif
34BuildRequires: python3-pexpect
35BuildRequires: python3-pickleshare
36BuildRequires: python3-prompt_toolkit >= 1.0.4
37BuildRequires: python3-prompt_toolkit < 2
38BuildRequires: python3-pygments
39BuildRequires: python3-requests
40BuildRequires: python3-simplegeneric >= 0.8
41BuildRequires: python3-testpath
42BuildRequires: python3-traitlets >= 4.2
43%endif
44%if %{with doc}
45BuildRequires: python3-docutils
46BuildRequires: python3-ipykernel
47BuildRequires: python3-sphinx_rtd_theme
48BuildRequires: sphinx-pdg-3 >= 1.3
49%endif
50Requires: python3-ipython = %{version}-%{release}
51Suggests: python3-PyQt5
c5cd9c46 52Suggests: python3-zmq
e33c22cf 53BuildArch: noarch
54BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
55
56%description
57IPython is a free software project which tries to:
58
ef8a19a7 591. Provide an interactive interpreter superior to Python's default.
60IPython has many features for object introspection, shell access, and
61its own special command system for adding functionality when working
62interactively.
e33c22cf 63
ef8a19a7 642. Serve as an embeddable, ready to use interpreter for your own
65programs. IPython can be started with a single call from inside
66another program, providing access to the current namespace. This can
67be very useful both for debugging purposes and for situations where a
68blend of batch-processing and interactive exploration are needed.
e33c22cf 69
ef8a19a7 703. Offer a flexible framework which can be used as the base
71environment for other systems with Python as the underlying language.
72Specifically scientific environments like Mathematica, IDL and Mathcad
73inspired its design, but similar ideas can be useful in many fields.
e33c22cf 74
9299d2f0 75This package contains IPython shell.
76
8251843b
JR
77%description -l pl.UTF-8
78IPython jest wolnym oprogramowaniem, którego celem jest:
79
801. Dostarczenie interaktywnej powłoki lepszej od standardowej
81dostarczanej z językiem Python. IPython umożliwia badanie obiektów,
82dostęp do powłoki oraz własny system poleceń, który umożliwia
83rozszerzanie funkcjonalności podczas pracy interaktywnej.
84
852. Dostarczenie gotowego interpretera, który można dołączać do własnej
86aplikacji. IPython może zostać uruchomiony za pomocą wywołania jednej
87funkcji z poziomu innego programu umożliwiając jednocześnie dostęp do
88aktualnej przestrzeni nazw tego programu. Może to być bardzo użyteczne
89do celów takich jak śledzenie programu czy też sytuacji gdzie jest
90wymagane połączenie przetwarzania wsadowego z interaktywną
91introspekcją.
92
933. Dostarczenie szkieletu, który może zostać użyty jako podstawa
94systemu, którego polecenia opierają się na zasadach języka Python.
95Projekt został zainspirowany przez oprogramowanie naukowe takie jak
96Mathematica, IDL oraz Mathcad, gdzie podobne idee mogą być realizowane
9299d2f0 97w wielu przypadkach.
98
8251843b 99Pakiet ten zawiera powłokę IPython.
9299d2f0 100
5648a7a4 101%package -n python3-ipython
9299d2f0 102Summary: An enhanced Interactive Python shell modules
ff6802f6 103Summary(pl.UTF-8): Moduły interaktywnej powłoki języka Python
9299d2f0 104Group: Libraries/Python
d0972d0f
JB
105Requires: pydoc3 >= 1:3.3
106Requires: python3-devel-tools >= 1:3.3
9299d2f0 107
5648a7a4 108%description -n python3-ipython
9299d2f0 109IPython is a free software project which tries to:
110
ef8a19a7 1111. Provide an interactive interpreter superior to Python's default.
112IPython has many features for object introspection, shell access, and
113its own special command system for adding functionality when working
114interactively.
9299d2f0 115
ef8a19a7 1162. Serve as an embeddable, ready to use interpreter for your own
117programs. IPython can be started with a single call from inside
118another program, providing access to the current namespace. This can
119be very useful both for debugging purposes and for situations where a
120blend of batch-processing and interactive exploration are needed.
9299d2f0 121
ef8a19a7 1223. Offer a flexible framework which can be used as the base
123environment for other systems with Python as the underlying language.
124Specifically scientific environments like Mathematica, IDL and Mathcad
125inspired its design, but similar ideas can be useful in many fields.
9299d2f0 126
127This package contains IPython modules.
128
5648a7a4 129%description -n python3-ipython -l pl.UTF-8
8251843b
JR
130IPython jest wolnym oprogramowaniem, którego celem jest:
131
1321. Dostarczenie interaktywnej powłoki lepszej od standardowej
133dostarczanej z językiem Python. IPython umożliwia badanie obiektów,
134dostęp do powłoki oraz własny system poleceń, który umożliwia
135rozszerzanie funkcjonalności podczas pracy interaktywnej.
136
1372. Dostarczenie gotowego interpretera, który można dołączać do własnej
138aplikacji. IPython może zostać uruchomiony za pomocą wywołania jednej
139funkcji z poziomu innego programu umożliwiając jednocześnie dostęp do
140aktualnej przestrzeni nazw tego programu. Może to być bardzo użyteczne
141do celów takich jak śledzenie programu czy też sytuacji gdzie jest
142wymagane połączenie przetwarzania wsadowego z interaktywną
143introspekcją.
144
1453. Dostarczenie szkieletu, który może zostać użyty jako podstawa
146systemu, którego polecenia opierają się na zasadach języka Python.
147Projekt został zainspirowany przez oprogramowanie naukowe takie jak
148Mathematica, IDL oraz Mathcad, gdzie podobne idee mogą być realizowane
ef8a19a7 149w wielu przypadkach.
150
8251843b 151Pakiet ten zawiera moduły interaktywnej powłoki języka Python.
ef8a19a7 152
e33c22cf 153%prep
d0972d0f
JB
154%setup -q -n ipython-%{version}
155%patch0 -p1
156
157%build
158%py3_build
159
160%if %{with tests}
161%{__python3} IPython/testing/iptest.py IPython
162%endif
163
164%if %{with doc}
165PYTHONPATH=$(pwd) \
166%{__make} -C docs html \
167 SPHINXBUILD=sphinx-build-3
168%endif
e33c22cf 169
170%install
171rm -rf $RPM_BUILD_ROOT
d0972d0f 172install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
e33c22cf 173
7b6aa749 174%py3_install
e33c22cf 175
d0972d0f
JB
176cp -pr examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
177
178# test suite
179%{__rm} $RPM_BUILD_ROOT%{_bindir}/iptest*
180%{__rm} -r $RPM_BUILD_ROOT%{py3_sitescriptdir}/IPython/{testing,core/tests,extensions/tests,lib/tests,terminal/tests,utils/tests}
4bd9f8e5 181
e33c22cf 182%clean
183rm -rf $RPM_BUILD_ROOT
184
185%files
186%defattr(644,root,root,755)
d0972d0f
JB
187%attr(755,root,root) %{_bindir}/ipython
188%attr(755,root,root) %{_bindir}/ipython3
189%{_mandir}/man1/ipython.1*
9299d2f0 190
5648a7a4 191%files -n python3-ipython
9299d2f0 192%defattr(644,root,root,755)
d0972d0f
JB
193%doc COPYING.rst README.rst
194%{py3_sitescriptdir}/IPython
195%{py3_sitescriptdir}/ipython-%{version}-py*.egg-info
196%{_examplesdir}/%{name}-%{version}
This page took 0.075099 seconds and 4 git commands to generate.