]> git.pld-linux.org Git - packages/insync.git/blame - insync.spec
more
[packages/insync.git] / insync.spec
CommitLineData
8b9cf8df
ER
1# TODO
2# - use python-gdata?
7fd5bc82
ER
3# - todo, gnome, cinnamon, kde subpackages
4# https://forums.insynchq.com/discussion/1437/insync-for-linux-beta-4-0-9-19
0327ffde 5# - if other DE .desktop added, fill them with OnlyShowIn fields
24cb7139
ER
6# - check over bundled libs -- rpm -qp --provides ..| grep ^lib | sed -e 's,(.*,,' | sort -u | sed -e 's,^,/usr/lib64/,' | xargs rpm -qf | sort -u
7# Qt4, flac, x11*, expat, gst*, vorbis, orc
8b9cf8df
ER
8Summary: Insync - Your Google Docs backup and sync tool
9Name: insync
7a826c39 10Version: 0.10.5
24cb7139 11Release: 0.5
8b9cf8df 12License: ?
0327ffde 13Group: X11/Applications
af735ed8 14# DownloadUrl: https://www.insynchq.com/linux
7a826c39
ER
15Source0: http://s.insynchq.com/builds/%{name}-beta_%{version}_i386.deb
16# NoSource0-md5: 1b5f38aa68c8495d51c83d92202b9ce6
e691900b 17NoSource: 0
7a826c39
ER
18Source1: http://s.insynchq.com/builds/%{name}-beta_%{version}_amd64.deb
19# NoSource1-md5: 0397e2edafc3391179c9762254d95789
8b9cf8df 20NoSource: 0
7a826c39
ER
21Source2: http://s.insynchq.com/builds/%{name}-beta-mate_%{version}_i386.deb
22# NoSource2-md5: f6297b2109d2064c8ad95055e5690f66
23NoSource: 2
24Source3: http://s.insynchq.com/builds/%{name}-beta-mate_%{version}_amd64.deb
25# NoSource3-md5: 5d13065677de9d60eec8050efd5cce5b
26NoSource: 2
8b9cf8df 27URL: https://www.insynchq.com/
e691900b 28BuildRequires: rpm-utils
0327ffde 29BuildRequires: sed >= 4.0
8b9cf8df
ER
30Requires: glib2
31Requires: gtk-update-icon-cache
32Requires: gvfs
33Requires: nautilus-python
34Requires: python-gevent
35Requires: xdotool
8b9cf8df
ER
36BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
7fd5bc82 38%define _appdir %{_libdir}/%{name}
0327ffde 39%define caja_pyextdir /usr/share/caja-python/extensions
e691900b
ER
40
41# a zip and executable at the same time
42%define _noautostrip .*/library.zip\\|.*/insync\\|.*/py
43
7a826c39
ER
44# bunch of Python symbols
45%define skip_post_check_so libpyglib-gi-2.0-python2.7.so.0
46
e691900b
ER
47# Filter GLIBC_PRIVATE Requires
48%define _noautoreq (GLIBC_PRIVATE)
8b9cf8df 49
eda6fc90 50# we don't want these to be provided as system libraries
ff0bf1ee 51%define _noautoprov libcrypto.so.1.0.0 libz.so.1 libsqlite3.so.0 libreadline.so.6 libdbus-glib-1.so.2 libgio-2.0.so.0 libICE.so.6 libSM.so.6
7b1ee1b4 52
eda6fc90
ER
53# and as we don't provide them, don't require either
54%define _noautoreq %{_noautoprov}
55
8b9cf8df
ER
56%description
57Insync is Google Drive for business and power users that sync and
58supports multiple accounts and offline Google Docs editing using local
59applications.
60
0327ffde
ER
61%package -n caja-insync
62Summary: Insync context menu and emblems for Caja
63Requires: %{name} = %{version}-%{release}
64Requires: mate-file-manager
65
66%description -n caja-insync
67Insync context menu and emblems for Mate File Manager (Caja).
68
8b9cf8df 69%prep
e691900b
ER
70%setup -qcT
71%ifarch %{ix86}
7a826c39
ER
72SOURCE1=%{SOURCE0}
73SOURCE2=%{SOURCE2}
e691900b
ER
74%endif
75%ifarch %{x8664}
7a826c39
ER
76SOURCE1=%{SOURCE1}
77SOURCE2=%{SOURCE3}
e691900b 78%endif
0327ffde 79%if 0
e691900b 80rpm2cpio $SOURCE | cpio -i -d
0327ffde 81%else
7a826c39
ER
82ar x $SOURCE1
83tar xzf data.tar.gz
84ar x $SOURCE2
0327ffde
ER
85tar xzf data.tar.gz
86%endif
8b9cf8df 87
e691900b
ER
88mv usr/bin .
89mv usr/lib/insync lib
e691900b 90mv usr/share/icons .
e691900b 91
0327ffde
ER
92# mate
93mv usr/share/applications/*.desktop .
94cp -p insync.desktop insync-mate.desktop
95mv usr/share/caja-python .
96
e691900b
ER
97# make into symlink, looks cleaner than hardlink:
98# we can attach executable attrs to binary and leave no attrs for symlink in
99# %files section.
af735ed8 100cmp lib/{insync,library.zip}
e691900b 101ln -sf insync lib/library.zip
e691900b 102
af735ed8
ER
103%{__sed} -i -e '
104 1s,/bin/bash,/bin/sh,
0327ffde 105s,%{_prefix}/lib/insync,%{_appdir},
af735ed8 106' bin/%{name}
8b9cf8df
ER
107
108%install
109rm -rf $RPM_BUILD_ROOT
0327ffde 110install -d $RPM_BUILD_ROOT{%{_bindir},%{_appdir},%{_iconsdir},%{_desktopdir},%{caja_pyextdir}}
8b9cf8df 111
e691900b
ER
112cp -a lib/* $RPM_BUILD_ROOT%{_appdir}
113install -p bin/* $RPM_BUILD_ROOT%{_bindir}
114cp -a icons/* $RPM_BUILD_ROOT%{_iconsdir}
8b9cf8df 115
0327ffde
ER
116# mate
117cp -p insync-mate.desktop $RPM_BUILD_ROOT%{_desktopdir}
118cp -a caja-python/extensions/* $RPM_BUILD_ROOT%{caja_pyextdir}
119
8b9cf8df
ER
120%post
121%update_icon_cache hicolor
122
123%postun
124%update_icon_cache hicolor
125
126%clean
127rm -rf $RPM_BUILD_ROOT
128
129%files
130%defattr(644,root,root,755)
e691900b 131#%doc README.txt COMMAND_LINE_HELP.txt
8b9cf8df 132%attr(755,root,root) %{_bindir}/insync*
e691900b
ER
133%dir %{_appdir}
134%attr(755,root,root) %{_appdir}/*.so*
135%attr(755,root,root) %{_appdir}/insync
e691900b 136%{_appdir}/library.zip
7a826c39 137#%{_iconsdir}/hicolor/*/emblems/*.png
8b9cf8df 138%dir %{_iconsdir}/insync
af735ed8 139%{_iconsdir}/insync/icons
7a826c39
ER
140#%{_iconsdir}/insync/Francesco-icons
141
142%{_appdir}/res
143%dir %{_appdir}/gevent-0.13.8-py*.egg
144%{_appdir}/gevent-0.13.8-py*.egg/EGG-INFO
145%dir %{_appdir}/gevent-0.13.8-py*.egg/gevent
146%{_appdir}/gevent-0.13.8-py*.egg/gevent/*.py[co]
147%attr(755,root,root) %{_appdir}/gevent-0.13.8-py*.egg/gevent/core.so
148
149%dir %{_appdir}/greenlet-0.4.0-py*.egg
150%{_appdir}/greenlet-0.4.0-py*.egg/EGG-INFO
151%{_appdir}/greenlet-0.4.0-py*.egg/greenlet.py[co]
152%attr(755,root,root) %{_appdir}/greenlet-0.4.0-py*.egg/greenlet.so
153
154%dir %{_appdir}/faulthandler-2.1-py*.egg
155%{_appdir}/faulthandler-2.1-py*.egg/EGG-INFO
156%{_appdir}/faulthandler-2.1-py*.egg/*.py[co]
157%attr(755,root,root) %{_appdir}/faulthandler-2.1-py*.egg/faulthandler.so
158
159%dir %{_appdir}/notify2-0.3-py*.egg
160%{_appdir}/notify2-0.3-py*.egg/notify2.py[co]
161%{_appdir}/notify2-0.3-py*.egg/EGG-INFO
162
163%dir %{_appdir}/pycrypto-2.6-py*.egg
164%{_appdir}/pycrypto-2.6-py*.egg/Crypto
165%{_appdir}/pycrypto-2.6-py*.egg/EGG-INFO
af735ed8 166
7a826c39
ER
167%dir %{_appdir}/python_ntlm-1.0.1-py*.egg
168%{_appdir}/python_ntlm-1.0.1-py*.egg/ntlm
169%{_appdir}/python_ntlm-1.0.1-py*.egg/EGG-INFO
af735ed8 170
7a826c39
ER
171%dir %{_appdir}/raven-3.1.0-py*.egg
172%{_appdir}/raven-3.1.0-py*.egg/raven
173%{_appdir}/raven-3.1.0-py*.egg/EGG-INFO
0327ffde
ER
174
175%files -n caja-insync
176%defattr(644,root,root,755)
177%{_desktopdir}/insync-mate.desktop
178%{caja_pyextdir}/insync-caja-plugin.py
7a826c39
ER
179#%dir %{caja_pyextdir}/libgio
180#%{caja_pyextdir}/libgio/__init__.py
0327ffde
ER
181
182# FIXME
183%dir %{caja_pyextdir}
7a826c39 184%dir %{_datadir}/caja-python
This page took 0.083643 seconds and 4 git commands to generate.