]> git.pld-linux.org Git - packages/icu.git/blame - icu.spec
Add geneartion of libicu-static
[packages/icu.git] / icu.spec
CommitLineData
2be58cbe 1%define ver %(echo %{version} | tr . _)
6a26a678 2Summary: International Components for Unicode
a9679d76 3Summary(pl.UTF-8): Międzynarodowe komponenty dla unikodu
6a26a678 4Name: icu
59f7b7fd 5Version: 49.1.2
ed6e54e1 6Release: 2
ff4ffa8b 7License: MIT-like
6a26a678 8Group: Libraries
2be58cbe 9Source0: http://download.icu-project.org/files/icu4c/%{version}/%{name}4c-%{ver}-src.tgz
59f7b7fd 10# Source0-md5: bbc609fe5237202d7abf016141012a45
5735de1c 11Patch0: ac264-hack.patch
29be82ba 12URL: http://www.icu-project.org/
59f7b7fd 13BuildRequires: autoconf >= 2.68
073720db 14BuildRequires: libstdc++-devel
f99b930f 15Requires: libicu = %{version}-%{release}
6a26a678 16BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18%description
19ICU is a set of C and C++ libraries that provides robust and
20full-featured Unicode and locale support. The library provides
21calendar support, conversions for many character sets, language
22sensitive collation, date and time formatting, support for many
23locales, message catalogs and resources, message formatting,
24normalization, number and currency formatting, time zones support,
25transliteration, word, line and sentence breaking, etc.
26
27This package contains the Unicode character database and derived
28properties, along with converters and time zones data.
29
eb45a078
JR
30%description -l pl.UTF-8
31ICU jest grupą bibliotek C i C++, które dostarczają kompletną i pełną
32obsługę Unikodu i lokalizacji. Biblioteka dostarcza obsługę
33kalendarza, konwersje dla wielu zestawów znaków, sortowanie zależne od
34języka, formatowanie daty i czasu, wsparcie dla wielu lokalizacji,
35katalogów komunikatów i zasobów, formatowanie komunikatów,
36normalizację, formatowanie liczb i walut, obsługę stref czasowych,
37transliterację, łamanie słów, linii i zdań itp.
f99b930f 38
eb45a078 39Ten pakiet zawiera bazę znaków unikodowych i pochodne własności wraz z
25330473 40konwerterami i danymi stref czasowych.
f99b930f
JB
41
42%package -n libicu
6a26a678 43Summary: International Components for Unicode (libraries)
a9679d76 44Summary(pl.UTF-8): Międzynarodowe Komponenty dla Unikodu (biblioteki)
5b19d04b 45Group: Libraries
f99b930f 46Obsoletes: libicu30
6a26a678 47
f99b930f 48%description -n libicu
6a26a678 49ICU is a set of C and C++ libraries that provides robust and
50full-featured Unicode support. This package contains the runtime
51libraries for ICU. It does not contain any of the data files needed at
5e7cb58a 52runtime and present in the `icu' package.
6a26a678 53
eb45a078
JR
54%description -n libicu -l pl.UTF-8
55ICU jest grupą bibliotek C i C++, które dostarczają kompletną i pełną
56obsługę Unikodu i lokalizacji. Ten pakiet zawiera biblioteki
57uruchomieniowe ICU. Nie zawiera żadnych plików z danymi potrzebnymi w
5e7cb58a 58czasie działania i obecnymi w pakietach "icu".
f99b930f 59
6a26a678 60%package -n libicu-devel
61Summary: International Components for Unicode (development files)
a9679d76 62Summary(pl.UTF-8): Międzynarodowe komponenty dla Unikodu (pliki dla programistów)
6a26a678 63Group: Development/Libraries
f99b930f 64Requires: libicu = %{version}-%{release}
6a26a678 65
66%description -n libicu-devel
67ICU is a set of C and C++ libraries that provides robust and
68full-featured Unicode support. This package contains the development
69files for ICU.
70
eb45a078
JR
71%description -n libicu-devel -l pl.UTF-8
72ICU jest grupą bibliotek C i C++, które dostarczają kompletną i pełną
73obsługę Unikodu i lokalizacji. Ten pakiet zawiera pliki
f99b930f
JB
74programistyczne ICU.
75
a59b4117
MM
76%package -n libicu-static
77Summary: International Components for Unicode (static libraries)
78Summary(pl.UTF-8): Międzynarodowe komponenty dla Unikodu (biblioteki statyczne)
79Group: Development/Libraries
80Requires: libicu-devel = %{version}-%{release}
81
82%description -n libicu-static
83ICU is a set of C and C++ libraries that provides robust and
84full-featured Unicode support. This package contains the static
85libraries for ICU.
86
87%description -n libicu-static -l pl.UTF-8
88ICU jest grupą bibliotek C i C++, które dostarczają kompletną i pełną
89obsługę Unikodu i lokalizacji. Ten pakiet zawiera statyczne
90biblioteki programistyczne ICU.
91
6a26a678 92%prep
7d3a284b 93%setup -q -n %{name}
2be58cbe 94%patch0 -p1
6a26a678 95
96%build
7d3a284b 97cd source
2be58cbe 98%{__autoconf}
ff4ffa8b 99%configure \
60ef1664 100 --sbindir=%{_bindir} \
6c6806e6 101 --with-data-packaging=library \
a59b4117 102 --enable-static \
073720db 103 --disable-samples
7d3a284b 104
430c90c8 105%{__make}
6a26a678 106
107%install
108rm -rf $RPM_BUILD_ROOT
6a26a678 109
073720db 110%{__make} -C source install \
6a26a678 111 DESTDIR=$RPM_BUILD_ROOT
112
5735de1c
JB
113for f in icu-i18n icu-io icu-le icu-lx icu-uc ; do
114sed -i \
115 -e 's/\$(THREADSCXXFLAGS)//' \
116 -e 's/\$(THREADSCFLAGS)//' \
117 -e 's/\$(THREADSCPPFLAGS)/-D_REENTRANT/' $RPM_BUILD_ROOT%{_pkgconfigdir}/${f}.pc
118done
2be58cbe 119
0f4824f4
JB
120# help rpm to generate deps
121chmod +x $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.*
122
7f0f98e4
JB
123# rpm is too stupid sometimes and fails on symlinks to symlinked resources
124# (reporting unresolved dependency at install time)
5735de1c
JB
125for f in Makefile.inc pkgdata.inc ; do
126 ln -sf %{version}/${f} $RPM_BUILD_ROOT%{_libdir}/%{name}/${f}
127done
7f0f98e4 128
5735de1c 129%{__rm} $RPM_BUILD_ROOT%{_datadir}/icu/%{version}/license.html
1f4b227d 130
6a26a678 131%clean
132rm -rf $RPM_BUILD_ROOT
133
073720db
JB
134%post -n libicu -p /sbin/ldconfig
135%postun -n libicu -p /sbin/ldconfig
136
6a26a678 137%files
138%defattr(644,root,root,755)
7d3a284b 139%doc license.html readme.html
53e9cdd2
JB
140%attr(755,root,root) %{_bindir}/derb
141%attr(755,root,root) %{_bindir}/gen*
142%attr(755,root,root) %{_bindir}/icuinfo
143%attr(755,root,root) %{_bindir}/icupkg
144%attr(755,root,root) %{_bindir}/makeconv
145%attr(755,root,root) %{_bindir}/pkgdata
146%attr(755,root,root) %{_bindir}/uconv
147%{_mandir}/man1/derb.1*
148%{_mandir}/man1/gen*.1*
149%{_mandir}/man1/makeconv.1*
150%{_mandir}/man1/pkgdata.1*
151%{_mandir}/man1/uconv.1*
152%{_mandir}/man8/gen*.8*
153%{_mandir}/man8/icupkg.8*
6a26a678 154
7d3a284b 155%files -n libicu
48b42393 156%defattr(644,root,root,755)
ff4ffa8b 157%attr(755,root,root) %{_libdir}/libicu*.so.*.*
fde45022 158%attr(755,root,root) %ghost %{_libdir}/libicu*.so.49
7d3a284b 159
7d3a284b 160%files -n libicu-devel
48b42393 161%defattr(644,root,root,755)
af4104d1 162%attr(755,root,root) %{_bindir}/icu-config
ff4ffa8b 163%attr(755,root,root) %{_libdir}/libicu*.so
5735de1c
JB
164%{_pkgconfigdir}/icu-i18n.pc
165%{_pkgconfigdir}/icu-io.pc
166%{_pkgconfigdir}/icu-le.pc
167%{_pkgconfigdir}/icu-lx.pc
168%{_pkgconfigdir}/icu-uc.pc
ff4ffa8b
JB
169%{_includedir}/unicode
170%{_includedir}/layout
a325d3da 171%dir %{_libdir}/%{name}
430c90c8 172%{_libdir}/%{name}/*.inc
a325d3da
JB
173%dir %{_libdir}/%{name}/current
174%dir %{_libdir}/%{name}/%{version}
430c90c8 175%{_libdir}/%{name}/%{version}/*.inc
a325d3da
JB
176%dir %{_datadir}/%{name}
177%dir %{_datadir}/%{name}/%{version}
7d3a284b 178%{_datadir}/%{name}/%{version}/config
8de4b80e 179%attr(755,root,root) %{_datadir}/%{name}/%{version}/install-sh
a325d3da 180%attr(755,root,root) %{_datadir}/%{name}/%{version}/mkinstalldirs
af4104d1 181%{_mandir}/man1/icu-config.1*
a59b4117
MM
182
183%files -n libicu-static
184%defattr(644,root,root,755)
185%{_libdir}/libicu*.a
This page took 0.10598 seconds and 4 git commands to generate.