]> git.pld-linux.org Git - packages/icu.git/blame - icu.spec
- up to 52.1
[packages/icu.git] / icu.spec
CommitLineData
84b38548
ER
1#
2# Conditional build:
3%bcond_without static_libs # don't build static libraries
4
2be58cbe 5%define ver %(echo %{version} | tr . _)
6a26a678 6Summary: International Components for Unicode
a9679d76 7Summary(pl.UTF-8): Międzynarodowe komponenty dla unikodu
6a26a678 8Name: icu
3b349192 9Version: 52.1
8090c317 10Release: 1
ff4ffa8b 11License: MIT-like
6a26a678 12Group: Libraries
2be58cbe 13Source0: http://download.icu-project.org/files/icu4c/%{version}/%{name}4c-%{ver}-src.tgz
3b349192 14# Source0-md5: 9e96ed4c1d99c0d14ac03c140f9f346c
5735de1c 15Patch0: ac264-hack.patch
29be82ba 16URL: http://www.icu-project.org/
59f7b7fd 17BuildRequires: autoconf >= 2.68
073720db 18BuildRequires: libstdc++-devel
f99b930f 19Requires: libicu = %{version}-%{release}
6a26a678 20BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22%description
23ICU is a set of C and C++ libraries that provides robust and
24full-featured Unicode and locale support. The library provides
25calendar support, conversions for many character sets, language
26sensitive collation, date and time formatting, support for many
27locales, message catalogs and resources, message formatting,
28normalization, number and currency formatting, time zones support,
29transliteration, word, line and sentence breaking, etc.
30
31This package contains the Unicode character database and derived
32properties, along with converters and time zones data.
33
eb45a078
JR
34%description -l pl.UTF-8
35ICU jest grupą bibliotek C i C++, które dostarczają kompletną i pełną
36obsługę Unikodu i lokalizacji. Biblioteka dostarcza obsługę
37kalendarza, konwersje dla wielu zestawów znaków, sortowanie zależne od
38języka, formatowanie daty i czasu, wsparcie dla wielu lokalizacji,
39katalogów komunikatów i zasobów, formatowanie komunikatów,
40normalizację, formatowanie liczb i walut, obsługę stref czasowych,
41transliterację, łamanie słów, linii i zdań itp.
f99b930f 42
eb45a078 43Ten pakiet zawiera bazę znaków unikodowych i pochodne własności wraz z
25330473 44konwerterami i danymi stref czasowych.
f99b930f
JB
45
46%package -n libicu
6a26a678 47Summary: International Components for Unicode (libraries)
a9679d76 48Summary(pl.UTF-8): Międzynarodowe Komponenty dla Unikodu (biblioteki)
5b19d04b 49Group: Libraries
f99b930f 50Obsoletes: libicu30
6a26a678 51
f99b930f 52%description -n libicu
6a26a678 53ICU is a set of C and C++ libraries that provides robust and
54full-featured Unicode support. This package contains the runtime
55libraries for ICU. It does not contain any of the data files needed at
5e7cb58a 56runtime and present in the `icu' package.
6a26a678 57
eb45a078
JR
58%description -n libicu -l pl.UTF-8
59ICU jest grupą bibliotek C i C++, które dostarczają kompletną i pełną
60obsługę Unikodu i lokalizacji. Ten pakiet zawiera biblioteki
61uruchomieniowe ICU. Nie zawiera żadnych plików z danymi potrzebnymi w
5e7cb58a 62czasie działania i obecnymi w pakietach "icu".
f99b930f 63
6a26a678 64%package -n libicu-devel
65Summary: International Components for Unicode (development files)
a9679d76 66Summary(pl.UTF-8): Międzynarodowe komponenty dla Unikodu (pliki dla programistów)
6a26a678 67Group: Development/Libraries
f99b930f 68Requires: libicu = %{version}-%{release}
6a26a678 69
70%description -n libicu-devel
71ICU is a set of C and C++ libraries that provides robust and
72full-featured Unicode support. This package contains the development
73files for ICU.
74
eb45a078
JR
75%description -n libicu-devel -l pl.UTF-8
76ICU jest grupą bibliotek C i C++, które dostarczają kompletną i pełną
77obsługę Unikodu i lokalizacji. Ten pakiet zawiera pliki
f99b930f
JB
78programistyczne ICU.
79
a59b4117
MM
80%package -n libicu-static
81Summary: International Components for Unicode (static libraries)
82Summary(pl.UTF-8): Międzynarodowe komponenty dla Unikodu (biblioteki statyczne)
83Group: Development/Libraries
84Requires: libicu-devel = %{version}-%{release}
85
86%description -n libicu-static
87ICU is a set of C and C++ libraries that provides robust and
88full-featured Unicode support. This package contains the static
89libraries for ICU.
90
91%description -n libicu-static -l pl.UTF-8
92ICU jest grupą bibliotek C i C++, które dostarczają kompletną i pełną
93obsługę Unikodu i lokalizacji. Ten pakiet zawiera statyczne
94biblioteki programistyczne ICU.
95
6a26a678 96%prep
7d3a284b 97%setup -q -n %{name}
2be58cbe 98%patch0 -p1
6a26a678 99
100%build
7d3a284b 101cd source
2be58cbe 102%{__autoconf}
ff4ffa8b 103%configure \
60ef1664 104 --sbindir=%{_bindir} \
6c6806e6 105 --with-data-packaging=library \
84b38548 106 %{?with_static_libs:--enable-static} \
073720db 107 --disable-samples
7d3a284b 108
430c90c8 109%{__make}
6a26a678 110
111%install
112rm -rf $RPM_BUILD_ROOT
6a26a678 113
073720db 114%{__make} -C source install \
6a26a678 115 DESTDIR=$RPM_BUILD_ROOT
116
5735de1c
JB
117for f in icu-i18n icu-io icu-le icu-lx icu-uc ; do
118sed -i \
119 -e 's/\$(THREADSCXXFLAGS)//' \
120 -e 's/\$(THREADSCFLAGS)//' \
121 -e 's/\$(THREADSCPPFLAGS)/-D_REENTRANT/' $RPM_BUILD_ROOT%{_pkgconfigdir}/${f}.pc
122done
2be58cbe 123
0f4824f4
JB
124# help rpm to generate deps
125chmod +x $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.*
126
7f0f98e4
JB
127# rpm is too stupid sometimes and fails on symlinks to symlinked resources
128# (reporting unresolved dependency at install time)
5735de1c
JB
129for f in Makefile.inc pkgdata.inc ; do
130 ln -sf %{version}/${f} $RPM_BUILD_ROOT%{_libdir}/%{name}/${f}
131done
7f0f98e4 132
5735de1c 133%{__rm} $RPM_BUILD_ROOT%{_datadir}/icu/%{version}/license.html
1f4b227d 134
6a26a678 135%clean
136rm -rf $RPM_BUILD_ROOT
137
073720db
JB
138%post -n libicu -p /sbin/ldconfig
139%postun -n libicu -p /sbin/ldconfig
140
6a26a678 141%files
142%defattr(644,root,root,755)
7d3a284b 143%doc license.html readme.html
53e9cdd2
JB
144%attr(755,root,root) %{_bindir}/derb
145%attr(755,root,root) %{_bindir}/gen*
146%attr(755,root,root) %{_bindir}/icuinfo
147%attr(755,root,root) %{_bindir}/icupkg
148%attr(755,root,root) %{_bindir}/makeconv
149%attr(755,root,root) %{_bindir}/pkgdata
150%attr(755,root,root) %{_bindir}/uconv
151%{_mandir}/man1/derb.1*
152%{_mandir}/man1/gen*.1*
153%{_mandir}/man1/makeconv.1*
154%{_mandir}/man1/pkgdata.1*
155%{_mandir}/man1/uconv.1*
156%{_mandir}/man8/gen*.8*
157%{_mandir}/man8/icupkg.8*
6a26a678 158
7d3a284b 159%files -n libicu
48b42393 160%defattr(644,root,root,755)
ff4ffa8b 161%attr(755,root,root) %{_libdir}/libicu*.so.*.*
3b349192 162%attr(755,root,root) %ghost %{_libdir}/libicu*.so.52
7d3a284b 163
7d3a284b 164%files -n libicu-devel
48b42393 165%defattr(644,root,root,755)
af4104d1 166%attr(755,root,root) %{_bindir}/icu-config
ff4ffa8b 167%attr(755,root,root) %{_libdir}/libicu*.so
5735de1c
JB
168%{_pkgconfigdir}/icu-i18n.pc
169%{_pkgconfigdir}/icu-io.pc
170%{_pkgconfigdir}/icu-le.pc
171%{_pkgconfigdir}/icu-lx.pc
172%{_pkgconfigdir}/icu-uc.pc
ff4ffa8b
JB
173%{_includedir}/unicode
174%{_includedir}/layout
a325d3da 175%dir %{_libdir}/%{name}
430c90c8 176%{_libdir}/%{name}/*.inc
a325d3da
JB
177%dir %{_libdir}/%{name}/current
178%dir %{_libdir}/%{name}/%{version}
430c90c8 179%{_libdir}/%{name}/%{version}/*.inc
a325d3da
JB
180%dir %{_datadir}/%{name}
181%dir %{_datadir}/%{name}/%{version}
7d3a284b 182%{_datadir}/%{name}/%{version}/config
8de4b80e 183%attr(755,root,root) %{_datadir}/%{name}/%{version}/install-sh
a325d3da 184%attr(755,root,root) %{_datadir}/%{name}/%{version}/mkinstalldirs
af4104d1 185%{_mandir}/man1/icu-config.1*
a59b4117 186
84b38548 187%if %{with static_libs}
a59b4117
MM
188%files -n libicu-static
189%defattr(644,root,root,755)
190%{_libdir}/libicu*.a
84b38548 191%endif
This page took 0.114447 seconds and 4 git commands to generate.