]> git.pld-linux.org Git - packages/iceweasel.git/blame - iceweasel.spec
- do parallel build the mozilla way
[packages/iceweasel.git] / iceweasel.spec
CommitLineData
aa946041 1# TODO:
4dc7b9b3 2# - provide proper $DISPLAY for PGO (Xvfb, Xdummy...) for unattended builds
64fd9f61 3#
64fd9f61 4# Conditional build:
25f97994 5%bcond_with tests # enable tests (whatever they check)
0ddb6810 6%bcond_with gtk3 # GTK+ 3.x instead of 2.x
25f97994 7%bcond_without kerberos # disable krb5 support
4dc7b9b3 8%bcond_without xulrunner # system xulrunner
aa946041 9%bcond_with pgo # PGO-enabled build (requires working $DISPLAY == :100)
557bfdce
JR
10# - disabled shared_js - https://bugzilla.mozilla.org/show_bug.cgi?id=1039964
11%bcond_with shared_js
25f97994 12
0ddb6810 13# convert firefox release number to platform version: 29.0.x -> 29.0.x
a1c18581
AM
14%define xulrunner_main 31.0
15%define xulrunner_ver %(v=%{version}; echo %{xulrunner_main}${v#31.0})
95d7e788 16
edeacddd
ER
17%if %{without xulrunner}
18# The actual sqlite version (see RHBZ#480989):
19%define sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
20%endif
21
557bfdce 22%define nspr_ver 4.10.6
0ddb6810 23%define nss_ver 3.16
837c600d 24
636318c9 25Summary: Iceweasel web browser
3c179095 26Summary(hu.UTF-8): Iceweasel web böngésző
1c0db0f7 27Summary(pl.UTF-8): Iceweasel - przeglądarka WWW
636318c9 28Name: iceweasel
4b35e69c 29Version: 32.0.3
09476966 30Release: 1
0ddb6810 31License: MPL v2.0
64fd9f61 32Group: X11/Applications/Networking
57727a75 33Source0: http://releases.mozilla.org/pub/mozilla.org/firefox/releases/%{version}/source/firefox-%{version}.source.tar.bz2
4b35e69c 34# Source0-md5: 618bf992a5cb80f8879435262bdfcee0
f7893426 35Source1: %{name}-branding.tar.xz
af9879cf 36# Source1-md5: 6e3c10921c5b243f33241646b7941ce9
6263e082 37Source2: %{name}-rm_nonfree.sh
38Source3: %{name}.desktop
39Source4: %{name}.sh
55f0784a
JR
40Source5: vendor.js
41Source6: vendor-ac.js
25f97994 42Patch0: %{name}-branding.patch
da892b7e 43
25f97994 44Patch7: %{name}-prefs.patch
0b8ebf73 45Patch8: %{name}-pld-branding.patch
9f488603 46Patch9: %{name}-no-subshell.patch
93241bee 47Patch11: %{name}-middle_click_paste.patch
d8c2b732 48Patch12: %{name}-packaging.patch
6a75f2e2 49Patch13: system-virtualenv.patch
ebf1b795 50Patch15: Disable-Firefox-Health-Report.patch
743c829e 51URL: http://www.pld-linux.org/Packages/Iceweasel
bcf987c2 52BuildRequires: OpenGL-devel
4a6ac63f 53BuildRequires: ImageMagick
f26228e9 54BuildRequires: ImageMagick-coder-png
72c3acea 55BuildRequires: alsa-lib-devel
64fd9f61 56BuildRequires: automake
526c2cf9 57BuildRequires: bzip2-devel
ec8ea9c6 58BuildRequires: cairo-devel >= 1.10.2-5
72c3acea 59BuildRequires: dbus-glib-devel >= 0.60
087998e5 60BuildRequires: gcc-c++ >= 6:4.4
11a3f988 61BuildRequires: glib2-devel >= 1:2.20
557bfdce
JR
62BuildRequires: gstreamer-devel >= 1.0
63BuildRequires: gstreamer-plugins-base-devel >= 1.0
0ddb6810
JB
64%{!?with_gtk3:BuildRequires: gtk+2-devel >= 2:2.14}
65%{?with_gtk3:BuildRequires: gtk+3-devel >= 3.0.0}
25f97994 66%{?with_kerberos:BuildRequires: heimdal-devel >= 0.7.1}
1668aa38 67BuildRequires: hunspell-devel
64fd9f61 68BuildRequires: libIDL-devel >= 0.8.0
526c2cf9 69BuildRequires: libdnet-devel
fa89a5f1 70BuildRequires: libevent-devel >= 1.4.7
58f7b9e2
JB
71# standalone libffi 3.0.9 or gcc's from 4.5(?)+
72BuildRequires: libffi-devel >= 6:3.0.9
0ddb6810 73BuildRequires: libicu-devel >= 50.1
dab03435 74# requires libjpeg-turbo implementing at least libjpeg 6b API
64fd9f61 75BuildRequires: libjpeg-devel >= 6b
dab03435 76BuildRequires: libjpeg-turbo-devel
2b51aba4
AM
77# for rsvg-convert
78BuildRequires: librsvg
25f97994 79BuildRequires: libpng(APNG)-devel >= 0.10
ba5d7125 80BuildRequires: libpng-devel >= 2:1.6.7
087998e5 81BuildRequires: libstdc++-devel >= 6:4.4
0ddb6810 82BuildRequires: libvpx-devel >= 1.3.0
837c600d
JR
83BuildRequires: nspr-devel >= 1:%{nspr_ver}
84BuildRequires: nss-devel >= 1:%{nss_ver}
18df252d 85BuildRequires: pango-devel >= 1:1.14.0
0ddb6810 86BuildRequires: pixman-devel >= 0.19.2
64fd9f61 87BuildRequires: perl-modules >= 5.004
88BuildRequires: pkgconfig
58f7b9e2 89BuildRequires: pkgconfig(libffi) >= 3.0.9
72c3acea 90BuildRequires: python-modules
aa946041 91%{?with_pgo:BuildRequires: python-modules-sqlite}
6a75f2e2 92BuildRequires: python-virtualenv
25f97994 93BuildRequires: rpm >= 4.4.9-56
28e49f45 94BuildRequires: rpmbuild(macros) >= 1.601
557bfdce 95BuildRequires: sqlite3-devel >= 3.8.3.1
72c3acea 96BuildRequires: startup-notification-devel >= 0.8
fa89a5f1 97BuildRequires: xorg-lib-libXScrnSaver-devel
18df252d 98BuildRequires: xorg-lib-libXext-devel
18df252d 99BuildRequires: xorg-lib-libXinerama-devel
64fd9f61 100BuildRequires: xorg-lib-libXt-devel
25f97994 101%if %{with xulrunner}
c4d76d99 102BuildRequires: xulrunner-devel >= 2:%{xulrunner_ver}
25f97994 103%endif
64fd9f61 104BuildRequires: zip
105BuildRequires: zlib-devel >= 1.2.3
636318c9 106Requires(post): mktemp >= 1.5-18
8309582e 107Requires: desktop-file-utils
28e49f45 108Requires: hicolor-icon-theme
43cd2d9e
ER
109%if %{with xulrunner}
110%requires_eq_to xulrunner xulrunner-devel
111%else
25f97994 112Requires: browser-plugins >= 2.0
9bc7e413 113Requires: cairo >= 1.10.2-5
18df252d 114Requires: dbus-glib >= 0.60
11a3f988 115Requires: glib2 >= 1:2.20
0ddb6810
JB
116%{!?with_gtk3:Requires: gtk+2 >= 2:2.14}
117%{?with_gtk3:Requires: gtk+3 >= 3.0.0}
dab03435 118Requires: libjpeg-turbo
ba5d7125 119Requires: libpng >= 2:1.6.7
25f97994 120Requires: libpng(APNG) >= 0.10
0ddb6810 121Requires: libvpx >= 1.3.0
3c179095 122Requires: myspell-common
837c600d
JR
123Requires: nspr >= 1:%{nspr_ver}
124Requires: nss >= 1:%{nss_ver}
18df252d 125Requires: pango >= 1:1.14.0
edeacddd 126Requires: sqlite3 >= %{sqlite_build_version}
18df252d 127Requires: startup-notification >= 0.8
25f97994 128%endif
64fd9f61 129Provides: wwwbrowser
25f97994 130Obsoletes: mozilla-firebird
131Obsoletes: mozilla-firefox
132Obsoletes: mozilla-firefox-lang-en < 2.0.0.8-3
133Obsoletes: mozilla-firefox-libs
8f1f83ff 134Conflicts: iceweasel-lang-resources < %{version}
64fd9f61 135BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
136
10a03c86
AM
137%define filterout_cpp -D_FORTIFY_SOURCE=[0-9]+
138
18df252d
JB
139# don't satisfy other packages
140%define _noautoprovfiles %{_libdir}/%{name}
0044292b 141%if %{without xulrunner}
25f97994 142# and as we don't provide them, don't require either
0044292b
JB
143%define _noautoreq libmozalloc.so libmozjs.so libxpcom.so libxul.so
144%endif
64fd9f61 145
64fd9f61 146%description
25f97994 147Iceweasel is an open-source web browser, designed for standards
148compliance, performance and portability.
64fd9f61 149
3c179095
ZU
150%description -l hu.UTF-8
151Iceweasel egy nyílt forrású webböngésző, hatékonyságra és
152hordozhatóságra tervezve.
153
6d49053f 154%description -l pl.UTF-8
25f97994 155Iceweasel jest przeglądarką WWW rozpowszechnianą zgodnie z ideami
3c179095
ZU
156ruchu otwartego oprogramowania oraz tworzoną z myślą o zgodności ze
157standardami, wydajnością i przenośnością.
64fd9f61 158
25f97994 159%prep
ed3ba396 160%setup -qc
dca77f61 161mv -f mozilla-release mozilla
ed3ba396 162%setup -q -T -D -a1
25f97994 163cd mozilla
6263e082 164/bin/sh %{SOURCE2}
64fd9f61 165
e73b7e54 166%patch0 -p1
da892b7e 167
25f97994 168%patch7 -p1
0b8ebf73 169%patch8 -p1
9f488603 170%patch9 -p2
93241bee 171%patch11 -p2
5a357718 172%patch12 -p2
6a75f2e2 173%patch13 -p2
ebf1b795 174%patch15 -p1
b72a40b3 175
aa946041
ŁK
176%if %{with pgo}
177sed -i -e 's@__BROWSER_PATH__@"../../dist/bin/iceweasel-bin"@' build/automation.py.in
178%endif
179
25f97994 180%build
181cd mozilla
64fd9f61 182cp -f %{_datadir}/automake/config.* build/autoconf
64fd9f61 183
c4d76d99
ER
184cat << EOF > .mozconfig
185. \$topsrcdir/browser/config/mozconfig
64fd9f61 186
25f97994 187mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/obj-%{_target_cpu}
b084e3e0 188# parallel build fails on _xpidlgen/
b2b1875b
ŁK
189%if %{without xulrunner}
190mk_add_options MOZ_MAKE_FLAGS=%{_smp_mflags}
191%endif
aa946041 192mk_add_options PROFILE_GEN_SCRIPT='@PYTHON@ @MOZ_OBJDIR@/_profile/pgo/profileserver.py'
25f97994 193
194# Options for 'configure' (same as command-line options).
a5076679
JR
195ac_add_options --build=%{_target_platform}
196ac_add_options --host=%{_target_platform}
64fd9f61 197ac_add_options --prefix=%{_prefix}
198ac_add_options --exec-prefix=%{_exec_prefix}
199ac_add_options --bindir=%{_bindir}
200ac_add_options --sbindir=%{_sbindir}
201ac_add_options --sysconfdir=%{_sysconfdir}
202ac_add_options --datadir=%{_datadir}
203ac_add_options --includedir=%{_includedir}
204ac_add_options --libdir=%{_libdir}
205ac_add_options --libexecdir=%{_libexecdir}
206ac_add_options --localstatedir=%{_localstatedir}
207ac_add_options --sharedstatedir=%{_sharedstatedir}
208ac_add_options --mandir=%{_mandir}
209ac_add_options --infodir=%{_infodir}
64fd9f61 210%if %{?debug:1}0
25f97994 211ac_add_options --disable-optimize
64fd9f61 212ac_add_options --enable-debug
213ac_add_options --enable-debug-modules
25f97994 214ac_add_options --enable-debugger-info-modules
215ac_add_options --enable-crash-on-assert
64fd9f61 216%else
217ac_add_options --disable-debug
218ac_add_options --disable-debug-modules
25f97994 219ac_add_options --disable-logging
220ac_add_options --enable-optimize="%{rpmcflags} -Os"
64fd9f61 221%endif
82955f33
ER
222ac_add_options --disable-strip
223ac_add_options --disable-strip-libs
a5076679 224ac_add_options --disable-install-strip
25f97994 225%if %{with tests}
226ac_add_options --enable-tests
39ef872e 227ac_add_options --enable-mochitest
25f97994 228%else
229ac_add_options --disable-tests
39ef872e 230ac_add_options --disable-mochitest
25f97994 231%endif
39ef872e 232ac_add_options --disable-cpp-exceptions
25f97994 233ac_add_options --disable-crashreporter
a5076679
JR
234ac_add_options --disable-elf-dynstr-gc
235ac_add_options --disable-gconf
236ac_add_options --disable-gnomeui
237ac_add_options --disable-gnomevfs
64fd9f61 238ac_add_options --disable-installer
25f97994 239ac_add_options --disable-javaxpcom
a5076679 240ac_add_options --disable-long-long-warning
39ef872e 241ac_add_options --disable-necko-wifi
a5076679 242ac_add_options --disable-pedantic
25f97994 243ac_add_options --disable-updater
a5076679
JR
244ac_add_options --disable-xterm-updates
245ac_add_options --enable-canvas
39ef872e 246ac_add_options --enable-chrome-format=omni
0ddb6810 247ac_add_options --enable-default-toolkit=%{?with_gtk3:cairo-gtk3}%{!?with_gtk3:cairo-gtk2}
7fc9bc0b 248ac_add_options --enable-extensions="default,gio"
0d0192cb 249ac_add_options --enable-gio
557bfdce 250ac_add_options --enable-gstreamer=1.0
d1ab36a9 251ac_add_options --enable-libxul
a5076679 252ac_add_options --enable-mathml
d1ab36a9 253ac_add_options --enable-pango
a5076679 254ac_add_options --enable-readline
39ef872e 255ac_add_options --enable-safe-browsing
557bfdce 256%{?with_shared_js:ac_add_options --enable-shared-js}
25f97994 257ac_add_options --enable-startup-notification
a5076679 258ac_add_options --enable-svg
64fd9f61 259ac_add_options --enable-system-cairo
a5076679 260ac_add_options --enable-system-ffi
01385fad 261ac_add_options --enable-system-hunspell
25f97994 262ac_add_options --enable-system-sqlite
a5076679 263ac_add_options --enable-url-classifier
39ef872e 264ac_add_options --enable-xinerama
25f97994 265ac_add_options --with-branding=iceweasel/branding
a5076679
JR
266ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
267ac_add_options --with-distribution-id=org.pld-linux
4dc7b9b3
JB
268%if %{with xulrunner}
269ac_add_options --with-libxul-sdk=$(pkg-config --variable=sdkdir libxul)
270%endif
64fd9f61 271ac_add_options --with-pthreads
82955f33 272ac_add_options --with-system-bz2
64fd9f61 273ac_add_options --with-system-jpeg
fa89a5f1 274ac_add_options --with-system-libevent
0d0192cb 275ac_add_options --with-system-libvpx
64fd9f61 276ac_add_options --with-system-nspr
277ac_add_options --with-system-nss
a5076679 278ac_add_options --with-system-ply
64fd9f61 279ac_add_options --with-system-png
280ac_add_options --with-system-zlib
cbbb6991 281ac_add_options --with-system-icu
a5076679 282ac_add_options --with-x
64fd9f61 283EOF
284
aa946041 285%if %{with pgo}
a5076679 286export DISPLAY=:100
cde8a231 287%{__make} -j1 -f client.mk profiledbuild \
aa946041 288 DESTDIR=obj-%{_target_cpu}/dist \
aa946041 289 CC="%{__cc}" \
cde8a231
JR
290 CXX="%{__cxx}" \
291 MOZ_MAKE_FLAGS="%{_smp_mflags}"
aa946041 292%else
cde8a231 293%{__make} -j1 -f client.mk build \
25f97994 294 CC="%{__cc}" \
cde8a231
JR
295 CXX="%{__cxx}" \
296 MOZ_MAKE_FLAGS="%{_smp_mflags}"
aa946041 297%endif
64fd9f61 298
299%install
300rm -rf $RPM_BUILD_ROOT
25f97994 301cd mozilla
64fd9f61 302install -d \
25f97994 303 $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_libdir}} \
28e49f45 304 $RPM_BUILD_ROOT%{_desktopdir} \
d5be93be 305 $RPM_BUILD_ROOT%{_datadir}/%{name}/browser \
4dc7b9b3 306 $RPM_BUILD_ROOT%{_libdir}/%{name}/browser/plugins
64fd9f61 307
d5be93be 308%browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/browser/plugins
64fd9f61 309
3e529974
JR
310cd obj-%{_target_cpu}
311%{__make} -C browser/installer stage-package \
25f97994 312 DESTDIR=$RPM_BUILD_ROOT \
3e529974 313 installdir=%{_libdir}/%{name} \
25f97994 314 PKG_SKIP_STRIP=1
315
3e529974
JR
316%{__make} -C iceweasel/branding install \
317 DESTDIR=$RPM_BUILD_ROOT
318
319cp -a dist/iceweasel/* $RPM_BUILD_ROOT%{_libdir}/%{name}/
ba83c719 320
61766208 321%if %{with xulrunner}
881b0f95
AM
322# >= 5.0 seems to require this
323ln -s ../xulrunner $RPM_BUILD_ROOT%{_libdir}/%{name}/xulrunner
324%endif
325
25f97994 326# move arch independant ones to datadir
d5be93be 327mv $RPM_BUILD_ROOT%{_libdir}/%{name}/browser/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/browser/chrome
3118200d 328mv $RPM_BUILD_ROOT%{_libdir}/%{name}/browser/extensions $RPM_BUILD_ROOT%{_datadir}/%{name}/browser/extensions
d5be93be
JR
329mv $RPM_BUILD_ROOT%{_libdir}/%{name}/browser/icons $RPM_BUILD_ROOT%{_datadir}/%{name}/browser/icons
330mv $RPM_BUILD_ROOT%{_libdir}/%{name}/browser/searchplugins $RPM_BUILD_ROOT%{_datadir}/%{name}/browser/searchplugins
25f97994 331%if %{without xulrunner}
031a929e
JR
332mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/browser/defaults
333mv $RPM_BUILD_ROOT%{_datadir}/%{name}/browser/defaults/{pref,preferences}
55002fb3
JR
334%else
335mv $RPM_BUILD_ROOT%{_libdir}/%{name}/browser/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/browser/defaults
25f97994 336%endif
95d7e788 337
d5be93be 338ln -s ../../../share/%{name}/browser/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/browser/chrome
4dc7b9b3 339ln -s ../../../share/%{name}/browser/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/browser/defaults
3118200d 340ln -s ../../../share/%{name}/browser/extensions $RPM_BUILD_ROOT%{_libdir}/%{name}/browser/extensions
d5be93be
JR
341ln -s ../../../share/%{name}/browser/icons $RPM_BUILD_ROOT%{_libdir}/%{name}/browser/icons
342ln -s ../../../share/%{name}/browser/searchplugins $RPM_BUILD_ROOT%{_libdir}/%{name}/browser/searchplugins
64fd9f61 343
25f97994 344%if %{without xulrunner}
b2c3c458 345%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
25f97994 346ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
347%endif
64fd9f61 348
6263e082 349sed 's,@LIBDIR@,%{_libdir},' %{SOURCE4} > $RPM_BUILD_ROOT%{_bindir}/iceweasel
57727a75 350chmod 755 $RPM_BUILD_ROOT%{_bindir}/iceweasel
25f97994 351ln -s iceweasel $RPM_BUILD_ROOT%{_bindir}/firefox
352ln -s iceweasel $RPM_BUILD_ROOT%{_bindir}/mozilla-firefox
64fd9f61 353
28e49f45 354# install icons and desktop file
3e529974 355cp iceweasel/branding/{mozicon,default}128.png
28e49f45
MB
356for i in 16 32 48 64 128; do
357 install -d $RPM_BUILD_ROOT%{_iconsdir}/hicolor/${i}x${i}/apps
3e529974 358 cp -a iceweasel/branding/default${i}.png \
28e49f45
MB
359 $RPM_BUILD_ROOT%{_iconsdir}/hicolor/${i}x${i}/apps/iceweasel.png
360done
361
c4d76d99 362cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
64fd9f61 363
55f0784a 364# install our settings
55f0784a 365%if "%{pld_release}" == "ac"
d5be93be 366cp -a %{SOURCE6} $RPM_BUILD_ROOT%{_datadir}/%{name}/browser/defaults/preferences/vendor.js
4dc7b9b3
JB
367%else
368cp -a %{SOURCE5} $RPM_BUILD_ROOT%{_datadir}/%{name}/browser/defaults/preferences/vendor.js
55f0784a
JR
369%endif
370
fa89a5f1 371# files created by iceweasel -register
d5be93be
JR
372touch $RPM_BUILD_ROOT%{_libdir}/%{name}/browser/components/compreg.dat
373touch $RPM_BUILD_ROOT%{_libdir}/%{name}/browser/components/xpti.dat
64fd9f61 374
56be5f03 375cat << 'EOF' > $RPM_BUILD_ROOT%{_sbindir}/%{name}-chrome+xpcom-generate
64fd9f61 376#!/bin/sh
377umask 022
d5be93be 378rm -f %{_libdir}/%{name}/browser/components/{compreg,xpti}.dat
64fd9f61 379
25f97994 380# it attempts to touch files in $HOME/.mozilla
381# beware if you run this with sudo!!!
382export HOME=$(mktemp -d)
383# also TMPDIR could be pointing to sudo user's homedir
384unset TMPDIR TMP || :
64fd9f61 385
25f97994 386%{_libdir}/%{name}/iceweasel -register
64fd9f61 387
b2c3c458 388rm -rf $HOME
64fd9f61 389EOF
18df252d 390chmod 755 $RPM_BUILD_ROOT%{_sbindir}/%{name}-chrome+xpcom-generate
64fd9f61 391
392%clean
393rm -rf $RPM_BUILD_ROOT
394
25f97994 395%pretrans
14b6c040 396if [ -d %{_libdir}/%{name}/browser/extensions ] && [ ! -L %{_libdir}/%{name}/browser/extensions ]; then
3118200d 397 install -d %{_datadir}/%{name}/browser
14b6c040
JR
398 if [ -e %{_datadir}/%{name}/browser/extensions ]; then
399 mv %{_datadir}/%{name}/browser/extensions{,.rpmsave}
400 fi
401 mv -v %{_libdir}/%{name}/browser/extensions %{_datadir}/%{name}/browser/extensions
0fadbc56 402fi
25f97994 403if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
404 mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
405fi
25f97994 406exit 0
407
64fd9f61 408%post
3e92c67c 409%{_sbindir}/%{name}-chrome+xpcom-generate
25f97994 410%update_browser_plugins
28e49f45 411%update_icon_cache hicolor
8309582e 412%update_desktop_database
64fd9f61 413
95d7e788 414%postun
25f97994 415if [ "$1" = 0 ]; then
416 %update_browser_plugins
28e49f45 417 %update_icon_cache hicolor
64fd9f61 418fi
419
64fd9f61 420%files
421%defattr(644,root,root,755)
25f97994 422%attr(755,root,root) %{_bindir}/%{name}
423%attr(755,root,root) %{_bindir}/firefox
424%attr(755,root,root) %{_bindir}/mozilla-firefox
425%attr(755,root,root) %{_sbindir}/%{name}-chrome+xpcom-generate
426
4dc7b9b3
JB
427%{_desktopdir}/iceweasel.desktop
428%{_iconsdir}/hicolor/*/apps/iceweasel.png
429
25f97994 430# browser plugins v2
431%{_browserpluginsconfdir}/browsers.d/%{name}.*
432%config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
64fd9f61 433
25f97994 434%dir %{_libdir}/%{name}
d5be93be
JR
435%dir %{_libdir}/%{name}/browser
436%dir %{_libdir}/%{name}/browser/components
d5be93be
JR
437%dir %{_libdir}/%{name}/browser/plugins
438
439%dir %{_datadir}/%{name}
440%dir %{_datadir}/%{name}/browser
3118200d 441%dir %{_datadir}/%{name}/browser/extensions
d5be93be 442%{_datadir}/%{name}/browser/chrome
4dc7b9b3 443%{_datadir}/%{name}/browser/defaults
d5be93be
JR
444%{_datadir}/%{name}/browser/icons
445%{_datadir}/%{name}/browser/searchplugins
d5be93be
JR
446
447# symlinks
3118200d 448%{_libdir}/%{name}/browser/extensions
d5be93be
JR
449%{_libdir}/%{name}/browser/chrome
450%{_libdir}/%{name}/browser/icons
451%{_libdir}/%{name}/browser/searchplugins
d5be93be
JR
452%if %{with xulrunner}
453%{_libdir}/%{name}/xulrunner
031a929e 454%endif
55002fb3 455%{_libdir}/%{name}/browser/defaults
d5be93be 456
4dc7b9b3
JB
457%attr(755,root,root) %{_libdir}/%{name}/iceweasel
458%attr(755,root,root) %{_libdir}/%{name}/iceweasel-bin
459%attr(755,root,root) %{_libdir}/%{name}/run-mozilla.sh
d5be93be
JR
460%{_libdir}/%{name}/application.ini
461%{_libdir}/%{name}/browser/blocklist.xml
462%{_libdir}/%{name}/browser/chrome.manifest
4dc7b9b3
JB
463%{_libdir}/%{name}/browser/components/components.manifest
464%attr(755,root,root) %{_libdir}/%{name}/browser/components/libbrowsercomps.so
d5be93be 465# the signature of the default theme
3118200d 466%{_datadir}/%{name}/browser/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
d5be93be 467%{_libdir}/%{name}/browser/omni.ja
d5be93be
JR
468%{_libdir}/%{name}/webapprt
469%attr(755,root,root) %{_libdir}/%{name}/webapprt-stub
470
d5be93be
JR
471# files created by iceweasel -register
472%ghost %{_libdir}/%{name}/browser/components/compreg.dat
473%ghost %{_libdir}/%{name}/browser/components/xpti.dat
25f97994 474
25f97994 475%if %{without xulrunner}
4dc7b9b3 476# private xulrunner instance
2c50337f 477%{_libdir}/%{name}/dependentlibs.list
25f97994 478%{_libdir}/%{name}/platform.ini
55002fb3
JR
479%dir %{_libdir}/%{name}/components
480%{_libdir}/%{name}/components/components.manifest
481%attr(755,root,root) %{_libdir}/%{name}/components/libdbusservice.so
482%attr(755,root,root) %{_libdir}/%{name}/components/libmozgnome.so
d5be93be 483%attr(755,root,root) %{_libdir}/%{name}/libmozalloc.so
557bfdce 484%{?with_shared_js:%attr(755,root,root) %{_libdir}/%{name}/libmozjs.so}
d5be93be 485%attr(755,root,root) %{_libdir}/%{name}/libxul.so
25f97994 486%attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
69dd136c 487%attr(755,root,root) %{_libdir}/%{name}/plugin-container
25f97994 488%{_libdir}/%{name}/dictionaries
55002fb3
JR
489%{_libdir}/%{name}/chrome.manifest
490%{_libdir}/%{name}/omni.ja
25f97994 491%endif
This page took 0.215959 seconds and 4 git commands to generate.