]> git.pld-linux.org Git - packages/icedtea8.git/blame - icedtea.spec
- just started
[packages/icedtea8.git] / icedtea.spec
CommitLineData
17425ea9
AM
1# TODO:
2# - fix bash substitution
3%define snap 20070626
4Summary: OpenJDK and GNU Classpath code
5Name: icedtea
6Version: 1.0
7Release: 0.%{snap}.1
8License: GPL
9Group: Development/Languages/Java
10Source0: %{name}-%{snap}.tar.gz
11# Source0-md5: 8a7d2c92662b06c31dc4ada65004a508
12Source1: http://download.java.net/openjdk/jdk7/promoted/b14/openjdk-7-ea-src-b14-21_jun_2007.zip
13# Source1-md5: c126a32966e4bdb6a60a5724d9447966
14URL: http://icedtea.classpath.org/wiki/Main_Page
15BuildRequires: bash
16BuildRequires: cups-devel
17BuildRequires: eclipse-ecj
18BuildRequires: libgcj
19BuildRequires: motif-devel
20BuildRequires: unzip
21BuildRequires: xalan-j
22BuildRequires: xerces-j
23BuildRequires: xorg-lib-libX11-devel
24BuildRequires: xorg-lib-libXt-devel
25BuildRequires: xorg-proto-printproto-devel
26BuildRequires: xorg-proto-xproto-devel
27BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29%description
30The IcedTea project provides a harness to build the source code from
31http://openjdk.java.net using Free Software build tools and provides
32replacements libraries for the binary plugs with code from the GNU
33Classpath project.
34
35%prep
36%setup -q -n %{name} -a1
37
38%build
39%configure \
40 --with-ecj-jar=%{_javadir}/ecj.jar \
41 --with-libgcj-jar=%{_javadir}/libgcj.jar \
42 --with-xalan2-jar=%{_javadir}/xalan.jar \
43 --with-xalan2-serializer-jar=%{_javadir}/xalan.jar \
44 --with-xerces2-jar=%{_javadir}/xerces.jar \
45 --with-openjdk-src-zip=%{SOURCE1} \
46 --with-openjdk-src=${PWD}/openjdk
47
48%{__make} -j1 \
49 SHELL=/bin/bash
50
51%install
52rm -rf $RPM_BUILD_ROOT
53
54%{__make} install \
55 DESTDIR=$RPM_BUILD_ROOT
56
57%clean
58rm -rf $RPM_BUILD_ROOT
59
60%files
61%defattr(644,root,root,755)
This page took 0.068812 seconds and 4 git commands to generate.