]> git.pld-linux.org Git - packages/ice.git/blame - ice.spec
- works with php 5.5, no need to force 5.3
[packages/ice.git] / ice.spec
CommitLineData
5a9bdbd6 1# TODO
9a1d0e0d 2# - finish (pldize) -servers package
11130741
ER
3#
4# Conditional build:
36f427ab 5%bcond_without gui # IceGrid GUI
11130741 6%bcond_without dotnet # .NET bindings
36f427ab
JR
7%bcond_with java # Java bindings (build requires X11 DISPLAY)
8%bcond_without php # PHP bindings
11130741
ER
9%bcond_without python # Python bindings
10%bcond_without ruby # Ruby bindings
11130741 11
6cff1ec8
ER
12%if %{without java}
13%undefine with_gui
14%endif
15
aa5bb803
ER
16%define php_name php%{?php_suffix}
17
b1a56e6f 18%{?with_java:%include /usr/lib/rpm/macros.java}
5a9bdbd6
ER
19Summary: The Ice base runtime and services
20Name: ice
56a96b27 21Version: 3.5.1
c7be5671 22Release: 1
5a9bdbd6 23License: GPL v2 with exceptions (see ICE_LICENSE)
85d0fae0 24Group: Applications
56a96b27
JR
25Source0: http://www.zeroc.com/download/Ice/3.5/Ice-%{version}.tar.gz
26# Source0-md5: f00c59983cc904bca977133c0a9b3e80
27# Extracted from http://zeroc.com/download/Ice/3.5/ice-3.5.1-1.src.rpm
28Source1: Ice-rpmbuild-%{version}.tar.gz
29# Source1-md5: 247ce2f92caf8d0615d4d35120421a7b
85bc9249 30# Man pages courtesy of Francisco Moya's Debian packages
85bc9249
ER
31Source3: %{name}gridgui
32Source4: IceGridAdmin.desktop
85d0fae0 33Patch0: %{name}-build.patch
11130741 34Patch1: dont-build-demo-test.patch
11130741 35Patch3: jgoodies.patch
aa5bb803 36URL: http://www.zeroc.com/
3470b65a 37BuildRequires: bzip2-devel
5a9bdbd6 38BuildRequires: db-cxx-devel
3470b65a 39BuildRequires: expat-devel
d2180ca6
ER
40BuildRequires: mcpp-devel
41BuildRequires: openssl-devel
1b7259a4 42BuildRequires: rpmbuild(macros) >= 1.665
d2180ca6
ER
43%if %{with gui}
44BuildRequires: ImageMagick
45BuildRequires: ImageMagick-coder-png
46%endif
47%if %{with dotnet}
48BuildRequires: mono-csharp
49%endif
c6913b64 50%if %{with java}
077f0ed8 51BuildRequires: ant
c6913b64 52BuildRequires: db-java-devel
68d99d1f 53BuildRequires: java-jgoodies-common
c6913b64 54BuildRequires: java-jgoodies-forms
55BuildRequires: java-jgoodies-looks
5d2be73c 56BuildRequires: jdk
c6913b64 57BuildRequires: jpackage-utils
c6913b64 58BuildRequires: rpm-javaprov
15085aa5 59%endif
d2180ca6 60%if %{with php}
aa5bb803 61BuildRequires: %{php_name}-devel >= 3:5.0.0
d2180ca6
ER
62%endif
63%if %{with python}
3470b65a 64BuildRequires: python-devel
d2180ca6
ER
65BuildRequires: rpm-pythonprov
66%endif
67%if %{with ruby}
1b7259a4 68BuildRequires: rpm-rubyprov
d2180ca6 69BuildRequires: ruby >= 1:1.8.6
3470b65a 70BuildRequires: ruby-devel
d2180ca6 71%endif
11130741
ER
72# Ice doesn't officially support ppc64 at all; sparc64 doesnt have mono
73ExcludeArch: ppc64 sparc64
85d0fae0 74BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
75
11130741 76# Some file suffixes we need to grab the right stuff for the file lists
f7e92609 77%define soversion 35
11130741 78
85d0fae0 79%description
5a9bdbd6
ER
80Ice is a modern alternative to object middleware such as CORBA or
81COM/DCOM/COM+. It is easy to learn, yet provides a powerful network
82infrastructure for demanding technical applications. It features an
83object-oriented specification language, easy to use C++, C#, Java,
84Python, Ruby, PHP, and Visual Basic mappings, a highly efficient
85protocol, asynchronous method invocation and dispatch, dynamic
86transport plug-ins, TCP/IP and UDP/IP support, SSL-based security, a
87firewall solution, and much more.
85d0fae0 88
89%package devel
5a9bdbd6 90Summary: Tools for developing Ice applications in C++
85d0fae0 91Group: Development/Libraries
92Requires: %{name} = %{version}-%{release}
93
94%description devel
5a9bdbd6 95Tools for developing Ice applications in C++.
85d0fae0 96
a33c5a13
ER
97%package servers
98Summary: Ice services to run through /etc/rc.d/init.d
11130741 99Group: Development/Tools
a33c5a13
ER
100Requires(post,preun): /sbin/chkconfig
101Requires: %{name} = %{version}-%{release}
102Requires: rc-scripts
11130741 103
a33c5a13
ER
104%description servers
105Ice services to run through /etc/rc.d/init.d
11130741 106
a33c5a13 107%package -n icegrid-gui
11130741 108Summary: IceGrid Admin Tool
11130741 109Group: Development/Tools
11130741 110Requires: %{name} = %{version}-%{release}
a33c5a13
ER
111Requires: java-%{name} = %{version}-%{release}
112Requires: java-jgoodies-forms
113Requires: java-jgoodies-looks
114Requires: jpackage-utils
115
116%description -n icegrid-gui
117Graphical administration tool for IceGrid
118
119%package -n java-%{name}
120Summary: The Ice runtime for Java
121Group: Libraries/Java
11130741 122Requires: %{name} = %{version}-%{release}
a33c5a13 123Requires: db-java
11130741 124Requires: jpackage-utils
11130741 125
a33c5a13
ER
126%description -n java-%{name}
127The Ice runtime for Java
11130741 128
a33c5a13
ER
129%package -n csharp-%{name}
130Summary: The Ice runtime for C#
131Group: Libraries
132Requires: %{name} = %{version}-%{release}
133Requires: mono >= 1.2.2
11130741 134
a33c5a13
ER
135%description -n csharp-%{name}
136The Ice runtime for C#
11130741 137
a33c5a13 138%package -n ruby-%{name}
11130741 139Summary: The Ice runtime for Ruby applications
a33c5a13 140Group: Development/Languages
11130741 141Requires: %{name} = %{version}-%{release}
11130741 142
a33c5a13 143%description -n ruby-%{name}
11130741
ER
144The Ice runtime for Ruby applications.
145
a33c5a13 146%package -n python-%{name}
11130741 147Summary: The Ice runtime for Python applications
a33c5a13 148Group: Development/Languages/Python
11130741 149Requires: %{name} = %{version}-%{release}
a33c5a13 150Requires: python >= 1:2.3.4
11130741 151
a33c5a13 152%description -n python-%{name}
11130741
ER
153The Ice runtime for Python applications.
154
aa5bb803 155%package -n %{php_name}-%{name}
11130741 156Summary: The Ice runtime for PHP applications
a33c5a13 157Group: Development/Languages/PHP
11130741
ER
158Requires: %{name} = %{version}-%{release}
159%{?requires_php_extension}
160
aa5bb803 161%description -n %{php_name}-%{name}
11130741
ER
162The Ice runtime for PHP applications.
163
85d0fae0 164%prep
56a96b27 165%setup -q -n Ice-%{version} -a1
85d0fae0 166%patch0 -p0
11130741 167%patch1 -p1
11130741 168%patch3 -p1
6cff1ec8 169
457093df
ER
170%{__sed} -i -e '1s,/usr/bin/env python,%{__python},' cpp/src/ca/iceca
171
fa987e4c
ER
172%if %{with java}
173# we nuke it only when we build new class later, as ice build system expects the file being around
6cff1ec8 174rm cpp/src/ca/ImportKey.class
fa987e4c 175%endif
11130741 176
6cff1ec8 177# update path to our install
eef55816 178sed -i -e 's,/usr/share/Ice-%{version},%{_datadir}/Ice,' cpp/src/ca/iceca Ice-rpmbuild-*/icegridregistry.conf
6cff1ec8 179
85bc9249
ER
180# force our CC/CXX as build system compares for exactly "c++" to setup other rules
181sed -i -e 's,c++,%{__cxx},g' cpp/config/Make.rules.Linux
182
6cff1ec8 183%build
9a1d0e0d
ER
184%if %{with java}
185# Rebuild the Java ImportKey class - need it early for main cpp build
186javac cpp/src/ca/ImportKey.java
187%endif
188
140b994f 189%{__make} -j1 -C cpp \
11130741 190 CFLAGS="%{rpmcflags} -fPIC" \
aed21784 191 CXXFLAGS="%{rpmcxxflags} -fPIC -pthread" \
11130741
ER
192 embedded_runpath_prefix=""
193
9a1d0e0d
ER
194%if %{with gui}
195# Create the IceGrid icon
196convert java/resources/icons/icegrid.ico temp.png
197mv temp-8.png java/resources/icons/icegrid.png
198rm temp*.png
199%endif
200
11130741
ER
201%if %{with java}
202# Set the CLASSPATH correctly for the Java compile
203export CLASSPATH=$(build-classpath db jgoodies-forms jgoodies-looks)
204
140b994f 205%{__make} -j1 -C java \
11130741 206 CFLAGS="%{rpmcflags} -fPIC" \
aed21784 207 CXXFLAGS="%{rpmcxxflags} -fPIC -pthread" \
11130741 208 embedded_runpath_prefix=""
11130741
ER
209%endif
210
211%if %{with dotnet}
140b994f 212%{__make} -j1 -C cs \
11130741 213 CFLAGS="%{rpmcflags} -fPIC" \
aed21784 214 CXXFLAGS="%{rpmcxxflags} -fPIC -pthread" \
11130741
ER
215 embedded_runpath_prefix=""
216%endif
217
218%if %{with python}
140b994f 219%{__make} -j1 -C py \
11130741 220 CFLAGS="%{rpmcflags} -fPIC" \
aed21784 221 CXXFLAGS="%{rpmcxxflags} -fPIC -pthread" \
11130741
ER
222 embedded_runpath_prefix=""
223%endif
224
225%if %{with ruby}
140b994f 226%{__make} -j1 -C rb \
11130741 227 CFLAGS="%{rpmcflags} -fPIC" \
aed21784 228 CXXFLAGS="%{rpmcxxflags} -fPIC -pthread" \
11130741
ER
229 embedded_runpath_prefix=""
230%endif
231
232%if %{with php}
140b994f 233%{__make} -j1 -C php \
11130741
ER
234 PHP_HOME=%{_prefix} \
235 CFLAGS="%{rpmcflags} -fPIC" \
aed21784 236 CXXFLAGS="%{rpmcxxflags} -fPIC -pthread" \
11130741
ER
237 embedded_runpath_prefix=""
238%endif
85d0fae0 239
240%install
241rm -rf $RPM_BUILD_ROOT
9a1d0e0d 242install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_includedir},%{_docdir}/Ice-%{version},%{_datadir}/Ice}
85d0fae0 243
6cff1ec8
ER
244%{__make} -C cpp install \
245 prefix=$RPM_BUILD_ROOT
246
457093df
ER
247# Move the ImportKey.class file
248mv $RPM_BUILD_ROOT/lib/ImportKey.class $RPM_BUILD_ROOT%{_datadir}/Ice
249
6cff1ec8 250mv $RPM_BUILD_ROOT/bin/* $RPM_BUILD_ROOT%{_bindir}
6cff1ec8 251mv $RPM_BUILD_ROOT/include/* $RPM_BUILD_ROOT%{_includedir}
d66964c1 252mv $RPM_BUILD_ROOT/%{_lib}/* $RPM_BUILD_ROOT%{_libdir}
85d0fae0 253
85bc9249 254mv $RPM_BUILD_ROOT/config/* $RPM_BUILD_ROOT%{_datadir}/Ice
85bc9249 255
11130741
ER
256%if %{with java}
257%{__make} -C java install \
6cff1ec8
ER
258 prefix=$RPM_BUILD_ROOT
259
11130741
ER
260# Move Java stuff where it should be
261install -d $RPM_BUILD_ROOT%{_javadir}
11130741
ER
262mv $RPM_BUILD_ROOT/lib/Ice.jar $RPM_BUILD_ROOT%{_javadir}/Ice-%{version}.jar
263ln -s Ice-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/Ice.jar
264mv $RPM_BUILD_ROOT/lib/Freeze.jar $RPM_BUILD_ROOT%{_javadir}/Freeze-%{version}.jar
265ln -s Freeze-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/Freeze.jar
d815748a 266
267# Register ant target
268install -d $RPM_BUILD_ROOT{%{_sysconfdir}/ant.d,%{_javadir}/ant}
269mv $RPM_BUILD_ROOT/lib/ant-ice.jar $RPM_BUILD_ROOT%{_javadir}/ant/ant-ice-%{version}.jar
270ln -s ant-ice-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/ant/ant-ice.jar
271echo 'ice ant/ant-ice' > $RPM_BUILD_ROOT%{_sysconfdir}/ant.d/ice
11130741
ER
272%endif
273
274%if %{with gui}
275# Install the IceGrid GUI
fa987e4c 276install -d $RPM_BUILD_ROOT{%{_pixmapsdir},%{_desktopdir}}
11130741 277mv $RPM_BUILD_ROOT/lib/IceGridGUI.jar $RPM_BUILD_ROOT%{_datadir}/Ice
85bc9249
ER
278cp -a %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}
279install -p %{SOURCE3} $RPM_BUILD_ROOT%{_bindir}
9a1d0e0d 280cp -a java/resources/icons/icegrid.png $RPM_BUILD_ROOT%{_pixmapsdir}
11130741 281mv $RPM_BUILD_ROOT/help/IceGridAdmin $RPM_BUILD_ROOT%{_docdir}/Ice-%{version}
6cff1ec8 282%endif
11130741
ER
283
284%if %{with dotnet}
6cff1ec8
ER
285install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
286%{__make} -C cs install \
287 prefix=$RPM_BUILD_ROOT \
288 GACINSTALL=yes \
d933ee2e 289 GAC_ROOT=$RPM_BUILD_ROOT%{_prefix}/lib \
6cff1ec8 290
fa987e4c 291mv $RPM_BUILD_ROOT/bin/* $RPM_BUILD_ROOT%{_bindir}
11130741
ER
292# .NET spec files (for csharp-devel) -- convert the paths
293for f in IceGrid Glacier2 IceBox Ice IceStorm IcePatch2; do
d933ee2e 294 sed -i -e "s#/lib/#%{_prefix}/lib/#" $RPM_BUILD_ROOT/lib/pkgconfig/$f.pc
6cff1ec8
ER
295 sed -i -e "s#mono_root}/usr#mono_root}#" $RPM_BUILD_ROOT/lib/pkgconfig/$f.pc
296 mv $RPM_BUILD_ROOT/lib/pkgconfig/$f.pc $RPM_BUILD_ROOT%{_pkgconfigdir}/$f.pc
11130741
ER
297done
298%endif
299
300%if %{with python}
6cff1ec8
ER
301%{__make} -C py install \
302 prefix=$RPM_BUILD_ROOT
11130741
ER
303%{__sed} -i -e '1s,/usr/bin/env python,%{__python},' $RPM_BUILD_ROOT/python/Ice.py
304install -d $RPM_BUILD_ROOT%{py_sitedir}/Ice
f905d0db
ER
305mv $RPM_BUILD_ROOT/python/IcePy.so.*.*.* $RPM_BUILD_ROOT%{py_sitedir}/Ice/IcePy.so
306rm -f $RPM_BUILD_ROOT/python/IcePy.so*
11130741 307mv $RPM_BUILD_ROOT/python/* $RPM_BUILD_ROOT%{py_sitedir}/Ice
eef55816 308cp -a Ice-rpmbuild-*/ice.pth $RPM_BUILD_ROOT%{py_sitedir}
46b0ec3f
ER
309%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
310%py_comp $RPM_BUILD_ROOT%{py_sitedir}
311%py_postclean
11130741
ER
312%endif
313
314%if %{with ruby}
6cff1ec8
ER
315%{__make} -C rb install \
316 prefix=$RPM_BUILD_ROOT
11130741 317%{__sed} -i -e '1s,/usr/bin/env ruby,%{__ruby},' $RPM_BUILD_ROOT/ruby/*.rb
1b7259a4
ER
318install -d $RPM_BUILD_ROOT%{ruby_vendorarchdir}
319mv $RPM_BUILD_ROOT/ruby/IceRuby.so.*.*.* $RPM_BUILD_ROOT%{ruby_vendorarchdir}/IceRuby.so
f905d0db 320rm -f $RPM_BUILD_ROOT/ruby/IceRuby.so*
1b7259a4 321mv $RPM_BUILD_ROOT/ruby/* $RPM_BUILD_ROOT%{ruby_vendorarchdir}
11130741
ER
322%endif
323
324%if %{with php}
6cff1ec8
ER
325%{__make} -C php install \
326 prefix=$RPM_BUILD_ROOT
11130741 327# Put the PHP stuff into the right place
46b0ec3f 328install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir},%{php_data_dir}}
eef55816 329cp -a Ice-rpmbuild-*/ice.ini $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
46b0ec3f
ER
330mv $RPM_BUILD_ROOT/php/IcePHP.so $RPM_BUILD_ROOT%{php_extensiondir}
331mv $RPM_BUILD_ROOT/php/* $RPM_BUILD_ROOT%{php_data_dir}
11130741
ER
332%endif
333
d66964c1
ER
334# move as last, bindings reinstall these if missing
335mv $RPM_BUILD_ROOT/slice $RPM_BUILD_ROOT%{_datadir}/Ice
336
337# Move the license files into the documentation directory
338mv $RPM_BUILD_ROOT/ICE_LICENSE $RPM_BUILD_ROOT%{_docdir}/Ice-%{version}/ICE_LICENSE
339mv $RPM_BUILD_ROOT/LICENSE $RPM_BUILD_ROOT%{_docdir}/Ice-%{version}/LICENSE
340# Copy in the other files too
341cp CHANGES RELEASE_NOTES $RPM_BUILD_ROOT%{_docdir}/Ice-%{version}
342
6cff1ec8
ER
343# Install the servers
344install -d $RPM_BUILD_ROOT%{_sysconfdir}
eef55816 345cp -a Ice-rpmbuild-*/*.conf $RPM_BUILD_ROOT%{_sysconfdir}
6cff1ec8
ER
346install -d $RPM_BUILD_ROOT%{_initrddir}
347for i in icegridregistry icegridnode glacier2router; do
eef55816 348 cp -a Ice-rpmbuild-*/$i.redhat $RPM_BUILD_ROOT%{_initrddir}/$i
6cff1ec8
ER
349done
350install -d $RPM_BUILD_ROOT%{_localstatedir}/lib/icegrid
351
c7be5671
JR
352## Copy the man pages into the correct directory
353install -d $RPM_BUILD_ROOT%{_mandir}/man1
354cp -a man/man1/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
355%{__rm} -r $RPM_BUILD_ROOT/man
356
85d0fae0 357%clean
358rm -rf $RPM_BUILD_ROOT
359
360%post -p /sbin/ldconfig
361%postun -p /sbin/ldconfig
362
aa5bb803 363%post -n %{php_name}-%{name}
46b0ec3f
ER
364%php_webserver_restart
365
aa5bb803 366%postun -n %{php_name}-%{name}
46b0ec3f
ER
367if [ "$1" = 0 ]; then
368 %php_webserver_restart
369fi
370
85d0fae0 371%files
372%defattr(644,root,root,755)
fa987e4c 373%doc %{_docdir}/Ice-%{version}
85d0fae0 374%attr(755,root,root) %{_bindir}/dumpdb
375%attr(755,root,root) %{_bindir}/glacier2router
376%attr(755,root,root) %{_bindir}/icebox
377%attr(755,root,root) %{_bindir}/iceboxadmin
378%attr(755,root,root) %{_bindir}/iceca
379%attr(755,root,root) %{_bindir}/icegridadmin
380%attr(755,root,root) %{_bindir}/icegridnode
381%attr(755,root,root) %{_bindir}/icegridregistry
382%attr(755,root,root) %{_bindir}/icepatch2calc
383%attr(755,root,root) %{_bindir}/icepatch2client
384%attr(755,root,root) %{_bindir}/icepatch2server
385%attr(755,root,root) %{_bindir}/icestormadmin
386%attr(755,root,root) %{_bindir}/icestormmigrate
f905d0db 387%attr(755,root,root) %{_bindir}/slice2html
9a1d0e0d 388%attr(755,root,root) %{_bindir}/transformdb
85bc9249
ER
389%{_mandir}/man1/dumpdb.1*
390%{_mandir}/man1/glacier2router.1*
391%{_mandir}/man1/icebox.1*
392%{_mandir}/man1/iceboxadmin.1*
c7be5671 393%{_mandir}/man1/iceca.1*
85bc9249
ER
394%{_mandir}/man1/icegridadmin.1*
395%{_mandir}/man1/icegridnode.1*
396%{_mandir}/man1/icegridregistry.1*
397%{_mandir}/man1/icepatch2calc.1*
398%{_mandir}/man1/icepatch2client.1*
399%{_mandir}/man1/icepatch2server.1*
400%{_mandir}/man1/icestormadmin.1*
c7be5671 401%{_mandir}/man1/icestormmigrate.1*
85bc9249
ER
402%{_mandir}/man1/slice2html.1*
403%{_mandir}/man1/transformdb.1*
46b0ec3f
ER
404%attr(755,root,root) %{_libdir}/libFreeze.so.*.*.*
405%attr(755,root,root) %ghost %{_libdir}/libFreeze.so.%{soversion}
406%attr(755,root,root) %{_libdir}/libGlacier2.so.*.*.*
407%attr(755,root,root) %ghost %{_libdir}/libGlacier2.so.%{soversion}
408%attr(755,root,root) %{_libdir}/libIce.so.*.*.*
409%attr(755,root,root) %ghost %{_libdir}/libIce.so.%{soversion}
410%attr(755,root,root) %{_libdir}/libIceBox.so.*.*.*
411%attr(755,root,root) %ghost %{_libdir}/libIceBox.so.%{soversion}
412%attr(755,root,root) %{_libdir}/libIceDB.so.*.*.*
413%attr(755,root,root) %ghost %{_libdir}/libIceDB.so.%{soversion}
414%attr(755,root,root) %{_libdir}/libIceGrid.so.*.*.*
415%attr(755,root,root) %ghost %{_libdir}/libIceGrid.so.%{soversion}
416%attr(755,root,root) %{_libdir}/libIceGridFreezeDB.so.*.*.*
417%attr(755,root,root) %ghost %{_libdir}/libIceGridFreezeDB.so.%{soversion}
418%attr(755,root,root) %{_libdir}/libIcePatch2.so.*.*.*
419%attr(755,root,root) %ghost %{_libdir}/libIcePatch2.so.%{soversion}
420%attr(755,root,root) %{_libdir}/libIceSSL.so.*.*.*
421%attr(755,root,root) %ghost %{_libdir}/libIceSSL.so.%{soversion}
422%attr(755,root,root) %{_libdir}/libIceStorm.so.*.*.*
423%attr(755,root,root) %ghost %{_libdir}/libIceStorm.so.%{soversion}
424%attr(755,root,root) %{_libdir}/libIceStormFreezeDB.so.*.*.*
425%attr(755,root,root) %ghost %{_libdir}/libIceStormFreezeDB.so.%{soversion}
426%attr(755,root,root) %{_libdir}/libIceStormService.so.*.*.*
427%attr(755,root,root) %ghost %{_libdir}/libIceStormService.so.%{soversion}
428%attr(755,root,root) %{_libdir}/libIceUtil.so.*.*.*
429%attr(755,root,root) %ghost %{_libdir}/libIceUtil.so.%{soversion}
430%attr(755,root,root) %{_libdir}/libIceXML.so.*.*.*
431%attr(755,root,root) %ghost %{_libdir}/libIceXML.so.%{soversion}
432%attr(755,root,root) %{_libdir}/libSlice.so.*.*.*
433%attr(755,root,root) %ghost %{_libdir}/libSlice.so.%{soversion}
5a9bdbd6 434%{_datadir}/Ice
85d0fae0 435
401734e9 436%if %{with gui}
fa987e4c
ER
437# Exclude the stuff that's in IceGrid
438%exclude %{_docdir}/Ice-%{version}/IceGridAdmin
439%exclude %{_datadir}/Ice/IceGridGUI.jar
440
fa987e4c
ER
441%files -n icegrid-gui
442%defattr(644,root,root,755)
443%doc %{_docdir}/Ice-%{version}/IceGridAdmin
46b0ec3f 444%attr(755,root,root) %{_bindir}/icegridgui
fa987e4c 445%{_datadir}/Ice/IceGridGUI.jar
85bc9249 446%{_mandir}/man1/icegridgui.1*
46b0ec3f 447%{_desktopdir}/IceGridAdmin.desktop
fa987e4c 448%{_pixmapsdir}/icegrid.png
6cff1ec8 449%endif
46b0ec3f 450
85d0fae0 451%files devel
452%defattr(644,root,root,755)
f905d0db
ER
453%attr(755,root,root) %{_bindir}/slice2cpp
454%attr(755,root,root) %{_bindir}/slice2freeze
85d0fae0 455%attr(755,root,root) %{_libdir}/libFreeze.so
456%attr(755,root,root) %{_libdir}/libGlacier2.so
457%attr(755,root,root) %{_libdir}/libIce.so
458%attr(755,root,root) %{_libdir}/libIceBox.so
459%attr(755,root,root) %{_libdir}/libIceDB.so
460%attr(755,root,root) %{_libdir}/libIceGrid.so
461%attr(755,root,root) %{_libdir}/libIceGridFreezeDB.so
462%attr(755,root,root) %{_libdir}/libIcePatch2.so
463%attr(755,root,root) %{_libdir}/libIceSSL.so
464%attr(755,root,root) %{_libdir}/libIceStorm.so
465%attr(755,root,root) %{_libdir}/libIceStormFreezeDB.so
466%attr(755,root,root) %{_libdir}/libIceStormService.so
467%attr(755,root,root) %{_libdir}/libIceUtil.so
468%attr(755,root,root) %{_libdir}/libIceXML.so
469%attr(755,root,root) %{_libdir}/libSlice.so
470%{_includedir}/Freeze
471%{_includedir}/Glacier2
472%{_includedir}/Ice
473%{_includedir}/IceBox
474%{_includedir}/IceGrid
475%{_includedir}/IcePatch2
476%{_includedir}/IceSSL
477%{_includedir}/IceStorm
478%{_includedir}/IceUtil
479%{_includedir}/IceXML
480%{_includedir}/Slice
85bc9249
ER
481%{_mandir}/man1/slice2cpp.1*
482%{_mandir}/man1/slice2freeze.1*
d815748a 483%if %{with java}
fe559ddb 484%{_sysconfdir}/ant.d/ice
d815748a 485%{_javadir}/ant/ant-ice-%{version}.jar
486%{_javadir}/ant/ant-ice.jar
487%endif
f905d0db 488
6cff1ec8 489%if %{with dotnet}
46b0ec3f
ER
490%{_pkgconfigdir}/Glacier2.pc
491%{_pkgconfigdir}/Ice.pc
492%{_pkgconfigdir}/IceBox.pc
493%{_pkgconfigdir}/IceGrid.pc
494%{_pkgconfigdir}/IcePatch2.pc
495%{_pkgconfigdir}/IceStorm.pc
6cff1ec8 496%endif
f905d0db
ER
497
498# as we do not have -devel for each binding, these are in main -devel
499# -csharp
500%attr(755,root,root) %{_bindir}/slice2cs
85bc9249 501%{_mandir}/man1/slice2cs.1*
f905d0db
ER
502# -java
503%attr(755,root,root) %{_bindir}/slice2freezej
504%attr(755,root,root) %{_bindir}/slice2java
85bc9249
ER
505%{_mandir}/man1/slice2freezej.1*
506%{_mandir}/man1/slice2java.1*
f905d0db
ER
507# -php
508%attr(755,root,root) %{_bindir}/slice2php
c7be5671 509%{_mandir}/man1/slice2php.1*
f905d0db
ER
510# -python
511%attr(755,root,root) %{_bindir}/slice2py
85bc9249 512%{_mandir}/man1/slice2py.1*
f905d0db
ER
513# -ruby
514%attr(755,root,root) %{_bindir}/slice2rb
85bc9249 515%{_mandir}/man1/slice2rb.1*
f905d0db 516
46b0ec3f
ER
517%files servers
518%defattr(644,root,root,755)
519%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/glacier2router.conf
520%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/icegridnode.conf
521%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/icegridregistry.conf
522%attr(754,root,root) /etc/rc.d/init.d/glacier2router
523%attr(754,root,root) /etc/rc.d/init.d/icegridnode
524%attr(754,root,root) /etc/rc.d/init.d/icegridregistry
525
6cff1ec8 526%if %{with dotnet}
a33c5a13 527%files -n csharp-%{name}
46b0ec3f
ER
528%defattr(644,root,root,755)
529%attr(755,root,root) %{_bindir}/iceboxnet.exe
f7e92609 530%{_mandir}/man1/iceboxnet.1*
d933ee2e 531%{_prefix}/lib/mono/Glacier2
532%{_prefix}/lib/mono/Ice
533%{_prefix}/lib/mono/IceBox
534%{_prefix}/lib/mono/IceGrid
535%{_prefix}/lib/mono/IcePatch2
536%{_prefix}/lib/mono/IceStorm
eef55816 537
d933ee2e 538%{_prefix}/lib/mono/gac/Glacier2
539%{_prefix}/lib/mono/gac/Ice
540%{_prefix}/lib/mono/gac/IceBox
541%{_prefix}/lib/mono/gac/IceGrid
542%{_prefix}/lib/mono/gac/IcePatch2
543%{_prefix}/lib/mono/gac/IceStorm
eef55816 544
f7e92609
JR
545%{_prefix}/lib/mono/gac/policy.3.5.Glacier2
546%{_prefix}/lib/mono/gac/policy.3.5.Ice
547%{_prefix}/lib/mono/gac/policy.3.5.IceBox
548%{_prefix}/lib/mono/gac/policy.3.5.IceGrid
549%{_prefix}/lib/mono/gac/policy.3.5.IcePatch2
550%{_prefix}/lib/mono/gac/policy.3.5.IceStorm
6cff1ec8 551%endif
46b0ec3f 552
6cff1ec8 553%if %{with python}
a33c5a13 554%files -n python-%{name}
46b0ec3f
ER
555%defattr(644,root,root,755)
556%{py_sitedir}/ice.pth
557%dir %{py_sitedir}/Ice
558%dir %{py_sitedir}/Ice/IceBox
559%dir %{py_sitedir}/Ice/IceGrid
c7be5671 560%dir %{py_sitedir}/Ice/IceMX
46b0ec3f
ER
561%dir %{py_sitedir}/Ice/IcePatch2
562%dir %{py_sitedir}/Ice/IceStorm
563%{py_sitedir}/Ice/*.py[co]
564%{py_sitedir}/Ice/IceBox/*.py[co]
565%{py_sitedir}/Ice/IceGrid/*.py[co]
c7be5671 566%{py_sitedir}/Ice/IceMX/*.py[co]
46b0ec3f
ER
567%{py_sitedir}/Ice/IcePatch2/*.py[co]
568%{py_sitedir}/Ice/IceStorm/*.py[co]
f905d0db 569%attr(755,root,root) %{py_sitedir}/Ice/IcePy.so
6cff1ec8 570%endif
46b0ec3f 571
6cff1ec8 572%if %{with ruby}
a33c5a13 573%files -n ruby-%{name}
46b0ec3f 574%defattr(644,root,root,755)
1b7259a4
ER
575%{ruby_vendorarchdir}/Glacier2.rb
576%{ruby_vendorarchdir}/Glacier2
577%{ruby_vendorarchdir}/Ice.rb
578%{ruby_vendorarchdir}/Ice
579%{ruby_vendorarchdir}/IceBox.rb
580%{ruby_vendorarchdir}/IceBox
581%{ruby_vendorarchdir}/IceGrid.rb
582%{ruby_vendorarchdir}/IceGrid
583%{ruby_vendorarchdir}/IcePatch2.rb
584%{ruby_vendorarchdir}/IcePatch2
585%{ruby_vendorarchdir}/IceStorm.rb
586%dir %{ruby_vendorarchdir}/IceStorm
587%{ruby_vendorarchdir}/IceStorm/IceStorm.rb
c7be5671 588%{ruby_vendorarchdir}/IceStorm/Metrics.rb
1b7259a4 589%attr(755,root,root) %{ruby_vendorarchdir}/IceRuby.so
6cff1ec8 590%endif
46b0ec3f 591
6cff1ec8 592%if %{with java}
a33c5a13 593%files -n java-%{name}
46b0ec3f
ER
594%defattr(644,root,root,755)
595%{_javadir}/Freeze-%{version}.jar
596%{_javadir}/Freeze.jar
597%{_javadir}/Ice-%{version}.jar
598%{_javadir}/Ice.jar
6cff1ec8 599%endif
46b0ec3f 600
6cff1ec8 601%if %{with php}
aa5bb803 602%files -n %{php_name}-%{name}
46b0ec3f
ER
603%defattr(644,root,root,755)
604%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/ice.ini
605%attr(755,root,root) %{php_extensiondir}/IcePHP.so
606%{php_data_dir}/Glacier2.php
607%{php_data_dir}/Glacier2
608%{php_data_dir}/Ice.php
609%{php_data_dir}/Ice
610%{php_data_dir}/IceBox.php
611%{php_data_dir}/IceBox
612%{php_data_dir}/IceGrid.php
613%{php_data_dir}/IceGrid
614%{php_data_dir}/IcePatch2.php
615%{php_data_dir}/IcePatch2
616%{php_data_dir}/IceStorm.php
617%{php_data_dir}/IceStorm
6cff1ec8 618%endif
This page took 0.163394 seconds and 4 git commands to generate.