]> git.pld-linux.org Git - packages/hwloc.git/blame - hwloc.spec
- updated to 2.0.3
[packages/hwloc.git] / hwloc.spec
CommitLineData
32528c53 1# TODO: scotch (for netlockscotch), CUDA >= 30.20, NVML/nvidia-ml on bcond?
3121520b
JB
2# NOTES (as of 1.9-1.11):
3# - kerrighed library (>= 2.0) is only checked for; kerrighed support in hwloc uses /proc filesystem
33daa92c
JB
4# - myriexpress (open-mx) library is only checked for, but not used by hwloc code
5# (just in one test); in binary packages only interface header is included
3121520b 6# - same with libibverbs
32528c53
JB
7#
8# Conditional build:
9%bcond_with mpi # MPI support in netloc
10%bcond_with scotch # SCOTCH support in netloc
11%bcond_without netloc # netloc library
12
8c44f071 13Summary: Portable Hardware Locality
ad5914df 14Summary(pl.UTF-8): Przenośna lokalizacja sprzętu
8c44f071 15Name: hwloc
32528c53 16Version: 2.0.3
3121520b 17Release: 1
8c44f071
TP
18License: BSD
19Group: Applications/System
32528c53
JB
20#Source0Download: https://www.open-mpi.org/software/hwloc/v2.0/
21Source0: https://download.open-mpi.org/release/hwloc/v2.0/%{name}-%{version}.tar.bz2
22# Source0-md5: f9346b6d9051f7fe07a997d405d71a59
3121520b 23URL: https://www.open-mpi.org/projects/hwloc/
ad5914df
JB
24BuildRequires: OpenCL-devel
25BuildRequires: OpenGL-devel
8c44f071 26BuildRequires: cairo-devel
ad5914df 27BuildRequires: libXNVCtrl-devel
3121520b 28BuildRequires: libltdl-devel >= 2:2.2.6
ad5914df
JB
29BuildRequires: libstdc++-devel
30BuildRequires: libxml2-devel >= 2.0
32528c53 31%{?with_mpi:BuildRequires: mpi-devel}
ad5914df 32BuildRequires: ncurses-devel
8c44f071 33BuildRequires: numactl-devel
ad5914df 34BuildRequires: pkgconfig >= 1:0.9.0
32528c53 35%{?with_scotch:BuildRequires: scotch-devel}
3121520b 36BuildRequires: udev-devel
8c44f071 37BuildRequires: xorg-lib-libX11-devel
ad5914df
JB
38BuildRequires: xorg-lib-libXext-devel
39BuildRequires: xorg-lib-libpciaccess-devel
8c44f071 40BuildRequires: xorg-proto-xproto-devel
3121520b
JB
41%if %{with tests}
42BuildRequires: libibverbs-devel
43BuildRequires: open-mx-devel
44%endif
8c44f071
TP
45Requires: %{name}-libs = %{version}-%{release}
46BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48%description
49The Portable Hardware Locality (hwloc) software package provides a
50portable abstraction (across OS, versions, architectures, ...) of the
51hierarchical topology of modern architectures, including NUMA memory
52nodes, sockets, shared caches, cores and simultaneous multithreading.
53It also gathers various system attributes such as cache and memory
54information. It primarily aims at helping applications with gathering
55information about modern computing hardware so as to exploit it
56accordingly and efficiently.
57
ad5914df
JB
58%description -l pl.UTF-8
59Pakiet HWLOC (Portable Hardware Locality) zapewnia przenośną (między
60systemami operacyjnymi, werjami, architekturami...) abstrakcję
61hierarchicznej topologii współczesnych architektur, w tym węzłów z
62pamięcią NUMA, gniazd, współdzielonych pamięci podręcznych, rdzeni i
63wielowątkowości. Gromadzi też różne właściwości systemów, takie jak
64informacje o pamięci głównej i podręcznej. Głównym celem jest pomoc
65aplikacjom w gromadzeniu informacji o współczesnym sprzęcie
66obliczeniowym w celu jego właściwego i wydajnego wykorzystania.
67
8c44f071 68%package libs
ad5914df
JB
69Summary: Portable Hardware Locality (hwloc) library
70Summary(pl.UTF-8): Biblioteka przenośnej lokalizacji sprzętu (hwloc)
8c44f071
TP
71Group: Libraries
72
73%description libs
ad5914df
JB
74Portable Hardware Locality (hwloc) library.
75
76%description libs -l pl.UTF-8
77Biblioteka przenośnej lokalizacji sprzętu (hwloc).
8c44f071
TP
78
79%package devel
ad5914df
JB
80Summary: Header files for hwloc library
81Summary(pl.UTF-8): Pliki nagłówkowe biblioteki hwloc
8c44f071
TP
82Group: Development/Libraries
83Requires: %{name}-libs = %{version}-%{release}
3121520b 84Requires: libltdl-devel >= 2:2.2.6
ad5914df 85Requires: numactl-devel
3121520b 86Requires: udev-devel
8c44f071
TP
87
88%description devel
ad5914df
JB
89Header files for hwloc library.
90
91%description devel -l pl.UTF-8
92Pliki nagłówkowe biblioteki hwloc.
8c44f071
TP
93
94%prep
95%setup -q
96
97%build
ad5914df 98%configure \
32528c53
JB
99 %{!?with_mpi:ac_cv_header_mpi_h=no} \
100 %{!?with_scotch:ac_cv_lib_scotch_SCOTCH_archSub=no} \
101 %{?with_netloc:--enable-netloc} \
ad5914df
JB
102 --enable-plugins \
103 --disable-silent-rules
104%{__make}
8c44f071
TP
105
106%install
107rm -rf $RPM_BUILD_ROOT
108
109%{__make} install \
110 DESTDIR=$RPM_BUILD_ROOT
111
32528c53 112%{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*.la \
ad5914df 113 $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
8c44f071 114
fe9dbd5e
JB
115# packaged as %doc
116%{__rm} $RPM_BUILD_ROOT%{_docdir}/hwloc/hwloc*.pdf
117
8c44f071
TP
118%clean
119rm -rf $RPM_BUILD_ROOT
120
121%post libs -p /sbin/ldconfig
122%postun libs -p /sbin/ldconfig
123
124%files
125%defattr(644,root,root,755)
ad5914df 126%attr(755,root,root) %{_bindir}/hwloc-*
8c44f071 127%attr(755,root,root) %{_bindir}/lstopo
ad5914df 128%attr(755,root,root) %{_bindir}/lstopo-no-graphics
32528c53
JB
129%if %{with netloc}
130%attr(755,root,root) %{_bindir}/netloc_*
131%endif
3121520b 132%attr(755,root,root) %{_sbindir}/hwloc-dump-hwdata
ad5914df
JB
133%dir %{_libdir}/%{name}
134%attr(755,root,root) %{_libdir}/%{name}/hwloc_opencl.so
135%attr(755,root,root) %{_libdir}/%{name}/hwloc_pci.so
136%attr(755,root,root) %{_libdir}/%{name}/hwloc_xml_libxml.so
8c44f071 137%{_datadir}/%{name}
3121520b 138%{_desktopdir}/lstopo.desktop
ad5914df 139%{_mandir}/man1/hwloc-*.1*
8c44f071 140%{_mandir}/man1/lstopo.1*
ad5914df
JB
141%{_mandir}/man1/lstopo-no-graphics.1*
142%{_mandir}/man7/hwloc.7*
8c44f071
TP
143
144%files libs
145%defattr(644,root,root,755)
ad5914df
JB
146%doc AUTHORS COPYING NEWS README
147%attr(755,root,root) %{_libdir}/libhwloc.so.*.*.*
32528c53
JB
148%attr(755,root,root) %ghost %{_libdir}/libhwloc.so.15
149%if %{with netloc}
150%attr(755,root,root) %{_libdir}/libnetloc.so.*.*.*
151%attr(755,root,root) %ghost %{_libdir}/libnetloc.so.0
152%endif
8c44f071
TP
153
154%files devel
155%defattr(644,root,root,755)
ad5914df
JB
156%doc doc/doxygen-doc/html doc/doxygen-doc/hwloc-a4.pdf
157%attr(755,root,root) %{_libdir}/libhwloc.so
32528c53
JB
158%if %{with netloc}
159%attr(755,root,root) %{_libdir}/libnetloc.so
160%endif
ad5914df
JB
161%{_pkgconfigdir}/hwloc.pc
162%{_includedir}/hwloc
163%{_includedir}/hwloc.h
8c44f071
TP
164%{_mandir}/man3/HWLOC_*.3*
165%{_mandir}/man3/hwloc_*.3*
166%{_mandir}/man3/hwlocality_*.3*
This page took 0.077582 seconds and 4 git commands to generate.