]> git.pld-linux.org Git - packages/hhvm.git/blame - hiphop-php.spec
- add old files (May 16 2010)
[packages/hhvm.git] / hiphop-php.spec
CommitLineData
ac2930bc 1# TODO
59f13ffd
ER
2# - system libmbfl, system xhp, sqlite3
3# - there should be a bit more packaged into files
4# - build fail:
5#Linking CXX executable hphp
6#Building hphpi
7#Exception: ParseError: [<string>:1] Unable to parse line hphpi_build.hdf
8#make[2]: *** [src/hphp/hphp] Error 255
9#make[1]: *** [src/hphp/CMakeFiles/hphp.dir/all] Error 2
65446f6c
ER
10Summary: HipHop for PHP transforms PHP source code into highly optimized C++
11Name: hiphop-php
3f49543c 12Version: 0.1
65446f6c 13Release: 0.1
3f49543c 14License: PHP 3.01
ac2930bc 15Group: Development/Languages
3f49543c 16# git clone git://github.com/facebook/hiphop-php.git
59f13ffd
ER
17# rm -rf hiphop-php/src/third_party/libmbfl
18# tar --exclude-vcs -cjf hiphop-php.tar.bz2 hiphop-php
ac2930bc 19Source0: %{name}.tar.bz2
4356f011 20# Source0-md5: fbeaba0785d6ae3a6f513576867fb5a6
59f13ffd
ER
21Patch0: cmake-missing-library.patch
22Patch1: system-libmbfl.patch
23Patch2: gcc45.patch
3f49543c
ER
24URL: http://wiki.github.com/facebook/hiphop-php/
25BuildRequires: binutils-devel
59f13ffd 26BuildRequires: bison >= 2.3
3f49543c
ER
27BuildRequires: boost-devel >= 1.37
28BuildRequires: cmake >= 2.6.4
ac2930bc 29BuildRequires: curl-devel >= 7.20.1-2
3f49543c 30BuildRequires: expat-devel
59f13ffd 31BuildRequires: flex >= 2.5.35
3f49543c
ER
32BuildRequires: gd-devel
33BuildRequires: libcap-devel
ac2930bc
ER
34BuildRequires: libevent-devel >= 1.4.13-2
35BuildRequires: libicu-devel >= 4.2
59f13ffd 36BuildRequires: libmbfl-devel
3f49543c
ER
37BuildRequires: libmcrypt
38BuildRequires: libstdc++-devel >= 6:4.1
ac2930bc 39BuildRequires: libxml2-devel
3f49543c 40BuildRequires: mysql-devel
ac2930bc 41BuildRequires: oniguruma-devel
3f49543c
ER
42BuildRequires: openssl-devel
43BuildRequires: pcre-devel
44BuildRequires: re2c >= 0.13.0
ac2930bc 45BuildRequires: tbb-devel >= 2.2
3f49543c 46BuildRequires: zlib-devel
ac2930bc 47ExclusiveArch: %{x8664}
65446f6c
ER
48BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50%description
51HipHop transforms your PHP source code into highly optimized C++ and
52then compiles it with g++ to build binary files. You keep coding in
53simpler PHP, then HipHop executes your source code in a semantically
54equivalent manner and sacrifices some rarely used features - such as
55eval() - in exchange for improved performance.
56
57Facebook sees about a 50% reduction in CPU usage when serving equal
58amounts of Web traffic when compared to Apache and PHP. Facebook's API
59tier can serve twice the traffic using 30% less CPU.
60
61Keep up to date on HipHop development by joining the HipHop for PHP
62Discussion Group.
63
64%prep
ac2930bc 65%setup -qn %{name}
59f13ffd
ER
66%patch0 -p1
67%patch1 -p1
68%patch2 -p1
69
70%{__sed} -i -e 's,/usr/local/bin/php,/usr/bin/php,g' src/crutch.php
ac2930bc
ER
71
72%build
73export HPHP_HOME=$(pwd)
74export HPHP_LIB=$HPHP_HOME/bin
75
59f13ffd
ER
76%cmake . \
77 -DCMAKE_BUILD_TYPE=%{!?debug:Release}%{?debug:Debug} \
78 -DCMAKE_INSTALL_PREFIX=%{_prefix} \
79%if "%{_lib}" == "lib64"
80 -DLIB_SUFFIX=64
81%endif
ac2930bc
ER
82%{__make}
83
65446f6c
ER
84%install
85rm -rf $RPM_BUILD_ROOT
59f13ffd
ER
86%{__make} install \
87 DESTDIR=$RPM_BUILD_ROOT
65446f6c
ER
88
89%clean
90rm -rf $RPM_BUILD_ROOT
91
92%files
93%defattr(644,root,root,755)
59f13ffd
ER
94%{_includedir}/afdt.h
95%{_libdir}/libafdt.a
96%{_libdir}/libxhp.a
This page took 0.173294 seconds and 4 git commands to generate.