]> git.pld-linux.org Git - packages/hhvm.git/blame - hiphop-php.spec
keep HPHP_HOME correct during install
[packages/hhvm.git] / hiphop-php.spec
CommitLineData
ac2930bc 1# TODO
11ccead6 2# - system libevent2: https://github.com/facebook/hiphop-php/pull/421
59f13ffd 3# - system libmbfl, system xhp, sqlite3
1c0ae000 4%define githash 78394ee
1fc71018 5%define rel 0.4
ed14b19f 6Summary: Virtual Machine, Runtime, and JIT for PHP
65446f6c 7Name: hiphop-php
ed14b19f 8Version: 2.1.0
1c0ae000 9Release: 0.%{githash}.%{rel}
3f49543c 10License: PHP 3.01
ac2930bc 11Group: Development/Languages
1c0ae000
ER
12Source0: https://github.com/facebook/hiphop-php/archive/%{githash}/HPHP-%{version}.%{githash}.tar.gz
13# Source0-md5: 81742a0535a6bab906208d3756b206d1
ef07ca95
ER
14# need fb.changes.patch, which is available for 1.4 only
15Source1: http://www.monkey.org/~provos/libevent-1.4.14b-stable.tar.gz
16# Source1-md5: a00e037e4d3f9e4fe9893e8a2d27918c
be373886 17Source2: get-source.sh
59f13ffd 18Patch0: cmake-missing-library.patch
be373886 19Patch1: libevent14.patch
ef07ca95
ER
20Patch3: system-xhp.patch
21Patch4: system-libafdt.patch
6147aa3c 22Patch5: system-folly.patch
37be4b7f 23Patch6: boost-system-category.patch
3f49543c
ER
24URL: http://wiki.github.com/facebook/hiphop-php/
25BuildRequires: binutils-devel
59f13ffd 26BuildRequires: bison >= 2.3
ed14b19f
ER
27BuildRequires: boost-devel >= 1.50
28BuildRequires: cmake >= 2.8.5
29BuildRequires: curl-devel >= 7.29.0
30BuildRequires: elfutils-devel
3f49543c 31BuildRequires: expat-devel
59f13ffd 32BuildRequires: flex >= 2.5.35
3f49543c 33BuildRequires: gd-devel
ed14b19f
ER
34BuildRequires: glog-devel >= 0.3.2
35BuildRequires: imap-devel >= 1:2007
a0922d01 36#BuildRequires: jemalloc-devel
ef07ca95 37BuildRequires: libafdt-devel >= 0.1.0
3f49543c 38BuildRequires: libcap-devel
ed14b19f
ER
39BuildRequires: libdwarf-devel
40#BuildRequires: libevent-devel >= 1.4.14
ac2930bc 41BuildRequires: libicu-devel >= 4.2
be373886 42#BuildRequires: libmbfl-devel
ed14b19f 43BuildRequires: libmcrypt-devel
e883c14f 44BuildRequires: libmemcached-devel >= 1.0.4
ef07ca95 45BuildRequires: libstdc++-devel >= 6:4.3
ed14b19f 46BuildRequires: libunwind-devel
ac2930bc 47BuildRequires: libxml2-devel
3f49543c 48BuildRequires: mysql-devel
ac2930bc 49BuildRequires: oniguruma-devel
3f49543c
ER
50BuildRequires: openssl-devel
51BuildRequires: pcre-devel
ed14b19f 52#BuildRequires: php-xhp-devel >= 1.3.9-6
3f49543c 53BuildRequires: re2c >= 0.13.0
ed14b19f 54BuildRequires: readline-devel
ef07ca95 55BuildRequires: rpmbuild(macros) >= 1.600
ed14b19f 56BuildRequires: tbb-devel >= 4.0.6000
3f49543c 57BuildRequires: zlib-devel
17c75ade 58ExclusiveArch: %{x8664}
65446f6c
ER
59BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
60
61%description
ed14b19f
ER
62HipHop VM (HHVM) is a new open-source virtual machine designed for
63executing programs written in PHP. HHVM uses a just-in-time
64compilation approach to achieve superior performance while maintaining
65the flexibility that PHP developers are accustomed to. HipHop VM (and
66before it HPHPc) has realized > 5x increase in throughput for Facebook
67compared with Zend PHP 5.2.
65446f6c 68
ed14b19f
ER
69HipHop is most commonly run as a standalone server, replacing both
70Apache and mod_php.
65446f6c 71
65446f6c 72%prep
1c0ae000
ER
73%setup -qc -a1
74mv %{name}-%{githash}*/* .
6147aa3c 75%patch5 -p1
37be4b7f 76%patch6 -p1
ed14b19f
ER
77
78ln -s libevent-1.4.*-stable libevent
79%{__patch} -d libevent -p1 < hphp/third_party/libevent-1.4.14.fb-changes.diff
80
81%if 0
59f13ffd 82%patch0 -p1
be373886 83%patch1 -p1
ef07ca95
ER
84#%patch3 -p1
85%patch4 -p1
86
59f13ffd 87
be373886
ER
88#rm -rf src/third_party/libmbfl
89#sed -i -e '/add_subdirectory(third_party\/libmbfl)/d' src/CMakeLists.txt
90
ef07ca95
ER
91rm -rf src/third_party/xhp
92rm -rf src/third_party/libafdt
ed14b19f 93%endif
ac2930bc
ER
94
95%build
ef07ca95
ER
96# build libevent 1.4 with fb patches
97if [ ! -d libevent/.libs ]; then
98 cd libevent
99 # TODO: should use static linking, but then it fails to detect libraries due missing -lrt
100 %configure \
101 %{?0:--enable-static} \
102 %{?0:--disable-shared}
103 %{__make}
104 ln -s .libs lib
105 ln -s . include
106 cd ..
107fi
108
ac2930bc
ER
109export HPHP_HOME=$(pwd)
110export HPHP_LIB=$HPHP_HOME/bin
111
ed14b19f
ER
112%if 0
113export LIBEVENT_PREFIX=$HPHP_HOME/libevent
114
115 -DLibEvent_LIB=$HPHP_HOME/libevent/libevent.so \
116 -DLibEvent_INCLUDE_PATHS=$HPHP_HOME/libevent \
117 -DLibEvent_LIB_PATHS=$HPHP_HOME/libevent/.libs \
118%endif
119
e883c14f
ER
120%if 0
121# out of dir build broken (can't find it's tools)
ef07ca95
ER
122install -d build
123cd build
e883c14f
ER
124%endif
125
ed14b19f 126CPPFLAGS="%{rpmcppflags} -fno-permissive"
ef07ca95 127%cmake \
ed14b19f 128 -DLIBEVENT_LIB=$HPHP_HOME/libevent/lib/libevent.so \
c5cd2e9b 129 -DLIBEVENT_INCLUDE_DIR=$HPHP_HOME/libevent \
ef07ca95
ER
130 -DCMAKE_PREFIX_PATH=%{_prefix} \
131 -DSKIP_BUNDLED_XHP=ON \
a0922d01 132 -DUSE_JEMALLOC=OFF \
be373886 133 -DUSE_TCMALLOC=OFF \
e883c14f 134 ./
ac2930bc
ER
135%{__make}
136
65446f6c
ER
137%install
138rm -rf $RPM_BUILD_ROOT
8d9f731f 139%{__make} install \
05199c54 140 HPHP_HOME=$(pwd) \
8d9f731f
ER
141 DESTDIR=$RPM_BUILD_ROOT
142
44fcba3e 143install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/hdf
17307be4 144cp -p hphp/doc/mime.hdf $RPM_BUILD_ROOT%{_datadir}/%{name}/hdf/static.mime-types.hdf
44fcba3e 145
8d9f731f
ER
146# install our libevent for now
147install -d $RPM_BUILD_ROOT%{_libdir}
148libtool --mode=install install -p libevent/libevent.la $RPM_BUILD_ROOT%{_libdir}
149%{__rm} $RPM_BUILD_ROOT%{_libdir}/libevent.{a,la,so}
65446f6c
ER
150
151%clean
152rm -rf $RPM_BUILD_ROOT
153
8d9f731f
ER
154%post -p /sbin/ldconfig
155%postun -p /sbin/ldconfig
156
65446f6c
ER
157%files
158%defattr(644,root,root,755)
1c0ae000 159%doc README.md hphp/NEWS
8d9f731f
ER
160%attr(755,root,root) %{_bindir}/hhvm
161%attr(755,root,root) %{_libdir}/libevent-1.4.so.*.*.*
162%ghost %{_libdir}/libevent-1.4.so.2
44fcba3e
ER
163
164%dir %{_datadir}/%{name}
165%dir %{_datadir}/%{name}/hdf
166%{_datadir}/%{name}/hdf/static.mime-types.hdf
This page took 0.643203 seconds and 4 git commands to generate.