]> git.pld-linux.org Git - packages/highway.git/blame - highway.spec
- disabled debug packages (static libs are not covered)
[packages/highway.git] / highway.spec
CommitLineData
a15f1265
JB
1#
2# Conditional build:
3%bcond_without apidocs # API documentation
4#
5Summary: Efficient and performance-portable SIMD
6Summary(pl.UTF-8): Wydajne i przenośne operacje SIMD
7Name: highway
8Version: 0.14.2
9Release: 1
10License: Apache v2.0
11Group: Libraries
12#Source0Download: https://github.com/google/highway/releases
13Source0: https://github.com/google/highway/archive/%{version}/%{name}-%{version}.tar.gz
14# Source0-md5: 4821b1064a35baa24ea36994c0d58c41
15URL: https://github.com/google/highway
16BuildRequires: cmake >= 3.10
8564459d 17BuildRequires: gtest-devel
a15f1265
JB
18BuildRequires: libstdc++-devel >= 6:4.7
19BuildRequires: rpm-build >= 4.6
20BuildRequires: rpmbuild(macros) >= 1.605
21BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
824a55eb
JB
23# only static libraries included
24%define _enable_debug_packages 0
25
a15f1265
JB
26%description
27Highway is a C++ library for SIMD (Single Instruction, Multiple Data),
28i.e. applying the same operation to multiple 'lanes' using a single
29CPU instruction.
30
31%description -l pl.UTF-8
32Highway to biblioteka C++ do operacji SIMD (Single Instruction,
33Multiple Data), czyli wykonywania tej samej operacji na wielu "pasach"
34przy użyciu pojedynczej instrukcji procesora.
35
36%package devel
37Summary: Development files for Highway library
38Summary(pl.UTF-8): Pliki programistyczne biblioteki Highway
39Group: Development/Libraries
40
41%description devel
42Development files for Highway library.
43
44%description devel -l pl.UTF-8
45Pliki programistyczne biblioteki Highway.
46
47%package apidocs
48Summary: API documentation for Highway library
49Summary(pl.UTF-8): Dokumentacja API biblioteki Highway
50Group: Documentation
51BuildArch: noarch
52
53%description apidocs
54API documentation for Highway library.
55
56%description apidocs -l pl.UTF-8
57Dokumentacja API biblioteki Highway.
58
59%prep
60%setup -q
61
62%build
63install -d build
64cd build
65%cmake .. \
66 -DCMAKE_INSTALL_INCLUDEDIR=include \
8564459d
JB
67 -DCMAKE_INSTALL_LIBDIR=%{_lib} \
68 -DHWY_SYSTEM_GTEST=ON
a15f1265
JB
69
70%{__make}
71
72%install
73rm -rf $RPM_BUILD_ROOT
74
75%{__make} -C build install \
76 DESTDIR=$RPM_BUILD_ROOT
77
78%clean
79rm -rf $RPM_BUILD_ROOT
80
81%files devel
82%defattr(644,root,root,755)
83%doc README.md
84%{_libdir}/libhwy.a
85%{_libdir}/libhwy_contrib.a
86%{_includedir}/hwy
87%{_pkgconfigdir}/libhwy.pc
88%{_pkgconfigdir}/libhwy-contrib.pc
89%{_pkgconfigdir}/libhwy-test.pc
90
91%if %{with apidocs}
92%files apidocs
93%defattr(644,root,root,755)
94%doc g3doc/*.{md,pdf}
95%endif
This page took 0.126082 seconds and 4 git commands to generate.