]> git.pld-linux.org Git - packages/hdhomerun.git/blame - hdhomerun.spec
new, version 20140604
[packages/hdhomerun.git] / hdhomerun.spec
CommitLineData
3197483f
ER
1# TODO
2# - fix icons
3%define releasedate 20140604
4%define rel 0.1
5Summary: Silicon Dust HDHomeRun configuration utility
6Name: hdhomerun
7Version: 0.0
8Release: 0.%{releasedate}.%{rel}
9License: LGPL v3 and GPL v3
10Group: Applications/System
11Source0: http://download.silicondust.com/hdhomerun/lib%{name}_%{releasedate}.tgz
12# Source0-md5: 13d4b0f5f20448179a5c05ee85b83786
13Source1: http://download.silicondust.com/hdhomerun/%{name}_config_gui_%{releasedate}.tgz
14# Source1-md5: 317c833cab1a2c50bdb651ed3149ee2d
15Source2: %{name}_config_gui.desktop
16URL: http://www.silicondust.com/
17BuildRequires: desktop-file-utils
18BuildRequires: gtk+2-devel
19BuildRequires: libicns
20Requires: gtk+2
21Requires: gtk-update-icon-cache
22Requires: hicolor-icon-theme
23BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25%description
26The configuration and firmware upgrade utility for Silicon Dust's
27networked HDTV dual-tuner HDHomeRun device.
28
29%description
30The configuration and firmware upgrade utility for Silicon Dust's
31networked HDTV dual-tuner HDHomeRun device.
32
33%package devel
34Summary: Developer tools for the hdhomerun library
35Group: Development
36Requires: %{name} = %{version}-%{release}
37
38%description devel
39The hdhumerun-devel package provides developer tools for the hdhomerun
40library.
41
42%prep
43%setup -qc -a 1
44
45# Fix up linefeeds, drop execute bit and don't strip binaries
46%{__sed} -i 's/\r//' libhdhomerun/*
47%{__chmod} -x libhdhomerun/*
48%{__sed} -i -e '/$(STRIP).*/d' -e 's/C\(PP\)\?FLAGS .=/C\1FLAGS ?=/' libhdhomerun/Makefile
49
50# Convert files to utf8
51for f in libhdhomerun/*; do
52 iconv -f iso-8859-1 -t utf-8 --output $f.new $f && mv $f.new $f
53done
54
55cat << __EOF__ > README.firmware
56The HDHomeRun Firmwares are not redistributable, but the latest versions of
57both the US ATSC and European DVB-T firmwares can always be obtained from
58the Silicon Dust web site:
59
60http://www.silicondust.com/downloads/linux
61
62__EOF__
63
64%build
65cd hdhomerun_config_gui
66%configure
67%{__make}
68cd ..
69
70%if 0
71# fails with assertion:
72#+ icns2png -x hdhr.icns
73#icns2png: jpc_dec.c:1072: jpc_dec_tiledecode: Assertion `dec->numcomps == 3' failed.
74cd hdhomerun_config_gui/OSX
75icns2png -x hdhr.icns
76cd -
77%endif
78
79%install
80rm -rf $RPM_BUILD_ROOT
81%{__make} -C hdhomerun_config_gui install \
82 DESTDIR=$RPM_BUILD_ROOT
83
84install -p libhdhomerun/hdhomerun_config $RPM_BUILD_ROOT%{_bindir}
85rm -rf include
86install -d include
87cp -a libhdhomerun/*.h include
88sed -r 's|(^#include +["])(.*)(["] *$)|#include <hdhomerun/\2>|' \
89 libhdhomerun/hdhomerun.h > include/hdhomerun.h
90install -d $RPM_BUILD_ROOT%{_includedir}/hdhomerun
91cp -p include/*.h $RPM_BUILD_ROOT%{_includedir}/hdhomerun
92desktop-file-install --dir=${RPM_BUILD_ROOT}%{_desktopdir} %{SOURCE2}
93
94%if 0
95for size in 16x16 32x32 128x128 256x256 512x512; do
96 install -d $RPM_BUILD_ROOT%{_iconsdir}/hicolor/${size}
97 cp -p hdhomerun_config_gui/OSX/hdhr_${size}x32.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/${size}/hdhr.png
98done
99%endif
100
101%clean
102rm -rf $RPM_BUILD_ROOT
103
104%if 0
105%post
106%update_icon_cache hicolor
107
108%postun
109%update_icon_cache hicolor
110%endif
111
112%files
113%defattr(644,root,root,755)
114%doc libhdhomerun/lgpl.txt libhdhomerun/README hdhomerun_config_gui/COPYING README.firmware
115# lib and cli are LGPLv3
116%{_libdir}/libhdhomerun.so
117%attr(755,root,root) %{_bindir}/hdhomerun_config
118# gui is GPLv3
119%attr(755,root,root) %{_bindir}/hdhomerun_config_gui
120%{_desktopdir}/hdhomerun_config_gui.desktop
121#%{_iconsdir}/hicolor/*/hdhr.png
122
123%files devel
124%defattr(644,root,root,755)
125%dir %{_includedir}/hdhomerun
126%{_includedir}/hdhomerun/*.h
This page took 0.097996 seconds and 4 git commands to generate.