]> git.pld-linux.org Git - packages/gyp.git/blame - gyp.spec
- release 2
[packages/gyp.git] / gyp.spec
CommitLineData
c0a97864
ER
1#
2# Conditional build:
3%bcond_without tests # build without tests
4
d97eea3f 5%define svnrev 795
235ee385 6%define rel 2
c0a97864
ER
7Summary: Generate Your Projects
8Name: gyp
2e583992 9Version: 1
7f23d1d9 10Release: %{svnrev}.%{rel}
c0a97864
ER
11License: New BSD
12Group: Development/Building
d97eea3f 13# revno=795
2e583992
ER
14# svn co http://gyp.googlecode.com/svn/trunk${revno:+@$revno} gyp
15# tar -cjf gyp-$(svnversion gyp).tar.bz2 --exclude=.svn gyp
16# ../dropin gyp-$(svnversion gyp).tar.bz2
c0a97864 17Source0: %{name}-%{svnrev}.tar.bz2
d97eea3f 18# Source0-md5: 7ff7a085e5e352c6d3188acce3661a89
c0a97864
ER
19URL: http://code.google.com/p/gyp/
20BuildRequires: python-devel
21BuildRequires: rpm-pythonprov
22BuildRequires: rpmbuild(macros) >= 1.219
593a2a50 23Requires: python-%{name} = %{version}-%{release}
c0a97864
ER
24BuildArch: noarch
25BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27%description
28GYP is a tool to generates native Visual Studio, Xcode and SCons
29and/or make build files from a platform-independent input format. It's
30syntax is a universal cross-platform build representation that still
31allows sufficient per-platform flexibility to accommodate
32irreconcilable differences.
33
593a2a50
ER
34%package -n python-%{name}
35Summary: Python module for GYP
36Group: Development/Languages/Python
37
38%description -n python-%{name}
39GYP is a tool to generates native Visual Studio, Xcode and SCons
40and/or make build files from a platform-independent input format. It's
41syntax is a universal cross-platform build representation that still
42allows sufficient per-platform flexibility to accommodate
43irreconcilable differences.
44
c0a97864
ER
45%prep
46%setup -q -n %{name}
47
48%build
49%{__python} setup.py build
50
51%install
52rm -rf $RPM_BUILD_ROOT
53%{__python} setup.py install \
54 --optimize=2 \
55 --root=$RPM_BUILD_ROOT
56
57%py_postclean
58
59%clean
60rm -rf $RPM_BUILD_ROOT
61
62%files
63%defattr(644,root,root,755)
64%attr(755,root,root) %{_bindir}/gyp
593a2a50
ER
65
66%files -n python-%{name}
7f23d1d9 67%defattr(644,root,root,755)
c0a97864
ER
68%dir %{py_sitescriptdir}/gyp
69%dir %{py_sitescriptdir}/gyp/generator
70%{py_sitescriptdir}/gyp/*.py[co]
71%{py_sitescriptdir}/gyp/generator/*.py[co]
72
73%if "%{py_ver}" > "2.4"
74%{py_sitescriptdir}/gyp-*.egg-info
75%endif
This page took 0.033513 seconds and 4 git commands to generate.