]> git.pld-linux.org Git - packages/gyp.git/blame - gyp.spec
- cosmetics
[packages/gyp.git] / gyp.spec
CommitLineData
c0a97864
ER
1#
2# Conditional build:
d01b1cd9 3%bcond_with tests # build without tests
8eebf2c2 4%bcond_with python3 # build with python 3.x
c0a97864 5
f33fa229
AM
6%define gitrev e87d37d6
7%define rel 1
c0a97864 8Summary: Generate Your Projects
ba2c7f2a 9Summary(pl.UTF-8): GYP (Generate Your Projects) - narzędzie do generowania systemów budowania
c0a97864 10Name: gyp
e1338491
ER
11# grep version= setup.py
12Version: 0.1
f33fa229 13Release: 1.%{rel}.%{gitrev}
c0a97864
ER
14License: New BSD
15Group: Development/Building
b5cae1dc 16# use get-source.sh
f33fa229
AM
17Source0: %{name}-%{version}-git%{gitrev}.tar.xz
18# Source0-md5: 9b6f6c10bb8def91e26c17f0be1f7f90
19Patch0: gyp-rpmoptflags.patch
20Patch1: gyp-ninja-build.patch
21Patch2: gyp-python3.patch
22Patch3: gyp-python38.patch
23Patch4: gyp-fix-cmake.patch
24Patch5: gyp-python39.patch
f78d47c3 25URL: https://gyp.gsrc.io/
c5734287
MK
26%{!?with_python3:BuildRequires: python-devel}
27%{?with_python3:BuildRequires: python3-devel}
c0a97864
ER
28BuildRequires: rpm-pythonprov
29BuildRequires: rpmbuild(macros) >= 1.219
c5734287
MK
30%{!?with_python3:Requires: python-%{name} = %{version}-%{release}}
31%{?with_python3:Requires: python3-%{name} = %{version}-%{release}}
c0a97864
ER
32BuildArch: noarch
33BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35%description
36GYP is a tool to generates native Visual Studio, Xcode and SCons
37and/or make build files from a platform-independent input format. It's
38syntax is a universal cross-platform build representation that still
39allows sufficient per-platform flexibility to accommodate
40irreconcilable differences.
41
ba2c7f2a
JB
42%description -l pl.UTF-8
43GYP to narzędzie generujące natywne pliki budowania dla Visual Studio,
44Xcode, SCons i/lub make'a z formatu wejściowego niezależnego od
45platformy. Składnia jest uniwersalną, wieloplatformową reprezentacją
46reguł, która nadal pozwala na wystarczającą elastyczność dla
47poszczególnych platform, aby obsłużyć różnice między nimi.
48
593a2a50 49%package -n python-%{name}
ba2c7f2a
JB
50Summary: Python modules for GYP
51Summary(pl.UTF-8): Moduły Pythona module dla GYP
593a2a50
ER
52Group: Development/Languages/Python
53
54%description -n python-%{name}
55GYP is a tool to generates native Visual Studio, Xcode and SCons
56and/or make build files from a platform-independent input format. It's
57syntax is a universal cross-platform build representation that still
58allows sufficient per-platform flexibility to accommodate
ba2c7f2a
JB
59poszczególnych platform, aby obsłużyć różnice między nimi.
60
61This package contains Python modules.
62
63%description -n python-%{name} -l pl.UTF-8
64GYP to narzędzie generujące natywne pliki budowania dla Visual Studio,
65Xcode, SCons i/lub make'a z formatu wejściowego niezależnego od
66platformy. Składnia jest uniwersalną, wieloplatformową reprezentacją
67reguł, która nadal pozwala na wystarczającą elastyczność dla
68poszczególnych platform, aby obsłużyć różnice między nimi.
69
70Ten pakiet zawiera moduły Pythona.
593a2a50 71
c5734287
MK
72%package -n python3-%{name}
73Summary: Python modules for GYP
74Summary(pl.UTF-8): Moduły Pythona module dla GYP
75Group: Development/Languages/Python
76
77%description -n python3-%{name}
78GYP is a tool to generates native Visual Studio, Xcode and SCons
79and/or make build files from a platform-independent input format. It's
80syntax is a universal cross-platform build representation that still
81allows sufficient per-platform flexibility to accommodate
82poszczególnych platform, aby obsłużyć różnice między nimi.
83
84This package contains Python modules.
85
86%description -n python3-%{name} -l pl.UTF-8
87GYP to narzędzie generujące natywne pliki budowania dla Visual Studio,
88Xcode, SCons i/lub make'a z formatu wejściowego niezależnego od
89platformy. Składnia jest uniwersalną, wieloplatformową reprezentacją
90reguł, która nadal pozwala na wystarczającą elastyczność dla
91poszczególnych platform, aby obsłużyć różnice między nimi.
92
93Ten pakiet zawiera moduły Pythona.
94
c0a97864 95%prep
f33fa229
AM
96%setup -q -c
97%patch0 -p1
98%patch1 -p1
99%patch2 -p1
100%patch3 -p1
101%patch4 -p1
102%patch5 -p1
c0a97864
ER
103
104%build
c5734287
MK
105%if %{with python3}
106%py3_build
107%else
54b7c2c7 108%py_build
c5734287 109%endif
c0a97864 110
d01b1cd9
ER
111%{?with_tests:%{__python} gyptest.py -a}
112
c0a97864
ER
113%install
114rm -rf $RPM_BUILD_ROOT
54b7c2c7 115
c5734287
MK
116%if %{with python3}
117%py3_install
118%else
54b7c2c7 119%py_install
c0a97864 120%py_postclean
c5734287 121%endif
c0a97864
ER
122
123%clean
124rm -rf $RPM_BUILD_ROOT
125
126%files
127%defattr(644,root,root,755)
d01b1cd9 128%doc AUTHORS LICENSE
c0a97864 129%attr(755,root,root) %{_bindir}/gyp
593a2a50 130
c5734287 131%if !%{with python3}
593a2a50 132%files -n python-%{name}
7f23d1d9 133%defattr(644,root,root,755)
c0a97864
ER
134%dir %{py_sitescriptdir}/gyp
135%dir %{py_sitescriptdir}/gyp/generator
136%{py_sitescriptdir}/gyp/*.py[co]
137%{py_sitescriptdir}/gyp/generator/*.py[co]
c0a97864 138%if "%{py_ver}" > "2.4"
ba2c7f2a 139%{py_sitescriptdir}/gyp-%{version}-py*.egg-info
c0a97864 140%endif
c5734287 141%endif
368464aa
MK
142
143%if %{with python3}
144%files -n python3-%{name}
145%defattr(644,root,root,755)
146%dir %{py3_sitescriptdir}/gyp
147%dir %{py3_sitescriptdir}/gyp/generator
148%{py3_sitescriptdir}/gyp/*.py
149%{py3_sitescriptdir}/gyp/__pycache__
150%{py3_sitescriptdir}/gyp/generator/*.py
151%{py3_sitescriptdir}/gyp/generator/__pycache__
152%{py3_sitescriptdir}/gyp-%{version}-py*.egg-info
153%endif
This page took 0.314924 seconds and 4 git commands to generate.