]> git.pld-linux.org Git - packages/gwenhywfar.git/blame - gwenhywfar.spec
- work around qmake and libtool incompatibilities to build qt5 gui, rel 2
[packages/gwenhywfar.git] / gwenhywfar.spec
CommitLineData
af34125f 1#
2# TODO: - define _one_, system-wide place for ca-bundle.crt and use one, up-to-date file
837db2f5 3# - fix qt5 link error and bring back qt5 gui subpackage
a57bd46d
JB
4#
5# Conditional build:
4a25ca26
JB
6%bcond_without fox # FOX 1.6 GUI
7%bcond_without qt # any Qt GUI (convenience)
8%bcond_without qt4 # Qt 4 GUI
fe619c65 9%bcond_without qt5 # Qt 5 GUI
4a25ca26 10%bcond_without static_libs # static libraries
837db2f5
BS
11%bcond_with tests # run tests
12
af34125f 13#
4a25ca26
JB
14%if %{without qt}
15%undefine with_qt4
16%undefine with_qt5
17%endif
c9677431 18Summary: Gwenhywfar - a multi-platform helper library for networking and security
c0251854 19Summary(pl.UTF-8): Gwenhywfar - wieloplatformowa biblioteka pomocnicza do sieci i bezpieczeństwa
c9677431 20Name: gwenhywfar
736f284c 21Version: 5.7.3
fe619c65 22Release: 2
c9677431
JB
23License: LGPL v2.1+ with OpenSSL linking exception
24Group: Libraries
26eacd05 25# https://www.aquamaniac.de/sites/download/packages.php
736f284c
KM
26Source0: https://www.aquamaniac.de/rdm/attachments/download/390/%{name}-%{version}.tar.gz
27# Source0-md5: ba92064a046501524064c926492ecc3d
ddd06fd7 28Patch0: gcc.patch
4a25ca26
JB
29Patch1: %{name}-qt5.patch
30URL: https://www.aquamaniac.de/sites/aqbanking/
45b54d76 31BuildRequires: autoconf >= 2.60
a24cb890 32BuildRequires: automake
a57bd46d 33%{?with_fox:BuildRequires: fox16-devel >= 1.6}
9f3f6391 34BuildRequires: gettext-tools
4a25ca26 35BuildRequires: gnutls-devel >= 2.9.8
9db45f92 36BuildRequires: gtk+2-devel >= 2:2.17.5
837db2f5 37BuildRequires: gtk+3-devel >= 3.10.8
9db45f92 38BuildRequires: libgcrypt-devel >= 1.2.0
4a25ca26
JB
39BuildRequires: libgpg-error-devel
40BuildRequires: libstdc++-devel
41BuildRequires: libtool >= 2:1.5
c9677431 42BuildRequires: openssl-devel
9db45f92 43BuildRequires: pkgconfig
4a25ca26
JB
44%if %{with qt4}
45BuildRequires: QtCore-devel >= 4
46BuildRequires: QtGui-devel >= 4
c3f30a6d 47BuildRequires: qt4-build
4a25ca26
JB
48%endif
49%if %{with qt5}
50BuildRequires: Qt5Core-devel >= 5
51BuildRequires: Qt5Gui-devel >= 5
52BuildRequires: Qt5Widgets-devel >= 5
53BuildRequires: qt5-build >= 5
54BuildRequires: qt5-qmake >= 5
55%endif
56Requires: gnutls-libs >= 2.9.8
9db45f92 57Requires: libgcrypt >= 1.2.0
c9677431
JB
58BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
59
4a25ca26
JB
60%define ver_cmake %(echo %{version} | cut -d. -f 1-2)
61
c9677431
JB
62%description
63This is Gwenhywfar, a multi-platform helper library for networking and
64security applications and libraries. It is used by:
45b54d76 65 - Libchipcard (http://www.libchipcard.de/),
c9677431
JB
66 - OpenHBCI2 (http://www.openhbci.de/),
67 - Simthetic, the simulation tool (http://simthetic.sourceforge.net/)
68 - AqBanking/AqHBCI (http://www.aquamaniac.de/aqbanking/).
69
4dabdb30 70%description -l pl.UTF-8
c9677431 71To jest Gwenhywfar - wieloplatformowa biblioteka pomocnicza do
4dabdb30
JR
72aplikacji i bibliotek związanych z siecią i bezpieczeństwem. Jest
73używana przez:
45b54d76 74 - Libchipcard (http://www.libchipcard.de/),
c9677431 75 - OpenHBCI2 (http://www.openhbci.de/),
4dabdb30 76 - narzędzie do symulacji Simthetic (http://simthetic.sourceforge.net/)
c9677431
JB
77 - AqBanking/AqHBCI (http://www.aquamaniac.de/aqbanking/).
78
79%package devel
80Summary: Header files for Gwenhywfar library
c0251854 81Summary(pl.UTF-8): Pliki nagłówkowe biblioteki Gwenhywfar
c9677431
JB
82Group: Development/Libraries
83Requires: %{name} = %{version}-%{release}
4a25ca26 84Requires: gnutls-devel >= 2.9.8
9db45f92 85Requires: libgcrypt-devel >= 1.2.0
c9677431
JB
86
87%description devel
88Header files for Gwenhywfar library.
89
4dabdb30
JR
90%description devel -l pl.UTF-8
91Pliki nagłówkowe biblioteki Gwenhywfar.
c9677431
JB
92
93%package static
94Summary: Static Gwenhywfar library
c0251854 95Summary(pl.UTF-8): Statyczna biblioteka Gwenhywfar
c9677431
JB
96Group: Development/Libraries
97Requires: %{name}-devel = %{version}-%{release}
98
99%description static
100Static Gwenhywfar library.
101
4dabdb30 102%description static -l pl.UTF-8
c9677431
JB
103Statyczna biblioteka Gwenhywfar.
104
4a25ca26
JB
105%package gui-cpp
106Summary: C++ wrapper classes for Gwenhywfar GUI functions
107Summary(pl.UTF-8): Klasy C++ obudowujące funkcje GUI biblioteki Gwenhywfar
108Group: Libraries
109Requires: %{name} = %{version}-%{release}
110
111%description gui-cpp
112C++ wrapper classes for Gwenhywfar GUI functions.
113
114%description gui-cpp -l pl.UTF-8
115Klasy C++ obudowujące funkcje GUI biblioteki Gwenhywfar.
116
117%package gui-cpp-devel
118Summary: Header files for Gwenhywfar GUI C++ library
119Summary(pl.UTF-8): Pliki nagłówkowe biblioteki Gwenhywfar GUI C++
120Group: Development/Libraries
121Requires: %{name}-devel = %{version}-%{release}
122Requires: %{name}-gui-cpp = %{version}-%{release}
123Requires: libstdc++-devel
124
125%description gui-cpp-devel
126Header files for Gwenhywfar GUI C++ library.
127
128%description gui-cpp-devel -l pl.UTF-8
129Pliki nagłówkowe biblioteki Gwenhywfar GUI C++.
130
131%package gui-cpp-static
132Summary: Static Gwenhywfar GUI C++ library
133Summary(pl.UTF-8): Statyczna biblioteka Gwenhywfar GUI C++
134Group: Development/Libraries
135Requires: %{name}-gui-cpp-devel = %{version}-%{release}
136
137%description gui-cpp-static
138Static Gwenhywfar GUI C++ library.
139
140%description gui-cpp-static -l pl.UTF-8
141Statyczna biblioteka Gwenhywfar GUI C++.
142
143# TODO: rename to gui-fox[16] when something changes
a57bd46d 144%package fox
4a25ca26
JB
145Summary: FOX 1.6 Gwenhywfar GUI library implementation of the GWEN_DIALOG framework
146Summary(pl.UTF-8): Biblioteka graficznego interfejsu FOX 1.6 do Gwenhywfar
a57bd46d 147Group: X11/Libraries
4a25ca26 148Requires: %{name}-gui-cpp = %{version}-%{release}
a57bd46d
JB
149
150%description fox
4a25ca26 151FOX 1.6 Gwenhywfar GUI library, containing FOX implementation of the
a57bd46d
JB
152GWEN_DIALOG framework.
153
837db2f5 154%description fox -l pl.UTF-8
4a25ca26
JB
155Biblioteka graficznego interfejsu FOX 1.6 do Gwenhywfar, zawierająca
156implementację FOX szkieletu GWEN_DIALOG.
a57bd46d
JB
157
158%package fox-devel
159Summary: Header files for FOX 1.6 Gwenhywfar GUI library
160Summary(pl.UTF-8): Pliki nagłówkowe biblioteki graficznego interfejsu FOX 1.6 do Gwenhywfar
161Group: X11/Development/Libraries
a57bd46d 162Requires: %{name}-fox = %{version}-%{release}
4a25ca26 163Requires: %{name}-gui-cpp-devel = %{version}-%{release}
a57bd46d
JB
164Requires: fox16-devel >= 1.6
165
166%description fox-devel
167Header files for FOX 1.6 Gwenhywfar GUI library
168
169%description fox-devel -l pl.UTF-8
170Pliki nagłówkowe biblioteki graficznego interfejsu FOX 1.6 do
171Gwenhywfar.
172
173%package fox-static
174Summary: Static FOX 1.6 Gwenhywfar GUI library
175Summary(pl.UTF-8): Statyczna biblioteka graficznego interfejsu FOX 1.6 do Gwenhywfar
176Group: X11/Development/Libraries
177Requires: %{name}-fox-devel = %{version}-%{release}
178
179%description fox-static
180Static FOX 1.6 Gwenhywfar GUI library.
181
182%description fox-static -l pl.UTF-8
183Statyczna biblioteka graficznego interfejsu FOX 1.6 do Gwenhywfar.
184
837db2f5 185%package gui-gtk2
ce6dc1cb
JB
186Summary: GTK+ 2 Gwenhywfar GUI library implementation of the GWEN_DIALOG framework
187Summary(pl.UTF-8): Biblioteka graficznego interfejsu GTK+ 2 do Gwenhywfar
188Group: X11/Libraries
189Requires: %{name} = %{version}-%{release}
a57bd46d 190Requires: gtk+2 >= 2:2.17.5
837db2f5 191Obsoletes: gwenhywfar-gtk < 5.6.0
ce6dc1cb 192
837db2f5 193%description gui-gtk2
ce6dc1cb
JB
194GTK+ 2 Gwenhywfar GUI library, containing GTK+ 2 implementation of the
195GWEN_DIALOG framework.
196
837db2f5 197%description gui-gtk2 -l pl.UTF-8
ce6dc1cb 198Biblioteka graficznego interfejsu GTK+ 2 do Gwenhywfar, zawierająca
837db2f5 199implementację gui-gtk2+ 2 szkieletu GWEN_DIALOG.
ce6dc1cb 200
837db2f5 201%package gui-gtk2-devel
ce6dc1cb
JB
202Summary: Header files for GTK+ 2 Gwenhywfar GUI library
203Summary(pl.UTF-8): Pliki nagłówkowe biblioteki graficznego interfejsu GTK+ 2 do Gwenhywfar
204Group: X11/Development/Libraries
205Requires: %{name}-devel = %{version}-%{release}
837db2f5 206Requires: %{name}-gui-gtk2 = %{version}-%{release}
a57bd46d 207Requires: gtk+2-devel >= 2:2.17.5
837db2f5 208Obsoletes: gwenhywfar-gtk-devel < 5.6.0
ce6dc1cb 209
837db2f5 210%description gui-gtk2-devel
ce6dc1cb
JB
211Header files for GTK+ 2 Gwenhywfar GUI library
212
837db2f5 213%description gui-gtk2-devel -l pl.UTF-8
ce6dc1cb
JB
214Pliki nagłówkowe biblioteki graficznego interfejsu GTK+ 2 do
215Gwenhywfar.
216
837db2f5 217%package gui-gtk2-static
ce6dc1cb
JB
218Summary: Static GTK+ 2 Gwenhywfar GUI library
219Summary(pl.UTF-8): Statyczna biblioteka graficznego interfejsu GTK+ 2 do Gwenhywfar
220Group: X11/Development/Libraries
837db2f5
BS
221Requires: %{name}-gui-gtk2-devel = %{version}-%{release}
222Obsoletes: gwenhywfar-gtk-static < 5.6.0
ce6dc1cb 223
837db2f5 224%description gui-gtk2-static
ce6dc1cb
JB
225Static GTK+ 2 Gwenhywfar GUI library.
226
837db2f5 227%description gui-gtk2-static -l pl.UTF-8
ce6dc1cb
JB
228Statyczna biblioteka graficznego interfejsu GTK+ 2 do Gwenhywfar.
229
837db2f5
BS
230%package gui-gtk3
231Summary: GTK+ 3 Gwenhywfar GUI library implementation of the GWEN_DIALOG framework
232Summary(pl.UTF-8): Biblioteka graficznego interfejsu GTK+ 3 do Gwenhywfar
233Group: X11/Libraries
234Requires: %{name} = %{version}-%{release}
235Requires: gtk+3 >= 3.10.8
236
237%description gui-gtk3
238GTK+ 3 Gwenhywfar GUI library, containing GTK+ 3 implementation of the
239GWEN_DIALOG framework.
240
241%description gui-gtk3 -l pl.UTF-8
242Biblioteka graficznego interfejsu GTK+ 3 do Gwenhywfar, zawierająca
243implementację GTK+ 3 szkieletu GWEN_DIALOG.
244
245%package gui-gtk3-devel
246Summary: Header files for GTK+ 3 Gwenhywfar GUI library
247Summary(pl.UTF-8): Pliki nagłówkowe biblioteki graficznego interfejsu GTK+ 2 do Gwenhywfar
248Group: X11/Development/Libraries
249Requires: %{name}-devel = %{version}-%{release}
250Requires: %{name}-gui-gtk3 = %{version}-%{release}
251Requires: gtk+3-devel >= 3.10.8
252
253%description gui-gtk3-devel
254Header files for GTK+ 3 Gwenhywfar GUI library
255
256%description gui-gtk3-devel -l pl.UTF-8
257Pliki nagłówkowe biblioteki graficznego interfejsu GTK+ 3 do
258Gwenhywfar.
259
260%package gui-gtk3-static
261Summary: Static GTK+ 3 Gwenhywfar GUI library
262Summary(pl.UTF-8): Statyczna biblioteka graficznego interfejsu GTK+ 3 do Gwenhywfar
263Group: X11/Development/Libraries
264Requires: %{name}-gui-gtk3-devel = %{version}-%{release}
265
266%description gui-gtk3-static
267Static GTK+ 3 Gwenhywfar GUI library.
268
269%description gui-gtk3-static -l pl.UTF-8
270Statyczna biblioteka graficznego interfejsu GTK+ 3 do Gwenhywfar.
271
4a25ca26 272%package gui-qt4
ce6dc1cb
JB
273Summary: Qt 4 Gwenhywfar GUI library implementation of the GWEN_DIALOG framework
274Summary(pl.UTF-8): Biblioteka graficznego interfejsu Qt 4 do Gwenhywfar
275Group: X11/Libraries
4a25ca26
JB
276Requires: %{name}-gui-cpp = %{version}-%{release}
277Obsoletes: gwenhywfar-qt < 4.15
ce6dc1cb 278
4a25ca26 279%description gui-qt4
ce6dc1cb
JB
280Qt 4 Gwenhywfar GUI library, containing Qt 4 implementation of the
281GWEN_DIALOG framework.
282
837db2f5 283%description gui-qt4 -l pl.UTF-8
ce6dc1cb 284Biblioteka graficznego interfejsu Qt 4 do Gwenhywfar, zawierająca
4a25ca26 285implementację Qt 4 szkieletu GWEN_DIALOG.
ce6dc1cb 286
4a25ca26 287%package gui-qt4-devel
ce6dc1cb
JB
288Summary: Header files for Qt 4 Gwenhywfar GUI library
289Summary(pl.UTF-8): Pliki nagłówkowe biblioteki graficznego interfejsu Qt 4 do Gwenhywfar
290Group: X11/Development/Libraries
4a25ca26
JB
291Requires: %{name}-gui-cpp-devel = %{version}-%{release}
292Requires: %{name}-gui-qt4 = %{version}-%{release}
293Requires: QtCore-devel >= 4
a57bd46d 294Requires: QtGui-devel >= 4
4a25ca26 295Obsoletes: gwenhywfar-qt-devel < 4.15
ce6dc1cb 296
4a25ca26 297%description gui-qt4-devel
ce6dc1cb
JB
298Header files for Qt 4 Gwenhywfar GUI library
299
4a25ca26 300%description gui-qt4-devel -l pl.UTF-8
ce6dc1cb
JB
301Pliki nagłówkowe biblioteki graficznego interfejsu Qt 4 do Gwenhywfar.
302
4a25ca26 303%package gui-qt4-static
ce6dc1cb
JB
304Summary: Static Qt 4 Gwenhywfar GUI library
305Summary(pl.UTF-8): Statyczna biblioteka graficznego interfejsu Qt 4 do Gwenhywfar
306Group: X11/Development/Libraries
4a25ca26
JB
307Requires: %{name}-gui-qt4-devel = %{version}-%{release}
308Obsoletes: gwenhywfar-qt-static < 4.15
ce6dc1cb 309
4a25ca26 310%description gui-qt4-static
ce6dc1cb
JB
311Static Qt 4 Gwenhywfar GUI library.
312
4a25ca26 313%description gui-qt4-static -l pl.UTF-8
ce6dc1cb
JB
314Statyczna biblioteka graficznego interfejsu Qt 4 do Gwenhywfar.
315
4a25ca26
JB
316%package gui-qt5
317Summary: Qt 5 Gwenhywfar GUI library implementation of the GWEN_DIALOG framework
318Summary(pl.UTF-8): Biblioteka graficznego interfejsu Qt 5 do Gwenhywfar
319Group: X11/Libraries
320Requires: %{name}-gui-cpp = %{version}-%{release}
321
322%description gui-qt5
323Qt 5 Gwenhywfar GUI library, containing Qt 5 implementation of the
324GWEN_DIALOG framework.
325
837db2f5 326%description gui-qt5 -l pl.UTF-8
4a25ca26
JB
327Biblioteka graficznego interfejsu Qt 5 do Gwenhywfar, zawierająca
328implementację Qt 5 szkieletu GWEN_DIALOG.
329
330%package gui-qt5-devel
331Summary: Header files for Qt 5 Gwenhywfar GUI library
332Summary(pl.UTF-8): Pliki nagłówkowe biblioteki graficznego interfejsu Qt 5 do Gwenhywfar
333Group: X11/Development/Libraries
334Requires: %{name}-gui-cpp-devel = %{version}-%{release}
335Requires: %{name}-gui-qt5 = %{version}-%{release}
336Requires: Qt5Core-devel >= 5
337Requires: Qt5Gui-devel >= 5
338Requires: Qt5Widgets-devel >= 5
339
340%description gui-qt5-devel
341Header files for Qt 5 Gwenhywfar GUI library
342
343%description gui-qt5-devel -l pl.UTF-8
344Pliki nagłówkowe biblioteki graficznego interfejsu Qt 5 do Gwenhywfar.
345
346%package gui-qt5-static
347Summary: Static Qt 5 Gwenhywfar GUI library
348Summary(pl.UTF-8): Statyczna biblioteka graficznego interfejsu Qt 5 do Gwenhywfar
349Group: X11/Development/Libraries
350Requires: %{name}-gui-qt5-devel = %{version}-%{release}
351
352%description gui-qt5-static
353Static Qt 5 Gwenhywfar GUI library.
354
355%description gui-qt5-static -l pl.UTF-8
356Statyczna biblioteka graficznego interfejsu Qt 5 do Gwenhywfar.
357
736f284c
KM
358%package gwenbuild
359Summary: Specific build system for the aqbanking universe
360Summary(pl.UTF-8): Specyficzny system budowania dla uniwersum aqbanking
361Group: Development/Libraries
362Requires: %{name}-devel = %{version}
363
364%description gwenbuild
365Gwenbuild is a lightweight and fast build system tailored for the
366aqbanking universe.
367
368%description gwenbuild -l pl.UTF-8
369Gwenbuild to lekki i szybki system budowania dopasowany do uniwersum
370aqbanking.
371
c9677431
JB
372%prep
373%setup -q
bcc983e9 374%patch0 -p1
4a25ca26 375%patch1 -p1
c9677431
JB
376
377%build
45b54d76
JB
378# gettextize not used (custom support instead of AM_GNU_GETTEXT)
379touch config.rpath
a24cb890
JB
380%{__libtoolize}
381%{__aclocal} -I m4
382%{__autoconf}
383%{__autoheader}
384%{__automake}
c9677431 385%configure \
4a25ca26
JB
386 --disable-network-checks \
387 %{?with_static_libs:--enable-static} \
837db2f5 388 --with-guis="%{?with_fox:fox16 }gtk2 gtk3%{?with_qt4: qt4}%{?with_qt5: qt5}" \
ce6dc1cb 389 --with-openssl-libs=%{_libdir} \
4a25ca26
JB
390 --with-qt4-libs=%{_libdir} \
391 --with-qt5-moc=%{_bindir}/moc-qt5 \
392 --with-qt5-qmake=%{_bindir}/qmake-qt5 \
393 --with-qt5-uic=%{_bindir}/uic-qt5
c77e6c9f 394
fe619c65
JR
395%{__make} \
396 QT_LIBS="-lQt5Widgets -lQt5Gui -lQt5Core -lGL -lpthread"
c9677431 397
837db2f5
BS
398%if %{with tests}
399%{__make} check
400%endif
401
c9677431
JB
402%install
403rm -rf $RPM_BUILD_ROOT
404
405%{__make} install \
406 DESTDIR=$RPM_BUILD_ROOT
407
ee88dacb
JB
408%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la \
409 $RPM_BUILD_ROOT%{_libdir}/gwenhywfar/plugins/*/*/*.la
410%if %{with static_libs}
411%{__rm} $RPM_BUILD_ROOT%{_libdir}/gwenhywfar/plugins/*/*/*.a
412%endif
c9677431
JB
413
414%find_lang %{name}
415
416%clean
417rm -rf $RPM_BUILD_ROOT
418
419%post -p /sbin/ldconfig
420%postun -p /sbin/ldconfig
421
4a25ca26
JB
422%post gui-cpp -p /sbin/ldconfig
423%postun gui-cpp -p /sbin/ldconfig
424
a57bd46d
JB
425%post fox -p /sbin/ldconfig
426%postun fox -p /sbin/ldconfig
427
837db2f5
BS
428%post gui-gtk2 -p /sbin/ldconfig
429%postun gui-gtk2 -p /sbin/ldconfig
430
431%post gui-gtk3 -p /sbin/ldconfig
432%postun gui-gtk3 -p /sbin/ldconfig
ce6dc1cb 433
4a25ca26
JB
434%post gui-qt4 -p /sbin/ldconfig
435%postun gui-qt4 -p /sbin/ldconfig
436
437%post gui-qt5 -p /sbin/ldconfig
438%postun gui-qt5 -p /sbin/ldconfig
ce6dc1cb 439
c9677431
JB
440%files -f %{name}.lang
441%defattr(644,root,root,755)
442%doc AUTHORS ChangeLog NEWS README TODO
c9677431 443%attr(755,root,root) %{_bindir}/gct-tool
9b17a7cc 444%attr(755,root,root) %{_bindir}/gsa
c9677431
JB
445%attr(755,root,root) %{_bindir}/mklistdoc
446%attr(755,root,root) %{_bindir}/typemaker
9599e188 447%attr(755,root,root) %{_bindir}/typemaker2
c9677431 448%attr(755,root,root) %{_bindir}/xmlmerge
2673ce26 449%attr(755,root,root) %{_libdir}/libgwenhywfar.so.*.*.*
837db2f5 450%ghost %{_libdir}/libgwenhywfar.so.??
c9677431
JB
451%dir %{_libdir}/gwenhywfar
452%dir %{_libdir}/gwenhywfar/plugins
453%dir %{_libdir}/gwenhywfar/plugins/*
45b54d76
JB
454%dir %{_libdir}/gwenhywfar/plugins/*/ct
455%attr(755,root,root) %{_libdir}/gwenhywfar/plugins/*/ct/*.so*
456%{_libdir}/gwenhywfar/plugins/*/ct/*.xml
c9677431
JB
457%dir %{_libdir}/gwenhywfar/plugins/*/dbio
458%attr(755,root,root) %{_libdir}/gwenhywfar/plugins/*/dbio/*.so*
459%{_libdir}/gwenhywfar/plugins/*/dbio/*.xml
104ef448
AF
460%dir %{_libdir}/gwenhywfar/plugins/*/configmgr
461%attr(755,root,root) %{_libdir}/gwenhywfar/plugins/*/configmgr/*.so
462%{_libdir}/gwenhywfar/plugins/*/configmgr/*.xml
45b54d76
JB
463# just ca-bundle.crt
464%{_datadir}/gwenhywfar
c9677431
JB
465
466%files devel
467%defattr(644,root,root,755)
468%attr(755,root,root) %{_bindir}/gwenhywfar-config
2673ce26 469%attr(755,root,root) %{_libdir}/libgwenhywfar.so
837db2f5
BS
470%dir %{_includedir}/gwenhywfar5
471%{_includedir}/gwenhywfar5/gwenhywfar
c9677431
JB
472%{_aclocaldir}/gwenhywfar.m4
473%{_pkgconfigdir}/gwenhywfar.pc
4a25ca26 474%{_libdir}/cmake/gwenhywfar-%{ver_cmake}
c9677431 475
4a25ca26 476%if %{with static_libs}
c9677431
JB
477%files static
478%defattr(644,root,root,755)
ce6dc1cb 479%{_libdir}/libgwenhywfar.a
4a25ca26
JB
480%endif
481
482%files gui-cpp
483%defattr(644,root,root,755)
484%attr(755,root,root) %{_libdir}/libgwengui-cpp.so.*.*.*
837db2f5 485%ghost %{_libdir}/libgwengui-cpp.so.??
4a25ca26
JB
486
487%files gui-cpp-devel
488%defattr(644,root,root,755)
489%attr(755,root,root) %{_libdir}/libgwengui-cpp.so
837db2f5 490%{_includedir}/gwenhywfar5/gwen-gui-cpp
4a25ca26
JB
491%{_libdir}/cmake/gwengui-cpp-%{ver_cmake}
492
493%if %{with static_libs}
494%files gui-cpp-static
495%defattr(644,root,root,755)
496%{_libdir}/libgwengui-cpp.a
497%endif
ce6dc1cb 498
a57bd46d
JB
499%if %{with fox}
500%files fox
501%defattr(644,root,root,755)
502%attr(755,root,root) %{_libdir}/libgwengui-fox16.so.*.*.*
837db2f5 503%ghost %{_libdir}/libgwengui-fox16.so.??
a57bd46d
JB
504
505%files fox-devel
506%defattr(644,root,root,755)
507%attr(755,root,root) %{_libdir}/libgwengui-fox16.so
837db2f5 508%{_includedir}/gwenhywfar5/gwen-gui-fox16
a57bd46d
JB
509%{_pkgconfigdir}/gwengui-fox16.pc
510
4a25ca26 511%if %{with static_libs}
a57bd46d
JB
512%files fox-static
513%defattr(644,root,root,755)
514%{_libdir}/libgwengui-fox16.a
515%endif
4a25ca26 516%endif
a57bd46d 517
837db2f5 518%files gui-gtk2
ce6dc1cb
JB
519%defattr(644,root,root,755)
520%attr(755,root,root) %{_libdir}/libgwengui-gtk2.so.*.*.*
837db2f5 521%ghost %{_libdir}/libgwengui-gtk2.so.??
ce6dc1cb 522
837db2f5 523%files gui-gtk2-devel
ce6dc1cb
JB
524%defattr(644,root,root,755)
525%attr(755,root,root) %{_libdir}/libgwengui-gtk2.so
837db2f5 526%{_includedir}/gwenhywfar5/gwen-gui-gtk2
ce6dc1cb
JB
527%{_pkgconfigdir}/gwengui-gtk2.pc
528
4a25ca26 529%if %{with static_libs}
837db2f5 530%files gui-gtk2-static
ce6dc1cb 531%defattr(644,root,root,755)
8fc6b9b9 532%{_libdir}/libgwengui-gtk2.a
4a25ca26 533%endif
ce6dc1cb 534
837db2f5
BS
535%files gui-gtk3
536%defattr(644,root,root,755)
537%attr(755,root,root) %{_libdir}/libgwengui-gtk3.so.*.*.*
538%ghost %{_libdir}/libgwengui-gtk3.so.??
539
540%files gui-gtk3-devel
541%defattr(644,root,root,755)
542%attr(755,root,root) %{_libdir}/libgwengui-gtk3.so
543%{_includedir}/gwenhywfar5/gwen-gui-gtk3
544%{_pkgconfigdir}/gwengui-gtk3.pc
545
546%if %{with static_libs}
547%files gui-gtk3-static
548%defattr(644,root,root,755)
549%{_libdir}/libgwengui-gtk3.a
550%endif
551
4a25ca26
JB
552%if %{with qt4}
553%files gui-qt4
ce6dc1cb
JB
554%defattr(644,root,root,755)
555%attr(755,root,root) %{_libdir}/libgwengui-qt4.so.*.*.*
837db2f5 556%ghost %{_libdir}/libgwengui-qt4.so.??
ce6dc1cb 557
4a25ca26 558%files gui-qt4-devel
ce6dc1cb
JB
559%defattr(644,root,root,755)
560%attr(755,root,root) %{_libdir}/libgwengui-qt4.so
837db2f5 561%{_includedir}/gwenhywfar5/gwen-gui-qt4
ce6dc1cb 562%{_pkgconfigdir}/gwengui-qt4.pc
4a25ca26 563%{_libdir}/cmake/gwengui-qt4-%{ver_cmake}
ce6dc1cb 564
4a25ca26
JB
565%if %{with static_libs}
566%files gui-qt4-static
ce6dc1cb 567%defattr(644,root,root,755)
8fc6b9b9 568%{_libdir}/libgwengui-qt4.a
4a25ca26
JB
569%endif
570%endif
571
572%if %{with qt5}
573%files gui-qt5
574%defattr(644,root,root,755)
575%attr(755,root,root) %{_libdir}/libgwengui-qt5.so.*.*.*
837db2f5 576%ghost %{_libdir}/libgwengui-qt5.so.??
4a25ca26
JB
577
578%files gui-qt5-devel
579%defattr(644,root,root,755)
580%attr(755,root,root) %{_libdir}/libgwengui-qt5.so
837db2f5 581%{_includedir}/gwenhywfar5/gwen-gui-qt5
4a25ca26
JB
582%{_pkgconfigdir}/gwengui-qt5.pc
583%{_libdir}/cmake/gwengui-qt5-%{ver_cmake}
584
585%if %{with static_libs}
586%files gui-qt5-static
587%defattr(644,root,root,755)
588%{_libdir}/libgwengui-qt5.a
589%endif
590%endif
736f284c
KM
591
592%files gwenbuild
593%defattr(644,root,root,755)
594%attr(755,root,root) %{_bindir}/gwbuild
595%{_datadir}/gwenbuild
This page took 0.128241 seconds and 4 git commands to generate.