]> git.pld-linux.org Git - packages/gtkmm4.git/blame - gtkmm4.spec
- updated to 4.10.0
[packages/gtkmm4.git] / gtkmm4.spec
CommitLineData
33bee831
AF
1#
2# Conditional build:
65b7ef8d 3%bcond_without static_libs # static library
222a6ef9 4
65b7ef8d
JB
5%define cairomm_ver 1.15.4
6%define glibmm_ver 2.68.0
619eabdb 7%define gtk4_ver 4.10.0
1ef4c6ae 8%define pangomm_ver 2.50.0
33bee831
AF
9Summary: A C++ interface for the GTK+ (a GUI library for X)
10Summary(pl.UTF-8): Wrapper C++ dla GTK+
65b7ef8d 11Name: gtkmm4
619eabdb 12Version: 4.10.0
70058bc0 13Release: 1
33bee831
AF
14License: LGPL v2+
15Group: X11/Libraries
619eabdb
JB
16Source0: https://download.gnome.org/sources/gtkmm/4.10/gtkmm-%{version}.tar.xz
17# Source0-md5: b3c2bd5dff7eb5215f5599c705100e18
7c1d0224 18URL: https://www.gtkmm.org/
33bee831 19BuildRequires: autoconf >= 2.59
31a8d119 20BuildRequires: automake >= 1:1.11
65b7ef8d 21BuildRequires: cairomm1.16-devel >= %{cairomm_ver}
c6e33ff3 22BuildRequires: doxygen >= 1:1.8.9
ef8910d5 23BuildRequires: gdk-pixbuf2-devel >= 2.36.0
65b7ef8d
JB
24BuildRequires: glibmm2.68-devel >= %{glibmm_ver}
25BuildRequires: gtk4-devel >= %{gtk4_ver}
70058bc0 26BuildRequires: libepoxy-devel >= 1.2
65b7ef8d
JB
27BuildRequires: libsigc++3-devel >= 3.0
28BuildRequires: libstdc++-devel >= 6:7
e3273d66 29BuildRequires: libtool >= 2:2.0
65b7ef8d
JB
30BuildRequires: mm-common >= 0.9.12
31BuildRequires: pangomm2.48-devel >= %{pangomm_ver}
33bee831
AF
32BuildRequires: perl-base >= 1:5.6.0
33BuildRequires: pkgconfig
e2ee4a25 34BuildRequires: rpm-build >= 4.6
c6e33ff3 35BuildRequires: rpmbuild(macros) >= 1.752
e3273d66
JB
36BuildRequires: tar >= 1:1.22
37BuildRequires: xz
65b7ef8d 38Requires: cairomm1.16 >= %{cairomm_ver}
ef8910d5 39Requires: gdk-pixbuf2 >= 2.36.0
65b7ef8d
JB
40Requires: glibmm2.68 >= %{glibmm_ver}
41Requires: gtk4 >= %{gtk4_ver}
42Requires: pangomm2.48 >= %{pangomm_ver}
33bee831
AF
43BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45%description
46This package provides a C++ interface for GTK+ (the Gimp ToolKit) GUI
47library. The interface provides a convenient interface for C++
48programmers to create GUIs with GTK+'s flexible object-oriented
49framework. Features include type safe callbacks, widgets that are
50extensible using inheritance and over 110 classes that can be freely
51combined to quickly create complex user interfaces.
52
53%description -l pl.UTF-8
54gtkmm jest wrapperem C++ dla Gimp ToolKit (GTK). GTK+ jest biblioteką
55służącą do tworzenia graficznych interfejsów. W pakiecie znajduje się
56także biblioteka gdkmm - wrapper C++ dla GDK (General Drawing Kit).
57
58%package devel
59Summary: gtkmm and gdkmm header files
60Summary(pl.UTF-8): Pliki nagłówkowe gtkmm i gdkmm
61Group: X11/Development/Libraries
62Requires: %{name} = %{version}-%{release}
65b7ef8d 63Requires: cairomm1.16-devel >= %{cairomm_ver}
ef8910d5 64Requires: gdk-pixbuf2-devel >= 2.36.0
65b7ef8d
JB
65Requires: glibmm2.68-devel >= %{glibmm_ver}
66Requires: gtk4-devel >= %{gtk4_ver}
67Requires: libstdc++-devel >= 6:7
68Requires: pangomm2.48-devel >= %{pangomm_ver}
33bee831
AF
69
70%description devel
71Header files for gtkmm library.
72
73%description devel -l pl.UTF-8
74Pliki nagłówkowe biblioteki gtkmm.
75
76%package static
77Summary: gtkmm and gdkmm static libraries
78Summary(pl.UTF-8): Biblioteki statyczne gtkmm i gdkmm
79Group: X11/Development/Libraries
80Requires: %{name}-devel = %{version}-%{release}
81
82%description static
83gtkmm and gdkmm static libraries.
84
85%description static -l pl.UTF-8
86Biblioteki statyczne gtkmm i gdkmm.
87
88%package apidocs
89Summary: Reference documentation for gtkmm and gdkmm
90Summary(pl.UTF-8): Szczegółowa dokumentacja gtkmm i gdkmm
91Group: Documentation
92Requires: devhelp
2baa9a08 93BuildArch: noarch
33bee831
AF
94
95%description apidocs
96Reference documentation for gtkmm and gdkmm.
97
98%description apidocs -l pl.UTF-8
99Szczegółowa dokumentacja gtkmm i gdkmm.
100
101%prep
102%setup -q -n gtkmm-%{version}
103
c6e33ff3
JB
104# missing in release tarball, not needed for Linux
105mkdir win32_installer
106touch win32_installer/filelist.am \
107 win32_installer/gtkmm-installer.nsi.in
108
33bee831 109%build
c6e33ff3 110mm-common-prepare --copy --force
33bee831
AF
111%{__libtoolize}
112%{__aclocal} -I build
113%{__autoconf}
114%{__autoheader}
115%{__automake}
116%configure \
c6e33ff3 117 --enable-maintainer-mode \
ef8910d5 118 --disable-silent-rules \
33bee831
AF
119 %{?with_static_libs:--enable-static}
120
121%{__make}
122
123%install
124rm -rf $RPM_BUILD_ROOT
125
126%{__make} install \
127 DESTDIR=$RPM_BUILD_ROOT
128
129%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
130
131%clean
132rm -rf $RPM_BUILD_ROOT
133
134%post -p /sbin/ldconfig
135%postun -p /sbin/ldconfig
136
137%files
138%defattr(644,root,root,755)
619eabdb 139%doc AUTHORS ChangeLog NEWS README.md
65b7ef8d
JB
140%attr(755,root,root) %{_libdir}/libgtkmm-4.0.so.*.*.*
141%attr(755,root,root) %ghost %{_libdir}/libgtkmm-4.0.so.0
33bee831
AF
142
143%files devel
144%defattr(644,root,root,755)
65b7ef8d
JB
145%attr(755,root,root) %{_libdir}/libgtkmm-4.0.so
146%{_libdir}/gtkmm-4.0
147%{_includedir}/gtkmm-4.0
148%{_pkgconfigdir}/gtkmm-4.0.pc
33bee831
AF
149
150%if %{with static_libs}
151%files static
152%defattr(644,root,root,755)
65b7ef8d 153%{_libdir}/libgtkmm-4.0.a
33bee831
AF
154%endif
155
156%files apidocs
157%defattr(644,root,root,755)
65b7ef8d
JB
158%{_docdir}/gtkmm-4.0
159%{_datadir}/devhelp/books/gtkmm-4.0
This page took 0.189741 seconds and 4 git commands to generate.