]> git.pld-linux.org Git - packages/gtk-webkit4.git/blame - gtk-webkit3.spec
- updated to 1.4.0
[packages/gtk-webkit4.git] / gtk-webkit3.spec
CommitLineData
7200a9cd 1# TODO:
7200a9cd 2# - review configure options
f8e56294
AF
3#
4# Conditional build:
5%bcond_without introspection # disable introspection
6#
7Summary: Port of WebKit embeddable web component to GTK+
8Summary(pl.UTF-8): Port osadzalnego komponentu WWW WebKit do GTK+
9Name: gtk-webkit3
250fd109
MB
10Version: 1.4.0
11Release: 1
f8e56294
AF
12License: BSD-like
13Group: X11/Libraries
14Source0: http://webkitgtk.org/webkit-%{version}.tar.gz
250fd109 15# Source0-md5: 10c969db3b5484c71df1aa9a338377ff
f8e56294
AF
16URL: http://webkitgtk.org/
17BuildRequires: autoconf >= 2.59
18BuildRequires: automake
19BuildRequires: bison
20BuildRequires: cairo-devel >= 1.6
21BuildRequires: enchant-devel >= 0.22
22BuildRequires: flex >= 2.5.33
23BuildRequires: fontconfig-devel >= 2.4.0
24BuildRequires: freetype-devel >= 1:2.1.8
25BuildRequires: geoclue-devel
26BuildRequires: gettext-devel
c66a3aee 27BuildRequires: glib2-devel >= 1:2.28.0
f8e56294 28BuildRequires: glibc-misc
c66a3aee 29%{?with_introspection:BuildRequires: gobject-introspection-devel >= 0.10.0}
f8e56294
AF
30BuildRequires: gperf
31BuildRequires: gstreamer-devel >= 0.10
32BuildRequires: gstreamer-plugins-base-devel >= 0.10.25
c66a3aee 33BuildRequires: gtk+3-devel >= 3.0.0
f8e56294
AF
34BuildRequires: gtk-doc >= 1.10
35BuildRequires: libicu-devel >= 4.2.1
36BuildRequires: libjpeg-devel
37BuildRequires: libpng-devel
1e21f0c2 38BuildRequires: libsoup-devel >= 2.34.0
f8e56294
AF
39BuildRequires: libstdc++-devel
40BuildRequires: libtool >= 2:1.5
41BuildRequires: libxml2-devel >= 1:2.6.30
42BuildRequires: libxslt-devel >= 1.1.7
43BuildRequires: pango-devel >= 1:1.12
44BuildRequires: pkgconfig
c66a3aee 45BuildRequires: rpmbuild(macros) >= 1.592
f8e56294
AF
46BuildRequires: sqlite3-devel
47BuildRequires: xorg-lib-libXft-devel >= 2.0.0
48BuildRequires: xorg-lib-libXt-devel
c66a3aee 49Requires(post,postun): glib2 >= 1:2.26.0
f8e56294
AF
50Requires: cairo >= 1.6
51Requires: enchant >= 0.22
52Requires: gstreamer-plugins-base >= 0.10.25
c66a3aee 53Requires: gtk+3 >= 3.0.0
1e21f0c2 54Requires: libsoup >= 2.34.0
f8e56294
AF
55Requires: libxml2 >= 1:2.6.30
56Requires: libxslt >= 1.1.7
57Requires: pango >= 1:1.12
58%{?with_introspection:Conflicts: gir-repository < 0.6.5-7}
59BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
60
61%description
62webkit is a port of the WebKit embeddable web component to GTK+.
63
64%description -l pl.UTF-8
65webkit to port osadzalnego komponentu WWW WebKit do GTK+.
66
67%package devel
68Summary: Development files for WebKit
69Summary(pl.UTF-8): Pliki programistyczne WebKit
70Group: X11/Development/Libraries
71Requires: %{name} = %{version}-%{release}
c66a3aee
MB
72Requires: glib2-devel >= 1:2.28.0
73Requires: gtk+3-devel >= 3.0.0
1e21f0c2 74Requires: libsoup-devel >= 2.34.0
f8e56294
AF
75
76%description devel
77Development files for WebKit.
78
79%description devel -l pl.UTF-8
80Pliki programistyczne WebKit.
81
82%prep
83%setup -q -n webkit-%{version}
d3159f4a 84mv Source/WebKit/gtk/po/{gr,el}.po
f8e56294
AF
85
86%build
87%{__gtkdocize}
f8e56294 88%{__libtoolize}
7f68fdfd 89%{__aclocal} -I Source/autotools
f8e56294
AF
90%{__autoheader}
91%{__automake}
92%{__autoconf}
93%configure \
f8e56294 94 --disable-silent-rules \
c66a3aee
MB
95 %{__enable_disable introspection} \
96 --with-gtk=3.0 \
bb409ad4 97 --enable-3d-transforms \
f8e56294
AF
98 --enable-dom-storage \
99 --enable-geolocation \
100 --enable-icon-database \
f8e56294
AF
101 --enable-video \
102 --with-font-backend=freetype
103
104%{__make}
105
106%install
107rm -rf $RPM_BUILD_ROOT
108
109%{__make} install \
110 DESTDIR=$RPM_BUILD_ROOT
111
959213a2
AF
112%{__rm} $RPM_BUILD_ROOT%{_libdir}/libwebkitgtk-3.0.la
113
5a54ae22 114%find_lang webkit-3.0
f8e56294
AF
115
116%clean
117rm -rf $RPM_BUILD_ROOT
118
c66a3aee
MB
119%post
120/sbin/ldconfig
121%glib_compile_schemas
122
123%postun
124/sbin/ldconfig
125%glib_compile_schemas
f8e56294
AF
126
127%files -f webkit-3.0.lang
128%defattr(644,root,root,755)
129%doc ChangeLog
130%attr(755,root,root) %{_bindir}/jsc-3
131%attr(755,root,root) %{_libdir}/libwebkitgtk-3.0.so.*.*.*
132%attr(755,root,root) %ghost %{_libdir}/libwebkitgtk-3.0.so.0
133%if %{with introspection}
134%{_libdir}/girepository-1.0/JSCore-3.0.typelib
135%{_libdir}/girepository-1.0/WebKit-3.0.typelib
136%endif
137%dir %{_datadir}/webkit-3.0
c53434ba
PZ
138%{_datadir}/webkit-3.0/resources
139%dir %{_datadir}/webkitgtk-3.0
f8e56294
AF
140%{_datadir}/webkitgtk-3.0/images
141%{_datadir}/webkitgtk-3.0/webinspector
c66a3aee 142%{_datadir}/glib-2.0/schemas/org.webkitgtk-3.0.gschema.xml
f8e56294
AF
143
144%files devel
145%defattr(644,root,root,755)
146%attr(755,root,root) %{_libdir}/libwebkitgtk-3.0.so
f8e56294
AF
147%if %{with introspection}
148%{_datadir}/gir-1.0/JSCore-3.0.gir
149%{_datadir}/gir-1.0/WebKit-3.0.gir
150%endif
151%{_includedir}/webkit-3.0
152%{_pkgconfigdir}/webkitgtk-3.0.pc
This page took 0.111449 seconds and 4 git commands to generate.