]> git.pld-linux.org Git - packages/gstreamer-libav.git/blame - gstreamer-libav.spec
- libav 10.5 inside
[packages/gstreamer-libav.git] / gstreamer-libav.spec
CommitLineData
9a2cc8d0
AM
1#
2# Conditional build:
3%bcond_without vdpau # build libav without VDPAU support
4%bcond_with system_libav # system libav (note: upstream does not accept bugs with system libav)
dd5c5789 5%bcond_with system_ffmpeg # system ffmpeg instead of libav (unadvised, only some ffmpeg versions are compatible)
9a2cc8d0
AM
6
7%define gstname gst-libav
8%define gst_major_ver 1.0
dd5c5789
JB
9%define gst_req_ver 1.4.0
10%define gstpb_req_ver 1.4.0
2978fefd 11%define libav_ver 10.5
dd5c5789 12%define ffmpeg_ver 2.2
9a2cc8d0 13
dd5c5789
JB
14%if %{with system_ffmpeg}
15%define with_system_libav 1
16%endif
9a2cc8d0
AM
17%include /usr/lib/rpm/macros.gstreamer
18Summary: GStreamer Streaming-media framework plug-in using libav
19Summary(pl.UTF-8): Wtyczka do środowiska obróbki strumieni GStreamer używająca libav
20Name: gstreamer-libav
1756b2e2 21Version: 1.4.3
9a2cc8d0 22Release: 1
19033c7c 23License: LGPL v2+ (gst part), GPL v2+ (some libav parts)
9a2cc8d0
AM
24Group: Libraries
25Source0: http://gstreamer.freedesktop.org/src/gst-libav/%{gstname}-%{version}.tar.xz
1756b2e2 26# Source0-md5: 248b6aae752710bbae77af01f74a082d
9a2cc8d0 27URL: http://gstreamer.net/
19033c7c
JB
28BuildRequires: autoconf >= 2.62
29BuildRequires: automake >= 1:1.11
9a2cc8d0
AM
30BuildRequires: bzip2-devel
31BuildRequires: gstreamer-devel >= %{gst_req_ver}
a1ca68bd 32BuildRequires: gstreamer-plugins-base-devel >= %{gstpb_req_ver}
19033c7c 33BuildRequires: gtk-doc >= 1.12
9a2cc8d0 34BuildRequires: libtool
19033c7c 35BuildRequires: orc-devel >= 0.4.16
9a2cc8d0
AM
36BuildRequires: pkgconfig
37BuildRequires: python >= 2.1
38BuildRequires: rpmbuild(macros) >= 1.470
39%if %{with system_libav}
19033c7c 40# libavformat,libavcodec,libavutil,libswscale needed
dd5c5789
JB
41%if %{with system_ffmpeg}
42BuildRequires: ffmpeg-devel >= %{ffmpeg_ver}
43%else
894a4536 44BuildRequires: libav-devel >= %{libav_ver}
dd5c5789 45%endif
9a2cc8d0 46%else
19033c7c
JB
47# libav dependencies
48BuildRequires: SDL-devel
49BuildRequires: zlib-devel
50%ifarch %{ix86} %{x8664}
51BuildRequires: yasm
52%endif
9a2cc8d0
AM
53%if %{with vdpau}
54BuildRequires: libvdpau-devel
55BuildRequires: xorg-lib-libXvMC-devel
56%endif
57%endif
19033c7c
JB
58BuildRequires: tar >= 1:1.22
59BuildRequires: xz
a1ca68bd
JB
60Requires: gstreamer >= %{gst_req_ver}
61Requires: gstreamer-plugins-base >= %{gstpb_req_ver}
dd5c5789
JB
62%if %{with system_libav}
63%if %{with system_ffmpeg}
64BuildRequires: ffmpeg-libs >= %{ffmpeg_ver}
65%else
66BuildRequires: libav >= %{libav_ver}
67%endif
68%endif
19033c7c 69Requires: orc >= 0.4.16
978acf86 70Obsoletes: gstreamer-ffmpeg
9a2cc8d0
AM
71BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
72
73%description
74GStreamer is a streaming-media framework, based on graphs of filters
75which operate on media data. Applications using this library can do
76anything from real-time sound processing to playing videos, and just
77about anything else media-related. Its plugin-based architecture means
78that new data types or processing capabilities can be added simply by
79installing new plug-ins.
80
81This plugin contains the libav codecs, containing codecs for most
82popular multimedia formats.
83
84%description -l pl.UTF-8
85GStreamer to środowisko obróbki danych strumieniowych, bazujące na
86grafie filtrów operujących na danych medialnych. Aplikacje używające
87tej biblioteki mogą robić wszystko od przetwarzania dźwięku w czasie
88rzeczywistym, do odtwarzania filmów i czegokolwiek innego związanego z
89mediami. Architektura bazująca na wtyczkach pozwala na łatwe dodawanie
90nowych typów danych lub możliwości obróbki.
91
92Wtyczka ta zawiera kodeki libav, potrafiące zdekodować
93najpopularniejsze formaty multimedialne.
94
dd5c5789
JB
95%package apidocs
96Summary: API documentation for GStreamer libav plugin
97Summary(pl.UTF-8): Dokumentacja API do wtyczki GStreamera libav
98Group: Documentation
99Requires: gtk-doc-common
100
101%description apidocs
102API documentation for GStreamer libav plugin.
103
104%description apidocs -l pl.UTF-8
105Dokumentacja API do wtyczki GStreamera libav.
106
9a2cc8d0
AM
107%prep
108%setup -q -n %{gstname}-%{version}
109
110%build
111%{__libtoolize}
112%{__aclocal} -I m4 -I common/m4
113%{__autoconf}
114%{__autoheader}
115%{__automake}
116
117%configure \
118 CPPFLAGS="%{rpmcppflags}" \
119 %{?with_system_libav:--with-system-libav} \
120 %{?with_vdpau:--with-libav-extra-configure="--enable-vdpau"} \
121 --disable-silent-rules \
dd5c5789
JB
122 --disable-static \
123 --with-html-dir=%{_gtkdocdir}
19033c7c
JB
124# V=1 is for libav (--disable-silent-rules affects only main gst-libav sources)
125%{__make} \
126 V=1
9a2cc8d0
AM
127
128%install
129rm -rf $RPM_BUILD_ROOT
130
131%{__make} install \
132 DESTDIR=$RPM_BUILD_ROOT
133
134%{__rm} $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{gst_major_ver}/*.la
135
136%clean
137rm -rf $RPM_BUILD_ROOT
138
139%files
140%defattr(644,root,root,755)
141%doc AUTHORS ChangeLog NEWS README TODO
142%attr(755,root,root) %{_libdir}/gstreamer-%{gst_major_ver}/libgstlibav.so
894a4536
JB
143# disabled in (upstream) 1.2.0 until someone fixes it
144#%attr(755,root,root) %{_libdir}/gstreamer-%{gst_major_ver}/libgstavscale.so
dd5c5789
JB
145
146%files apidocs
147%defattr(644,root,root,755)
148%{_gtkdocdir}/gst-libav-plugins-1.0
This page took 0.115224 seconds and 4 git commands to generate.