]> git.pld-linux.org Git - packages/grub2.git/blame - grub2.spec
- rel 4; fix build with gcc8
[packages/grub2.git] / grub2.spec
CommitLineData
f97cafb4 1# TODO
dc6928bc 2# - reap out which in probe scripts and drop R: which
f97cafb4 3# - subpackages? e.g. modules and utils
bcd6a47e 4# - check where is that locale path: /boot/grub/locale and fix it or change it
8fcee4aa
ER
5# - grubemu notes
6# --enable-grub-emu-usb conflicts with --enable-grub-emu-pci, emu-pci seems experimental
7# - to build and install the `grub-emu' debugging utility we need to re-run build with --target=emu
8# - put grub-emu to subpackage if it is fixed
f97cafb4 9#
90feddde 10# Conditional build:
1536aaf2 11%bcond_with grubemu # build grub-emu debugging utility
b06c130d 12%bcond_without efiemu # build efiemu runtimes
1536aaf2
JK
13%bcond_without pc # do not build for PC BIOS platform
14%bcond_without efi # do not build for EFI platform
b06c130d 15
50ffb0ba 16%ifnarch %{ix86} %{x8664} x32
feaacba3
JB
17%undefine with_pc
18%endif
50ffb0ba 19%ifnarch %{ix86} %{x8664} x32 ia64
feaacba3
JB
20%undefine with_efi
21%endif
22
50ffb0ba 23%ifnarch %{x8664} x32
2d8da575
AM
24# non-x86_64 arch doesn't support this
25%undefine with_efiemu
26%endif
27
1536aaf2 28# the 'most natural' platform should go last
50ffb0ba 29%ifarch %{ix86} %{x8664} x32 ia64
1536aaf2 30%define platforms %{?with_efi:efi} %{?with_pc:pc}
feaacba3
JB
31%endif
32%ifarch ppc ppc64 sparc64
33%define platforms ieee1275
34%endif
35%ifarch mips
36%define platforms arc
37%endif
38%ifarch mipsel
39%define platforms loongson
40%endif
1536aaf2 41
a4c52d96 42%define rel 1
afe8504a 43Summary: GRand Unified Bootloader
c8155f7f 44Summary(de.UTF-8): GRUB2 - ein Bootloader für x86 und ppc
f97cafb4 45Summary(hu.UTF-8): GRUB2 - rendszerbetöltő x86 és ppc gépekhez
c8155f7f
ER
46Summary(pl.UTF-8): GRUB2 - bootloader dla x86 i ppc
47Summary(pt_BR.UTF-8): Gerenciador de inicialização GRUB2
afe8504a 48Name: grub2
b876d99a 49Version: 2.02
c87c31b6 50Release: 4
2e4bec6f 51License: GPL v2
afe8504a 52Group: Base
729e6097
JP
53Source0: ftp://ftp.gnu.org/gnu/grub/grub-%{version}.tar.xz
54# Source0-md5: 8a4a2a95aac551fb0fba860ceabfa1d3
22909ca1
ER
55Source1: update-grub
56Source2: update-grub.8
b46589aa 57Source3: grub.sysconfig
e2964b87 58Source4: grub-custom.cfg
b46589aa 59Patch1: pld-sysconfdir.patch
872700b0 60Patch2: grub-garbage.patch
c9273ffc
JK
61Patch3: grub-lvmdevice.patch
62Patch4: pld-mkconfigdir.patch
63Patch5: grub-mkconfig-diagnostics.patch
668ecb01
JK
64Patch6: posix.patch
65Patch7: %{name}-fonts_path.patch
66Patch8: add-vlan-tag-support.patch
67Patch9: just-say-linux.patch
68Patch10: ignore-kernel-symlinks.patch
69Patch11: choose-preferred-initrd.patch
70Patch12: %{name}-cfg.patch
c287192d 71Patch13: efi-net-fix.patch
a4c52d96 72Patch14: blscfg.patch
c28d9078
AM
73# https://git.archlinux.org/svntogit/packages.git/plain/trunk/0002-intel-ucode.patch?h=packages/grub
74Patch15: intel-ucode.patch
d6c673ce 75Patch16: xfs.patch
c87c31b6 76Patch17: gcc8.patch
feaacba3 77URL: http://www.gnu.org/software/grub/
27550907
ER
78BuildRequires: autoconf >= 2.53
79BuildRequires: automake >= 1:1.11.1-1
8b781299 80BuildRequires: bison
06df59fd 81BuildRequires: device-mapper-devel
feaacba3 82BuildRequires: flex >= 2.5.35
26996aed 83BuildRequires: fonts-TTF-DejaVu
feaacba3 84BuildRequires: freetype-devel >= 2
12fd19f5 85BuildRequires: gawk
39b1c916 86BuildRequires: gcc >= 5:3.4
5d291ad2 87BuildRequires: gettext-tools
5bafb558 88BuildRequires: glibc-localedb-all
feaacba3 89BuildRequires: glibc-static
1349ebb8 90BuildRequires: help2man
42985b0d 91BuildRequires: libfuse-devel
afe8504a 92BuildRequires: libtool
feaacba3 93BuildRequires: ncurses-devel
5bafb558
JK
94BuildRequires: python
95BuildRequires: python-modules
feaacba3
JB
96BuildRequires: rpm >= 4.4.9-56
97BuildRequires: rpmbuild(macros) >= 1.213
98BuildRequires: sed >= 4.0
99BuildRequires: tar >= 1:1.22
81a7e0ba 100BuildRequires: texinfo
feaacba3
JB
101BuildRequires: xz
102BuildRequires: xz-devel
c668211a
ER
103%ifarch %{x8664}
104BuildRequires: /usr/lib/libc.so
8905dae4
ER
105%if "%{pld_release}" == "ac"
106BuildRequires: libgcc32
107%else
50ffb0ba 108BuildRequires: gcc-multilib-32
c668211a 109%endif
dee0d6f5 110%endif
feaacba3 111Requires: %{name}-platform = %{version}-%{release}
a5138d8d 112Requires: pld-release
dc6928bc 113Requires: which
feaacba3
JB
114%ifarch %{ix86} %{x8664}
115Suggests: %{name}-platform-pc
116%endif
190cc685 117Suggests: cdrkit-mkisofs
97ee543c 118Suggests: os-prober
afe8504a 119Provides: bootloader
fc835b5e 120Conflicts: grub
50ffb0ba 121ExclusiveArch: %{ix86} %{x8664} x32 ia64 mips mipsel ppc ppc64 sparc64
afe8504a
SP
122BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
123
124%define _sbindir /sbin
4a00f3b7 125%define _bindir %{_sbindir}
1536aaf2 126%define _libdir /lib
e6fbd304 127%define _datadir %{_libdir}
26e757db 128%define _libexecdir %{_libdir}/grub
1536aaf2 129%define _grubdir /boot/grub
da9b7cf9 130%define _localedir /usr/share/locale
9d44d75e 131
0e2cbb94
JK
132# part of grub code is not relocable (these are not Linux libs)
133# stack protector also breaks non-Linux binaries
8c5e5aa2
JR
134# any kind of forced optimizations makes grub2 unreliable (random
135# reboots and hangs on boot menu screen)
5bc5d891 136%define filterout_c -fPIC -O.
5967241e 137%undefine _ssp_cflags
5bc5d891 138%undefine _fortify_cflags
0e2cbb94 139
afe8504a
SP
140%description
141GRUB is a GPLed bootloader intended to unify bootloading across x86
142operating systems. In addition to loading the Linux and *BSD kernels,
143it implements the Multiboot standard, which allows for flexible
144loading of multiple boot images (needed for modular kernels such as
145the GNU Hurd).
146
211df1ed
ER
147GRUB 2 is derived from PUPA which was a research project to
148investigate the next generation of GRUB. GRUB 2 has been rewritten
149from scratch to clean up everything for modularity and portability.
150
151GRUB 2 targets at the following goals:
152- Scripting support, such as conditionals, loops, variables and
153 functions.
154- Graphical interface.
155- Dynamic loading of modules in order to extend itself at the run time
156 rather than at the build time.
157- Portability for various architectures.
158- Internationalization. This includes support for non-ASCII character
159 code, message catalogs like gettext, fonts, graphics console, and so
160 on.
161- Real memory management, to make GNU GRUB more extensible.
162- Modular, hierarchical, object-oriented framework for file systems,
163 files, devices, drives, terminals, commands, partition tables and OS
164 loaders.
165- Cross-platform installation which allows for installing GRUB from a
166 different architecture.
167- Rescue mode saves unbootable cases. Stage 1.5 was eliminated.
168- Fix design mistakes in GRUB Legacy, which could not be solved for
169 backward-compatibility, such as the way of numbering partitions.
170
6b0aefbf 171%description -l de.UTF-8
afe8504a
SP
172GRUB (GRand Unified Boot-loader) ist ein Bootloader, der oft auf
173Rechnern eingesetzt wird, auf denen das freie Betriebssystem Linux
6b0aefbf 174läuft. GRUB löst den betagten LILO (Linux-Loader) ab.
afe8504a
SP
175
176GRUB wurde innerhalb des GNU Hurd-Projektes als Boot-Loader entwickelt
6b0aefbf
JR
177und wird unter der GPL vertrieben. Aufgrund seiner höheren
178Flexibilität verdrängt GRUB in vielen Linux-Distributionen den
afe8504a
SP
179traditionellen Boot-Loader LILO.
180
f97cafb4
ZU
181%description -l hu.UTF-8
182GRUB egy GPL liszenszű rendszerbetöltő. Linux és *BSD kernelek
183betöltése mellett támogatja a Multiboot standard-ot, amely lehetővé
184teszi boot képek betöltését (moduláris kerneleknek kell, mint pl. a
185GNU Hurd).
186
187GRUB2 céljai a következők:
188- szkriptelés támogatása, úgymint feltételek, ciklusok, változók,
189 függvények.
190- grafikus felület
191- modulok dinamikus betöltése futási időben
192- hordozhatóság több architektúrára
193- többnyelvűség: nem-ASCII karakterek támogatása, üzenetkatalógusok,
194 mint gettext, betűtípusok, grafikus konzolon, és így tovább
195- valós memória kezelés, amellyel még bővíthetőbbé tehetjük
196- moduláris, hierarchikus, objektum-orientált keretrendszer
197 fájlrendszerekhez, fájlokhoz, eszközökhöz, meghajtókhoz,
198 terminálokhoz, parancsokhoz, partíciós táblákhoz és OS betöltőkhöz
199
6b0aefbf
JR
200%description -l es.UTF-8
201Éste es GRUB - Grand Unified Boot Loader - un administrador de
202inicialización capaz de entrar en la mayoría de los sistemas
afe8504a 203operacionales libres - Linux, FreeBSD, NetBSD, GNU Mach, etc. como
6b0aefbf 204también en la mayoría de los sistemas operacionales comerciales para
afe8504a
SP
205PC.
206
207El administrador GRUB puede ser una buena alternativa a LILO, para
6b0aefbf
JR
208usuarios conmás experiencia y que deseen obtener más recursos de su
209cargador de inicialización (boot loader).
afe8504a 210
6b0aefbf 211%description -l pl.UTF-8
feaacba3 212GRUB jest bootloaderem na licencji GNU GPL, mającym na celu unifikację
6b0aefbf 213procesu bootowania na systemach x86. Potrafi nie tylko ładować jądra
feaacba3 214Linuksa i *BSD: posiada również implementację standardu Multiboot,
6b0aefbf
JR
215który pozwala na elastyczne ładowanie wielu obrazów bootowalnych
216(czego wymagają modułowe jądra, takie jak GNU Hurd).
afe8504a 217
6b0aefbf
JR
218%description -l pt_BR.UTF-8
219Esse é o GRUB - Grand Unified Boot Loader - um gerenciador de boot
afe8504a
SP
220capaz de entrar na maioria dos sistemas operacionais livres - Linux,
221FreeBSD, NetBSD, GNU Mach, etc. assim como na maioria dos sistemas
222operacionais comerciais para PC.
223
6b0aefbf
JR
224O GRUB pode ser uma boa alternativa ao LILO, para usuários mais
225avançados e que querem mais recursos de seu boot loader.
afe8504a 226
565fe2e3
ER
227%package -n bash-completion-%{name}
228Summary: bash-completion for GRUB
feaacba3 229Summary(pl.UTF-8): Bashowe uzupełnianie nazw dla GRUB-a
565fe2e3
ER
230Group: Applications/Shells
231Requires: bash-completion
d28207fb
ER
232%if "%{_rpmversion}" >= "5"
233BuildArch: noarch
234%endif
565fe2e3
ER
235
236%description -n bash-completion-%{name}
237This package provides bash-completion for GRUB.
238
239%description -n bash-completion-%{name} -l pl.UTF-8
feaacba3 240Pakiet ten dostarcza bashowe uzupełnianie nazw dla GRUB-a.
565fe2e3 241
6d8475a4 242%package platform-pc
62081337 243Summary: PC BIOS platform support for GRUB
feaacba3 244Summary(pl.UTF-8): Obsługa platformy PC BIOS dla GRUB-a
62081337 245Group: Base
6d8475a4 246Provides: %{name}-platform = %{version}-%{release}
1536aaf2 247
6d8475a4 248%description platform-pc
62081337 249PC BIOS platform support for GRUB.
1536aaf2 250
feaacba3
JB
251%description platform-pc -l pl.UTF-8
252Obsługa platformy PC BIOS dla GRUB-a.
253
6d8475a4 254%package platform-efi
1536aaf2 255Summary: (U)EFI platform support for GRUB
feaacba3 256Summary(pl.UTF-8): Obsługa platformy (U)EFI dla GRUB-a
1536aaf2 257Group: Base
6e81e1fe 258Suggests: efibootmgr
6d8475a4 259Provides: %{name}-platform = %{version}-%{release}
1536aaf2 260
6d8475a4 261%description platform-efi
1536aaf2
JK
262(U)EFI platform support for GRUB.
263
feaacba3
JB
264%description platform-efi -l pl.UTF-8
265Obsługa platformy (U)EFI dla GRUB-a.
266
7615a862
JK
267%package mkfont
268Summary: GRUB font files converter
feaacba3 269Summary(pl.UTF-8): Konwerter plików fontów GRUB-a
7615a862
JK
270Group: Base
271
272%description mkfont
273Converts common font file formats into PF2.
274
feaacba3
JB
275%description mkfont -l pl.UTF-8
276Program do konwersji popularnych formatów plików fontów do PF2.
277
8ac8605d
JK
278%package theme-starfield
279Summary: starfield theme for GRUB
feaacba3 280Summary(pl.UTF-8): Motyw starfield dla GRUB-a
8ac8605d
JK
281Group: Base
282
283%description theme-starfield
284starfield theme for GRUB.
285
feaacba3
JB
286%description theme-starfield -l pl.UTF-8
287Motyw starfield dla GRUB-a.
288
afe8504a 289%prep
729e6097 290%setup -q -n grub-%{version}
b46589aa 291%patch1 -p1
872700b0 292%patch2 -p1
f951fcbe 293%patch3 -p1
aec70abd 294%patch4 -p1
f7ae30d0 295%patch5 -p1
668ecb01
JK
296%patch6 -p1
297%patch7 -p1
61d105fa 298%patch8 -p1
668ecb01 299%patch9 -p1
26996aed 300%patch10 -p1
668ecb01
JK
301%patch11 -p1
302%patch12 -p0
c287192d 303%patch13 -p1
2c79d729 304%patch14 -p1
c28d9078 305%patch15 -p1
d6c673ce 306%patch16 -p1
c87c31b6 307%patch17 -p1
5bafb558
JK
308
309# we don't have C.utf-8 and need an UTF-8 locale for build
310sed -i -e 's/LC_ALL=C.UTF-8/LC_ALL=en_US.utf-8/g' po/Makefile* po/Rules*
afe8504a
SP
311
312%build
928eb9c1 313# if gold is used then grub doesn't even boot
9bc7aab3
AM
314# https://savannah.gnu.org/bugs/?34539
315# http://sourceware.org/bugzilla/show_bug.cgi?id=14196
7a73b7a5 316install -d our-ld
70fd3248 317ln -f -s /usr/bin/ld.bfd our-ld/ld
7a73b7a5 318export PATH=$(pwd)/our-ld:$PATH
928eb9c1 319
b876d99a
JK
320## not only the typicall autotools stuff
321#./autogen.sh
322
50ffb0ba 323#{__gettextize}
b876d99a
JK
324%{__aclocal} -I m4
325%{__autoconf}
326%{__autoheader}
327%{__automake}
12fd19f5 328
1536aaf2 329for platform in %{platforms} ; do
fc490c3e
JK
330 install -d build-${platform}
331 cd build-${platform}
0e2cbb94
JK
332
333 if [ "$platform" != "efi" ] ; then
feaacba3 334 platform_opts="--enable-efiemu%{!?with_efiemu:=no}"
0e2cbb94
JK
335 else
336 platform_opts=""
337 fi
338
55d67ca1 339 ln -f -s ../configure .
1536aaf2
JK
340 # mawk stalls at ./genmoddep.awk, so force gawk
341 AWK=gawk \
342 %configure \
343 --with-platform=${platform} \
344 --disable-werror \
18b992da 345 --enable-grub-themes \
1536aaf2
JK
346 %if %{with grubemu}
347 --enable-grub-emu-usb \
348 --enable-grub-emu-sdl \
349 --enable-grub-emu-pci \
350 %endif
0e2cbb94 351 $platform_opts \
1536aaf2
JK
352 TARGET_LDFLAGS=-static
353
ec98fb4c 354 %{__make} -j1 -C po update-gmo
1536aaf2
JK
355 %{__make}
356 cd ..
357done
0fb8b1a5 358
afe8504a
SP
359%install
360rm -rf $RPM_BUILD_ROOT
afe8504a 361
1536aaf2 362for platform in %{platforms} ; do
fc490c3e 363 cd build-${platform}
1536aaf2
JK
364 %{__make} install \
365 pkgdatadir=%{_libexecdir} \
366 pkglibdir=%{_libexecdir} \
367 DESTDIR=$RPM_BUILD_ROOT
368 cd ..
369done
afe8504a 370
7615a862
JK
371# not in Th (?)
372%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/de@hebrew
373%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/en@{arabic,cyrillic,greek,hebrew,piglatin}
374
f951fcbe
AM
375%find_lang grub
376
bcd6a47e
ER
377# this must be after 'make install'
378install -d $RPM_BUILD_ROOT%{_libexecdir}/locale
379
1536aaf2
JK
380install -d $RPM_BUILD_ROOT%{_grubdir}
381cp -p docs/grub.cfg $RPM_BUILD_ROOT%{_grubdir}
382
7b6caae9 383# grub.d/41_custom
1536aaf2 384cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_grubdir}/custom.cfg
7b6caae9
ER
385%{__rm} $RPM_BUILD_ROOT/lib/grub.d/40_custom
386
22909ca1 387install -p %{SOURCE1} $RPM_BUILD_ROOT%{_sbindir}/update-grub
7b6caae9
ER
388cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_mandir}/man8/update-grub.8
389
390install -d $RPM_BUILD_ROOT/etc/sysconfig
391cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/grub
392
393# rm -f, because it sometimes exists, sometimes not, depending which texlive you have installed
47069130 394rm -f $RPM_BUILD_ROOT%{_infodir}/dir
e2964b87 395
feaacba3 396# platform specific, unnecessarily always installed
50ffb0ba 397%ifnarch %{ix86} %{x8664} x32
feaacba3
JB
398%{__rm} $RPM_BUILD_ROOT{%{_sbindir}/grub-bios-setup,%{_mandir}/man8/grub-bios-setup.8}
399%endif
400%ifnarch sparc64
401%{__rm} $RPM_BUILD_ROOT{%{_sbindir}/grub-sparc64-setup,%{_mandir}/man8/grub-sparc64-setup.8}
402%endif
403
cbd79801 404# core.img - bootable image generated by grub-mkimage(1) via grub-install(1)
1536aaf2
JK
405touch $RPM_BUILD_ROOT%{_grubdir}/core.img
406touch $RPM_BUILD_ROOT%{_grubdir}/device.map
cbd79801 407
8b5c394b
ER
408# needs to be exactly 1KiB
409# but we're ghosting it. so whom are we kidding here? :P (maybe %config it in future?)
1536aaf2 410dd bs=1024 if=/dev/zero count=1 of=$RPM_BUILD_ROOT%{_grubdir}/grubenv
8b5c394b 411
afe8504a
SP
412%clean
413rm -rf $RPM_BUILD_ROOT
414
5028d8c9 415%post -p %{_sbindir}/postshell
fc58858a 416-/usr/sbin/fix-info-dir -c %{_infodir}
f4604ef8 417
5028d8c9 418%postun -p %{_sbindir}/postshell
fc58858a 419-/usr/sbin/fix-info-dir -c %{_infodir}
f4604ef8 420
8c5e5aa2
JR
421%triggerpostun -- %{name} < 2.00-2
422# Note this trigger on version upgrade needed only for upgrade from
423# old grub2 packages which contained modules in /boot/grub
424# or were built with optimizations enabled
92904505
ER
425# don't do anything on --downgrade
426if [ $1 -le 1 ]; then
427 exit 0
428fi
429echo "Grub was upgraded, trying to setup it to boot sector"
430/sbin/grub-install '(hd0)' || :
431
7b6caae9
ER
432%triggerpostun -- %{name} < 1.99-7.3
433# migrate /etc/grub.d/custom.cfg.rpmsave -> /boot/grub/custom.cfg
434if [ -f %{_sysconfdir}/grub.d/custom.cfg.rpmsave ]; then
1536aaf2
JK
435 cp -f %{_grubdir}/custom.cfg{,.rpmnew}
436 mv -f %{_sysconfdir}/grub.d/custom.cfg.rpmsave %{_grubdir}/custom.cfg
7b6caae9
ER
437fi
438
f951fcbe 439%files -f grub.lang
afe8504a 440%defattr(644,root,root,755)
2e4bec6f 441%doc AUTHORS ChangeLog NEWS README THANKS TODO
aec70abd 442%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/grub
71c933c0 443%attr(755,root,root) %{_sbindir}/grub-editenv
3ea0c40e 444%attr(755,root,root) %{_sbindir}/grub-fstest
5bafb558
JK
445%attr(755,root,root) %{_sbindir}/grub-file
446%attr(755,root,root) %{_sbindir}/grub-glue-efi
e9d73181 447%attr(755,root,root) %{_sbindir}/grub-kbdcomp
fc835b5e 448%attr(755,root,root) %{_sbindir}/grub-install
5bafb558 449%attr(755,root,root) %{_sbindir}/grub-macbless
e9d73181 450%attr(755,root,root) %{_sbindir}/grub-menulst2cfg
fc835b5e 451%attr(755,root,root) %{_sbindir}/grub-mkconfig
e9d73181
AM
452%attr(755,root,root) %{_sbindir}/grub-mklayout
453%attr(755,root,root) %{_sbindir}/grub-mknetdir
71c933c0
ER
454%attr(755,root,root) %{_sbindir}/grub-mkpasswd-pbkdf2
455%attr(755,root,root) %{_sbindir}/grub-mkrelpath
456%attr(755,root,root) %{_sbindir}/grub-mkrescue
7615a862
JK
457%attr(755,root,root) %{_sbindir}/grub-mkstandalone
458%attr(755,root,root) %{_sbindir}/grub-mount
459%attr(755,root,root) %{_sbindir}/grub-ofpathname
71c933c0 460%attr(755,root,root) %{_sbindir}/grub-reboot
5bafb558 461%attr(755,root,root) %{_sbindir}/grub-render-label
71c933c0
ER
462%attr(755,root,root) %{_sbindir}/grub-script-check
463%attr(755,root,root) %{_sbindir}/grub-set-default
5bafb558 464%attr(755,root,root) %{_sbindir}/grub-syslinux2cfg
22909ca1 465%attr(755,root,root) %{_sbindir}/update-grub
50ffb0ba 466%ifarch %{ix86} %{x8664} x32
feaacba3
JB
467%attr(755,root,root) %{_sbindir}/grub-bios-setup
468%{_mandir}/man8/grub-bios-setup.8*
469%endif
50ffb0ba 470%ifarch %{ix86} %{x8664} x32
76be4c4a 471%attr(755,root,root) %{_sbindir}/grub-mkimage
fc835b5e 472%{_mandir}/man1/grub-mkimage.1*
76be4c4a
AM
473%else
474%attr(755,root,root) %{_sbindir}/grub-probe
76be4c4a 475%{_mandir}/man8/grub-probe.8*
76be4c4a 476%endif
feaacba3
JB
477%ifarch sparc64
478%attr(755,root,root) %{_sbindir}/grub-sparc64-setup
479%{_mandir}/man8/grub-sparc64-setup.8*
480%endif
71c933c0 481%{_mandir}/man1/grub-editenv.1*
5bafb558 482%{_mandir}/man1/grub-file.1*
3ea0c40e 483%{_mandir}/man1/grub-fstest.1*
5bafb558 484%{_mandir}/man1/grub-glue-efi.1*
7615a862 485%{_mandir}/man1/grub-kbdcomp.1*
e9d73181 486%{_mandir}/man1/grub-menulst2cfg.1*
e9d73181 487%{_mandir}/man1/grub-mklayout.1*
5bafb558 488%{_mandir}/man1/grub-mknetdir.1*
71c933c0 489%{_mandir}/man1/grub-mkpasswd-pbkdf2.1*
03b9d04b 490%{_mandir}/man1/grub-mkrelpath.1*
71c933c0 491%{_mandir}/man1/grub-mkrescue.1*
7615a862
JK
492%{_mandir}/man1/grub-mkstandalone.1*
493%{_mandir}/man1/grub-mount.1*
5bafb558 494%{_mandir}/man1/grub-render-label.1*
71c933c0 495%{_mandir}/man1/grub-script-check.1*
5bafb558 496%{_mandir}/man1/grub-syslinux2cfg.1*
71c933c0 497%{_mandir}/man8/grub-install.8*
a4c52d96 498%{_mandir}/man8/grub-macbless.8*
fc835b5e 499%{_mandir}/man8/grub-mkconfig.8*
7615a862 500%{_mandir}/man8/grub-ofpathname.8*
71c933c0
ER
501%{_mandir}/man8/grub-reboot.8*
502%{_mandir}/man8/grub-set-default.8*
22909ca1 503%{_mandir}/man8/update-grub.8*
797addca 504%if %{with grubemu}
8fcee4aa
ER
505%attr(755,root,root) %{_sbindir}/grub-emu
506%{_mandir}/man8/grub-emu.8*
797addca 507%endif
e6fbd304 508%{_libexecdir}/grub-mkconfig_lib
aec70abd 509
1536aaf2 510%dir %{_grubdir}
26e757db 511%dir %{_libexecdir}
bcd6a47e 512# XXX: check this locale dir location and if it is neccesaary to exist on /boot
565fe2e3 513
bcd6a47e 514%dir %{_libexecdir}/locale
1536aaf2
JK
515%config(noreplace) %verify(not md5 mtime size) %{_grubdir}/grub.cfg
516%config(noreplace) %verify(not md5 mtime size) %{_grubdir}/custom.cfg
aec70abd 517
cbd79801 518# generated by grub at runtime
1536aaf2
JK
519%ghost %{_grubdir}/device.map
520%ghost %{_grubdir}/core.img
521%ghost %{_grubdir}/grubenv
cbd79801 522
e2964b87
ER
523%dir /lib/grub.d
524%doc /lib/grub.d/README
525%attr(755,root,root) /lib/grub.d/00_header
526%attr(755,root,root) /lib/grub.d/10_linux
e9d73181 527%attr(755,root,root) /lib/grub.d/20_linux_xen
e2964b87 528%attr(755,root,root) /lib/grub.d/30_os-prober
e9d73181 529%attr(755,root,root) /lib/grub.d/41_custom
e2964b87 530
b876d99a
JK
531# these are now installed only on matching hosts
532#%attr(755,root,root) /lib/grub.d/10_hurd
533#%attr(755,root,root) /lib/grub.d/10_illumos
534#%attr(755,root,root) /lib/grub.d/10_kfreebsd
535#%attr(755,root,root) /lib/grub.d/10_netbsd
536#%attr(755,root,root) /lib/grub.d/10_xnu
537
50ffb0ba 538%ifarch %{ix86} %{x8664} x32
1ffaf1f6 539%attr(755,root,root) %{_sbindir}/grub-probe
fc835b5e 540%{_mandir}/man8/grub-probe.8*
4a00f3b7 541%endif
aec70abd 542
f4604ef8 543%{_infodir}/grub*.info*
565fe2e3 544
8ac8605d
JK
545%dir %{_datadir}/grub/themes
546
1536aaf2 547%if %{with pc}
6d8475a4 548%files platform-pc
1536aaf2
JK
549%defattr(644,root,root,755)
550%dir %{_libexecdir}/*-pc
551%{_libexecdir}/*-pc/modinfo.sh
552%{_libexecdir}/*-pc/*.exec
553%{_libexecdir}/*-pc/*.image
554%{_libexecdir}/*-pc/*.lst
555%{_libexecdir}/*-pc/*.mod
556%{_libexecdir}/*-pc/*.module
557%{_libexecdir}/*-pc/lzma_decompress.img
558%{_libexecdir}/*-pc/config.h
559%{_libexecdir}/*-pc/gdb_grub
560%{_libexecdir}/*-pc/gmodule.pl
561%if %{with efiemu}
1536aaf2
JK
562%{_libexecdir}/*-pc/efiemu*.o
563%endif
1536aaf2 564%{_libexecdir}/*-pc/kernel.img
50ffb0ba 565%ifarch %{ix86} %{x8664} x32 sparc sparc64
1536aaf2 566%{_libexecdir}/*-pc/boot.img
5bafb558 567%{_libexecdir}/*-pc/boot_hybrid.img
1536aaf2
JK
568%{_libexecdir}/*-pc/cdboot.img
569%{_libexecdir}/*-pc/diskboot.img
570%{_libexecdir}/*-pc/lnxboot.img
571%{_libexecdir}/*-pc/pxeboot.img
572%endif
573%endif
574
575%if %{with efi}
6d8475a4 576%files platform-efi
1536aaf2
JK
577%defattr(644,root,root,755)
578%dir %{_libexecdir}/*-efi
579%{_libexecdir}/*-efi/modinfo.sh
580%{_libexecdir}/*-efi/*.exec
581%{_libexecdir}/*-efi/*.lst
582%{_libexecdir}/*-efi/*.mod
583%{_libexecdir}/*-efi/*.module
584%{_libexecdir}/*-efi/config.h
585%{_libexecdir}/*-efi/gdb_grub
586%{_libexecdir}/*-efi/gmodule.pl
1536aaf2
JK
587%{_libexecdir}/*-efi/kernel.img
588%endif
589
7615a862
JK
590%files mkfont
591%defattr(644,root,root,755)
7615a862 592%attr(755,root,root) %{_sbindir}/grub-mkfont
feaacba3 593%{_mandir}/man1/grub-mkfont.1*
7615a862 594
8ac8605d
JK
595%files theme-starfield
596%defattr(644,root,root,755)
597%{_datadir}/grub/themes/starfield
598
565fe2e3
ER
599%files -n bash-completion-%{name}
600%defattr(644,root,root,755)
601/etc/bash_completion.d/grub
This page took 0.194087 seconds and 4 git commands to generate.