]> git.pld-linux.org Git - packages/grub2.git/blame - grub2.spec
- rel 2; make grub-mkconfig add ucode to grub config when needed
[packages/grub2.git] / grub2.spec
CommitLineData
f97cafb4 1# TODO
dc6928bc 2# - reap out which in probe scripts and drop R: which
f97cafb4 3# - subpackages? e.g. modules and utils
bcd6a47e 4# - check where is that locale path: /boot/grub/locale and fix it or change it
8fcee4aa
ER
5# - grubemu notes
6# --enable-grub-emu-usb conflicts with --enable-grub-emu-pci, emu-pci seems experimental
7# - to build and install the `grub-emu' debugging utility we need to re-run build with --target=emu
8# - put grub-emu to subpackage if it is fixed
f97cafb4 9#
90feddde 10# Conditional build:
1536aaf2 11%bcond_with grubemu # build grub-emu debugging utility
b06c130d 12%bcond_without efiemu # build efiemu runtimes
1536aaf2
JK
13%bcond_without pc # do not build for PC BIOS platform
14%bcond_without efi # do not build for EFI platform
b06c130d 15
50ffb0ba 16%ifnarch %{ix86} %{x8664} x32
feaacba3
JB
17%undefine with_pc
18%endif
50ffb0ba 19%ifnarch %{ix86} %{x8664} x32 ia64
feaacba3
JB
20%undefine with_efi
21%endif
22
50ffb0ba 23%ifnarch %{x8664} x32
2d8da575
AM
24# non-x86_64 arch doesn't support this
25%undefine with_efiemu
26%endif
27
1536aaf2 28# the 'most natural' platform should go last
50ffb0ba 29%ifarch %{ix86} %{x8664} x32 ia64
1536aaf2 30%define platforms %{?with_efi:efi} %{?with_pc:pc}
feaacba3
JB
31%endif
32%ifarch ppc ppc64 sparc64
33%define platforms ieee1275
34%endif
35%ifarch mips
36%define platforms arc
37%endif
38%ifarch mipsel
39%define platforms loongson
40%endif
1536aaf2 41
a4c52d96 42%define rel 1
afe8504a 43Summary: GRand Unified Bootloader
c8155f7f 44Summary(de.UTF-8): GRUB2 - ein Bootloader für x86 und ppc
f97cafb4 45Summary(hu.UTF-8): GRUB2 - rendszerbetöltő x86 és ppc gépekhez
c8155f7f
ER
46Summary(pl.UTF-8): GRUB2 - bootloader dla x86 i ppc
47Summary(pt_BR.UTF-8): Gerenciador de inicialização GRUB2
afe8504a 48Name: grub2
b876d99a 49Version: 2.02
c28d9078 50Release: 2
2e4bec6f 51License: GPL v2
afe8504a 52Group: Base
729e6097
JP
53Source0: ftp://ftp.gnu.org/gnu/grub/grub-%{version}.tar.xz
54# Source0-md5: 8a4a2a95aac551fb0fba860ceabfa1d3
22909ca1
ER
55Source1: update-grub
56Source2: update-grub.8
b46589aa 57Source3: grub.sysconfig
e2964b87 58Source4: grub-custom.cfg
b46589aa 59Patch1: pld-sysconfdir.patch
872700b0 60Patch2: grub-garbage.patch
c9273ffc
JK
61Patch3: grub-lvmdevice.patch
62Patch4: pld-mkconfigdir.patch
63Patch5: grub-mkconfig-diagnostics.patch
668ecb01
JK
64Patch6: posix.patch
65Patch7: %{name}-fonts_path.patch
66Patch8: add-vlan-tag-support.patch
67Patch9: just-say-linux.patch
68Patch10: ignore-kernel-symlinks.patch
69Patch11: choose-preferred-initrd.patch
70Patch12: %{name}-cfg.patch
c287192d 71Patch13: efi-net-fix.patch
a4c52d96 72Patch14: blscfg.patch
c28d9078
AM
73# https://git.archlinux.org/svntogit/packages.git/plain/trunk/0002-intel-ucode.patch?h=packages/grub
74Patch15: intel-ucode.patch
feaacba3 75URL: http://www.gnu.org/software/grub/
27550907
ER
76BuildRequires: autoconf >= 2.53
77BuildRequires: automake >= 1:1.11.1-1
8b781299 78BuildRequires: bison
06df59fd 79BuildRequires: device-mapper-devel
feaacba3 80BuildRequires: flex >= 2.5.35
26996aed 81BuildRequires: fonts-TTF-DejaVu
feaacba3 82BuildRequires: freetype-devel >= 2
12fd19f5 83BuildRequires: gawk
39b1c916 84BuildRequires: gcc >= 5:3.4
5d291ad2 85BuildRequires: gettext-tools
5bafb558 86BuildRequires: glibc-localedb-all
feaacba3 87BuildRequires: glibc-static
1349ebb8 88BuildRequires: help2man
42985b0d 89BuildRequires: libfuse-devel
afe8504a 90BuildRequires: libtool
feaacba3 91BuildRequires: ncurses-devel
5bafb558
JK
92BuildRequires: python
93BuildRequires: python-modules
feaacba3
JB
94BuildRequires: rpm >= 4.4.9-56
95BuildRequires: rpmbuild(macros) >= 1.213
96BuildRequires: sed >= 4.0
97BuildRequires: tar >= 1:1.22
81a7e0ba 98BuildRequires: texinfo
feaacba3
JB
99BuildRequires: xz
100BuildRequires: xz-devel
c668211a
ER
101%ifarch %{x8664}
102BuildRequires: /usr/lib/libc.so
8905dae4
ER
103%if "%{pld_release}" == "ac"
104BuildRequires: libgcc32
105%else
50ffb0ba 106BuildRequires: gcc-multilib-32
c668211a 107%endif
dee0d6f5 108%endif
feaacba3 109Requires: %{name}-platform = %{version}-%{release}
a5138d8d 110Requires: pld-release
dc6928bc 111Requires: which
feaacba3
JB
112%ifarch %{ix86} %{x8664}
113Suggests: %{name}-platform-pc
114%endif
190cc685 115Suggests: cdrkit-mkisofs
97ee543c 116Suggests: os-prober
afe8504a 117Provides: bootloader
fc835b5e 118Conflicts: grub
50ffb0ba 119ExclusiveArch: %{ix86} %{x8664} x32 ia64 mips mipsel ppc ppc64 sparc64
afe8504a
SP
120BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
121
122%define _sbindir /sbin
4a00f3b7 123%define _bindir %{_sbindir}
1536aaf2 124%define _libdir /lib
e6fbd304 125%define _datadir %{_libdir}
26e757db 126%define _libexecdir %{_libdir}/grub
1536aaf2 127%define _grubdir /boot/grub
da9b7cf9 128%define _localedir /usr/share/locale
9d44d75e 129
0e2cbb94
JK
130# part of grub code is not relocable (these are not Linux libs)
131# stack protector also breaks non-Linux binaries
8c5e5aa2
JR
132# any kind of forced optimizations makes grub2 unreliable (random
133# reboots and hangs on boot menu screen)
5bc5d891 134%define filterout_c -fPIC -O.
5967241e 135%undefine _ssp_cflags
5bc5d891 136%undefine _fortify_cflags
0e2cbb94 137
afe8504a
SP
138%description
139GRUB is a GPLed bootloader intended to unify bootloading across x86
140operating systems. In addition to loading the Linux and *BSD kernels,
141it implements the Multiboot standard, which allows for flexible
142loading of multiple boot images (needed for modular kernels such as
143the GNU Hurd).
144
211df1ed
ER
145GRUB 2 is derived from PUPA which was a research project to
146investigate the next generation of GRUB. GRUB 2 has been rewritten
147from scratch to clean up everything for modularity and portability.
148
149GRUB 2 targets at the following goals:
150- Scripting support, such as conditionals, loops, variables and
151 functions.
152- Graphical interface.
153- Dynamic loading of modules in order to extend itself at the run time
154 rather than at the build time.
155- Portability for various architectures.
156- Internationalization. This includes support for non-ASCII character
157 code, message catalogs like gettext, fonts, graphics console, and so
158 on.
159- Real memory management, to make GNU GRUB more extensible.
160- Modular, hierarchical, object-oriented framework for file systems,
161 files, devices, drives, terminals, commands, partition tables and OS
162 loaders.
163- Cross-platform installation which allows for installing GRUB from a
164 different architecture.
165- Rescue mode saves unbootable cases. Stage 1.5 was eliminated.
166- Fix design mistakes in GRUB Legacy, which could not be solved for
167 backward-compatibility, such as the way of numbering partitions.
168
6b0aefbf 169%description -l de.UTF-8
afe8504a
SP
170GRUB (GRand Unified Boot-loader) ist ein Bootloader, der oft auf
171Rechnern eingesetzt wird, auf denen das freie Betriebssystem Linux
6b0aefbf 172läuft. GRUB löst den betagten LILO (Linux-Loader) ab.
afe8504a
SP
173
174GRUB wurde innerhalb des GNU Hurd-Projektes als Boot-Loader entwickelt
6b0aefbf
JR
175und wird unter der GPL vertrieben. Aufgrund seiner höheren
176Flexibilität verdrängt GRUB in vielen Linux-Distributionen den
afe8504a
SP
177traditionellen Boot-Loader LILO.
178
f97cafb4
ZU
179%description -l hu.UTF-8
180GRUB egy GPL liszenszű rendszerbetöltő. Linux és *BSD kernelek
181betöltése mellett támogatja a Multiboot standard-ot, amely lehetővé
182teszi boot képek betöltését (moduláris kerneleknek kell, mint pl. a
183GNU Hurd).
184
185GRUB2 céljai a következők:
186- szkriptelés támogatása, úgymint feltételek, ciklusok, változók,
187 függvények.
188- grafikus felület
189- modulok dinamikus betöltése futási időben
190- hordozhatóság több architektúrára
191- többnyelvűség: nem-ASCII karakterek támogatása, üzenetkatalógusok,
192 mint gettext, betűtípusok, grafikus konzolon, és így tovább
193- valós memória kezelés, amellyel még bővíthetőbbé tehetjük
194- moduláris, hierarchikus, objektum-orientált keretrendszer
195 fájlrendszerekhez, fájlokhoz, eszközökhöz, meghajtókhoz,
196 terminálokhoz, parancsokhoz, partíciós táblákhoz és OS betöltőkhöz
197
6b0aefbf
JR
198%description -l es.UTF-8
199Éste es GRUB - Grand Unified Boot Loader - un administrador de
200inicialización capaz de entrar en la mayoría de los sistemas
afe8504a 201operacionales libres - Linux, FreeBSD, NetBSD, GNU Mach, etc. como
6b0aefbf 202también en la mayoría de los sistemas operacionales comerciales para
afe8504a
SP
203PC.
204
205El administrador GRUB puede ser una buena alternativa a LILO, para
6b0aefbf
JR
206usuarios conmás experiencia y que deseen obtener más recursos de su
207cargador de inicialización (boot loader).
afe8504a 208
6b0aefbf 209%description -l pl.UTF-8
feaacba3 210GRUB jest bootloaderem na licencji GNU GPL, mającym na celu unifikację
6b0aefbf 211procesu bootowania na systemach x86. Potrafi nie tylko ładować jądra
feaacba3 212Linuksa i *BSD: posiada również implementację standardu Multiboot,
6b0aefbf
JR
213który pozwala na elastyczne ładowanie wielu obrazów bootowalnych
214(czego wymagają modułowe jądra, takie jak GNU Hurd).
afe8504a 215
6b0aefbf
JR
216%description -l pt_BR.UTF-8
217Esse é o GRUB - Grand Unified Boot Loader - um gerenciador de boot
afe8504a
SP
218capaz de entrar na maioria dos sistemas operacionais livres - Linux,
219FreeBSD, NetBSD, GNU Mach, etc. assim como na maioria dos sistemas
220operacionais comerciais para PC.
221
6b0aefbf
JR
222O GRUB pode ser uma boa alternativa ao LILO, para usuários mais
223avançados e que querem mais recursos de seu boot loader.
afe8504a 224
565fe2e3
ER
225%package -n bash-completion-%{name}
226Summary: bash-completion for GRUB
feaacba3 227Summary(pl.UTF-8): Bashowe uzupełnianie nazw dla GRUB-a
565fe2e3
ER
228Group: Applications/Shells
229Requires: bash-completion
d28207fb
ER
230%if "%{_rpmversion}" >= "5"
231BuildArch: noarch
232%endif
565fe2e3
ER
233
234%description -n bash-completion-%{name}
235This package provides bash-completion for GRUB.
236
237%description -n bash-completion-%{name} -l pl.UTF-8
feaacba3 238Pakiet ten dostarcza bashowe uzupełnianie nazw dla GRUB-a.
565fe2e3 239
6d8475a4 240%package platform-pc
62081337 241Summary: PC BIOS platform support for GRUB
feaacba3 242Summary(pl.UTF-8): Obsługa platformy PC BIOS dla GRUB-a
62081337 243Group: Base
6d8475a4 244Provides: %{name}-platform = %{version}-%{release}
1536aaf2 245
6d8475a4 246%description platform-pc
62081337 247PC BIOS platform support for GRUB.
1536aaf2 248
feaacba3
JB
249%description platform-pc -l pl.UTF-8
250Obsługa platformy PC BIOS dla GRUB-a.
251
6d8475a4 252%package platform-efi
1536aaf2 253Summary: (U)EFI platform support for GRUB
feaacba3 254Summary(pl.UTF-8): Obsługa platformy (U)EFI dla GRUB-a
1536aaf2 255Group: Base
6e81e1fe 256Suggests: efibootmgr
6d8475a4 257Provides: %{name}-platform = %{version}-%{release}
1536aaf2 258
6d8475a4 259%description platform-efi
1536aaf2
JK
260(U)EFI platform support for GRUB.
261
feaacba3
JB
262%description platform-efi -l pl.UTF-8
263Obsługa platformy (U)EFI dla GRUB-a.
264
7615a862
JK
265%package mkfont
266Summary: GRUB font files converter
feaacba3 267Summary(pl.UTF-8): Konwerter plików fontów GRUB-a
7615a862
JK
268Group: Base
269
270%description mkfont
271Converts common font file formats into PF2.
272
feaacba3
JB
273%description mkfont -l pl.UTF-8
274Program do konwersji popularnych formatów plików fontów do PF2.
275
8ac8605d
JK
276%package theme-starfield
277Summary: starfield theme for GRUB
feaacba3 278Summary(pl.UTF-8): Motyw starfield dla GRUB-a
8ac8605d
JK
279Group: Base
280
281%description theme-starfield
282starfield theme for GRUB.
283
feaacba3
JB
284%description theme-starfield -l pl.UTF-8
285Motyw starfield dla GRUB-a.
286
afe8504a 287%prep
729e6097 288%setup -q -n grub-%{version}
b46589aa 289%patch1 -p1
872700b0 290%patch2 -p1
f951fcbe 291%patch3 -p1
aec70abd 292%patch4 -p1
f7ae30d0 293%patch5 -p1
668ecb01
JK
294%patch6 -p1
295%patch7 -p1
61d105fa 296%patch8 -p1
668ecb01 297%patch9 -p1
26996aed 298%patch10 -p1
668ecb01
JK
299%patch11 -p1
300%patch12 -p0
c287192d 301%patch13 -p1
2c79d729 302%patch14 -p1
c28d9078 303%patch15 -p1
5bafb558
JK
304
305# we don't have C.utf-8 and need an UTF-8 locale for build
306sed -i -e 's/LC_ALL=C.UTF-8/LC_ALL=en_US.utf-8/g' po/Makefile* po/Rules*
afe8504a
SP
307
308%build
928eb9c1 309# if gold is used then grub doesn't even boot
9bc7aab3
AM
310# https://savannah.gnu.org/bugs/?34539
311# http://sourceware.org/bugzilla/show_bug.cgi?id=14196
7a73b7a5 312install -d our-ld
70fd3248 313ln -f -s /usr/bin/ld.bfd our-ld/ld
7a73b7a5 314export PATH=$(pwd)/our-ld:$PATH
928eb9c1 315
b876d99a
JK
316## not only the typicall autotools stuff
317#./autogen.sh
318
50ffb0ba 319#{__gettextize}
b876d99a
JK
320%{__aclocal} -I m4
321%{__autoconf}
322%{__autoheader}
323%{__automake}
12fd19f5 324
1536aaf2 325for platform in %{platforms} ; do
fc490c3e
JK
326 install -d build-${platform}
327 cd build-${platform}
0e2cbb94
JK
328
329 if [ "$platform" != "efi" ] ; then
feaacba3 330 platform_opts="--enable-efiemu%{!?with_efiemu:=no}"
0e2cbb94
JK
331 else
332 platform_opts=""
333 fi
334
55d67ca1 335 ln -f -s ../configure .
1536aaf2
JK
336 # mawk stalls at ./genmoddep.awk, so force gawk
337 AWK=gawk \
338 %configure \
339 --with-platform=${platform} \
340 --disable-werror \
341 %if %{with grubemu}
342 --enable-grub-emu-usb \
343 --enable-grub-emu-sdl \
344 --enable-grub-emu-pci \
345 %endif
0e2cbb94 346 $platform_opts \
1536aaf2
JK
347 TARGET_LDFLAGS=-static
348
ec98fb4c 349 %{__make} -j1 -C po update-gmo
1536aaf2
JK
350 %{__make}
351 cd ..
352done
0fb8b1a5 353
afe8504a
SP
354%install
355rm -rf $RPM_BUILD_ROOT
afe8504a 356
1536aaf2 357for platform in %{platforms} ; do
fc490c3e 358 cd build-${platform}
1536aaf2
JK
359 %{__make} install \
360 pkgdatadir=%{_libexecdir} \
361 pkglibdir=%{_libexecdir} \
362 DESTDIR=$RPM_BUILD_ROOT
363 cd ..
364done
afe8504a 365
7615a862
JK
366# not in Th (?)
367%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/de@hebrew
368%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/en@{arabic,cyrillic,greek,hebrew,piglatin}
369
f951fcbe
AM
370%find_lang grub
371
bcd6a47e
ER
372# this must be after 'make install'
373install -d $RPM_BUILD_ROOT%{_libexecdir}/locale
374
1536aaf2
JK
375install -d $RPM_BUILD_ROOT%{_grubdir}
376cp -p docs/grub.cfg $RPM_BUILD_ROOT%{_grubdir}
377
7b6caae9 378# grub.d/41_custom
1536aaf2 379cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_grubdir}/custom.cfg
7b6caae9
ER
380%{__rm} $RPM_BUILD_ROOT/lib/grub.d/40_custom
381
22909ca1 382install -p %{SOURCE1} $RPM_BUILD_ROOT%{_sbindir}/update-grub
7b6caae9
ER
383cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_mandir}/man8/update-grub.8
384
385install -d $RPM_BUILD_ROOT/etc/sysconfig
386cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/grub
387
388# rm -f, because it sometimes exists, sometimes not, depending which texlive you have installed
47069130 389rm -f $RPM_BUILD_ROOT%{_infodir}/dir
e2964b87 390
feaacba3 391# platform specific, unnecessarily always installed
50ffb0ba 392%ifnarch %{ix86} %{x8664} x32
feaacba3
JB
393%{__rm} $RPM_BUILD_ROOT{%{_sbindir}/grub-bios-setup,%{_mandir}/man8/grub-bios-setup.8}
394%endif
395%ifnarch sparc64
396%{__rm} $RPM_BUILD_ROOT{%{_sbindir}/grub-sparc64-setup,%{_mandir}/man8/grub-sparc64-setup.8}
397%endif
398
cbd79801 399# core.img - bootable image generated by grub-mkimage(1) via grub-install(1)
1536aaf2
JK
400touch $RPM_BUILD_ROOT%{_grubdir}/core.img
401touch $RPM_BUILD_ROOT%{_grubdir}/device.map
cbd79801 402
8b5c394b
ER
403# needs to be exactly 1KiB
404# but we're ghosting it. so whom are we kidding here? :P (maybe %config it in future?)
1536aaf2 405dd bs=1024 if=/dev/zero count=1 of=$RPM_BUILD_ROOT%{_grubdir}/grubenv
8b5c394b 406
afe8504a
SP
407%clean
408rm -rf $RPM_BUILD_ROOT
409
5028d8c9 410%post -p %{_sbindir}/postshell
fc58858a 411-/usr/sbin/fix-info-dir -c %{_infodir}
f4604ef8 412
5028d8c9 413%postun -p %{_sbindir}/postshell
fc58858a 414-/usr/sbin/fix-info-dir -c %{_infodir}
f4604ef8 415
8c5e5aa2
JR
416%triggerpostun -- %{name} < 2.00-2
417# Note this trigger on version upgrade needed only for upgrade from
418# old grub2 packages which contained modules in /boot/grub
419# or were built with optimizations enabled
92904505
ER
420# don't do anything on --downgrade
421if [ $1 -le 1 ]; then
422 exit 0
423fi
424echo "Grub was upgraded, trying to setup it to boot sector"
425/sbin/grub-install '(hd0)' || :
426
7b6caae9
ER
427%triggerpostun -- %{name} < 1.99-7.3
428# migrate /etc/grub.d/custom.cfg.rpmsave -> /boot/grub/custom.cfg
429if [ -f %{_sysconfdir}/grub.d/custom.cfg.rpmsave ]; then
1536aaf2
JK
430 cp -f %{_grubdir}/custom.cfg{,.rpmnew}
431 mv -f %{_sysconfdir}/grub.d/custom.cfg.rpmsave %{_grubdir}/custom.cfg
7b6caae9
ER
432fi
433
f951fcbe 434%files -f grub.lang
afe8504a 435%defattr(644,root,root,755)
2e4bec6f 436%doc AUTHORS ChangeLog NEWS README THANKS TODO
aec70abd 437%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/grub
71c933c0 438%attr(755,root,root) %{_sbindir}/grub-editenv
3ea0c40e 439%attr(755,root,root) %{_sbindir}/grub-fstest
5bafb558
JK
440%attr(755,root,root) %{_sbindir}/grub-file
441%attr(755,root,root) %{_sbindir}/grub-glue-efi
e9d73181 442%attr(755,root,root) %{_sbindir}/grub-kbdcomp
fc835b5e 443%attr(755,root,root) %{_sbindir}/grub-install
5bafb558 444%attr(755,root,root) %{_sbindir}/grub-macbless
e9d73181 445%attr(755,root,root) %{_sbindir}/grub-menulst2cfg
fc835b5e 446%attr(755,root,root) %{_sbindir}/grub-mkconfig
e9d73181
AM
447%attr(755,root,root) %{_sbindir}/grub-mklayout
448%attr(755,root,root) %{_sbindir}/grub-mknetdir
71c933c0
ER
449%attr(755,root,root) %{_sbindir}/grub-mkpasswd-pbkdf2
450%attr(755,root,root) %{_sbindir}/grub-mkrelpath
451%attr(755,root,root) %{_sbindir}/grub-mkrescue
7615a862
JK
452%attr(755,root,root) %{_sbindir}/grub-mkstandalone
453%attr(755,root,root) %{_sbindir}/grub-mount
454%attr(755,root,root) %{_sbindir}/grub-ofpathname
71c933c0 455%attr(755,root,root) %{_sbindir}/grub-reboot
5bafb558 456%attr(755,root,root) %{_sbindir}/grub-render-label
71c933c0
ER
457%attr(755,root,root) %{_sbindir}/grub-script-check
458%attr(755,root,root) %{_sbindir}/grub-set-default
5bafb558 459%attr(755,root,root) %{_sbindir}/grub-syslinux2cfg
22909ca1 460%attr(755,root,root) %{_sbindir}/update-grub
50ffb0ba 461%ifarch %{ix86} %{x8664} x32
feaacba3
JB
462%attr(755,root,root) %{_sbindir}/grub-bios-setup
463%{_mandir}/man8/grub-bios-setup.8*
464%endif
50ffb0ba 465%ifarch %{ix86} %{x8664} x32
76be4c4a 466%attr(755,root,root) %{_sbindir}/grub-mkimage
fc835b5e 467%{_mandir}/man1/grub-mkimage.1*
76be4c4a
AM
468%else
469%attr(755,root,root) %{_sbindir}/grub-probe
76be4c4a 470%{_mandir}/man8/grub-probe.8*
76be4c4a 471%endif
feaacba3
JB
472%ifarch sparc64
473%attr(755,root,root) %{_sbindir}/grub-sparc64-setup
474%{_mandir}/man8/grub-sparc64-setup.8*
475%endif
71c933c0 476%{_mandir}/man1/grub-editenv.1*
5bafb558 477%{_mandir}/man1/grub-file.1*
3ea0c40e 478%{_mandir}/man1/grub-fstest.1*
5bafb558 479%{_mandir}/man1/grub-glue-efi.1*
7615a862 480%{_mandir}/man1/grub-kbdcomp.1*
e9d73181 481%{_mandir}/man1/grub-menulst2cfg.1*
e9d73181 482%{_mandir}/man1/grub-mklayout.1*
5bafb558 483%{_mandir}/man1/grub-mknetdir.1*
71c933c0 484%{_mandir}/man1/grub-mkpasswd-pbkdf2.1*
03b9d04b 485%{_mandir}/man1/grub-mkrelpath.1*
71c933c0 486%{_mandir}/man1/grub-mkrescue.1*
7615a862
JK
487%{_mandir}/man1/grub-mkstandalone.1*
488%{_mandir}/man1/grub-mount.1*
5bafb558 489%{_mandir}/man1/grub-render-label.1*
71c933c0 490%{_mandir}/man1/grub-script-check.1*
5bafb558 491%{_mandir}/man1/grub-syslinux2cfg.1*
71c933c0 492%{_mandir}/man8/grub-install.8*
a4c52d96 493%{_mandir}/man8/grub-macbless.8*
fc835b5e 494%{_mandir}/man8/grub-mkconfig.8*
7615a862 495%{_mandir}/man8/grub-ofpathname.8*
71c933c0
ER
496%{_mandir}/man8/grub-reboot.8*
497%{_mandir}/man8/grub-set-default.8*
22909ca1 498%{_mandir}/man8/update-grub.8*
797addca 499%if %{with grubemu}
8fcee4aa
ER
500%attr(755,root,root) %{_sbindir}/grub-emu
501%{_mandir}/man8/grub-emu.8*
797addca 502%endif
e6fbd304 503%{_libexecdir}/grub-mkconfig_lib
aec70abd 504
1536aaf2 505%dir %{_grubdir}
26e757db 506%dir %{_libexecdir}
bcd6a47e 507# XXX: check this locale dir location and if it is neccesaary to exist on /boot
565fe2e3 508
bcd6a47e 509%dir %{_libexecdir}/locale
1536aaf2
JK
510%config(noreplace) %verify(not md5 mtime size) %{_grubdir}/grub.cfg
511%config(noreplace) %verify(not md5 mtime size) %{_grubdir}/custom.cfg
aec70abd 512
cbd79801 513# generated by grub at runtime
1536aaf2
JK
514%ghost %{_grubdir}/device.map
515%ghost %{_grubdir}/core.img
516%ghost %{_grubdir}/grubenv
cbd79801 517
e2964b87
ER
518%dir /lib/grub.d
519%doc /lib/grub.d/README
520%attr(755,root,root) /lib/grub.d/00_header
521%attr(755,root,root) /lib/grub.d/10_linux
e9d73181 522%attr(755,root,root) /lib/grub.d/20_linux_xen
e2964b87 523%attr(755,root,root) /lib/grub.d/30_os-prober
e9d73181 524%attr(755,root,root) /lib/grub.d/41_custom
e2964b87 525
b876d99a
JK
526# these are now installed only on matching hosts
527#%attr(755,root,root) /lib/grub.d/10_hurd
528#%attr(755,root,root) /lib/grub.d/10_illumos
529#%attr(755,root,root) /lib/grub.d/10_kfreebsd
530#%attr(755,root,root) /lib/grub.d/10_netbsd
531#%attr(755,root,root) /lib/grub.d/10_xnu
532
50ffb0ba 533%ifarch %{ix86} %{x8664} x32
1ffaf1f6 534%attr(755,root,root) %{_sbindir}/grub-probe
fc835b5e 535%{_mandir}/man8/grub-probe.8*
4a00f3b7 536%endif
aec70abd 537
f4604ef8 538%{_infodir}/grub*.info*
565fe2e3 539
8ac8605d
JK
540%dir %{_datadir}/grub/themes
541
1536aaf2 542%if %{with pc}
6d8475a4 543%files platform-pc
1536aaf2
JK
544%defattr(644,root,root,755)
545%dir %{_libexecdir}/*-pc
546%{_libexecdir}/*-pc/modinfo.sh
547%{_libexecdir}/*-pc/*.exec
548%{_libexecdir}/*-pc/*.image
549%{_libexecdir}/*-pc/*.lst
550%{_libexecdir}/*-pc/*.mod
551%{_libexecdir}/*-pc/*.module
552%{_libexecdir}/*-pc/lzma_decompress.img
553%{_libexecdir}/*-pc/config.h
554%{_libexecdir}/*-pc/gdb_grub
555%{_libexecdir}/*-pc/gmodule.pl
556%if %{with efiemu}
1536aaf2
JK
557%{_libexecdir}/*-pc/efiemu*.o
558%endif
1536aaf2 559%{_libexecdir}/*-pc/kernel.img
50ffb0ba 560%ifarch %{ix86} %{x8664} x32 sparc sparc64
1536aaf2 561%{_libexecdir}/*-pc/boot.img
5bafb558 562%{_libexecdir}/*-pc/boot_hybrid.img
1536aaf2
JK
563%{_libexecdir}/*-pc/cdboot.img
564%{_libexecdir}/*-pc/diskboot.img
565%{_libexecdir}/*-pc/lnxboot.img
566%{_libexecdir}/*-pc/pxeboot.img
567%endif
568%endif
569
570%if %{with efi}
6d8475a4 571%files platform-efi
1536aaf2
JK
572%defattr(644,root,root,755)
573%dir %{_libexecdir}/*-efi
574%{_libexecdir}/*-efi/modinfo.sh
575%{_libexecdir}/*-efi/*.exec
576%{_libexecdir}/*-efi/*.lst
577%{_libexecdir}/*-efi/*.mod
578%{_libexecdir}/*-efi/*.module
579%{_libexecdir}/*-efi/config.h
580%{_libexecdir}/*-efi/gdb_grub
581%{_libexecdir}/*-efi/gmodule.pl
1536aaf2
JK
582%{_libexecdir}/*-efi/kernel.img
583%endif
584
7615a862
JK
585%files mkfont
586%defattr(644,root,root,755)
7615a862 587%attr(755,root,root) %{_sbindir}/grub-mkfont
feaacba3 588%{_mandir}/man1/grub-mkfont.1*
7615a862 589
8ac8605d
JK
590%files theme-starfield
591%defattr(644,root,root,755)
592%{_datadir}/grub/themes/starfield
593
565fe2e3
ER
594%files -n bash-completion-%{name}
595%defattr(644,root,root,755)
596/etc/bash_completion.d/grub
This page took 0.191689 seconds and 4 git commands to generate.