]> git.pld-linux.org Git - packages/grub2.git/blame - grub2.spec
- ld.gold is still broken
[packages/grub2.git] / grub2.spec
CommitLineData
f97cafb4 1# TODO
dc6928bc 2# - reap out which in probe scripts and drop R: which
f97cafb4 3# - subpackages? e.g. modules and utils
bcd6a47e 4# - check where is that locale path: /boot/grub/locale and fix it or change it
8fcee4aa
ER
5# - grubemu notes
6# --enable-grub-emu-usb conflicts with --enable-grub-emu-pci, emu-pci seems experimental
7# - to build and install the `grub-emu' debugging utility we need to re-run build with --target=emu
8# - put grub-emu to subpackage if it is fixed
f97cafb4 9#
90feddde 10# Conditional build:
1536aaf2 11%bcond_with grubemu # build grub-emu debugging utility
b06c130d 12%bcond_without efiemu # build efiemu runtimes
1536aaf2
JK
13%bcond_without pc # do not build for PC BIOS platform
14%bcond_without efi # do not build for EFI platform
b06c130d
ER
15
16%if "%{cc_version}" < "3.4"
17# cc does not support:
18# cc1: sorry, unimplemented: code model `large' not supported yet
19%undefine with_efiemu
20%endif
21
feaacba3
JB
22%ifnarch %{ix86} %{x8664}
23%undefine with_pc
24%endif
25%ifnarch %{ix86} %{x8664} ia64
26%undefine with_efi
27%endif
28
2d8da575
AM
29%ifnarch %{x8664}
30# non-x86_64 arch doesn't support this
31%undefine with_efiemu
32%endif
33
1536aaf2 34# the 'most natural' platform should go last
feaacba3 35%ifarch %{ix86} %{x8664} ia64
1536aaf2 36%define platforms %{?with_efi:efi} %{?with_pc:pc}
feaacba3
JB
37%endif
38%ifarch ppc ppc64 sparc64
39%define platforms ieee1275
40%endif
41%ifarch mips
42%define platforms arc
43%endif
44%ifarch mipsel
45%define platforms loongson
46%endif
1536aaf2 47
afe8504a 48Summary: GRand Unified Bootloader
c8155f7f 49Summary(de.UTF-8): GRUB2 - ein Bootloader für x86 und ppc
f97cafb4 50Summary(hu.UTF-8): GRUB2 - rendszerbetöltő x86 és ppc gépekhez
c8155f7f
ER
51Summary(pl.UTF-8): GRUB2 - bootloader dla x86 i ppc
52Summary(pt_BR.UTF-8): Gerenciador de inicialização GRUB2
afe8504a 53Name: grub2
7615a862 54Version: 2.00
7a73b7a5 55Release: 1.3
2e4bec6f 56License: GPL v2
afe8504a 57Group: Base
f951fcbe 58Source0: http://ftp.gnu.org/gnu/grub/grub-%{version}.tar.xz
7615a862 59# Source0-md5: a1043102fbc7bcedbf53e7ee3d17ab91
22909ca1
ER
60Source1: update-grub
61Source2: update-grub.8
b46589aa 62Source3: grub.sysconfig
e2964b87 63Source4: grub-custom.cfg
b46589aa 64Patch1: pld-sysconfdir.patch
872700b0 65Patch2: grub-garbage.patch
c9273ffc
JK
66Patch3: grub-lvmdevice.patch
67Patch4: pld-mkconfigdir.patch
68Patch5: grub-mkconfig-diagnostics.patch
69Patch6: ppc.patch
70Patch7: %{name}-awk.patch
71Patch8: posix.patch
72Patch9: %{name}-gets.patch
26996aed 73Patch10: %{name}-fonts_path.patch
55de8afc 74Patch11: %{name}-tftp_fix.patch
50fb4025
JR
75Patch12: add-vlan-tag-support.patch
76Patch13: just-say-linux.patch
77Patch14: add-GRUB-DISABLE-SUBMENU-option.patch
78Patch15: add-X-option-to-printf-functions.patch
79Patch16: dhcp-client-id-and-uuid-options-added.patch
80Patch17: fix-http-crash.patch
81Patch18: Issue-separate-DNS-queries-for-ipv4-and-ipv6.patch
82Patch19: search-for-specific-config-file-for-netboot.patch
b78e362f 83Patch20: ignore-kernel-symlinks.patch
806364c8 84Patch21: choose-preferred-initrd.patch
feaacba3 85URL: http://www.gnu.org/software/grub/
27550907
ER
86BuildRequires: autoconf >= 2.53
87BuildRequires: automake >= 1:1.11.1-1
8b781299 88BuildRequires: bison
06df59fd 89BuildRequires: device-mapper-devel
feaacba3 90BuildRequires: flex >= 2.5.35
26996aed 91BuildRequires: fonts-TTF-DejaVu
feaacba3 92BuildRequires: freetype-devel >= 2
12fd19f5 93BuildRequires: gawk
63e45785 94BuildRequires: gettext-devel
feaacba3 95BuildRequires: glibc-static
1349ebb8 96BuildRequires: help2man
42985b0d 97BuildRequires: libfuse-devel
afe8504a 98BuildRequires: libtool
feaacba3
JB
99BuildRequires: ncurses-devel
100BuildRequires: rpm >= 4.4.9-56
101BuildRequires: rpmbuild(macros) >= 1.213
102BuildRequires: sed >= 4.0
103BuildRequires: tar >= 1:1.22
81a7e0ba 104BuildRequires: texinfo
feaacba3
JB
105BuildRequires: xz
106BuildRequires: xz-devel
c668211a
ER
107%ifarch %{x8664}
108BuildRequires: /usr/lib/libc.so
8905dae4
ER
109%if "%{pld_release}" == "ac"
110BuildRequires: libgcc32
111%else
797addca 112BuildRequires: gcc-multilib
c668211a 113%endif
dee0d6f5 114%endif
feaacba3 115Requires: %{name}-platform = %{version}-%{release}
dc6928bc 116Requires: which
feaacba3
JB
117%ifarch %{ix86} %{x8664}
118Suggests: %{name}-platform-pc
119%endif
190cc685 120Suggests: cdrkit-mkisofs
97ee543c 121Suggests: os-prober
afe8504a 122Provides: bootloader
fc835b5e 123Conflicts: grub
feaacba3 124ExclusiveArch: %{ix86} %{x8664} ia64 mips mipsel ppc ppc64 sparc64
afe8504a
SP
125BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
126
127%define _sbindir /sbin
4a00f3b7 128%define _bindir %{_sbindir}
1536aaf2 129%define _libdir /lib
e6fbd304 130%define _datadir %{_libdir}
26e757db 131%define _libexecdir %{_libdir}/grub
1536aaf2 132%define _grubdir /boot/grub
da9b7cf9 133%define _localedir /usr/share/locale
9d44d75e 134
0e2cbb94
JK
135# part of grub code is not relocable (these are not Linux libs)
136# stack protector also breaks non-Linux binaries
5bc5d891 137%define filterout_c -fPIC -O.
5967241e 138%undefine _ssp_cflags
5bc5d891 139%undefine _fortify_cflags
0e2cbb94 140
afe8504a
SP
141%description
142GRUB is a GPLed bootloader intended to unify bootloading across x86
143operating systems. In addition to loading the Linux and *BSD kernels,
144it implements the Multiboot standard, which allows for flexible
145loading of multiple boot images (needed for modular kernels such as
146the GNU Hurd).
147
211df1ed
ER
148GRUB 2 is derived from PUPA which was a research project to
149investigate the next generation of GRUB. GRUB 2 has been rewritten
150from scratch to clean up everything for modularity and portability.
151
152GRUB 2 targets at the following goals:
153- Scripting support, such as conditionals, loops, variables and
154 functions.
155- Graphical interface.
156- Dynamic loading of modules in order to extend itself at the run time
157 rather than at the build time.
158- Portability for various architectures.
159- Internationalization. This includes support for non-ASCII character
160 code, message catalogs like gettext, fonts, graphics console, and so
161 on.
162- Real memory management, to make GNU GRUB more extensible.
163- Modular, hierarchical, object-oriented framework for file systems,
164 files, devices, drives, terminals, commands, partition tables and OS
165 loaders.
166- Cross-platform installation which allows for installing GRUB from a
167 different architecture.
168- Rescue mode saves unbootable cases. Stage 1.5 was eliminated.
169- Fix design mistakes in GRUB Legacy, which could not be solved for
170 backward-compatibility, such as the way of numbering partitions.
171
6b0aefbf 172%description -l de.UTF-8
afe8504a
SP
173GRUB (GRand Unified Boot-loader) ist ein Bootloader, der oft auf
174Rechnern eingesetzt wird, auf denen das freie Betriebssystem Linux
6b0aefbf 175läuft. GRUB löst den betagten LILO (Linux-Loader) ab.
afe8504a
SP
176
177GRUB wurde innerhalb des GNU Hurd-Projektes als Boot-Loader entwickelt
6b0aefbf
JR
178und wird unter der GPL vertrieben. Aufgrund seiner höheren
179Flexibilität verdrängt GRUB in vielen Linux-Distributionen den
afe8504a
SP
180traditionellen Boot-Loader LILO.
181
f97cafb4
ZU
182%description -l hu.UTF-8
183GRUB egy GPL liszenszű rendszerbetöltő. Linux és *BSD kernelek
184betöltése mellett támogatja a Multiboot standard-ot, amely lehetővé
185teszi boot képek betöltését (moduláris kerneleknek kell, mint pl. a
186GNU Hurd).
187
188GRUB2 céljai a következők:
189- szkriptelés támogatása, úgymint feltételek, ciklusok, változók,
190 függvények.
191- grafikus felület
192- modulok dinamikus betöltése futási időben
193- hordozhatóság több architektúrára
194- többnyelvűség: nem-ASCII karakterek támogatása, üzenetkatalógusok,
195 mint gettext, betűtípusok, grafikus konzolon, és így tovább
196- valós memória kezelés, amellyel még bővíthetőbbé tehetjük
197- moduláris, hierarchikus, objektum-orientált keretrendszer
198 fájlrendszerekhez, fájlokhoz, eszközökhöz, meghajtókhoz,
199 terminálokhoz, parancsokhoz, partíciós táblákhoz és OS betöltőkhöz
200
6b0aefbf
JR
201%description -l es.UTF-8
202Éste es GRUB - Grand Unified Boot Loader - un administrador de
203inicialización capaz de entrar en la mayoría de los sistemas
afe8504a 204operacionales libres - Linux, FreeBSD, NetBSD, GNU Mach, etc. como
6b0aefbf 205también en la mayoría de los sistemas operacionales comerciales para
afe8504a
SP
206PC.
207
208El administrador GRUB puede ser una buena alternativa a LILO, para
6b0aefbf
JR
209usuarios conmás experiencia y que deseen obtener más recursos de su
210cargador de inicialización (boot loader).
afe8504a 211
6b0aefbf 212%description -l pl.UTF-8
feaacba3 213GRUB jest bootloaderem na licencji GNU GPL, mającym na celu unifikację
6b0aefbf 214procesu bootowania na systemach x86. Potrafi nie tylko ładować jądra
feaacba3 215Linuksa i *BSD: posiada również implementację standardu Multiboot,
6b0aefbf
JR
216który pozwala na elastyczne ładowanie wielu obrazów bootowalnych
217(czego wymagają modułowe jądra, takie jak GNU Hurd).
afe8504a 218
6b0aefbf
JR
219%description -l pt_BR.UTF-8
220Esse é o GRUB - Grand Unified Boot Loader - um gerenciador de boot
afe8504a
SP
221capaz de entrar na maioria dos sistemas operacionais livres - Linux,
222FreeBSD, NetBSD, GNU Mach, etc. assim como na maioria dos sistemas
223operacionais comerciais para PC.
224
6b0aefbf
JR
225O GRUB pode ser uma boa alternativa ao LILO, para usuários mais
226avançados e que querem mais recursos de seu boot loader.
afe8504a 227
565fe2e3
ER
228%package -n bash-completion-%{name}
229Summary: bash-completion for GRUB
feaacba3 230Summary(pl.UTF-8): Bashowe uzupełnianie nazw dla GRUB-a
565fe2e3
ER
231Group: Applications/Shells
232Requires: bash-completion
233
234%description -n bash-completion-%{name}
235This package provides bash-completion for GRUB.
236
237%description -n bash-completion-%{name} -l pl.UTF-8
feaacba3 238Pakiet ten dostarcza bashowe uzupełnianie nazw dla GRUB-a.
565fe2e3 239
6d8475a4 240%package platform-pc
62081337 241Summary: PC BIOS platform support for GRUB
feaacba3 242Summary(pl.UTF-8): Obsługa platformy PC BIOS dla GRUB-a
62081337 243Group: Base
6d8475a4 244Provides: %{name}-platform = %{version}-%{release}
1536aaf2 245
6d8475a4 246%description platform-pc
62081337 247PC BIOS platform support for GRUB.
1536aaf2 248
feaacba3
JB
249%description platform-pc -l pl.UTF-8
250Obsługa platformy PC BIOS dla GRUB-a.
251
6d8475a4 252%package platform-efi
1536aaf2 253Summary: (U)EFI platform support for GRUB
feaacba3 254Summary(pl.UTF-8): Obsługa platformy (U)EFI dla GRUB-a
1536aaf2 255Group: Base
6e81e1fe 256Suggests: efibootmgr
6d8475a4 257Provides: %{name}-platform = %{version}-%{release}
1536aaf2 258
6d8475a4 259%description platform-efi
1536aaf2
JK
260(U)EFI platform support for GRUB.
261
feaacba3
JB
262%description platform-efi -l pl.UTF-8
263Obsługa platformy (U)EFI dla GRUB-a.
264
7615a862
JK
265%package mkfont
266Summary: GRUB font files converter
feaacba3 267Summary(pl.UTF-8): Konwerter plików fontów GRUB-a
7615a862
JK
268Group: Base
269
270%description mkfont
271Converts common font file formats into PF2.
272
feaacba3
JB
273%description mkfont -l pl.UTF-8
274Program do konwersji popularnych formatów plików fontów do PF2.
275
8ac8605d
JK
276%package theme-starfield
277Summary: starfield theme for GRUB
feaacba3 278Summary(pl.UTF-8): Motyw starfield dla GRUB-a
8ac8605d
JK
279Group: Base
280
281%description theme-starfield
282starfield theme for GRUB.
283
feaacba3
JB
284%description theme-starfield -l pl.UTF-8
285Motyw starfield dla GRUB-a.
286
afe8504a 287%prep
f951fcbe 288%setup -q -n grub-%{version}
b46589aa 289%patch1 -p1
872700b0 290%patch2 -p1
f951fcbe 291%patch3 -p1
aec70abd 292%patch4 -p1
f7ae30d0 293%patch5 -p1
e2964b87 294%patch6 -p1
449dde54 295%patch7 -p1
61d105fa 296%patch8 -p1
4c7bb96e 297%patch9 -p1
26996aed 298%patch10 -p1
55de8afc 299%patch11 -p1
50fb4025
JR
300%patch12 -p1
301%patch13 -p1
302%patch14 -p1
303%patch15 -p1
304%patch16 -p1
305%patch17 -p1
306%patch18 -p1
307%patch19 -p1
b78e362f 308%patch20 -p1
ab6bbe27 309%patch21 -p1
afe8504a 310
71c933c0 311%if "%{cc_version}" < "3.4"
dea0c850
ER
312grep -rl -- -Wno-missing-field-initializers . | xargs %{__sed} -i -e 's,-Wno-missing-field-initializers,,'
313%{__sed} -i -e '/video_mod_CFLAGS/s/$/ -Wno-error/' conf/common.rmk
71c933c0
ER
314%endif
315
afe8504a 316%build
928eb9c1 317# if gold is used then grub doesn't even boot
7a73b7a5
JR
318install -d our-ld
319ln -s /usr/bin/ld.bfd our-ld/ld
320export PATH=$(pwd)/our-ld:$PATH
928eb9c1 321
3ff87e8a 322cp -f /usr/share/automake/config.sub .
afe8504a 323%{__libtoolize}
e9d73181 324%{__aclocal} -I m4
afe8504a 325%{__autoheader}
b1a4846d 326echo timestamp > stamp-h.in
afe8504a 327%{__autoconf}
80936b4a 328%{__automake}
98a41f0f 329#export CFLAGS="%{rpmcflags} -Os %{?debug:-g}"
12fd19f5 330
1536aaf2 331for platform in %{platforms} ; do
fc490c3e
JK
332 install -d build-${platform}
333 cd build-${platform}
0e2cbb94
JK
334
335 if [ "$platform" != "efi" ] ; then
feaacba3 336 platform_opts="--enable-efiemu%{!?with_efiemu:=no}"
0e2cbb94
JK
337 else
338 platform_opts=""
339 fi
340
1536aaf2
JK
341 ln -s ../configure .
342 # mawk stalls at ./genmoddep.awk, so force gawk
343 AWK=gawk \
344 %configure \
345 --with-platform=${platform} \
346 --disable-werror \
347 %if %{with grubemu}
348 --enable-grub-emu-usb \
349 --enable-grub-emu-sdl \
350 --enable-grub-emu-pci \
351 %endif
0e2cbb94 352 $platform_opts \
1536aaf2
JK
353 TARGET_LDFLAGS=-static
354
355 %{__make}
356 cd ..
357done
0fb8b1a5 358
afe8504a
SP
359%install
360rm -rf $RPM_BUILD_ROOT
afe8504a 361
1536aaf2 362for platform in %{platforms} ; do
fc490c3e 363 cd build-${platform}
1536aaf2
JK
364 %{__make} install \
365 pkgdatadir=%{_libexecdir} \
366 pkglibdir=%{_libexecdir} \
367 DESTDIR=$RPM_BUILD_ROOT
368 cd ..
369done
afe8504a 370
7615a862
JK
371# not in Th (?)
372%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/de@hebrew
373%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/en@{arabic,cyrillic,greek,hebrew,piglatin}
374
f951fcbe
AM
375%find_lang grub
376
bcd6a47e
ER
377# this must be after 'make install'
378install -d $RPM_BUILD_ROOT%{_libexecdir}/locale
379
1536aaf2
JK
380install -d $RPM_BUILD_ROOT%{_grubdir}
381cp -p docs/grub.cfg $RPM_BUILD_ROOT%{_grubdir}
382
7b6caae9 383# grub.d/41_custom
1536aaf2 384cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_grubdir}/custom.cfg
7b6caae9
ER
385%{__rm} $RPM_BUILD_ROOT/lib/grub.d/40_custom
386
22909ca1 387install -p %{SOURCE1} $RPM_BUILD_ROOT%{_sbindir}/update-grub
7b6caae9
ER
388cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_mandir}/man8/update-grub.8
389
390install -d $RPM_BUILD_ROOT/etc/sysconfig
391cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/grub
392
393# rm -f, because it sometimes exists, sometimes not, depending which texlive you have installed
47069130 394rm -f $RPM_BUILD_ROOT%{_infodir}/dir
e2964b87 395
feaacba3
JB
396# platform specific, unnecessarily always installed
397%ifnarch %{ix86} %{x8664}
398%{__rm} $RPM_BUILD_ROOT{%{_sbindir}/grub-bios-setup,%{_mandir}/man8/grub-bios-setup.8}
399%endif
400%ifnarch sparc64
401%{__rm} $RPM_BUILD_ROOT{%{_sbindir}/grub-sparc64-setup,%{_mandir}/man8/grub-sparc64-setup.8}
402%endif
403
cbd79801 404# core.img - bootable image generated by grub-mkimage(1) via grub-install(1)
1536aaf2
JK
405touch $RPM_BUILD_ROOT%{_grubdir}/core.img
406touch $RPM_BUILD_ROOT%{_grubdir}/device.map
cbd79801 407
8b5c394b
ER
408# needs to be exactly 1KiB
409# but we're ghosting it. so whom are we kidding here? :P (maybe %config it in future?)
1536aaf2 410dd bs=1024 if=/dev/zero count=1 of=$RPM_BUILD_ROOT%{_grubdir}/grubenv
8b5c394b 411
afe8504a
SP
412%clean
413rm -rf $RPM_BUILD_ROOT
414
5028d8c9 415%post -p %{_sbindir}/postshell
fc58858a 416-/usr/sbin/fix-info-dir -c %{_infodir}
f4604ef8 417
5028d8c9 418%postun -p %{_sbindir}/postshell
fc58858a 419-/usr/sbin/fix-info-dir -c %{_infodir}
f4604ef8 420
287a39cc 421%triggerpostun -- %{name} < 2.00-0.1
a7bef3b9 422# Note this trigger on version upgrade
287a39cc
JK
423# needed only for upgrade from old grub2 packages
424# which contained modules in /boot/grub
92904505
ER
425# don't do anything on --downgrade
426if [ $1 -le 1 ]; then
427 exit 0
428fi
429echo "Grub was upgraded, trying to setup it to boot sector"
430/sbin/grub-install '(hd0)' || :
431
7b6caae9
ER
432%triggerpostun -- %{name} < 1.99-7.3
433# migrate /etc/grub.d/custom.cfg.rpmsave -> /boot/grub/custom.cfg
434if [ -f %{_sysconfdir}/grub.d/custom.cfg.rpmsave ]; then
1536aaf2
JK
435 cp -f %{_grubdir}/custom.cfg{,.rpmnew}
436 mv -f %{_sysconfdir}/grub.d/custom.cfg.rpmsave %{_grubdir}/custom.cfg
7b6caae9
ER
437fi
438
f951fcbe 439%files -f grub.lang
afe8504a 440%defattr(644,root,root,755)
2e4bec6f 441%doc AUTHORS ChangeLog NEWS README THANKS TODO
aec70abd 442%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/grub
71c933c0 443%attr(755,root,root) %{_sbindir}/grub-editenv
3ea0c40e 444%attr(755,root,root) %{_sbindir}/grub-fstest
e9d73181 445%attr(755,root,root) %{_sbindir}/grub-kbdcomp
fc835b5e 446%attr(755,root,root) %{_sbindir}/grub-install
e9d73181 447%attr(755,root,root) %{_sbindir}/grub-menulst2cfg
fc835b5e 448%attr(755,root,root) %{_sbindir}/grub-mkconfig
e9d73181
AM
449%attr(755,root,root) %{_sbindir}/grub-mklayout
450%attr(755,root,root) %{_sbindir}/grub-mknetdir
71c933c0
ER
451%attr(755,root,root) %{_sbindir}/grub-mkpasswd-pbkdf2
452%attr(755,root,root) %{_sbindir}/grub-mkrelpath
453%attr(755,root,root) %{_sbindir}/grub-mkrescue
7615a862
JK
454%attr(755,root,root) %{_sbindir}/grub-mkstandalone
455%attr(755,root,root) %{_sbindir}/grub-mount
456%attr(755,root,root) %{_sbindir}/grub-ofpathname
71c933c0
ER
457%attr(755,root,root) %{_sbindir}/grub-reboot
458%attr(755,root,root) %{_sbindir}/grub-script-check
459%attr(755,root,root) %{_sbindir}/grub-set-default
22909ca1 460%attr(755,root,root) %{_sbindir}/update-grub
76be4c4a 461%ifarch %{ix86} %{x8664}
feaacba3
JB
462%attr(755,root,root) %{_sbindir}/grub-bios-setup
463%{_mandir}/man8/grub-bios-setup.8*
464%endif
465%ifarch %{ix86} %{x8664}
76be4c4a 466%attr(755,root,root) %{_sbindir}/grub-mkimage
fc835b5e 467%{_mandir}/man1/grub-mkimage.1*
76be4c4a
AM
468%else
469%attr(755,root,root) %{_sbindir}/grub-probe
76be4c4a 470%{_mandir}/man8/grub-probe.8*
76be4c4a 471%endif
feaacba3
JB
472%ifarch sparc64
473%attr(755,root,root) %{_sbindir}/grub-sparc64-setup
474%{_mandir}/man8/grub-sparc64-setup.8*
475%endif
71c933c0 476%{_mandir}/man1/grub-editenv.1*
3ea0c40e 477%{_mandir}/man1/grub-fstest.1*
7615a862 478%{_mandir}/man1/grub-kbdcomp.1*
e9d73181 479%{_mandir}/man1/grub-menulst2cfg.1*
e9d73181 480%{_mandir}/man1/grub-mklayout.1*
71c933c0 481%{_mandir}/man1/grub-mkpasswd-pbkdf2.1*
03b9d04b 482%{_mandir}/man1/grub-mkrelpath.1*
71c933c0 483%{_mandir}/man1/grub-mkrescue.1*
7615a862
JK
484%{_mandir}/man1/grub-mkstandalone.1*
485%{_mandir}/man1/grub-mount.1*
71c933c0
ER
486%{_mandir}/man1/grub-script-check.1*
487%{_mandir}/man8/grub-install.8*
fc835b5e 488%{_mandir}/man8/grub-mkconfig.8*
e9d73181 489%{_mandir}/man8/grub-mknetdir.8*
7615a862 490%{_mandir}/man8/grub-ofpathname.8*
71c933c0
ER
491%{_mandir}/man8/grub-reboot.8*
492%{_mandir}/man8/grub-set-default.8*
22909ca1 493%{_mandir}/man8/update-grub.8*
797addca 494%if %{with grubemu}
8fcee4aa
ER
495%attr(755,root,root) %{_sbindir}/grub-emu
496%{_mandir}/man8/grub-emu.8*
797addca 497%endif
e6fbd304 498%{_libexecdir}/grub-mkconfig_lib
aec70abd 499
1536aaf2 500%dir %{_grubdir}
26e757db 501%dir %{_libexecdir}
bcd6a47e 502# XXX: check this locale dir location and if it is neccesaary to exist on /boot
565fe2e3 503
bcd6a47e 504%dir %{_libexecdir}/locale
1536aaf2
JK
505%config(noreplace) %verify(not md5 mtime size) %{_grubdir}/grub.cfg
506%config(noreplace) %verify(not md5 mtime size) %{_grubdir}/custom.cfg
aec70abd 507
cbd79801 508# generated by grub at runtime
1536aaf2
JK
509%ghost %{_grubdir}/device.map
510%ghost %{_grubdir}/core.img
511%ghost %{_grubdir}/grubenv
cbd79801 512
e2964b87
ER
513%dir /lib/grub.d
514%doc /lib/grub.d/README
515%attr(755,root,root) /lib/grub.d/00_header
516%attr(755,root,root) /lib/grub.d/10_linux
e9d73181 517%attr(755,root,root) /lib/grub.d/20_linux_xen
e2964b87 518%attr(755,root,root) /lib/grub.d/30_os-prober
e9d73181 519%attr(755,root,root) /lib/grub.d/41_custom
e2964b87 520
1e58ef6c 521%ifarch %{ix86} %{x8664}
1ffaf1f6 522%attr(755,root,root) %{_sbindir}/grub-probe
fc835b5e 523%{_mandir}/man8/grub-probe.8*
4a00f3b7 524%endif
aec70abd 525
f4604ef8 526%{_infodir}/grub*.info*
565fe2e3 527
8ac8605d
JK
528%dir %{_datadir}/grub/themes
529
1536aaf2 530%if %{with pc}
6d8475a4 531%files platform-pc
1536aaf2
JK
532%defattr(644,root,root,755)
533%dir %{_libexecdir}/*-pc
534%{_libexecdir}/*-pc/modinfo.sh
535%{_libexecdir}/*-pc/*.exec
536%{_libexecdir}/*-pc/*.image
537%{_libexecdir}/*-pc/*.lst
538%{_libexecdir}/*-pc/*.mod
539%{_libexecdir}/*-pc/*.module
540%{_libexecdir}/*-pc/lzma_decompress.img
541%{_libexecdir}/*-pc/config.h
542%{_libexecdir}/*-pc/gdb_grub
543%{_libexecdir}/*-pc/gmodule.pl
544%if %{with efiemu}
1536aaf2
JK
545%{_libexecdir}/*-pc/efiemu*.o
546%endif
1536aaf2
JK
547%{_libexecdir}/*-pc/kernel.img
548%ifarch %{ix86} %{x8664} sparc sparc64
549%{_libexecdir}/*-pc/boot.img
550%{_libexecdir}/*-pc/cdboot.img
551%{_libexecdir}/*-pc/diskboot.img
552%{_libexecdir}/*-pc/lnxboot.img
553%{_libexecdir}/*-pc/pxeboot.img
554%endif
555%endif
556
557%if %{with efi}
6d8475a4 558%files platform-efi
1536aaf2
JK
559%defattr(644,root,root,755)
560%dir %{_libexecdir}/*-efi
561%{_libexecdir}/*-efi/modinfo.sh
562%{_libexecdir}/*-efi/*.exec
563%{_libexecdir}/*-efi/*.lst
564%{_libexecdir}/*-efi/*.mod
565%{_libexecdir}/*-efi/*.module
566%{_libexecdir}/*-efi/config.h
567%{_libexecdir}/*-efi/gdb_grub
568%{_libexecdir}/*-efi/gmodule.pl
1536aaf2
JK
569%{_libexecdir}/*-efi/kernel.img
570%endif
571
7615a862
JK
572%files mkfont
573%defattr(644,root,root,755)
7615a862 574%attr(755,root,root) %{_sbindir}/grub-mkfont
feaacba3 575%{_mandir}/man1/grub-mkfont.1*
7615a862 576
8ac8605d
JK
577%files theme-starfield
578%defattr(644,root,root,755)
579%{_datadir}/grub/themes/starfield
580
565fe2e3
ER
581%files -n bash-completion-%{name}
582%defattr(644,root,root,755)
583/etc/bash_completion.d/grub
This page took 0.453536 seconds and 4 git commands to generate.