]> git.pld-linux.org Git - packages/grub2.git/blame - grub2.spec
renumber patches
[packages/grub2.git] / grub2.spec
CommitLineData
f97cafb4 1# TODO
dc6928bc 2# - reap out which in probe scripts and drop R: which
f97cafb4 3# - subpackages? e.g. modules and utils
bcd6a47e 4# - check where is that locale path: /boot/grub/locale and fix it or change it
8fcee4aa
ER
5# - grubemu notes
6# --enable-grub-emu-usb conflicts with --enable-grub-emu-pci, emu-pci seems experimental
7# - to build and install the `grub-emu' debugging utility we need to re-run build with --target=emu
8# - put grub-emu to subpackage if it is fixed
f97cafb4 9#
90feddde 10# Conditional build:
1536aaf2 11%bcond_with grubemu # build grub-emu debugging utility
b06c130d 12%bcond_without efiemu # build efiemu runtimes
1536aaf2
JK
13%bcond_without pc # do not build for PC BIOS platform
14%bcond_without efi # do not build for EFI platform
b06c130d 15
feaacba3
JB
16%ifnarch %{ix86} %{x8664}
17%undefine with_pc
18%endif
19%ifnarch %{ix86} %{x8664} ia64
20%undefine with_efi
21%endif
22
2d8da575
AM
23%ifnarch %{x8664}
24# non-x86_64 arch doesn't support this
25%undefine with_efiemu
26%endif
27
1536aaf2 28# the 'most natural' platform should go last
feaacba3 29%ifarch %{ix86} %{x8664} ia64
1536aaf2 30%define platforms %{?with_efi:efi} %{?with_pc:pc}
feaacba3
JB
31%endif
32%ifarch ppc ppc64 sparc64
33%define platforms ieee1275
34%endif
35%ifarch mips
36%define platforms arc
37%endif
38%ifarch mipsel
39%define platforms loongson
40%endif
1536aaf2 41
afe8504a 42Summary: GRand Unified Bootloader
c8155f7f 43Summary(de.UTF-8): GRUB2 - ein Bootloader für x86 und ppc
f97cafb4 44Summary(hu.UTF-8): GRUB2 - rendszerbetöltő x86 és ppc gépekhez
c8155f7f
ER
45Summary(pl.UTF-8): GRUB2 - bootloader dla x86 i ppc
46Summary(pt_BR.UTF-8): Gerenciador de inicialização GRUB2
afe8504a 47Name: grub2
b876d99a
JK
48Version: 2.02
49%define beta beta2
50Release: 0.%{beta}.1
2e4bec6f 51License: GPL v2
afe8504a 52Group: Base
5bafb558 53# git://git.savannah.gnu.org/grub.git
b876d99a
JK
54# git checkout %{version}~%{beta} ; make dist
55Source0: grub-%{version}~%{beta}.tar.gz
56# Source0-md5: ca6c18f6c5f1ed05b7444017a40573d9
22909ca1
ER
57Source1: update-grub
58Source2: update-grub.8
b46589aa 59Source3: grub.sysconfig
e2964b87 60Source4: grub-custom.cfg
5bafb558
JK
61# ./linguas.sh
62# TS=$(date +'%Y%m%d') ; tar cjvf grub-po-2.00.git$TS.tar.bz2 po/*.po po/LINGUAS
b876d99a
JK
63Source5: grub-po-2.02.git20140104.tar.bz2
64# Source5-md5: aeef3e636178093cf9d780d92da7afdb
b46589aa 65Patch1: pld-sysconfdir.patch
872700b0 66Patch2: grub-garbage.patch
c9273ffc
JK
67Patch3: grub-lvmdevice.patch
68Patch4: pld-mkconfigdir.patch
69Patch5: grub-mkconfig-diagnostics.patch
668ecb01
JK
70Patch6: posix.patch
71Patch7: %{name}-fonts_path.patch
72Patch8: add-vlan-tag-support.patch
73Patch9: just-say-linux.patch
74Patch10: ignore-kernel-symlinks.patch
75Patch11: choose-preferred-initrd.patch
76Patch12: %{name}-cfg.patch
feaacba3 77URL: http://www.gnu.org/software/grub/
27550907
ER
78BuildRequires: autoconf >= 2.53
79BuildRequires: automake >= 1:1.11.1-1
8b781299 80BuildRequires: bison
06df59fd 81BuildRequires: device-mapper-devel
feaacba3 82BuildRequires: flex >= 2.5.35
26996aed 83BuildRequires: fonts-TTF-DejaVu
feaacba3 84BuildRequires: freetype-devel >= 2
12fd19f5 85BuildRequires: gawk
63e45785 86BuildRequires: gettext-devel
5bafb558 87BuildRequires: glibc-localedb-all
feaacba3 88BuildRequires: glibc-static
1349ebb8 89BuildRequires: help2man
42985b0d 90BuildRequires: libfuse-devel
afe8504a 91BuildRequires: libtool
feaacba3 92BuildRequires: ncurses-devel
5bafb558
JK
93BuildRequires: python
94BuildRequires: python-modules
feaacba3
JB
95BuildRequires: rpm >= 4.4.9-56
96BuildRequires: rpmbuild(macros) >= 1.213
97BuildRequires: sed >= 4.0
98BuildRequires: tar >= 1:1.22
81a7e0ba 99BuildRequires: texinfo
feaacba3
JB
100BuildRequires: xz
101BuildRequires: xz-devel
c668211a
ER
102%ifarch %{x8664}
103BuildRequires: /usr/lib/libc.so
8905dae4
ER
104%if "%{pld_release}" == "ac"
105BuildRequires: libgcc32
106%else
797addca 107BuildRequires: gcc-multilib
c668211a 108%endif
dee0d6f5 109%endif
feaacba3 110Requires: %{name}-platform = %{version}-%{release}
a5138d8d 111Requires: pld-release
dc6928bc 112Requires: which
feaacba3
JB
113%ifarch %{ix86} %{x8664}
114Suggests: %{name}-platform-pc
115%endif
190cc685 116Suggests: cdrkit-mkisofs
97ee543c 117Suggests: os-prober
afe8504a 118Provides: bootloader
fc835b5e 119Conflicts: grub
feaacba3 120ExclusiveArch: %{ix86} %{x8664} ia64 mips mipsel ppc ppc64 sparc64
afe8504a
SP
121BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
122
123%define _sbindir /sbin
4a00f3b7 124%define _bindir %{_sbindir}
1536aaf2 125%define _libdir /lib
e6fbd304 126%define _datadir %{_libdir}
26e757db 127%define _libexecdir %{_libdir}/grub
1536aaf2 128%define _grubdir /boot/grub
da9b7cf9 129%define _localedir /usr/share/locale
9d44d75e 130
0e2cbb94
JK
131# part of grub code is not relocable (these are not Linux libs)
132# stack protector also breaks non-Linux binaries
8c5e5aa2
JR
133# any kind of forced optimizations makes grub2 unreliable (random
134# reboots and hangs on boot menu screen)
5bc5d891 135%define filterout_c -fPIC -O.
5967241e 136%undefine _ssp_cflags
5bc5d891 137%undefine _fortify_cflags
0e2cbb94 138
afe8504a
SP
139%description
140GRUB is a GPLed bootloader intended to unify bootloading across x86
141operating systems. In addition to loading the Linux and *BSD kernels,
142it implements the Multiboot standard, which allows for flexible
143loading of multiple boot images (needed for modular kernels such as
144the GNU Hurd).
145
211df1ed
ER
146GRUB 2 is derived from PUPA which was a research project to
147investigate the next generation of GRUB. GRUB 2 has been rewritten
148from scratch to clean up everything for modularity and portability.
149
150GRUB 2 targets at the following goals:
151- Scripting support, such as conditionals, loops, variables and
152 functions.
153- Graphical interface.
154- Dynamic loading of modules in order to extend itself at the run time
155 rather than at the build time.
156- Portability for various architectures.
157- Internationalization. This includes support for non-ASCII character
158 code, message catalogs like gettext, fonts, graphics console, and so
159 on.
160- Real memory management, to make GNU GRUB more extensible.
161- Modular, hierarchical, object-oriented framework for file systems,
162 files, devices, drives, terminals, commands, partition tables and OS
163 loaders.
164- Cross-platform installation which allows for installing GRUB from a
165 different architecture.
166- Rescue mode saves unbootable cases. Stage 1.5 was eliminated.
167- Fix design mistakes in GRUB Legacy, which could not be solved for
168 backward-compatibility, such as the way of numbering partitions.
169
6b0aefbf 170%description -l de.UTF-8
afe8504a
SP
171GRUB (GRand Unified Boot-loader) ist ein Bootloader, der oft auf
172Rechnern eingesetzt wird, auf denen das freie Betriebssystem Linux
6b0aefbf 173läuft. GRUB löst den betagten LILO (Linux-Loader) ab.
afe8504a
SP
174
175GRUB wurde innerhalb des GNU Hurd-Projektes als Boot-Loader entwickelt
6b0aefbf
JR
176und wird unter der GPL vertrieben. Aufgrund seiner höheren
177Flexibilität verdrängt GRUB in vielen Linux-Distributionen den
afe8504a
SP
178traditionellen Boot-Loader LILO.
179
f97cafb4
ZU
180%description -l hu.UTF-8
181GRUB egy GPL liszenszű rendszerbetöltő. Linux és *BSD kernelek
182betöltése mellett támogatja a Multiboot standard-ot, amely lehetővé
183teszi boot képek betöltését (moduláris kerneleknek kell, mint pl. a
184GNU Hurd).
185
186GRUB2 céljai a következők:
187- szkriptelés támogatása, úgymint feltételek, ciklusok, változók,
188 függvények.
189- grafikus felület
190- modulok dinamikus betöltése futási időben
191- hordozhatóság több architektúrára
192- többnyelvűség: nem-ASCII karakterek támogatása, üzenetkatalógusok,
193 mint gettext, betűtípusok, grafikus konzolon, és így tovább
194- valós memória kezelés, amellyel még bővíthetőbbé tehetjük
195- moduláris, hierarchikus, objektum-orientált keretrendszer
196 fájlrendszerekhez, fájlokhoz, eszközökhöz, meghajtókhoz,
197 terminálokhoz, parancsokhoz, partíciós táblákhoz és OS betöltőkhöz
198
6b0aefbf
JR
199%description -l es.UTF-8
200Éste es GRUB - Grand Unified Boot Loader - un administrador de
201inicialización capaz de entrar en la mayoría de los sistemas
afe8504a 202operacionales libres - Linux, FreeBSD, NetBSD, GNU Mach, etc. como
6b0aefbf 203también en la mayoría de los sistemas operacionales comerciales para
afe8504a
SP
204PC.
205
206El administrador GRUB puede ser una buena alternativa a LILO, para
6b0aefbf
JR
207usuarios conmás experiencia y que deseen obtener más recursos de su
208cargador de inicialización (boot loader).
afe8504a 209
6b0aefbf 210%description -l pl.UTF-8
feaacba3 211GRUB jest bootloaderem na licencji GNU GPL, mającym na celu unifikację
6b0aefbf 212procesu bootowania na systemach x86. Potrafi nie tylko ładować jądra
feaacba3 213Linuksa i *BSD: posiada również implementację standardu Multiboot,
6b0aefbf
JR
214który pozwala na elastyczne ładowanie wielu obrazów bootowalnych
215(czego wymagają modułowe jądra, takie jak GNU Hurd).
afe8504a 216
6b0aefbf
JR
217%description -l pt_BR.UTF-8
218Esse é o GRUB - Grand Unified Boot Loader - um gerenciador de boot
afe8504a
SP
219capaz de entrar na maioria dos sistemas operacionais livres - Linux,
220FreeBSD, NetBSD, GNU Mach, etc. assim como na maioria dos sistemas
221operacionais comerciais para PC.
222
6b0aefbf
JR
223O GRUB pode ser uma boa alternativa ao LILO, para usuários mais
224avançados e que querem mais recursos de seu boot loader.
afe8504a 225
565fe2e3
ER
226%package -n bash-completion-%{name}
227Summary: bash-completion for GRUB
feaacba3 228Summary(pl.UTF-8): Bashowe uzupełnianie nazw dla GRUB-a
565fe2e3
ER
229Group: Applications/Shells
230Requires: bash-completion
231
232%description -n bash-completion-%{name}
233This package provides bash-completion for GRUB.
234
235%description -n bash-completion-%{name} -l pl.UTF-8
feaacba3 236Pakiet ten dostarcza bashowe uzupełnianie nazw dla GRUB-a.
565fe2e3 237
6d8475a4 238%package platform-pc
62081337 239Summary: PC BIOS platform support for GRUB
feaacba3 240Summary(pl.UTF-8): Obsługa platformy PC BIOS dla GRUB-a
62081337 241Group: Base
6d8475a4 242Provides: %{name}-platform = %{version}-%{release}
1536aaf2 243
6d8475a4 244%description platform-pc
62081337 245PC BIOS platform support for GRUB.
1536aaf2 246
feaacba3
JB
247%description platform-pc -l pl.UTF-8
248Obsługa platformy PC BIOS dla GRUB-a.
249
6d8475a4 250%package platform-efi
1536aaf2 251Summary: (U)EFI platform support for GRUB
feaacba3 252Summary(pl.UTF-8): Obsługa platformy (U)EFI dla GRUB-a
1536aaf2 253Group: Base
6e81e1fe 254Suggests: efibootmgr
6d8475a4 255Provides: %{name}-platform = %{version}-%{release}
1536aaf2 256
6d8475a4 257%description platform-efi
1536aaf2
JK
258(U)EFI platform support for GRUB.
259
feaacba3
JB
260%description platform-efi -l pl.UTF-8
261Obsługa platformy (U)EFI dla GRUB-a.
262
7615a862
JK
263%package mkfont
264Summary: GRUB font files converter
feaacba3 265Summary(pl.UTF-8): Konwerter plików fontów GRUB-a
7615a862
JK
266Group: Base
267
268%description mkfont
269Converts common font file formats into PF2.
270
feaacba3
JB
271%description mkfont -l pl.UTF-8
272Program do konwersji popularnych formatów plików fontów do PF2.
273
8ac8605d
JK
274%package theme-starfield
275Summary: starfield theme for GRUB
feaacba3 276Summary(pl.UTF-8): Motyw starfield dla GRUB-a
8ac8605d
JK
277Group: Base
278
279%description theme-starfield
280starfield theme for GRUB.
281
feaacba3
JB
282%description theme-starfield -l pl.UTF-8
283Motyw starfield dla GRUB-a.
284
afe8504a 285%prep
b876d99a 286%setup -q -n grub-%{version}~%{beta} -a5
b46589aa 287%patch1 -p1
872700b0 288%patch2 -p1
f951fcbe 289%patch3 -p1
aec70abd 290%patch4 -p1
f7ae30d0 291%patch5 -p1
668ecb01
JK
292%patch6 -p1
293%patch7 -p1
61d105fa 294%patch8 -p1
668ecb01 295%patch9 -p1
26996aed 296%patch10 -p1
668ecb01
JK
297%patch11 -p1
298%patch12 -p0
5bafb558
JK
299
300# we don't have C.utf-8 and need an UTF-8 locale for build
301sed -i -e 's/LC_ALL=C.UTF-8/LC_ALL=en_US.utf-8/g' po/Makefile* po/Rules*
afe8504a
SP
302
303%build
928eb9c1 304# if gold is used then grub doesn't even boot
9bc7aab3
AM
305# https://savannah.gnu.org/bugs/?34539
306# http://sourceware.org/bugzilla/show_bug.cgi?id=14196
7a73b7a5
JR
307install -d our-ld
308ln -s /usr/bin/ld.bfd our-ld/ld
309export PATH=$(pwd)/our-ld:$PATH
928eb9c1 310
b876d99a
JK
311## not only the typicall autotools stuff
312#./autogen.sh
313
314%{__gettextize}
315%{__aclocal} -I m4
316%{__autoconf}
317%{__autoheader}
318%{__automake}
12fd19f5 319
1536aaf2 320for platform in %{platforms} ; do
fc490c3e
JK
321 install -d build-${platform}
322 cd build-${platform}
0e2cbb94
JK
323
324 if [ "$platform" != "efi" ] ; then
feaacba3 325 platform_opts="--enable-efiemu%{!?with_efiemu:=no}"
0e2cbb94
JK
326 else
327 platform_opts=""
328 fi
329
1536aaf2
JK
330 ln -s ../configure .
331 # mawk stalls at ./genmoddep.awk, so force gawk
332 AWK=gawk \
333 %configure \
334 --with-platform=${platform} \
335 --disable-werror \
336 %if %{with grubemu}
337 --enable-grub-emu-usb \
338 --enable-grub-emu-sdl \
339 --enable-grub-emu-pci \
340 %endif
0e2cbb94 341 $platform_opts \
1536aaf2
JK
342 TARGET_LDFLAGS=-static
343
b876d99a 344 %{__make} -C po update-gmo
1536aaf2
JK
345 %{__make}
346 cd ..
347done
0fb8b1a5 348
afe8504a
SP
349%install
350rm -rf $RPM_BUILD_ROOT
afe8504a 351
1536aaf2 352for platform in %{platforms} ; do
fc490c3e 353 cd build-${platform}
1536aaf2
JK
354 %{__make} install \
355 pkgdatadir=%{_libexecdir} \
356 pkglibdir=%{_libexecdir} \
357 DESTDIR=$RPM_BUILD_ROOT
358 cd ..
359done
afe8504a 360
7615a862
JK
361# not in Th (?)
362%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/de@hebrew
363%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/en@{arabic,cyrillic,greek,hebrew,piglatin}
364
f951fcbe
AM
365%find_lang grub
366
bcd6a47e
ER
367# this must be after 'make install'
368install -d $RPM_BUILD_ROOT%{_libexecdir}/locale
369
1536aaf2
JK
370install -d $RPM_BUILD_ROOT%{_grubdir}
371cp -p docs/grub.cfg $RPM_BUILD_ROOT%{_grubdir}
372
7b6caae9 373# grub.d/41_custom
1536aaf2 374cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_grubdir}/custom.cfg
7b6caae9
ER
375%{__rm} $RPM_BUILD_ROOT/lib/grub.d/40_custom
376
22909ca1 377install -p %{SOURCE1} $RPM_BUILD_ROOT%{_sbindir}/update-grub
7b6caae9
ER
378cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_mandir}/man8/update-grub.8
379
380install -d $RPM_BUILD_ROOT/etc/sysconfig
381cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/grub
382
383# rm -f, because it sometimes exists, sometimes not, depending which texlive you have installed
47069130 384rm -f $RPM_BUILD_ROOT%{_infodir}/dir
e2964b87 385
feaacba3
JB
386# platform specific, unnecessarily always installed
387%ifnarch %{ix86} %{x8664}
388%{__rm} $RPM_BUILD_ROOT{%{_sbindir}/grub-bios-setup,%{_mandir}/man8/grub-bios-setup.8}
389%endif
390%ifnarch sparc64
391%{__rm} $RPM_BUILD_ROOT{%{_sbindir}/grub-sparc64-setup,%{_mandir}/man8/grub-sparc64-setup.8}
392%endif
393
cbd79801 394# core.img - bootable image generated by grub-mkimage(1) via grub-install(1)
1536aaf2
JK
395touch $RPM_BUILD_ROOT%{_grubdir}/core.img
396touch $RPM_BUILD_ROOT%{_grubdir}/device.map
cbd79801 397
8b5c394b
ER
398# needs to be exactly 1KiB
399# but we're ghosting it. so whom are we kidding here? :P (maybe %config it in future?)
1536aaf2 400dd bs=1024 if=/dev/zero count=1 of=$RPM_BUILD_ROOT%{_grubdir}/grubenv
8b5c394b 401
afe8504a
SP
402%clean
403rm -rf $RPM_BUILD_ROOT
404
5028d8c9 405%post -p %{_sbindir}/postshell
fc58858a 406-/usr/sbin/fix-info-dir -c %{_infodir}
f4604ef8 407
5028d8c9 408%postun -p %{_sbindir}/postshell
fc58858a 409-/usr/sbin/fix-info-dir -c %{_infodir}
f4604ef8 410
8c5e5aa2
JR
411%triggerpostun -- %{name} < 2.00-2
412# Note this trigger on version upgrade needed only for upgrade from
413# old grub2 packages which contained modules in /boot/grub
414# or were built with optimizations enabled
92904505
ER
415# don't do anything on --downgrade
416if [ $1 -le 1 ]; then
417 exit 0
418fi
419echo "Grub was upgraded, trying to setup it to boot sector"
420/sbin/grub-install '(hd0)' || :
421
7b6caae9
ER
422%triggerpostun -- %{name} < 1.99-7.3
423# migrate /etc/grub.d/custom.cfg.rpmsave -> /boot/grub/custom.cfg
424if [ -f %{_sysconfdir}/grub.d/custom.cfg.rpmsave ]; then
1536aaf2
JK
425 cp -f %{_grubdir}/custom.cfg{,.rpmnew}
426 mv -f %{_sysconfdir}/grub.d/custom.cfg.rpmsave %{_grubdir}/custom.cfg
7b6caae9
ER
427fi
428
f951fcbe 429%files -f grub.lang
afe8504a 430%defattr(644,root,root,755)
2e4bec6f 431%doc AUTHORS ChangeLog NEWS README THANKS TODO
aec70abd 432%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/grub
71c933c0 433%attr(755,root,root) %{_sbindir}/grub-editenv
3ea0c40e 434%attr(755,root,root) %{_sbindir}/grub-fstest
5bafb558
JK
435%attr(755,root,root) %{_sbindir}/grub-file
436%attr(755,root,root) %{_sbindir}/grub-glue-efi
e9d73181 437%attr(755,root,root) %{_sbindir}/grub-kbdcomp
fc835b5e 438%attr(755,root,root) %{_sbindir}/grub-install
5bafb558 439%attr(755,root,root) %{_sbindir}/grub-macbless
e9d73181 440%attr(755,root,root) %{_sbindir}/grub-menulst2cfg
fc835b5e 441%attr(755,root,root) %{_sbindir}/grub-mkconfig
e9d73181
AM
442%attr(755,root,root) %{_sbindir}/grub-mklayout
443%attr(755,root,root) %{_sbindir}/grub-mknetdir
71c933c0
ER
444%attr(755,root,root) %{_sbindir}/grub-mkpasswd-pbkdf2
445%attr(755,root,root) %{_sbindir}/grub-mkrelpath
446%attr(755,root,root) %{_sbindir}/grub-mkrescue
7615a862
JK
447%attr(755,root,root) %{_sbindir}/grub-mkstandalone
448%attr(755,root,root) %{_sbindir}/grub-mount
449%attr(755,root,root) %{_sbindir}/grub-ofpathname
71c933c0 450%attr(755,root,root) %{_sbindir}/grub-reboot
5bafb558 451%attr(755,root,root) %{_sbindir}/grub-render-label
71c933c0
ER
452%attr(755,root,root) %{_sbindir}/grub-script-check
453%attr(755,root,root) %{_sbindir}/grub-set-default
5bafb558 454%attr(755,root,root) %{_sbindir}/grub-syslinux2cfg
22909ca1 455%attr(755,root,root) %{_sbindir}/update-grub
76be4c4a 456%ifarch %{ix86} %{x8664}
feaacba3
JB
457%attr(755,root,root) %{_sbindir}/grub-bios-setup
458%{_mandir}/man8/grub-bios-setup.8*
459%endif
460%ifarch %{ix86} %{x8664}
76be4c4a 461%attr(755,root,root) %{_sbindir}/grub-mkimage
fc835b5e 462%{_mandir}/man1/grub-mkimage.1*
76be4c4a
AM
463%else
464%attr(755,root,root) %{_sbindir}/grub-probe
76be4c4a 465%{_mandir}/man8/grub-probe.8*
76be4c4a 466%endif
feaacba3
JB
467%ifarch sparc64
468%attr(755,root,root) %{_sbindir}/grub-sparc64-setup
469%{_mandir}/man8/grub-sparc64-setup.8*
470%endif
71c933c0 471%{_mandir}/man1/grub-editenv.1*
5bafb558 472%{_mandir}/man1/grub-file.1*
3ea0c40e 473%{_mandir}/man1/grub-fstest.1*
5bafb558 474%{_mandir}/man1/grub-glue-efi.1*
7615a862 475%{_mandir}/man1/grub-kbdcomp.1*
5bafb558 476%{_mandir}/man1/grub-macbless.1*
e9d73181 477%{_mandir}/man1/grub-menulst2cfg.1*
e9d73181 478%{_mandir}/man1/grub-mklayout.1*
5bafb558 479%{_mandir}/man1/grub-mknetdir.1*
71c933c0 480%{_mandir}/man1/grub-mkpasswd-pbkdf2.1*
03b9d04b 481%{_mandir}/man1/grub-mkrelpath.1*
71c933c0 482%{_mandir}/man1/grub-mkrescue.1*
7615a862
JK
483%{_mandir}/man1/grub-mkstandalone.1*
484%{_mandir}/man1/grub-mount.1*
5bafb558 485%{_mandir}/man1/grub-render-label.1*
71c933c0 486%{_mandir}/man1/grub-script-check.1*
5bafb558 487%{_mandir}/man1/grub-syslinux2cfg.1*
71c933c0 488%{_mandir}/man8/grub-install.8*
fc835b5e 489%{_mandir}/man8/grub-mkconfig.8*
7615a862 490%{_mandir}/man8/grub-ofpathname.8*
71c933c0
ER
491%{_mandir}/man8/grub-reboot.8*
492%{_mandir}/man8/grub-set-default.8*
22909ca1 493%{_mandir}/man8/update-grub.8*
797addca 494%if %{with grubemu}
8fcee4aa
ER
495%attr(755,root,root) %{_sbindir}/grub-emu
496%{_mandir}/man8/grub-emu.8*
797addca 497%endif
e6fbd304 498%{_libexecdir}/grub-mkconfig_lib
aec70abd 499
1536aaf2 500%dir %{_grubdir}
26e757db 501%dir %{_libexecdir}
bcd6a47e 502# XXX: check this locale dir location and if it is neccesaary to exist on /boot
565fe2e3 503
bcd6a47e 504%dir %{_libexecdir}/locale
1536aaf2
JK
505%config(noreplace) %verify(not md5 mtime size) %{_grubdir}/grub.cfg
506%config(noreplace) %verify(not md5 mtime size) %{_grubdir}/custom.cfg
aec70abd 507
cbd79801 508# generated by grub at runtime
1536aaf2
JK
509%ghost %{_grubdir}/device.map
510%ghost %{_grubdir}/core.img
511%ghost %{_grubdir}/grubenv
cbd79801 512
e2964b87
ER
513%dir /lib/grub.d
514%doc /lib/grub.d/README
515%attr(755,root,root) /lib/grub.d/00_header
516%attr(755,root,root) /lib/grub.d/10_linux
e9d73181 517%attr(755,root,root) /lib/grub.d/20_linux_xen
e2964b87 518%attr(755,root,root) /lib/grub.d/30_os-prober
e9d73181 519%attr(755,root,root) /lib/grub.d/41_custom
e2964b87 520
b876d99a
JK
521# these are now installed only on matching hosts
522#%attr(755,root,root) /lib/grub.d/10_hurd
523#%attr(755,root,root) /lib/grub.d/10_illumos
524#%attr(755,root,root) /lib/grub.d/10_kfreebsd
525#%attr(755,root,root) /lib/grub.d/10_netbsd
526#%attr(755,root,root) /lib/grub.d/10_xnu
527
1e58ef6c 528%ifarch %{ix86} %{x8664}
1ffaf1f6 529%attr(755,root,root) %{_sbindir}/grub-probe
fc835b5e 530%{_mandir}/man8/grub-probe.8*
4a00f3b7 531%endif
aec70abd 532
f4604ef8 533%{_infodir}/grub*.info*
565fe2e3 534
8ac8605d
JK
535%dir %{_datadir}/grub/themes
536
1536aaf2 537%if %{with pc}
6d8475a4 538%files platform-pc
1536aaf2
JK
539%defattr(644,root,root,755)
540%dir %{_libexecdir}/*-pc
541%{_libexecdir}/*-pc/modinfo.sh
542%{_libexecdir}/*-pc/*.exec
543%{_libexecdir}/*-pc/*.image
544%{_libexecdir}/*-pc/*.lst
545%{_libexecdir}/*-pc/*.mod
546%{_libexecdir}/*-pc/*.module
547%{_libexecdir}/*-pc/lzma_decompress.img
548%{_libexecdir}/*-pc/config.h
549%{_libexecdir}/*-pc/gdb_grub
550%{_libexecdir}/*-pc/gmodule.pl
551%if %{with efiemu}
1536aaf2
JK
552%{_libexecdir}/*-pc/efiemu*.o
553%endif
1536aaf2
JK
554%{_libexecdir}/*-pc/kernel.img
555%ifarch %{ix86} %{x8664} sparc sparc64
556%{_libexecdir}/*-pc/boot.img
5bafb558 557%{_libexecdir}/*-pc/boot_hybrid.img
1536aaf2
JK
558%{_libexecdir}/*-pc/cdboot.img
559%{_libexecdir}/*-pc/diskboot.img
560%{_libexecdir}/*-pc/lnxboot.img
561%{_libexecdir}/*-pc/pxeboot.img
562%endif
563%endif
564
565%if %{with efi}
6d8475a4 566%files platform-efi
1536aaf2
JK
567%defattr(644,root,root,755)
568%dir %{_libexecdir}/*-efi
569%{_libexecdir}/*-efi/modinfo.sh
570%{_libexecdir}/*-efi/*.exec
571%{_libexecdir}/*-efi/*.lst
572%{_libexecdir}/*-efi/*.mod
573%{_libexecdir}/*-efi/*.module
574%{_libexecdir}/*-efi/config.h
575%{_libexecdir}/*-efi/gdb_grub
576%{_libexecdir}/*-efi/gmodule.pl
1536aaf2
JK
577%{_libexecdir}/*-efi/kernel.img
578%endif
579
7615a862
JK
580%files mkfont
581%defattr(644,root,root,755)
7615a862 582%attr(755,root,root) %{_sbindir}/grub-mkfont
feaacba3 583%{_mandir}/man1/grub-mkfont.1*
7615a862 584
8ac8605d
JK
585%files theme-starfield
586%defattr(644,root,root,755)
587%{_datadir}/grub/themes/starfield
588
565fe2e3
ER
589%files -n bash-completion-%{name}
590%defattr(644,root,root,755)
591/etc/bash_completion.d/grub
This page took 0.167159 seconds and 4 git commands to generate.