]> git.pld-linux.org Git - packages/grub2.git/blame - grub2.spec
undo case change from 8ac8605dc0d9b195833845091bb1a15eac49fd5d
[packages/grub2.git] / grub2.spec
CommitLineData
f97cafb4 1# TODO
dc6928bc 2# - reap out which in probe scripts and drop R: which
f97cafb4 3# - subpackages? e.g. modules and utils
bcd6a47e 4# - check where is that locale path: /boot/grub/locale and fix it or change it
8fcee4aa
ER
5# - grubemu notes
6# --enable-grub-emu-usb conflicts with --enable-grub-emu-pci, emu-pci seems experimental
7# - to build and install the `grub-emu' debugging utility we need to re-run build with --target=emu
8# - put grub-emu to subpackage if it is fixed
659f8cfc 9# - warning: Installed (but unpackaged) file(s) found:
1536aaf2
JK
10# /sbin/grub-sparc64-setup
11# /usr/share/man/man8/grub-sparc64-setup.8.gz
12
659f8cfc
ER
13# /boot/grub/config.h
14# /etc/bash_completion.d/grub
7615a862
JK
15# /sbin/grub-sparc64-setup
16# /boot/grub/gdb_grub
17# /boot/grub/gmodule.pl
18# /sbin/grub-sparc64-setup
f97cafb4 19#
90feddde 20# Conditional build:
1536aaf2 21%bcond_with grubemu # build grub-emu debugging utility
b06c130d 22%bcond_without efiemu # build efiemu runtimes
1536aaf2
JK
23%bcond_without pc # do not build for PC BIOS platform
24%bcond_without efi # do not build for EFI platform
b06c130d
ER
25
26%if "%{cc_version}" < "3.4"
27# cc does not support:
28# cc1: sorry, unimplemented: code model `large' not supported yet
29%undefine with_efiemu
30%endif
31
2d8da575
AM
32%ifnarch %{x8664}
33# non-x86_64 arch doesn't support this
34%undefine with_efiemu
35%endif
36
1536aaf2
JK
37# the 'most natural' platform should go last
38%define platforms %{?with_efi:efi} %{?with_pc:pc}
39
afe8504a 40Summary: GRand Unified Bootloader
c8155f7f 41Summary(de.UTF-8): GRUB2 - ein Bootloader für x86 und ppc
f97cafb4 42Summary(hu.UTF-8): GRUB2 - rendszerbetöltő x86 és ppc gépekhez
c8155f7f
ER
43Summary(pl.UTF-8): GRUB2 - bootloader dla x86 i ppc
44Summary(pt_BR.UTF-8): Gerenciador de inicialização GRUB2
afe8504a 45Name: grub2
7615a862
JK
46Version: 2.00
47Release: 0.1
2e4bec6f 48License: GPL v2
afe8504a 49Group: Base
f951fcbe 50Source0: http://ftp.gnu.org/gnu/grub/grub-%{version}.tar.xz
7615a862 51# Source0-md5: a1043102fbc7bcedbf53e7ee3d17ab91
22909ca1
ER
52Source1: update-grub
53Source2: update-grub.8
b46589aa 54Source3: grub.sysconfig
e2964b87 55Source4: grub-custom.cfg
695ab3a5 56URL: http://www.gnu.org/software/grub/
5028d8c9 57Patch0: pld-initrd.patch
b46589aa 58Patch1: pld-sysconfdir.patch
872700b0 59Patch2: grub-garbage.patch
c9273ffc
JK
60Patch3: grub-lvmdevice.patch
61Patch4: pld-mkconfigdir.patch
62Patch5: grub-mkconfig-diagnostics.patch
63Patch6: ppc.patch
64Patch7: %{name}-awk.patch
65Patch8: posix.patch
66Patch9: %{name}-gets.patch
26996aed 67Patch10: %{name}-fonts_path.patch
55de8afc 68Patch11: %{name}-tftp_fix.patch
27550907
ER
69BuildRequires: autoconf >= 2.53
70BuildRequires: automake >= 1:1.11.1-1
8b781299 71BuildRequires: bison
06df59fd 72BuildRequires: device-mapper-devel
26996aed 73BuildRequires: fonts-TTF-DejaVu
013b927c 74BuildRequires: freetype-devel
12fd19f5 75BuildRequires: gawk
63e45785 76BuildRequires: gettext-devel
1349ebb8 77BuildRequires: help2man
afe8504a 78BuildRequires: libtool
81a7e0ba 79BuildRequires: texinfo
c668211a
ER
80%ifarch %{x8664}
81BuildRequires: /usr/lib/libc.so
8905dae4
ER
82%if "%{pld_release}" == "ac"
83BuildRequires: libgcc32
84%else
797addca 85BuildRequires: gcc-multilib
c668211a 86%endif
dee0d6f5 87%endif
6b675158 88BuildRequires: glibc-static
565fe2e3 89BuildRequires: ncurses-devel
8905dae4 90BuildRequires: rpm >= 4.4.9-56
403e7b01 91BuildRequires: rpmbuild(macros) >= 1.213
565fe2e3 92BuildRequires: sed >= 4.0
dc6928bc 93Requires: which
190cc685 94Suggests: cdrkit-mkisofs
97ee543c 95Suggests: os-prober
afe8504a 96Provides: bootloader
fc835b5e 97Conflicts: grub
1536aaf2
JK
98Suggests: %{name}-pc
99Suggests: %{name}-efi
58a823d7 100ExclusiveArch: %{ix86} %{x8664} ppc sparc64
afe8504a
SP
101BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
102
103%define _sbindir /sbin
4a00f3b7 104%define _bindir %{_sbindir}
1536aaf2 105%define _libdir /lib
e6fbd304 106%define _datadir %{_libdir}
26e757db 107%define _libexecdir %{_libdir}/grub
1536aaf2 108%define _grubdir /boot/grub
da9b7cf9 109%define _localedir /usr/share/locale
9d44d75e 110
0e2cbb94
JK
111# part of grub code is not relocable (these are not Linux libs)
112# stack protector also breaks non-Linux binaries
113%define filterout_c -fPIC -fstack-protector
114
afe8504a
SP
115%description
116GRUB is a GPLed bootloader intended to unify bootloading across x86
117operating systems. In addition to loading the Linux and *BSD kernels,
118it implements the Multiboot standard, which allows for flexible
119loading of multiple boot images (needed for modular kernels such as
120the GNU Hurd).
121
211df1ed
ER
122GRUB 2 is derived from PUPA which was a research project to
123investigate the next generation of GRUB. GRUB 2 has been rewritten
124from scratch to clean up everything for modularity and portability.
125
126GRUB 2 targets at the following goals:
127- Scripting support, such as conditionals, loops, variables and
128 functions.
129- Graphical interface.
130- Dynamic loading of modules in order to extend itself at the run time
131 rather than at the build time.
132- Portability for various architectures.
133- Internationalization. This includes support for non-ASCII character
134 code, message catalogs like gettext, fonts, graphics console, and so
135 on.
136- Real memory management, to make GNU GRUB more extensible.
137- Modular, hierarchical, object-oriented framework for file systems,
138 files, devices, drives, terminals, commands, partition tables and OS
139 loaders.
140- Cross-platform installation which allows for installing GRUB from a
141 different architecture.
142- Rescue mode saves unbootable cases. Stage 1.5 was eliminated.
143- Fix design mistakes in GRUB Legacy, which could not be solved for
144 backward-compatibility, such as the way of numbering partitions.
145
6b0aefbf 146%description -l de.UTF-8
afe8504a
SP
147GRUB (GRand Unified Boot-loader) ist ein Bootloader, der oft auf
148Rechnern eingesetzt wird, auf denen das freie Betriebssystem Linux
6b0aefbf 149läuft. GRUB löst den betagten LILO (Linux-Loader) ab.
afe8504a
SP
150
151GRUB wurde innerhalb des GNU Hurd-Projektes als Boot-Loader entwickelt
6b0aefbf
JR
152und wird unter der GPL vertrieben. Aufgrund seiner höheren
153Flexibilität verdrängt GRUB in vielen Linux-Distributionen den
afe8504a
SP
154traditionellen Boot-Loader LILO.
155
f97cafb4
ZU
156%description -l hu.UTF-8
157GRUB egy GPL liszenszű rendszerbetöltő. Linux és *BSD kernelek
158betöltése mellett támogatja a Multiboot standard-ot, amely lehetővé
159teszi boot képek betöltését (moduláris kerneleknek kell, mint pl. a
160GNU Hurd).
161
162GRUB2 céljai a következők:
163- szkriptelés támogatása, úgymint feltételek, ciklusok, változók,
164 függvények.
165- grafikus felület
166- modulok dinamikus betöltése futási időben
167- hordozhatóság több architektúrára
168- többnyelvűség: nem-ASCII karakterek támogatása, üzenetkatalógusok,
169 mint gettext, betűtípusok, grafikus konzolon, és így tovább
170- valós memória kezelés, amellyel még bővíthetőbbé tehetjük
171- moduláris, hierarchikus, objektum-orientált keretrendszer
172 fájlrendszerekhez, fájlokhoz, eszközökhöz, meghajtókhoz,
173 terminálokhoz, parancsokhoz, partíciós táblákhoz és OS betöltőkhöz
174
6b0aefbf
JR
175%description -l es.UTF-8
176Éste es GRUB - Grand Unified Boot Loader - un administrador de
177inicialización capaz de entrar en la mayoría de los sistemas
afe8504a 178operacionales libres - Linux, FreeBSD, NetBSD, GNU Mach, etc. como
6b0aefbf 179también en la mayoría de los sistemas operacionales comerciales para
afe8504a
SP
180PC.
181
182El administrador GRUB puede ser una buena alternativa a LILO, para
6b0aefbf
JR
183usuarios conmás experiencia y que deseen obtener más recursos de su
184cargador de inicialización (boot loader).
afe8504a 185
6b0aefbf
JR
186%description -l pl.UTF-8
187GRUB jest bootloaderem na licencji GNU, mającym na celu unifikację
188procesu bootowania na systemach x86. Potrafi nie tylko ładować jądra
189Linuksa i *BSD: posiada również implementacje standardu Multiboot,
190który pozwala na elastyczne ładowanie wielu obrazów bootowalnych
191(czego wymagają modułowe jądra, takie jak GNU Hurd).
afe8504a 192
6b0aefbf
JR
193%description -l pt_BR.UTF-8
194Esse é o GRUB - Grand Unified Boot Loader - um gerenciador de boot
afe8504a
SP
195capaz de entrar na maioria dos sistemas operacionais livres - Linux,
196FreeBSD, NetBSD, GNU Mach, etc. assim como na maioria dos sistemas
197operacionais comerciais para PC.
198
6b0aefbf
JR
199O GRUB pode ser uma boa alternativa ao LILO, para usuários mais
200avançados e que querem mais recursos de seu boot loader.
afe8504a 201
565fe2e3
ER
202%package -n bash-completion-%{name}
203Summary: bash-completion for GRUB
204Summary(pl.UTF-8): bashowe uzupełnianie nazw dla GRUB
205Group: Applications/Shells
206Requires: bash-completion
207
208%description -n bash-completion-%{name}
209This package provides bash-completion for GRUB.
210
211%description -n bash-completion-%{name} -l pl.UTF-8
212Pakiet ten dostarcza bashowe uzupełnianie nazw dla GRUB.
213
1536aaf2 214%package pc
62081337
ER
215Summary: PC BIOS platform support for GRUB
216Group: Base
217Requires: %{name} = %{version}-%{release}
1536aaf2
JK
218
219%description pc
62081337 220PC BIOS platform support for GRUB.
1536aaf2
JK
221
222%package efi
223Summary: (U)EFI platform support for GRUB
224Group: Base
225Requires: %{name} = %{version}-%{release}
226
227%description efi
228(U)EFI platform support for GRUB.
229
7615a862
JK
230%package mkfont
231Summary: GRUB font files converter
232Group: Base
233
234%description mkfont
235Converts common font file formats into PF2.
236
8ac8605d
JK
237%package theme-starfield
238Summary: starfield theme for GRUB
239Group: Base
240
241%description theme-starfield
242starfield theme for GRUB.
243
afe8504a 244%prep
f951fcbe 245%setup -q -n grub-%{version}
5028d8c9 246%patch0 -p1
b46589aa 247%patch1 -p1
872700b0 248%patch2 -p1
f951fcbe 249%patch3 -p1
aec70abd 250%patch4 -p1
f7ae30d0 251%patch5 -p1
e2964b87 252%patch6 -p1
449dde54 253%patch7 -p1
61d105fa 254%patch8 -p1
4c7bb96e 255%patch9 -p1
26996aed 256%patch10 -p1
55de8afc 257%patch11 -p1
afe8504a 258
71c933c0 259%if "%{cc_version}" < "3.4"
dea0c850
ER
260grep -rl -- -Wno-missing-field-initializers . | xargs %{__sed} -i -e 's,-Wno-missing-field-initializers,,'
261%{__sed} -i -e '/video_mod_CFLAGS/s/$/ -Wno-error/' conf/common.rmk
71c933c0
ER
262%endif
263
afe8504a 264%build
928eb9c1
AM
265# if gold is used then grub doesn't even boot
266install -d our-ld
267ln -s /usr/bin/ld.bfd our-ld/ld
268export PATH=$(pwd)/our-ld:$PATH
269
3ff87e8a 270cp -f /usr/share/automake/config.sub .
afe8504a 271%{__libtoolize}
e9d73181 272%{__aclocal} -I m4
afe8504a 273%{__autoheader}
b1a4846d 274echo timestamp > stamp-h.in
afe8504a 275%{__autoconf}
53c50f89 276export CFLAGS="%{rpmcflags} -Os %{?debug:-g}"
12fd19f5 277
1536aaf2 278for platform in %{platforms} ; do
fc490c3e
JK
279 install -d build-${platform}
280 cd build-${platform}
0e2cbb94
JK
281
282 if [ "$platform" != "efi" ] ; then
283 platform_opts="--%{!?with_efiemu:dis}%{?with_efiemu:en}able-efiemu"
284 else
285 platform_opts=""
286 fi
287
1536aaf2
JK
288 ln -s ../configure .
289 # mawk stalls at ./genmoddep.awk, so force gawk
290 AWK=gawk \
291 %configure \
292 --with-platform=${platform} \
293 --disable-werror \
294 %if %{with grubemu}
295 --enable-grub-emu-usb \
296 --enable-grub-emu-sdl \
297 --enable-grub-emu-pci \
298 %endif
0e2cbb94 299 $platform_opts \
1536aaf2
JK
300 TARGET_LDFLAGS=-static
301
302 %{__make}
303 cd ..
304done
0fb8b1a5 305
afe8504a
SP
306%install
307rm -rf $RPM_BUILD_ROOT
afe8504a 308
1536aaf2 309for platform in %{platforms} ; do
fc490c3e 310 cd build-${platform}
1536aaf2
JK
311 %{__make} install \
312 pkgdatadir=%{_libexecdir} \
313 pkglibdir=%{_libexecdir} \
314 DESTDIR=$RPM_BUILD_ROOT
315 cd ..
316done
afe8504a 317
7615a862
JK
318# not in Th (?)
319%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/de@hebrew
320%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/en@{arabic,cyrillic,greek,hebrew,piglatin}
321
f951fcbe
AM
322%find_lang grub
323
bcd6a47e
ER
324# this must be after 'make install'
325install -d $RPM_BUILD_ROOT%{_libexecdir}/locale
326
1536aaf2
JK
327install -d $RPM_BUILD_ROOT%{_grubdir}
328cp -p docs/grub.cfg $RPM_BUILD_ROOT%{_grubdir}
329
7b6caae9 330# grub.d/41_custom
1536aaf2 331cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_grubdir}/custom.cfg
7b6caae9
ER
332%{__rm} $RPM_BUILD_ROOT/lib/grub.d/40_custom
333
22909ca1 334install -p %{SOURCE1} $RPM_BUILD_ROOT%{_sbindir}/update-grub
7b6caae9
ER
335cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_mandir}/man8/update-grub.8
336
337install -d $RPM_BUILD_ROOT/etc/sysconfig
338cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/grub
339
340# rm -f, because it sometimes exists, sometimes not, depending which texlive you have installed
47069130 341rm -f $RPM_BUILD_ROOT%{_infodir}/dir
e2964b87 342
cbd79801 343# core.img - bootable image generated by grub-mkimage(1) via grub-install(1)
1536aaf2
JK
344touch $RPM_BUILD_ROOT%{_grubdir}/core.img
345touch $RPM_BUILD_ROOT%{_grubdir}/device.map
cbd79801 346
8b5c394b
ER
347# needs to be exactly 1KiB
348# but we're ghosting it. so whom are we kidding here? :P (maybe %config it in future?)
1536aaf2 349dd bs=1024 if=/dev/zero count=1 of=$RPM_BUILD_ROOT%{_grubdir}/grubenv
8b5c394b 350
afe8504a
SP
351%clean
352rm -rf $RPM_BUILD_ROOT
353
5028d8c9 354%post -p %{_sbindir}/postshell
fc58858a 355-/usr/sbin/fix-info-dir -c %{_infodir}
f4604ef8 356
5028d8c9 357%postun -p %{_sbindir}/postshell
fc58858a 358-/usr/sbin/fix-info-dir -c %{_infodir}
f4604ef8 359
92904505 360%triggerpostun -- %{name} < %{version}-0
a7bef3b9 361# Note this trigger on version upgrade
92904505
ER
362# don't do anything on --downgrade
363if [ $1 -le 1 ]; then
364 exit 0
365fi
366echo "Grub was upgraded, trying to setup it to boot sector"
367/sbin/grub-install '(hd0)' || :
368
7b6caae9
ER
369%triggerpostun -- %{name} < 1.99-7.3
370# migrate /etc/grub.d/custom.cfg.rpmsave -> /boot/grub/custom.cfg
371if [ -f %{_sysconfdir}/grub.d/custom.cfg.rpmsave ]; then
1536aaf2
JK
372 cp -f %{_grubdir}/custom.cfg{,.rpmnew}
373 mv -f %{_sysconfdir}/grub.d/custom.cfg.rpmsave %{_grubdir}/custom.cfg
7b6caae9
ER
374fi
375
f951fcbe 376%files -f grub.lang
afe8504a 377%defattr(644,root,root,755)
2e4bec6f 378%doc AUTHORS ChangeLog NEWS README THANKS TODO
aec70abd 379%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/grub
7615a862 380%attr(755,root,root) %{_sbindir}/grub-bios-setup
71c933c0 381%attr(755,root,root) %{_sbindir}/grub-editenv
3ea0c40e 382%attr(755,root,root) %{_sbindir}/grub-fstest
e9d73181 383%attr(755,root,root) %{_sbindir}/grub-kbdcomp
fc835b5e 384%attr(755,root,root) %{_sbindir}/grub-install
e9d73181 385%attr(755,root,root) %{_sbindir}/grub-menulst2cfg
fc835b5e 386%attr(755,root,root) %{_sbindir}/grub-mkconfig
e9d73181
AM
387%attr(755,root,root) %{_sbindir}/grub-mklayout
388%attr(755,root,root) %{_sbindir}/grub-mknetdir
71c933c0
ER
389%attr(755,root,root) %{_sbindir}/grub-mkpasswd-pbkdf2
390%attr(755,root,root) %{_sbindir}/grub-mkrelpath
391%attr(755,root,root) %{_sbindir}/grub-mkrescue
7615a862
JK
392%attr(755,root,root) %{_sbindir}/grub-mkstandalone
393%attr(755,root,root) %{_sbindir}/grub-mount
394%attr(755,root,root) %{_sbindir}/grub-ofpathname
71c933c0
ER
395%attr(755,root,root) %{_sbindir}/grub-reboot
396%attr(755,root,root) %{_sbindir}/grub-script-check
397%attr(755,root,root) %{_sbindir}/grub-set-default
22909ca1 398%attr(755,root,root) %{_sbindir}/update-grub
76be4c4a
AM
399%ifarch %{ix86} %{x8664}
400%attr(755,root,root) %{_sbindir}/grub-mkimage
fc835b5e 401%{_mandir}/man1/grub-mkimage.1*
76be4c4a
AM
402%else
403%attr(755,root,root) %{_sbindir}/grub-probe
76be4c4a 404%{_mandir}/man8/grub-probe.8*
76be4c4a 405%endif
71c933c0 406%{_mandir}/man1/grub-editenv.1*
3ea0c40e 407%{_mandir}/man1/grub-fstest.1*
7615a862 408%{_mandir}/man1/grub-kbdcomp.1*
e9d73181 409%{_mandir}/man1/grub-menulst2cfg.1*
e9d73181 410%{_mandir}/man1/grub-mklayout.1*
71c933c0 411%{_mandir}/man1/grub-mkpasswd-pbkdf2.1*
03b9d04b 412%{_mandir}/man1/grub-mkrelpath.1*
71c933c0 413%{_mandir}/man1/grub-mkrescue.1*
7615a862
JK
414%{_mandir}/man1/grub-mkstandalone.1*
415%{_mandir}/man1/grub-mount.1*
71c933c0 416%{_mandir}/man1/grub-script-check.1*
7615a862 417%{_mandir}/man8/grub-bios-setup.8*
71c933c0 418%{_mandir}/man8/grub-install.8*
fc835b5e 419%{_mandir}/man8/grub-mkconfig.8*
e9d73181 420%{_mandir}/man8/grub-mknetdir.8*
7615a862 421%{_mandir}/man8/grub-ofpathname.8*
71c933c0
ER
422%{_mandir}/man8/grub-reboot.8*
423%{_mandir}/man8/grub-set-default.8*
22909ca1 424%{_mandir}/man8/update-grub.8*
797addca 425%if %{with grubemu}
8fcee4aa
ER
426%attr(755,root,root) %{_sbindir}/grub-emu
427%{_mandir}/man8/grub-emu.8*
797addca 428%endif
e6fbd304 429%{_libexecdir}/grub-mkconfig_lib
aec70abd 430
1536aaf2 431%dir %{_grubdir}
26e757db 432%dir %{_libexecdir}
bcd6a47e 433# XXX: check this locale dir location and if it is neccesaary to exist on /boot
565fe2e3 434
bcd6a47e 435%dir %{_libexecdir}/locale
1536aaf2
JK
436%config(noreplace) %verify(not md5 mtime size) %{_grubdir}/grub.cfg
437%config(noreplace) %verify(not md5 mtime size) %{_grubdir}/custom.cfg
aec70abd 438
cbd79801 439# generated by grub at runtime
1536aaf2
JK
440%ghost %{_grubdir}/device.map
441%ghost %{_grubdir}/core.img
442%ghost %{_grubdir}/grubenv
cbd79801 443
e2964b87
ER
444%dir /lib/grub.d
445%doc /lib/grub.d/README
446%attr(755,root,root) /lib/grub.d/00_header
447%attr(755,root,root) /lib/grub.d/10_linux
e9d73181 448%attr(755,root,root) /lib/grub.d/20_linux_xen
e2964b87 449%attr(755,root,root) /lib/grub.d/30_os-prober
e9d73181 450%attr(755,root,root) /lib/grub.d/41_custom
e2964b87 451
1e58ef6c 452%ifarch %{ix86} %{x8664}
1ffaf1f6 453%attr(755,root,root) %{_sbindir}/grub-probe
fc835b5e 454%{_mandir}/man8/grub-probe.8*
4a00f3b7 455%endif
aec70abd 456
f4604ef8 457%{_infodir}/grub*.info*
565fe2e3 458
8ac8605d
JK
459%dir %{_datadir}/grub/themes
460
1536aaf2
JK
461%if %{with pc}
462%files pc
463%defattr(644,root,root,755)
464%dir %{_libexecdir}/*-pc
465%{_libexecdir}/*-pc/modinfo.sh
466%{_libexecdir}/*-pc/*.exec
467%{_libexecdir}/*-pc/*.image
468%{_libexecdir}/*-pc/*.lst
469%{_libexecdir}/*-pc/*.mod
470%{_libexecdir}/*-pc/*.module
471%{_libexecdir}/*-pc/lzma_decompress.img
472%{_libexecdir}/*-pc/config.h
473%{_libexecdir}/*-pc/gdb_grub
474%{_libexecdir}/*-pc/gmodule.pl
475%if %{with efiemu}
476%ifarch %{x8664}
477%{_libexecdir}/*-pc/efiemu*.o
478%endif
479%endif
480%{_libexecdir}/*-pc/kernel.img
481%ifarch %{ix86} %{x8664} sparc sparc64
482%{_libexecdir}/*-pc/boot.img
483%{_libexecdir}/*-pc/cdboot.img
484%{_libexecdir}/*-pc/diskboot.img
485%{_libexecdir}/*-pc/lnxboot.img
486%{_libexecdir}/*-pc/pxeboot.img
487%endif
488%endif
489
490%if %{with efi}
491%files efi
492%defattr(644,root,root,755)
493%dir %{_libexecdir}/*-efi
494%{_libexecdir}/*-efi/modinfo.sh
495%{_libexecdir}/*-efi/*.exec
496%{_libexecdir}/*-efi/*.lst
497%{_libexecdir}/*-efi/*.mod
498%{_libexecdir}/*-efi/*.module
499%{_libexecdir}/*-efi/config.h
500%{_libexecdir}/*-efi/gdb_grub
501%{_libexecdir}/*-efi/gmodule.pl
1536aaf2
JK
502%{_libexecdir}/*-efi/kernel.img
503%endif
504
7615a862
JK
505%files mkfont
506%defattr(644,root,root,755)
507%{_mandir}/man1/grub-mkfont.1*
508%attr(755,root,root) %{_sbindir}/grub-mkfont
509
8ac8605d
JK
510%files theme-starfield
511%defattr(644,root,root,755)
512%{_datadir}/grub/themes/starfield
513
565fe2e3
ER
514%files -n bash-completion-%{name}
515%defattr(644,root,root,755)
516/etc/bash_completion.d/grub
This page took 0.310717 seconds and 4 git commands to generate.