]> git.pld-linux.org Git - packages/grantlee-qt5.git/blame - grantlee-qt5.spec
rebuild with separate debuginfo build-ids
[packages/grantlee-qt5.git] / grantlee-qt5.spec
CommitLineData
c50b6f90
BS
1
2%bcond_without tests # unit tests
3
3f7d5483 4%define qt_ver 5.3.0
c50b6f90 5%define major_ver 5.2
c24ff63c
JB
6
7Summary: Grantlee - set of frameworks for use with Qt 5
8Summary(pl.UTF-8): Grantlee - zbiór szkieletów do wykorzystania z Qt 5
9Name: grantlee-qt5
c50b6f90 10Version: 5.2.0
0dada3b2 11Release: 2
92f3aa95
JB
12License: LGPL v2.1+
13Group: Libraries
c24ff63c 14Source0: http://downloads.grantlee.org/grantlee-%{version}.tar.gz
c50b6f90 15# Source0-md5: 6239b3703674f88b2236d30d0ed67eea
3f7d5483 16URL: http://www.grantlee.org/
c24ff63c
JB
17BuildRequires: Qt5Core-devel >= %{qt_ver}
18BuildRequires: Qt5Gui-devel >= %{qt_ver}
19BuildRequires: Qt5Network-devel >= %{qt_ver}
20BuildRequires: Qt5Script-devel >= %{qt_ver}
21BuildRequires: Qt5Sql-devel >= %{qt_ver}
22BuildRequires: Qt5Test-devel >= %{qt_ver}
23BuildRequires: Qt5WebKit-devel >= %{qt_ver}
24BuildRequires: Qt5Widgets-devel >= %{qt_ver}
25BuildRequires: Qt5XmlPatterns-devel >= %{qt_ver}
c50b6f90 26BuildRequires: cmake >= 3.5
c24ff63c
JB
27BuildRequires: qt5-build >= %{qt_ver}
28BuildRequires: qt5-qmake >= %{qt_ver}
29BuildRequires: qt5-linguist >= %{qt_ver}
92f3aa95 30BuildRequires: rpmbuild(macros) >= 1.605
c24ff63c
JB
31Requires: Qt5Core >= %{qt_ver}
32Requires: Qt5Gui >= %{qt_ver}
33Requires: Qt5Script >= %{qt_ver}
6c46a9eb 34BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36%description
37Grantlee is a string template engine based on the Django template
92f3aa95 38system and written using Qt.
6c46a9eb 39
92f3aa95
JB
40%description -l pl.UTF-8
41Grantlee to silnik szablonów oparty na systemie szablonów Django i
42napisany przy użyciu Qt.
6c46a9eb 43
44%package devel
92f3aa95
JB
45Summary: Header files for grantlee libraries
46Summary(pl.UTF-8): Pliki nagłówkowe bibliotek grantlee
6c46a9eb 47Group: Development/Libraries
48Requires: %{name} = %{version}-%{release}
c24ff63c
JB
49Requires: Qt5Core-devel >= %{qt_ver}
50# only textdocument library
51Requires: Qt5Gui-devel >= %{qt_ver}
52Conflicts: grantlee-devel
6c46a9eb 53
54%description devel
92f3aa95 55Header files for grantlee libraries.
6c46a9eb 56
57%description devel -l pl.UTF-8
92f3aa95 58Pliki nagłówkowe bibliotek grantlee.
6c46a9eb 59
60%prep
c24ff63c 61%setup -q -n grantlee-%{version}
6c46a9eb 62
63%build
64install -d build
65cd build
92f3aa95 66%cmake ..
6c46a9eb 67
68%{__make}
69
c50b6f90
BS
70%if %{with tests}
71QT_QPA_PLATFORM=offscreen \
72%{__make} test ARGS=-V
73%endif
74
6c46a9eb 75%install
76rm -rf $RPM_BUILD_ROOT
77
78%{__make} -C build install \
79 DESTDIR=$RPM_BUILD_ROOT
80
81%clean
82rm -rf $RPM_BUILD_ROOT
83
92f3aa95
JB
84%post -p /sbin/ldconfig
85%postun -p /sbin/ldconfig
6c46a9eb 86
87%files
88%defattr(644,root,root,755)
3f338a11 89%doc AUTHORS CHANGELOG README.md
c24ff63c
JB
90%attr(755,root,root) %{_libdir}/libGrantlee_Templates.so.*.*.*
91%attr(755,root,root) %ghost %{_libdir}/libGrantlee_Templates.so.5
92%attr(755,root,root) %{_libdir}/libGrantlee_TextDocument.so.*.*.*
93%attr(755,root,root) %ghost %{_libdir}/libGrantlee_TextDocument.so.5
92f3aa95 94%dir %{_libdir}/grantlee
077b68f9
BS
95%dir %{_libdir}/grantlee/%{major_ver}
96%attr(755,root,root) %{_libdir}/grantlee/%{major_ver}/grantlee_defaultfilters.so
97%attr(755,root,root) %{_libdir}/grantlee/%{major_ver}/grantlee_defaulttags.so
98%attr(755,root,root) %{_libdir}/grantlee/%{major_ver}/grantlee_i18ntags.so
99%attr(755,root,root) %{_libdir}/grantlee/%{major_ver}/grantlee_loadertags.so
6c46a9eb 100
101%files devel
102%defattr(644,root,root,755)
c24ff63c
JB
103%attr(755,root,root) %{_libdir}/libGrantlee_Templates.so
104%attr(755,root,root) %{_libdir}/libGrantlee_TextDocument.so
92f3aa95 105%{_includedir}/grantlee_templates.h
077b68f9 106%{_includedir}/grantlee_textdocument.h
92f3aa95 107%{_includedir}/grantlee
c24ff63c 108%{_libdir}/cmake/Grantlee5
This page took 0.114453 seconds and 4 git commands to generate.