]> git.pld-linux.org Git - packages/gr-osmosdr.git/blame - gr-osmosdr.spec
- updated files
[packages/gr-osmosdr.git] / gr-osmosdr.spec
CommitLineData
e5cb1905
AM
1%define snap 20140111
2Summary: Common software API for various radio hardware
3Name: gr-osmosdr
4Version: 0.1.1
5Release: 0.%{snap}.1
6License: GPL v3+
7Group: Applications/Engineering
8URL: http://sdr.osmocom.org/trac/wiki/GrOsmoSDR
9Source0: %{name}-%{snap}.tar.bz2
10# Source0-md5: 15fbc7e472ee40669c083c1715c7bc58
11BuildRequires: boost-devel
12BuildRequires: cmake
13BuildRequires: doxygen
e5d3419e 14BuildRequires: gnuradio-devel >= 3.7
e5cb1905
AM
15BuildRequires: graphviz
16BuildRequires: python-devel
17BuildRequires: rtl-sdr-devel
18BuildRequires: swig
19BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21%description
22Primarily gr-osmosdr supports the OsmoSDR hardware, but it also offers
23a wrapper functionality for FunCube Dongle, Ettus UHD and rtl-sdr
24radios. By using gr-osmosdr source you can take advantage of a common
25software api in your application(s) independent of the underlying
26radio hardware.
27
28%package devel
29Summary: Development files for gr-osmosdr
30Group: Applications/Engineering
31Requires: %{name} = %{version}-%{release}
32
33%description devel
34Development files for gr-osmosdr.
35
36%prep
37%setup -q -n %{name}
38
39%build
40install -d build
41cd build
42%cmake \
43 -DENABLE_DOXYGEN=on \
44 -DGR_PKG_DOC_DIR=%{_docdir}/%{name} \
45 ..
46
47%{__make}
48
49%install
50rm -rf $RPM_BUILD_ROOT
51
52%{__make} -C build install \
53 DESTDIR=$RPM_BUILD_ROOT
54
e5d3419e
AM
55rm -rf doc-inst
56mv $RPM_BUILD_ROOT%{_docdir}/%{name} doc-inst
57
e5cb1905
AM
58%clean
59rm -rf $RPM_BUILD_ROOT
60
61%post -p /sbin/ldconfig
62%postun -p /sbin/ldconfig
63
64%files
65%defattr(644,root,root,755)
e5d3419e
AM
66%doc AUTHORS COPYING doc-inst/*
67%attr(755,root,root) %{_bindir}/osmocom_fft
68%attr(755,root,root) %{_bindir}/osmocom_siggen
69%attr(755,root,root) %{_bindir}/osmocom_siggen_nogui
70%attr(755,root,root) %{_bindir}/osmocom_spectrum_sense
71%attr(755,root,root) %{_libdir}/libgnuradio-osmosdr-*.so.*.*
72%attr(755,root,root) %ghost %{_libdir}/libgnuradio-osmosdr-*.so.0
73%dir %{py_sitedir}/osmosdr
74%attr(755,root,root) %{py_sitedir}/osmosdr/*.so
75%{py_sitedir}/osmosdr/*.py*
76%{_datadir}/gnuradio/grc/blocks/osmosdr_sink.xml
77%{_datadir}/gnuradio/grc/blocks/osmosdr_source.xml
78%{_datadir}/gnuradio/grc/blocks/rtlsdr_source.xml
e5cb1905
AM
79
80%files devel
81%defattr(644,root,root,755)
82%{_includedir}/osmosdr
e5d3419e
AM
83%attr(755,root,root) %{_libdir}/libgnuradio-osmosdr.so
84%attr(755,root,root) %{_libdir}/libgnuradio-osmosdr-*.so
85%{_pkgconfigdir}/gnuradio-osmosdr.pc
This page took 0.066088 seconds and 4 git commands to generate.