]> git.pld-linux.org Git - packages/gperftools.git/blame - gperftools.spec
Update to 2.0 and rename to gperftools
[packages/gperftools.git] / gperftools.spec
CommitLineData
9c42e86e
JB
1# NOTE: shared /%{_lib}/libtcmalloc* is useless without /usr/%{_lib}/libstdc++.so.6
2#
3ec036a2 3Summary: Fast, multi-threaded malloc and performance analysis tools
9c42e86e 4Summary(pl.UTF-8): Szybka, wielowątkowa implementacja malloc i narzędzia do analizy wydajności
717c9fde
MB
5Name: gperftools
6Version: 2.0
d576bc99 7Release: 1
3ec036a2
ŁK
8License: BSD
9Group: Libraries
717c9fde 10# Source0Download: http://code.google.com/p/gperftools/downloads/list
c3be83d6 11Source0: http://gperftools.googlecode.com/files/%{name}-%{version}.tar.gz
717c9fde
MB
12# Source0-md5: 13f6e8961bc6a26749783137995786b6
13Patch0: %{name}-glibc216-siginfo_t.patch
14URL: http://code.google.com/p/gperftools/
9c42e86e 15BuildRequires: libstdc++-devel
3ec036a2 16BuildRequires: libtool
9c42e86e 17%ifarch %{x8664} ia64
7c48e001 18BuildRequires: libunwind-devel >= 0.98.6
3ec036a2 19%endif
9c42e86e 20Requires: libtcmalloc = %{version}-%{release}
717c9fde 21Obsoletes: google-perftools < 2.0
3ec036a2
ŁK
22BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24%description
7c48e001
ER
25Perf Tools is a collection of performance analysis tools, including a
26high-performance multi-threaded malloc() implementation that works
27particularly well with threads and STL, a thread-friendly
28heap-checker, a heap profiler, and a cpu-profiler.
3ec036a2 29
9c42e86e
JB
30%description -l pl.UTF-8
31Perf Tools to zbiór narzędzi do analizy wydajności, zawierający także
32bardzo wydajną, wielowątkową implementację malloc(), działającą dobrze
33w szczególności z wątkami i STL-em, a także przyjazne wątkom narzędzie
34do kontroli sterty, profilter sterty oraz profile wykorzystania CPU.
35
3ec036a2 36%package devel
9c42e86e
JB
37Summary: Development files of perftools libraries
38Summary(pl.UTF-8): Pliki programistyczne bibliotek perftools
3ec036a2
ŁK
39Group: Development/Libraries
40Requires: %{name} = %{version}-%{release}
9c42e86e 41Requires: libtcmalloc-devel = %{version}-%{release}
717c9fde 42Obsoletes: google-perftools-devel < 2.0
3ec036a2
ŁK
43
44%description devel
9c42e86e
JB
45The google-perftools-devel package contains the header files needed to
46develop applications with google-perftools libraries.
47
48%description devel -l pl.UTF-8
49Ten pakiet zawiera pliki nagłówkowe niezbędne do tworzenia aplikacji z
50użyciem bibliotek google-perftools.
3ec036a2
ŁK
51
52%package static
9c42e86e
JB
53Summary: Static perftools libraries
54Summary(pl.UTF-8): Statyczne biblioteki perftools
3ec036a2
ŁK
55Group: Development/Libraries
56Requires: %{name}-devel = %{version}-%{release}
717c9fde 57Obsoletes: google-perftools-static < 2.0
3ec036a2
ŁK
58
59%description static
60The google-perftools-static package contains the static libraries of
61google-perftools.
62
9c42e86e
JB
63%description static -l pl.UTF-8
64Ten pakiet zawiera biblioteki statyczne google-perftools.
65
66%package -n libtcmalloc
67Summary: Fast, multi-threaded malloc by Google
68Summary(pl.UTF-8): Szybka, wielowątkowa implementacja malloc firmy Google
69Group: Libraries
70Conflicts: google-perftools < 1.8.3-3
71
72%description -n libtcmalloc
73Fast, multi-threaded malloc by Google.
74
75%description -n libtcmalloc -l pl.UTF-8
76Szybka, wielowątkowa implementacja malloc firmy Google.
77
78%package -n libtcmalloc-devel
79Summary: Fast, multi-threaded malloc by Google - header files
80Summary(pl.UTF-8): Szybka, wielowątkowa implementacja malloc firmy Google - pliki nagłówkowe
81Group: Development/Libraries
9c42e86e 82Requires: libstdc++-devel
c3be83d6 83Requires: libtcmalloc = %{version}-%{release}
9c42e86e
JB
84
85%description -n libtcmalloc-devel
86Fast, multi-threaded malloc by Google - header files.
87
88%description -n libtcmalloc-devel -l pl.UTF-8
89Szybka, wielowątkowa implementacja malloc firmy Google - pliki
90nagłówkowe.
91
92%package -n libtcmalloc-static
93Summary: Fast, multi-threaded malloc by Google - static libraries
94Summary(pl.UTF-8): Szybka, wielowątkowa implementacja malloc firmy Google - biblioteki statyczne
95Group: Development/Libraries
96Requires: libtcmalloc-devel = %{version}-%{release}
97
98%description -n libtcmalloc-static
99Fast, multi-threaded malloc by Google - static libraries.
100
101%description -n libtcmalloc-static -l pl.UTF-8
102Szybka, wielowątkowa implementacja malloc firmy Google - biblioteki
103statyczne.
104
3ec036a2
ŁK
105%prep
106%setup -q
717c9fde 107%patch0 -p1
3ec036a2
ŁK
108
109%build
9c42e86e
JB
110%configure \
111%ifnarch %{x8664} ia64
112 ac_cv_lib_unwind_backtrace=no
113%endif
114
3ec036a2
ŁK
115%{__make}
116
117%install
118rm -rf $RPM_BUILD_ROOT
9b04b22a
AM
119install -d $RPM_BUILD_ROOT/%{_lib}
120
3ec036a2
ŁK
121%{__make} install \
122 DESTDIR=$RPM_BUILD_ROOT
123
9b04b22a
AM
124for pkg in libtcmalloc libtcmalloc_minimal; do
125 mv $RPM_BUILD_ROOT%{_libdir}/${pkg}.so.* \
126 $RPM_BUILD_ROOT/%{_lib}
127 ln -snf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/${pkg}.so.*.*.*) \
128 $RPM_BUILD_ROOT/%{_libdir}/${pkg}.so
129done
130
717c9fde
MB
131# clean docdir
132%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/doc/%{name}-%{version}
133
3ec036a2
ŁK
134%clean
135rm -rf $RPM_BUILD_ROOT
136
9c42e86e
JB
137%post -p /sbin/ldconfig
138%postun -p /sbin/ldconfig
139
140%post -n libtcmalloc -p /sbin/ldconfig
141%postun -n libtcmalloc -p /sbin/ldconfig
3ec036a2
ŁK
142
143%files
144%defattr(644,root,root,755)
9c42e86e
JB
145# note: INSTALL contains many perftools-specific notes
146%doc AUTHORS COPYING ChangeLog INSTALL NEWS README TODO doc/*{html,png,gif,txt}
7c48e001 147%attr(755,root,root) %{_bindir}/pprof
7c48e001 148%attr(755,root,root) %{_libdir}/libprofiler.so.*.*.*
9c42e86e 149%attr(755,root,root) %ghost %{_libdir}/libprofiler.so.0
7c48e001 150%attr(755,root,root) %{_libdir}/libtcmalloc_and_profiler.so.*.*.*
c3be83d6 151%attr(755,root,root) %ghost %{_libdir}/libtcmalloc_and_profiler.so.4
7c48e001 152%attr(755,root,root) %{_libdir}/libtcmalloc_debug.so.*.*.*
c3be83d6 153%attr(755,root,root) %ghost %{_libdir}/libtcmalloc_debug.so.4
7c48e001 154%attr(755,root,root) %{_libdir}/libtcmalloc_minimal_debug.so.*.*.*
c3be83d6 155%attr(755,root,root) %ghost %{_libdir}/libtcmalloc_minimal_debug.so.4
7c48e001 156%{_mandir}/man1/pprof.1*
3ec036a2
ŁK
157
158%files devel
159%defattr(644,root,root,755)
9c42e86e
JB
160%attr(755,root,root) %{_libdir}/libtcmalloc_and_profiler.so
161%attr(755,root,root) %{_libdir}/libtcmalloc_debug.so
162%attr(755,root,root) %{_libdir}/libtcmalloc_minimal_debug.so
163%attr(755,root,root) %{_libdir}/libprofiler.so
7c48e001
ER
164%{_libdir}/libtcmalloc_and_profiler.la
165%{_libdir}/libtcmalloc_debug.la
7c48e001 166%{_libdir}/libtcmalloc_minimal_debug.la
9c42e86e
JB
167%{_libdir}/libprofiler.la
168%{_includedir}/google/profiler.h
717c9fde 169%{_includedir}/gperftools/profiler.h
7c48e001 170%{_pkgconfigdir}/libprofiler.pc
7c48e001 171%{_pkgconfigdir}/libtcmalloc_debug.pc
7c48e001 172%{_pkgconfigdir}/libtcmalloc_minimal_debug.pc
3ec036a2
ŁK
173
174%files static
175%defattr(644,root,root,755)
7c48e001 176%{_libdir}/libprofiler.a
7c48e001
ER
177%{_libdir}/libtcmalloc_and_profiler.a
178%{_libdir}/libtcmalloc_debug.a
7c48e001 179%{_libdir}/libtcmalloc_minimal_debug.a
9c42e86e
JB
180
181%files -n libtcmalloc
182%defattr(644,root,root,755)
183%attr(755,root,root) /%{_lib}/libtcmalloc.so.*.*.*
c3be83d6 184%attr(755,root,root) %ghost /%{_lib}/libtcmalloc.so.4
9c42e86e 185%attr(755,root,root) /%{_lib}/libtcmalloc_minimal.so.*.*.*
c3be83d6 186%attr(755,root,root) %ghost /%{_lib}/libtcmalloc_minimal.so.4
9c42e86e
JB
187
188%files -n libtcmalloc-devel
189%defattr(644,root,root,755)
190%attr(755,root,root) %{_libdir}/libtcmalloc.so
191%attr(755,root,root) %{_libdir}/libtcmalloc_minimal.so
192%{_libdir}/libtcmalloc.la
193%{_libdir}/libtcmalloc_minimal.la
194%dir %{_includedir}/google
195%{_includedir}/google/heap-*.h
196%{_includedir}/google/malloc_extension*.h
197%{_includedir}/google/malloc_hook*.h
198%{_includedir}/google/stacktrace.h
199%{_includedir}/google/tcmalloc.h
717c9fde
MB
200%dir %{_includedir}/gperftools
201%{_includedir}/gperftools/heap-*.h
202%{_includedir}/gperftools/malloc_extension*.h
203%{_includedir}/gperftools/malloc_hook*.h
204%{_includedir}/gperftools/stacktrace.h
205%{_includedir}/gperftools/tcmalloc.h
9c42e86e
JB
206%{_pkgconfigdir}/libtcmalloc.pc
207%{_pkgconfigdir}/libtcmalloc_minimal.pc
208
209%files -n libtcmalloc-static
210%defattr(644,root,root,755)
211%{_libdir}/libtcmalloc.a
212%{_libdir}/libtcmalloc_minimal.a
This page took 0.067639 seconds and 4 git commands to generate.