]> git.pld-linux.org Git - packages/gnustep-gui.git/blame - gnustep-gui.spec
- release 15 (by relup.sh)
[packages/gnustep-gui.git] / gnustep-gui.spec
CommitLineData
5717de99
JB
1#
2# Conditional build:
3%bcond_without cups # GSCUPS bundle
58075a32 4%bcond_without magick # ImageMagick support
5717de99
JB
5%bcond_without portaudio # gsnd tool
6#
829d10ca 7Summary: GNUstep GUI library package
fb1f7b25 8Summary(pl.UTF-8): Biblioteka GNUstep GUI
829d10ca 9Name: gnustep-gui
b4d1c253
JB
10%define ver 0.24
11Version: %{ver}.0
f742cdc0 12Release: 15
58075a32 13License: LGPL v2+ (library), GPL v3+ (applications)
4b35d086 14Group: Libraries
829d10ca 15Source0: ftp://ftp.gnustep.org/pub/gnustep/core/%{name}-%{version}.tar.gz
b4d1c253 16# Source0-md5: bd289f0c7b2626d093ad92364069b9a7
58075a32
JB
17Patch0: %{name}-nocompressdocs.patch
18Patch1: %{name}-doc.patch
b4d1c253 19Patch2: %{name}-giflib.patch
319a56d2 20Patch3: imagemagick7.patch
aa92dd8e 21URL: http://www.gnustep.org/
58075a32 22%{?with_magick:BuildRequires: ImageMagick-devel}
c3847b61 23BuildRequires: aspell-devel
5717de99 24%{?with_cups:BuildRequires: cups-devel}
58075a32 25BuildRequires: flite-devel
f6967d0c 26BuildRequires: gcc-objc
5717de99
JB
27BuildRequires: giflib-devel
28BuildRequires: gnustep-base-devel >= 1.13.0
58075a32
JB
29BuildRequires: gnustep-make-devel
30BuildRequires: libao-devel
b4d1c253 31BuildRequires: libicns-devel
58075a32 32BuildRequires: libicu-devel >= 4.0
f6967d0c 33BuildRequires: libjpeg-devel
5717de99 34BuildRequires: libpng-devel
58075a32 35BuildRequires: libsndfile-devel
f6967d0c 36BuildRequires: libtiff-devel
58075a32 37BuildRequires: pkgconfig
5717de99 38%{?with_portaudio:BuildRequires: portaudio-devel >= 19}
f6967d0c 39BuildRequires: zlib-devel
5717de99 40Requires: gnustep-base >= 1.13.0
f6967d0c
JB
41Conflicts: gnustep-core
42BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
aa92dd8e 44%description
829d10ca 45It is a library of graphical user interface classes written completely
46in the Objective-C language; the classes are based upon the OpenStep
47specification as release by NeXT Software, Inc. The library does not
48completely conform to the specification and has been enhanced in a
49number of ways to take advantage of the GNU system. These classes
aa92dd8e 50include graphical objects such as buttons, text fields, popup lists,
51browser lists, and windows; there are also many associated classes for
52handling events, colors, fonts, pasteboards and images.
53
c261d120
JR
54%description -l pl.UTF-8
55To jest biblioteka klas graficznego interfejsu użytkownika napisana w
56Objective-C. Klasy bazują na specyfikacji OpenStep wypuszczonej przez
57NeXT Software. Biblioteka nie jest całkowicie zgodna ze specyfikacją i
58została rozszerzona, aby wykorzystać możliwości systemu GNU. Klasy
59zawierają graficzne obiekty takie jak przyciski, pola tekstowe, listy
60rozwijane, listy przewijane i okienka; jest także wiele klas do
61obsługi zdarzeń, kolorów, fontów i obrazków.
e0359688 62
aa92dd8e 63%package devel
e0359688 64Summary: GNUstep GUI headers and libs
fb1f7b25 65Summary(pl.UTF-8): Pliki nagłówkowe GNUstep GUI
829d10ca 66Group: Development/Libraries
40ce32db 67Requires: %{name} = %{version}-%{release}
5717de99 68Requires: gnustep-base-devel >= 1.13.0
829d10ca 69Conflicts: gnustep-core
aa92dd8e 70
71%description devel
829d10ca 72Header files required to build applications against the GNUstep GUI
f6967d0c 73library.
aa92dd8e 74
c261d120
JR
75%description devel -l pl.UTF-8
76Pliki nagłówkowe potrzebne do budowania aplikacji korzystających z
e0359688
JB
77biblioteki GNUstep GUI.
78
aa92dd8e 79%prep
f6967d0c 80%setup -q
41dc2ea6 81%patch0 -p1
0f8149d4 82%patch1 -p1
b4d1c253 83%patch2 -p1
319a56d2 84%patch3 -p1
aa92dd8e 85
86%build
f669a675 87export GNUSTEP_MAKEFILES=%{_datadir}/GNUstep/Makefiles
5717de99 88export GNUSTEP_FLATTENED=yes
120e1cac
JB
89# disable gsnd - not ready for current portaudio
90%configure \
5717de99 91 %{!?with_cups:--disable-cups} \
58075a32
JB
92 %{!?with_portaudio:--disable-gsnd} \
93 %{?with_magick:--enable-imagemagick} \
94 --enable-libgif \
95 --disable-ungif
aa92dd8e 96
d4d24605
SS
97# with __make -jN we can got non-deterministic errors
98%{__make} -j1 \
f6967d0c 99 messages=yes
aa92dd8e 100
f6967d0c
JB
101%install
102rm -rf $RPM_BUILD_ROOT
f669a675 103export GNUSTEP_MAKEFILES=%{_datadir}/GNUstep/Makefiles
8bc301c9 104export GNUSTEP_INSTALLATION_DOMAIN=SYSTEM
5717de99 105export GNUSTEP_FLATTENED=yes
aa92dd8e 106
f6967d0c 107%{__make} install \
f669a675
JR
108 DESTDIR=$RPM_BUILD_ROOT
109
0bd255f5 110%{__make} install -C Documentation \
f669a675 111 DESTDIR=$RPM_BUILD_ROOT
aa92dd8e 112
f669a675 113find $RPM_BUILD_ROOT%{_datadir}/GNUstep/Documentation \
3e8a68a7 114 -type f -name .cvsignore | xargs rm -f
aa92dd8e 115
f669a675
JR
116# not (yet?) supported by rpm-compress-doc
117find $RPM_BUILD_ROOT%{_datadir}/GNUstep/Documentation \
118 -type f -a ! -name '*.html' -a ! -name '*.gz' -a ! -name '*.jpg' -a ! -name '*.css' | xargs gzip -9nf
c387a5cc 119
aa92dd8e 120%clean
121rm -rf $RPM_BUILD_ROOT
122
e0359688
JB
123%post -p /sbin/ldconfig
124%postun -p /sbin/ldconfig
125
f6967d0c 126%files
829d10ca 127%defattr(644,root,root,755)
f6967d0c 128%doc ChangeLog
f669a675
JR
129%docdir %{_datadir}/GNUstep/Documentation
130%dir %{_datadir}/GNUstep/Documentation/Developer
131%dir %{_datadir}/GNUstep/Documentation/Developer/Gui
132%{_datadir}/GNUstep/Documentation/Developer/Gui/ReleaseNotes
133%{_datadir}/GNUstep/Documentation/User
134
58075a32
JB
135%{_mandir}/man1/gclose.1*
136%{_mandir}/man1/gcloseall.1*
137%{_mandir}/man1/gopen.1*
138%{_mandir}/man1/make_services.1*
139%{_mandir}/man1/set_show_service.1*
f6967d0c 140
58075a32
JB
141%attr(755,root,root) %{_bindir}/GSSpeechServer
142%attr(755,root,root) %{_bindir}/gclose
143%attr(755,root,root) %{_bindir}/gcloseall
144%attr(755,root,root) %{_bindir}/gopen
145%attr(755,root,root) %{_bindir}/make_services
146%attr(755,root,root) %{_bindir}/say
147%attr(755,root,root) %{_bindir}/set_show_service
148%attr(755,root,root) %{_libdir}/libgnustep-gui.so.*.*.*
149%attr(755,root,root) %ghost %{_libdir}/libgnustep-gui.so.%{ver}
150
c83d61ad 151# XXX: shared with WindowMaker - move to gnustep-dirs?
58075a32 152%dir %{_libdir}/GNUstep/Applications
c83d61ad 153
58075a32
JB
154%dir %{_libdir}/GNUstep/Applications/GSSpeechServer.app
155%attr(755,root,root) %{_libdir}/GNUstep/Applications/GSSpeechServer.app/GSSpeechServer
156%{_libdir}/GNUstep/Applications/GSSpeechServer.app/Resources
157%{_libdir}/GNUstep/Applications/GSSpeechServer.app/stamp.make
f6967d0c 158
b10e018b 159%dir %{_libdir}/GNUstep/Bundles
58075a32
JB
160
161%dir %{_libdir}/GNUstep/Bundles/AudioOutput.nssound
162%attr(755,root,root) %{_libdir}/GNUstep/Bundles/AudioOutput.nssound/AudioOutput
163%{_libdir}/GNUstep/Bundles/AudioOutput.nssound/Resources
164%{_libdir}/GNUstep/Bundles/AudioOutput.nssound/stamp.make
165
f669a675
JR
166%dir %{_libdir}/GNUstep/Bundles/GSPrinting
167%dir %{_libdir}/GNUstep/Bundles/GSPrinting/GSLPR.bundle
58075a32 168%attr(755,root,root) %{_libdir}/GNUstep/Bundles/GSPrinting/GSLPR.bundle/GSLPR
f669a675 169%{_libdir}/GNUstep/Bundles/GSPrinting/GSLPR.bundle/Resources
58075a32 170%{_libdir}/GNUstep/Bundles/GSPrinting/GSLPR.bundle/stamp.make
5717de99
JB
171%if %{with cups}
172# R: cups-lib - separate?
f669a675 173%dir %{_libdir}/GNUstep/Bundles/GSPrinting/GSCUPS.bundle
58075a32 174%attr(755,root,root) %{_libdir}/GNUstep/Bundles/GSPrinting/GSCUPS.bundle/GSCUPS
f669a675 175%{_libdir}/GNUstep/Bundles/GSPrinting/GSCUPS.bundle/Resources
58075a32 176%{_libdir}/GNUstep/Bundles/GSPrinting/GSCUPS.bundle/stamp.make
5717de99 177%endif
f669a675 178
58075a32
JB
179%dir %{_libdir}/GNUstep/Bundles/Sndfile.nssound
180%attr(755,root,root) %{_libdir}/GNUstep/Bundles/Sndfile.nssound/Sndfile
181%{_libdir}/GNUstep/Bundles/Sndfile.nssound/Resources
182%{_libdir}/GNUstep/Bundles/Sndfile.nssound/stamp.make
183
f669a675
JR
184%dir %{_libdir}/GNUstep/Bundles/TextConverters
185%dir %{_libdir}/GNUstep/Bundles/TextConverters/RTFConverter.bundle
f669a675 186%attr(755,root,root) %{_libdir}/GNUstep/Bundles/TextConverters/RTFConverter.bundle/RTFConverter
58075a32
JB
187%{_libdir}/GNUstep/Bundles/TextConverters/RTFConverter.bundle/Resources
188%{_libdir}/GNUstep/Bundles/TextConverters/RTFConverter.bundle/stamp.make
189
f669a675 190%dir %{_libdir}/GNUstep/Bundles/libgmodel.bundle
f669a675 191%attr(755,root,root) %{_libdir}/GNUstep/Bundles/libgmodel.bundle/libgmodel
58075a32
JB
192%{_libdir}/GNUstep/Bundles/libgmodel.bundle/Resources
193%{_libdir}/GNUstep/Bundles/libgmodel.bundle/stamp.make
f669a675
JR
194
195%dir %{_libdir}/GNUstep/ColorPickers
58075a32 196
f669a675 197%dir %{_libdir}/GNUstep/ColorPickers/NamedPicker.bundle
f669a675 198%attr(755,root,root) %{_libdir}/GNUstep/ColorPickers/NamedPicker.bundle/NamedPicker
58075a32
JB
199%{_libdir}/GNUstep/ColorPickers/NamedPicker.bundle/Resources
200%{_libdir}/GNUstep/ColorPickers/NamedPicker.bundle/stamp.make
201
f669a675 202%dir %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle
58075a32 203%attr(755,root,root) %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/StandardPicker
f669a675
JR
204%dir %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/Resources
205%{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/Resources/*.tiff
206%{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/Resources/*.plist
207%{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/Resources/English.lproj
208%lang(fr) %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/Resources/French.lproj
58075a32 209%lang(es) %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/Resources/Spanish.lproj
f669a675 210%lang(sv) %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/Resources/Swedish.lproj
58075a32
JB
211%{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/stamp.make
212
f669a675 213%dir %{_libdir}/GNUstep/ColorPickers/WheelPicker.bundle
f669a675 214%attr(755,root,root) %{_libdir}/GNUstep/ColorPickers/WheelPicker.bundle/WheelPicker
58075a32
JB
215%{_libdir}/GNUstep/ColorPickers/WheelPicker.bundle/Resources
216%{_libdir}/GNUstep/ColorPickers/WheelPicker.bundle/stamp.make
f669a675 217
b10e018b
JR
218%{_libdir}/GNUstep/Images
219%{_libdir}/GNUstep/KeyBindings
f669a675
JR
220
221%dir %{_libdir}/GNUstep/Libraries/gnustep-gui
222%dir %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions
223%dir %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}
224%dir %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources
225%{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources/*.plist
226%{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources/English.lproj
227%lang(eo) %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources/Esperanto.lproj
58075a32 228%lang(fr) %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources/French.lproj
f669a675
JR
229%lang(de) %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources/German.lproj
230%lang(it) %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources/Italian.lproj
231%lang(jbo) %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources/Lojban.lproj
58075a32 232%lang(es) %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources/Spanish.lproj
f669a675
JR
233
234%dir %{_libdir}/GNUstep/PostScript
235%{_libdir}/GNUstep/PostScript/GSProlog.ps
236%dir %{_libdir}/GNUstep/PostScript/PPD
237%{_libdir}/GNUstep/PostScript/PPD/English.lproj
58075a32 238
b10e018b 239%dir %{_libdir}/GNUstep/Services
58075a32 240
f669a675 241%dir %{_libdir}/GNUstep/Services/GSspell.service
f669a675 242%attr(755,root,root) %{_libdir}/GNUstep/Services/GSspell.service/GSspell
58075a32
JB
243%{_libdir}/GNUstep/Services/GSspell.service/Resources
244
245%{_libdir}/GNUstep/Sounds
f6967d0c
JB
246
247%files devel
829d10ca 248%defattr(644,root,root,755)
58075a32
JB
249%attr(755,root,root) %{_libdir}/libgnustep-gui.so
250%{_includedir}/AppKit
251%{_includedir}/Cocoa
252%{_includedir}/GNUstepGUI
253%{_includedir}/gnustep/gui
254
f669a675
JR
255%docdir %{_datadir}/GNUstep/Documentation
256%{_datadir}/GNUstep/Documentation/Developer/Gui/Additions
257%{_datadir}/GNUstep/Documentation/Developer/Gui/General
258%{_datadir}/GNUstep/Documentation/Developer/Gui/ProgrammingManual
259%{_datadir}/GNUstep/Documentation/Developer/Gui/Reference
58075a32 260%{_infodir}/AppKit.info*
f669a675 261
f669a675 262%{_datadir}/GNUstep/Makefiles/Additional/gui.make
This page took 0.17211 seconds and 4 git commands to generate.