]> git.pld-linux.org Git - packages/gnu-efi.git/blame - gnu-efi.spec
- updated to 3.0.15
[packages/gnu-efi.git] / gnu-efi.spec
CommitLineData
8db950bd 1Summary: GNU-EFI - building EFI applications using the GNU toolchain
cba3c99f 2Summary(pl.UTF-8): GNU-EFI - tworzenie aplikacji EFI przy użyciu narzędzi GNU
8db950bd 3Name: gnu-efi
8892e088 4# NOTE: don't use early 3.1, it doesn't support EFI x86_64
0057aaa7 5Version: 3.0.15
eaa28bd0 6Release: 1
4a338a38 7Epoch: 1
b5a273a2 8# Intel and HP's BSD-like license, except setjmp code coming from GRUB
9808f4d4 9License: BSD-like
8db950bd 10Group: Development/Libraries
a09e768e 11Source0: https://downloads.sourceforge.net/gnu-efi/%{name}-%{version}.tar.bz2
0057aaa7 12# Source0-md5: 192d94e995ddd4ebdce4903adfd06039
a09e768e 13URL: https://sourceforge.net/projects/gnu-efi/
e9e39156 14BuildRequires: binutils >= 3:2.17.50.0.14
1b2ac276 15BuildRequires: gcc >= 6:4.1.1
e9e39156 16Requires: binutils >= 3:2.17.50.0.14
1b2ac276 17Requires: gcc >= 6:4.1.1
3015dce0 18ExclusiveArch: %{ix86} %{x8664} x32 %{arm} aarch64 ia64 mips64el
8db950bd
JB
19BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
9808f4d4
JB
21%define efi_arch %(echo %{_target_base_arch} | sed -e 's/i386/ia32/')
22
6e1fa7a0
JB
23# no native binaries, only EFI code packaged
24%define _enable_debug_packages 0
25
8db950bd
JB
26%description
27GNU-EFI development environment allows to create EFI applications for
77410af1 28IA-64, x86, ARM and MIPS platforms using the GNU toolchain.
8db950bd 29
e0803b09
JR
30%description -l pl.UTF-8
31Środowisko programistyczne GNU-EFI umożliwia tworzenie aplikacji EFI
77410af1 32dla platform IA-64, x86, ARM i MIPS przy użyciu narzędzi GNU.
8db950bd
JB
33
34%prep
4a338a38 35%setup -q
8db950bd
JB
36
37%build
1d10118d
JB
38ARCHFLAGS=
39%ifarch ia64
40ARCHFLAGS=-frename-registers
41%endif
9acb055c 42# on x32: use x86_64 EFI ABI
1d10118d 43CFLAGS="%{rpmcflags} $ARCHFLAGS" \
897cdb91 44%{__make} -j1 \
9808f4d4 45 ARCH=%{efi_arch} \
9acb055c
JB
46%ifarch x32
47 ARCH3264=-m64 \
48%endif
8db950bd 49 CC="%{__cc}" \
897cdb91 50 OBJCOPY=objcopy
8db950bd
JB
51
52%install
53rm -rf $RPM_BUILD_ROOT
54
55%{__make} install \
9808f4d4 56 ARCH=%{efi_arch} \
c38475d8
JB
57 INSTALLROOT=$RPM_BUILD_ROOT \
58 PREFIX=%{_prefix} \
59 LIBDIR=%{_libdir}
897cdb91 60
8db950bd
JB
61install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
62cp -a apps/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
63
64%clean
65rm -rf $RPM_BUILD_ROOT
66
67%files
68%defattr(644,root,root,755)
69%doc ChangeLog README.*
897cdb91
JB
70%{_libdir}/libefi.a
71%{_libdir}/libgnuefi.a
8db950bd
JB
72%{_libdir}/crt0-efi-*.o
73%{_libdir}/elf_*_efi.lds
74%{_includedir}/efi
75%{_examplesdir}/%{name}-%{version}
This page took 0.154453 seconds and 4 git commands to generate.