]> git.pld-linux.org Git - packages/gnu-efi.git/blame - gnu-efi.spec
- fixed build on x86_64
[packages/gnu-efi.git] / gnu-efi.spec
CommitLineData
8db950bd 1Summary: GNU-EFI - building EFI applications using the GNU toolchain
cba3c99f 2Summary(pl.UTF-8): GNU-EFI - tworzenie aplikacji EFI przy użyciu narzędzi GNU
8db950bd 3Name: gnu-efi
f7cc0991
JB
4# NOTE: don't use 3.1, it doesn't support EFI x86_64
5Version: 3.0d
2eadf440 6Release: 1
8db950bd
JB
7# efilib is on Intel's BSD-like license, HP's glue code is GPL'd
8License: GPL v2+, portions on Intel's BSD-like license (see README.*)
9Group: Development/Libraries
f7cc0991
JB
10Source0: http://dl.sourceforge.net/gnu-efi/%{name}-%{version}.tar.gz
11# Source0-md5: 29013d3cd15009942fb855ba3e1a8096
12URL: http://gnu-efi.sourceforge.net/
e9e39156 13BuildRequires: binutils >= 3:2.17.50.0.14
1b2ac276 14BuildRequires: gcc >= 6:4.1.1
e9e39156 15Requires: binutils >= 3:2.17.50.0.14
1b2ac276 16Requires: gcc >= 6:4.1.1
f7cc0991 17ExclusiveArch: %{ix86} %{x8664} ia64
8db950bd
JB
18BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20%define specflags_ia64 -frename-registers
21
22%description
23GNU-EFI development environment allows to create EFI applications for
24IA-64 and x86 platforms using the GNU toolchain.
25
e0803b09
JR
26%description -l pl.UTF-8
27Środowisko programistyczne GNU-EFI umożliwia tworzenie aplikacji EFI
28dla platform IA-64 i x86 przy użyciu narzędzi GNU.
8db950bd
JB
29
30%prep
31%setup -q
32
33%build
897cdb91
JB
34%ifarch %{x8664}
35WRAP="-DEFI_FUNCTION_WRAPPER"
36%else
37WRAP=
38%endif
39%{__make} -j1 \
40 ARCH="%{_target_base_arch}" \
8db950bd 41 CC="%{__cc}" \
897cdb91
JB
42 CFLAGS="%{rpmcflags} -fpic -Wall -fshort-wchar $WRAP" \
43 OBJCOPY=objcopy
8db950bd
JB
44
45%install
46rm -rf $RPM_BUILD_ROOT
47
48%{__make} install \
49 INSTALLROOT=$RPM_BUILD_ROOT%{_prefix}
50
897cdb91
JB
51%if "%{_lib}" != "lib"
52 mv -f $RPM_BUILD_ROOT%{_prefix}/{lib,%{_lib}}
53%endif
54
8db950bd
JB
55install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
56cp -a apps/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
57
58%clean
59rm -rf $RPM_BUILD_ROOT
60
61%files
62%defattr(644,root,root,755)
63%doc ChangeLog README.*
897cdb91
JB
64%{_libdir}/libefi.a
65%{_libdir}/libgnuefi.a
8db950bd
JB
66%{_libdir}/crt0-efi-*.o
67%{_libdir}/elf_*_efi.lds
68%{_includedir}/efi
69%{_examplesdir}/%{name}-%{version}
This page took 0.045474 seconds and 4 git commands to generate.