]> git.pld-linux.org Git - packages/gnu-efi.git/blame - gnu-efi.spec
- added make patch (don't recompile on install); release 2
[packages/gnu-efi.git] / gnu-efi.spec
CommitLineData
8db950bd 1Summary: GNU-EFI - building EFI applications using the GNU toolchain
cba3c99f 2Summary(pl.UTF-8): GNU-EFI - tworzenie aplikacji EFI przy użyciu narzędzi GNU
8db950bd 3Name: gnu-efi
8892e088 4# NOTE: don't use early 3.1, it doesn't support EFI x86_64
0057aaa7 5Version: 3.0.15
74c30fa6 6Release: 2
4a338a38 7Epoch: 1
b5a273a2 8# Intel and HP's BSD-like license, except setjmp code coming from GRUB
9808f4d4 9License: BSD-like
8db950bd 10Group: Development/Libraries
a09e768e 11Source0: https://downloads.sourceforge.net/gnu-efi/%{name}-%{version}.tar.bz2
0057aaa7 12# Source0-md5: 192d94e995ddd4ebdce4903adfd06039
74c30fa6 13Patch0: %{name}-make.patch
a09e768e 14URL: https://sourceforge.net/projects/gnu-efi/
e9e39156 15BuildRequires: binutils >= 3:2.17.50.0.14
74c30fa6 16BuildRequires: gcc >= 6:4.7
e9e39156 17Requires: binutils >= 3:2.17.50.0.14
74c30fa6 18Requires: gcc >= 6:4.7
3015dce0 19ExclusiveArch: %{ix86} %{x8664} x32 %{arm} aarch64 ia64 mips64el
8db950bd
JB
20BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
9808f4d4
JB
22%define efi_arch %(echo %{_target_base_arch} | sed -e 's/i386/ia32/')
23
6e1fa7a0
JB
24# no native binaries, only EFI code packaged
25%define _enable_debug_packages 0
26
8db950bd
JB
27%description
28GNU-EFI development environment allows to create EFI applications for
77410af1 29IA-64, x86, ARM and MIPS platforms using the GNU toolchain.
8db950bd 30
e0803b09
JR
31%description -l pl.UTF-8
32Środowisko programistyczne GNU-EFI umożliwia tworzenie aplikacji EFI
77410af1 33dla platform IA-64, x86, ARM i MIPS przy użyciu narzędzi GNU.
8db950bd
JB
34
35%prep
4a338a38 36%setup -q
74c30fa6 37%patch0 -p1
8db950bd
JB
38
39%build
1d10118d
JB
40ARCHFLAGS=
41%ifarch ia64
42ARCHFLAGS=-frename-registers
43%endif
9acb055c 44# on x32: use x86_64 EFI ABI
1d10118d 45CFLAGS="%{rpmcflags} $ARCHFLAGS" \
897cdb91 46%{__make} -j1 \
9808f4d4 47 ARCH=%{efi_arch} \
9acb055c
JB
48%ifarch x32
49 ARCH3264=-m64 \
50%endif
8db950bd 51 CC="%{__cc}" \
897cdb91 52 OBJCOPY=objcopy
8db950bd
JB
53
54%install
55rm -rf $RPM_BUILD_ROOT
56
57%{__make} install \
9808f4d4 58 ARCH=%{efi_arch} \
c38475d8
JB
59 INSTALLROOT=$RPM_BUILD_ROOT \
60 PREFIX=%{_prefix} \
61 LIBDIR=%{_libdir}
897cdb91 62
8db950bd
JB
63install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
64cp -a apps/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
65
66%clean
67rm -rf $RPM_BUILD_ROOT
68
69%files
70%defattr(644,root,root,755)
71%doc ChangeLog README.*
897cdb91
JB
72%{_libdir}/libefi.a
73%{_libdir}/libgnuefi.a
8db950bd
JB
74%{_libdir}/crt0-efi-*.o
75%{_libdir}/elf_*_efi.lds
76%{_includedir}/efi
77%{_examplesdir}/%{name}-%{version}
This page took 0.160652 seconds and 4 git commands to generate.