]> git.pld-linux.org Git - packages/glusterfs.git/blame - glusterfs.spec
- fixed stop, removed reload function (unsupported), added force-reload
[packages/glusterfs.git] / glusterfs.spec
CommitLineData
11c9e8ee 1# TODO: package docs
824dab89
MK
2# TODO: Fix init scripts
3# They work as expected, pid file contains correct pid,
4# but status and stop whip about daemon being dead.
d6a0cdd1 5Summary: Clustered File Storage that can scale to peta bytes
dae7af53 6Summary(pl.UTF-8): Klastrowy system przechowywania plików skalujący się do petabajtów
d6a0cdd1 7Name: glusterfs
1293e304 8Version: 1.3.7
824dab89 9Release: 1
d6a0cdd1 10License: GPL v2
dae7af53 11Group: Applications/System
1293e304
MK
12Source0: http://ftp.zresearch.com/pub/gluster/glusterfs/1.3/%{name}-%{version}.tar.gz
13# Source0-md5: ede5fe1e17e7c333536400e138a084f1
824dab89 14Source1: glusterfsd.init
d6a0cdd1 15URL: http://gluster.org/glusterfs.php
16BuildRequires: bison
17BuildRequires: flex
18BuildRequires: libfuse-devel
19BuildRequires: rpmbuild(macros) >= 1.228
20Requires(post,preun): /sbin/chkconfig
21BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23%description
24GlusterFS is a clustered file-system capable of scaling to several
25peta-bytes. It aggregates various storage bricks over Infiniband RDMA
26or TCP/IP interconnect into one large parallel network file system.
27GlusterFS is one of the most sophisticated file system in terms of
28features and extensibility. It borrows a powerful concept called
29Translators from GNU Hurd kernel. Much of the code in GlusterFS is in
30userspace and easily manageable.
31
dae7af53 32%description -l pl.UTF-8
11c9e8ee 33
dae7af53
JB
34GlusterFS to klastrowy system plików skalujący się do petabajtów.
35Scala różne kawałki miejsca po łączach Infiniband RDMA lub TCP/IP
11c9e8ee
MK
36w jeden duży, równoległy sieciowy system plików. GlusterFS to
37jeden z najbardziej wyszukanych systemów plików jeśli chodzi o
38możliwości i rozszerzalność. Zapożycza potężną ideę o nazwie
39Translators z jądra GNU Hurd. Duża część kodu GlusterFS działa w
40przestrzeni użytkownika i jest łatwo zarządzalna.
41
42%package common
43Summary: GlusterFS Library and Translators
44Group: Applications/System
45
46%description common
47GlusterFS is a clustered file-system capable of scaling to several
48peta-bytes. It aggregates various storage bricks over Infiniband RDMA
49or TCP/IP interconnect into one large parallel network file system.
50GlusterFS is one of the most sophisticated file system in terms of
51features and extensibility. It borrows a powerful concept called
52Translators from GNU Hurd kernel. Much of the code in GlusterFS is in
53userspace and easily manageable.
54
55This package includes libglusterfs and glusterfs translator modules
56common to both GlusterFS server and client framework.
57
58%description common -l pl.UTF-8
59Pakiet zawiera libglusterfs i moduly translatorow glusterfs wspolne
60dla klienta jak i serwera GlusterFS.
61
62%package server
63Summary: GlusterFS Server
64Group: Applications/System
65Requires: %{name}-common = %{version}
66
67
68%description server
69GlusterFS is a clustered file-system capable of scaling to several
70peta-bytes. It aggregates various storage bricks over Infiniband RDMA
71or TCP/IP interconnect into one large parallel network file system.
72GlusterFS is one of the most sophisticated file system in terms of
73features and extensibility. It borrows a powerful concept called
74Translators from GNU Hurd kernel. Much of the code in GlusterFS is in
75userspace and easily manageable.
76
77This package provides the glusterfs server daemon.
78
79%description server -l pl.UTF-8
80Pakiet zawiera czesc serwerowa GlusterFS.
81
82
83%package client
84Summary: GlusterFS Client
85Group: Applications/System
86Requires: %{name}-common = %{version}
87
88%description client
89GlusterFS is a clustered file-system capable of scaling to several
90peta-bytes. It aggregates various storage bricks over Infiniband RDMA
91or TCP/IP interconnect into one large parallel network file system.
92GlusterFS is one of the most sophisticated file system in terms of
93features and extensibility. It borrows a powerful concept called
94Translators from GNU Hurd kernel. Much of the code in GlusterFS is in
95userspace and easily manageable.
96
97This package provides the FUSE based GlusterFS client.
98
99%description client -l pl.UTF-8
100Pliki bazujacego na FUSE klienta GlusterFS.
101
102%package devel
103Summary: GlusterFS Development Libraries
104Group: Development/Libraries
105Requires: %{name}-common = %{version}
106
107%description devel
108GlusterFS is a clustered file-system capable of scaling to several
109peta-bytes. It aggregates various storage bricks over Infiniband RDMA
110or TCP/IP interconnect into one large parallel network file system.
111GlusterFS is one of the most sophisticated file system in terms of
112features and extensibility. It borrows a powerful concept called
113Translators from GNU Hurd kernel. Much of the code in GlusterFS is in
114userspace and easily manageable.
115
116This package provides the development libraries.
117
118%description devel -l pl.UTF-8
119Pliki i biblioteki potrzebne do rozwoju GlusterFS.
120
d6a0cdd1 121
122%prep
123%setup -q
d6a0cdd1 124
125%build
1293e304
MK
126%configure \
127 --disable-ibverbs
d6a0cdd1 128%{__make}
129
130%install
131rm -rf $RPM_BUILD_ROOT
d6a0cdd1 132
824dab89
MK
133install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
134install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/glusterfsd
135
d6a0cdd1 136%{__make} install \
137 DESTDIR=$RPM_BUILD_ROOT
138
139%clean
140rm -rf $RPM_BUILD_ROOT
141
11c9e8ee
MK
142
143%files common
144%defattr(644,root,root,755)
145%doc AUTHORS ChangeLog COPYING INSTALL NEWS README
11c9e8ee 146%attr(755,root,root) %{_libdir}/libglusterfs.so.*
796930f1 147%dir %{_libdir}/glusterfs
11c9e8ee
MK
148%dir %{_libdir}/glusterfs/%{version}
149%dir %{_libdir}/glusterfs/%{version}/scheduler
150%attr(755,root,root) %{_libdir}/glusterfs/%{version}/scheduler/*.so
151%dir %{_libdir}/glusterfs/%{version}/transport
152%attr(755,root,root) %{_libdir}/glusterfs/%{version}/transport/*/*.so
153%dir %{_libdir}/glusterfs/%{version}/xlator
154%dir %{_libdir}/glusterfs/%{version}/xlator/*
155%attr(755,root,root) %{_libdir}/glusterfs/%{version}/xlator/*/*.so
156
11c9e8ee
MK
157%dir /var/log/glusterfs
158
159
160%files server
161%defattr(644,root,root,755)
162%doc AUTHORS ChangeLog COPYING INSTALL NEWS README
163%dir %{_sysconfdir}/%{name}
164%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*
824dab89 165%attr(754,root,root) /etc/rc.d/init.d/glusterfsd
11c9e8ee
MK
166%attr(755,root,root) %{_sbindir}/glusterfsd
167
168
169%files client
170%defattr(644,root,root,755)
171%doc AUTHORS ChangeLog COPYING INSTALL NEWS README
172%attr(755,root,root) %{_sbindir}/glusterfs
173%attr(755,root,root) /sbin/mount.glusterfs
174
175%files devel
d6a0cdd1 176%defattr(644,root,root,755)
11c9e8ee
MK
177%doc AUTHORS ChangeLog COPYING INSTALL NEWS README THANKS
178%{_libdir}/libglusterfs.a
179%{_libdir}/libglusterfs.la
180##%{_includedir}/*.h
This page took 0.094218 seconds and 4 git commands to generate.