]> git.pld-linux.org Git - packages/glibc.git/blame - glibc.spec
- added ia64_unwind patch and disabled nptl on sparc (but not tls - am curious
[packages/glibc.git] / glibc.spec
CommitLineData
98a7741e 1#
2# You can define min_kernel macro by "rpm --define 'min_kernel version'"
742b2751 3# default is 2.4.6
029d2051 4#
b287d865 5# Conditional build:
60cb42b4 6%bcond_with omitfp # build without frame pointer (pass \--enable-omitfp)
fd1d4127
JB
7%bcond_without memusage # don't build memusage utility
8%bcond_with kernelheaders # use headers from kernel-headers instead of
b2327ef2 9 # linux-libc-headers (evil, breakage etc., don't use)
fd1d4127 10%bcond_without dist_kernel # for above, allow non-distribution kernel
2e1eb688
JB
11%bcond_without nptl # don't use NPTL (implies using linuxthreads)
12%bcond_without tls # don't use tls (implies no NPTL)
c9d8e545 13%bcond_with tests # perform "make test"
61918272 14
b287d865 15#
37cd6ebc
JB
16# TODO:
17# - localedb-gen man pages(?)
4acad1ec 18# - fix what trojan broke while upgreading (getaddrinfo-workaround)
feca75cc
JB
19# - math/{test-fenv,test-tgmath,test-float,test-ifloat},
20# linuxthreads/tst-cancel8, debug/backtrace-tst(SEGV) fail on alpha
76f01b70 21#
61918272 22
3900e225 23%{!?min_kernel:%global min_kernel 2.4.6}
61918272 24
25%if %{with nptl}
dc3eddd2 26# it seems that nptl uses cmpxchgl (available since i486) on x86
dd75ad7c 27%ifarch i486 i586 i686 pentium3 pentium4 athlon amd64 ia64 alpha s390 s390x sparcv9 ppc ppc64
76131947
AM
28%if "%{min_kernel}" < "2.6.0"
29%global min_kernel 2.6.0
30%endif
3900e225 31%endif
61918272 32%endif
61918272 33
f3f771b7 34%if %{with tls}
dd75ad7c 35%ifnarch %{ix86} amd64 ia64 alpha s390 s390x sparc sparcv9 ppc ppc64
5f56f24b 36%undefine with_tls
f3f771b7
AM
37%endif
38%endif
39
2e1eb688
JB
40%if %{without tls}
41# NPTL requires TLS
42%undefine with_nptl
43%endif
44
e24149ab
PS
45%ifarch sparc64
46%undefine with_memusage
47%endif
48
3e233c2a
MM
49%ifarch sparc
50%undefine with_nptl
51#%%undefine with_tls
52%endif
53
121eb47e 54%define llh_version 7:2.6.6.0
78007e8e 55%define _snap 20041030
e8c60795 56
236a5027 57Summary: GNU libc
58Summary(de): GNU libc
4a04bb32 59Summary(es): GNU libc
236a5027 60Summary(fr): GNU libc
c5387ad5 61