]> git.pld-linux.org Git - packages/git-lfs.git/blame - git-lfs.spec
up to 1.5.2 (22 November, 2016)
[packages/git-lfs.git] / git-lfs.spec
CommitLineData
c5539a21
ER
1#
2# Conditional build:
3%bcond_with tests # build without tests
42f23e25 4%bcond_without doc # build manual page
c5539a21
ER
5
6Summary: Git extension for versioning large files
7Name: git-lfs
4cdf72e6 8Version: 1.5.2
c5539a21
ER
9Release: 1
10License: MIT
11Group: Applications/Archiving
7426848e 12Source0: https://github.com/github/git-lfs/archive/v%{version}/%{name}-%{version}.tar.gz
4cdf72e6 13# Source0-md5: 6585ffb66f30180c98f8038e5b7d1349
c5539a21 14URL: https://git-lfs.github.com/
c5539a21
ER
15BuildRequires: git-core
16BuildRequires: golang
5b986cd4 17BuildRequires: groff
42f23e25 18%{?with_doc:BuildRequires: ronn}
4cdf72e6 19Requires: git-core >= 1.8.5
fc4d2e84 20ExclusiveArch: %{ix86} %{x8664} %{arm}
c5539a21
ER
21BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23%define _enable_debug_packages 0
4cdf72e6 24%define import_path github.com/git-lfs/%{name}
c5539a21 25
84475c9a
ER
26%ifarch %{ix86}
27%define GOARCH 386
28%endif
29%ifarch %{x8664}
30%define GOARCH amd64
31%endif
32
c5539a21
ER
33%description
34Git Large File Storage (LFS) replaces large files such as audio
35samples, videos, datasets, and graphics with text pointers inside Git,
36while storing the file contents on a remote server like GitHub.com or
37GitHub Enterprise.
38
39%prep
4cdf72e6
ER
40%setup -qc
41
42# preserve for %doc
43mv %{name}-%{version}/*.md .
44
45install -d src/$(dirname %{import_path})
46mv %{name}-%{version} src/%{import_path}
c5539a21
ER
47
48%build
61923bef 49unset GOROOT
c5539a21 50export GOPATH=$(pwd)
84475c9a 51export GOARCH=%{GOARCH}
4cdf72e6
ER
52
53cd src/%{import_path}
84475c9a 54sh -x ./script/bootstrap
c5539a21
ER
55
56%if %{with doc}
57./script/man
58%endif
59
60%if %{with tests}
2cab5a6b 61# ensure there are no GIT env vars for testing
2cab5a6b
ER
62env | grep GIT_ && exit 3
63
c5539a21
ER
64./script/test
65./script/integration
66%endif
67
68%install
69rm -rf $RPM_BUILD_ROOT
70install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1}
71
4cdf72e6 72cd src/%{import_path}
c5539a21
ER
73install -p bin/git-lfs $RPM_BUILD_ROOT%{_bindir}/git-lfs
74%if %{with doc}
75cp -p man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
76%endif
77
78%clean
79rm -rf $RPM_BUILD_ROOT
80
81%files
82%defattr(644,root,root,755)
1bb03b08 83%doc LICENSE.md README.md ROADMAP.md CHANGELOG.md
c5539a21
ER
84%attr(755,root,root) %{_bindir}/git-lfs
85%{?with_doc:%{_mandir}/man1/*.1*}
This page took 0.073761 seconds and 4 git commands to generate.