]> git.pld-linux.org Git - packages/ghc-yaml.git/blame - ghc-yaml.spec
- up to 0.11.4.0
[packages/ghc-yaml.git] / ghc-yaml.spec
CommitLineData
330e6b89
JB
1#
2# Conditional build:
3%bcond_without prof # profiling library
4#
5%define pkgname yaml
6Summary: Support for parsing and rendering YAML documents
7Summary(pl.UTF-8): Analiza i renderowanie dokumentów YAML
8Name: ghc-%{pkgname}
63660211 9Version: 0.11.4.0
330e6b89
JB
10Release: 1
11License: BSD
12Group: Development/Languages
13#Source0Download: http://hackage.haskell.org/package/yaml
14Source0: http://hackage.haskell.org/package/%{pkgname}-%{version}/%{pkgname}-%{version}.tar.gz
63660211 15# Source0-md5: 18322a12aa993871315c33dbe7529026
330e6b89
JB
16URL: http://hackage.haskell.org/package/yaml
17BuildRequires: ghc >= 6.12.3
63660211
JR
18BuildRequires: ghc-aeson >= 0.11
19BuildRequires: ghc-attoparsec >= 0.11.3.0
20BuildRequires: ghc-base >= 4.9.1
330e6b89 21BuildRequires: ghc-bytestring >= 0.9.1.4
63660211 22BuildRequires: ghc-conduit >= 1.2.8
330e6b89 23BuildRequires: ghc-containers
63660211
JR
24BuildRequires: ghc-directory
25BuildRequires: ghc-filepath
26BuildRequires: ghc-libyaml >= 0.1
27BuildRequires: ghc-mtl
330e6b89 28BuildRequires: ghc-resourcet >= 0.3
63660211
JR
29BuildRequires: ghc-scientific >= 0.3
30BuildRequires: ghc-template-haskell
330e6b89
JB
31BuildRequires: ghc-text
32BuildRequires: ghc-transformers >= 0.1
330e6b89
JB
33BuildRequires: ghc-unordered-containers
34BuildRequires: ghc-vector
35%if %{with prof}
36BuildRequires: ghc-prof >= 6.12.3
63660211
JR
37BuildRequires: ghc-aeson-prof >= 0.11
38BuildRequires: ghc-attoparsec-prof >= 0.11.3.0
39BuildRequires: ghc-base-prof >= 4.9.1
330e6b89 40BuildRequires: ghc-bytestring-prof >= 0.9.1.4
63660211 41BuildRequires: ghc-conduit-prof >= 1.2.8
330e6b89 42BuildRequires: ghc-containers-prof
63660211
JR
43BuildRequires: ghc-directory-prof
44BuildRequires: ghc-filepath-prof
45BuildRequires: ghc-libyaml-prof >= 0.1
46BuildRequires: ghc-mtl-prof
330e6b89 47BuildRequires: ghc-resourcet-prof >= 0.3
63660211
JR
48BuildRequires: ghc-scientific-prof >= 0.3
49BuildRequires: ghc-template-haskell-prof
330e6b89
JB
50BuildRequires: ghc-text-prof
51BuildRequires: ghc-transformers-prof >= 0.1
330e6b89
JB
52BuildRequires: ghc-unordered-containers-prof
53BuildRequires: ghc-vector-prof
54%endif
55BuildRequires: pkgconfig
56BuildRequires: rpmbuild(macros) >= 1.608
330e6b89
JB
57Requires(post,postun): /usr/bin/ghc-pkg
58%requires_eq ghc
63660211
JR
59Requires: ghc-aeson >= 0.11
60Requires: ghc-attoparsec >= 0.11.3.0
61Requires: ghc-base >= 4.9.1
330e6b89 62Requires: ghc-bytestring >= 0.9.1.4
63660211 63Requires: ghc-conduit >= 1.2.8
330e6b89 64Requires: ghc-containers
63660211
JR
65Requires: ghc-directory
66Requires: ghc-filepath
67Requires: ghc-libyaml >= 0.1
68Requires: ghc-mtl
330e6b89 69Requires: ghc-resourcet >= 0.3
63660211
JR
70Requires: ghc-scientific >= 0.3
71Requires: ghc-template-haskell
330e6b89
JB
72Requires: ghc-text
73Requires: ghc-transformers >= 0.1
330e6b89
JB
74Requires: ghc-unordered-containers
75Requires: ghc-vector
76BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
77
78# debuginfo is not useful for ghc
79%define _enable_debug_packages 0
80
81# don't compress haddock files
82%define _noautocompressdoc *.haddock
83
84%description
85This package provides support for parsing and emitting YAML documents.
86
87%description -l pl.UTF-8
88Ten pakiet zapewnia obsługę analizy i tworzenia dokumentów YAML.
89
90%package prof
91Summary: Profiling %{pkgname} library for GHC
92Summary(pl.UTF-8): Biblioteka profilująca %{pkgname} dla GHC
93Group: Development/Libraries
94Requires: %{name} = %{version}-%{release}
63660211
JR
95Requires: ghc-prof >= 6.12.3
96Requires: ghc-aeson-prof >= 0.11
97Requires: ghc-attoparsec-prof >= 0.11.3.0
98Requires: ghc-base-prof >= 4.9.1
330e6b89 99Requires: ghc-bytestring-prof >= 0.9.1.4
63660211 100Requires: ghc-conduit-prof >= 1.2.8
330e6b89 101Requires: ghc-containers-prof
63660211
JR
102Requires: ghc-directory-prof
103Requires: ghc-filepath-prof
104Requires: ghc-libyaml-prof >= 0.1
105Requires: ghc-mtl-prof
330e6b89 106Requires: ghc-resourcet-prof >= 0.3
63660211
JR
107Requires: ghc-scientific-prof >= 0.3
108Requires: ghc-template-haskell-prof
330e6b89
JB
109Requires: ghc-text-prof
110Requires: ghc-transformers-prof >= 0.1
330e6b89
JB
111Requires: ghc-unordered-containers-prof
112Requires: ghc-vector-prof
113
114%description prof
115Profiling %{pkgname} library for GHC. Should be installed when
116GHC's profiling subsystem is needed.
117
118%description prof -l pl.UTF-8
119Biblioteka profilująca %{pkgname} dla GHC. Powinna być zainstalowana
120kiedy potrzebujemy systemu profilującego z GHC.
121
122%package doc
123Summary: HTML documentation for ghc %{pkgname} package
124Summary(pl.UTF-8): Dokumentacja w formacie HTML dla pakietu ghc %{pkgname}
125Group: Documentation
126
127%description doc
128HTML documentation for ghc %{pkgname} package.
129
130%description doc -l pl.UTF-8
131Dokumentacja w formacie HTML dla pakietu ghc %{pkgname}.
132
133%prep
134%setup -q -n %{pkgname}-%{version}
135
136%build
137runhaskell Setup.lhs configure -v2 \
138 %{?with_prof:--enable-library-profiling} \
63660211 139 --flags="-no-exe" \
330e6b89
JB
140 --prefix=%{_prefix} \
141 --libdir=%{_libdir} \
142 --libexecdir=%{_libexecdir} \
143 --docdir=%{_docdir}/%{name}-%{version}
144
145runhaskell Setup.lhs build
146runhaskell Setup.lhs haddock
147# --executables fails here
148
149%install
150rm -rf $RPM_BUILD_ROOT
151install -d $RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d
152
153runhaskell Setup.lhs copy --destdir=$RPM_BUILD_ROOT
154
155# work around automatic haddock docs installation
156%{__rm} -rf %{name}-%{version}-doc
157cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version} %{name}-%{version}-doc
158%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
159
160runhaskell Setup.lhs register \
161 --gen-pkg-config=$RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
162
163%clean
164rm -rf $RPM_BUILD_ROOT
165
166%post
167%ghc_pkg_recache
168
169%postun
170%ghc_pkg_recache
171
172%files
173%defattr(644,root,root,755)
174%doc LICENSE
175%attr(755,root,root) %{_bindir}/yaml2json
63660211 176%attr(755,root,root) %{_bindir}/json2yaml
330e6b89
JB
177%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
178%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}
63660211
JR
179%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSyaml-%{version}-*.so
180%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSyaml-%{version}-*.a
181%exclude %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSyaml-%{version}-*_p.a
182%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*.hi
183%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*.dyn_hi
330e6b89 184%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data
63660211
JR
185%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/*.hi
186%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/*.dyn_hi
187%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Yaml
188%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Yaml/*.hi
189%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Yaml/*.dyn_hi
330e6b89
JB
190
191%if %{with prof}
192%files prof
193%defattr(644,root,root,755)
63660211
JR
194%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHSyaml-%{version}-*_p.a
195%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*.p_hi
196%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/*.p_hi
197%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/Yaml/*.p_hi
330e6b89
JB
198%endif
199
200%files doc
201%defattr(644,root,root,755)
202%doc %{name}-%{version}-doc/*
This page took 0.114228 seconds and 4 git commands to generate.